Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Deltac0

HELP TOPIC - for help in OS X Yosemite (10.10) and below

2,847 posts in this topic

Recommended Posts

jejejejeje!!!!! and like you want boot your system!!!!! if you not have a SMBIOS , post your Extra folder, and please put your hardware in your signature for support

Share this post


Link to post
Share on other sites

Bitcore, which kernel are you using?

 

You have to use the name of the kernel as a boot flag, did you do it? I.e.: if you're using AnV's latest kernel, you'll have to use the boot flag amd_kernel before typing arch=x86_64 and the other boot flags.

 

Best regards!

 

P.S.: and edit your signature so it has your exact specs, like iFire said.

Share this post


Link to post
Share on other sites

Bitcore, which kernel are you using?

 

You have to use the name of the kernel as a boot flag, did you do it? I.e.: if you're using AnV's latest kernel, you'll have to use the boot flag amd_kernel before typing arch=x86_64 and the other boot flags.

 

Best regards!

 

P.S.: and edit your signature so it has your exact specs, like iFire said.

I always boot with amd_kernel as flag. i do not have a mach_kernel on it so if i boot without amd_kernel it just says "cant find mach_kernel" ;)

Share this post


Link to post
Share on other sites

Hey! back on Lion, trying to get 64-bit with Itz shanes latest build. First boot I had a KP on AppleRTC, so I disabled it, now after a -f boot I got a KP on AppleOnboardPCATA...however when I look in my Extensions folder, there is no such kext?

 

Alright pictures. This one is normal boot. (with -f)

20130111_113224_zps00691b23.jpg

 

 

This is with safe mode(and -f)

20130111_111519_zpsb2371b6c.jpg

 

It seems im stuck on FakeSMC and this AppleOnboardPCATA(which sometimes is AppleOnboardPCATARoot)

 

Ive tried a newer FakeSMC to no avail...and like I said I can not find an AppleOnboardPCATA kext, nor a plugin in kexts like AppleACPIFamily and such. Any ideas?

Share this post


Link to post
Share on other sites

 

 

I have no plugins inside FakeSMC, Thanks for the answer though!

IOATAFamily.kext/Contents/PlugIns maybe...

Share this post


Link to post
Share on other sites

@byransays

 

[s]sudo find /System/Library/Extensions -type F -name AppleOnboardPCATA*[/s]
[s]sudo find /Extra/Extensions -type F -name AppleOnboardPCATA*[/s]

EDIT:

it's  f  (lower-case) 
and add  /Volumes/osx_hdd_name/  before the full path (/S/L/E & /E/E)

sudo find /Volumes/osx_hdd_name/System/Library/Extensions -type f -name AppleOnboardPCATA*
sudo find /Volumes/osx_hdd_name/Extra/Extensions -type f -name AppleOnboardPCATA*

 

note: filename is case-sensitive

Share this post


Link to post
Share on other sites

@byransays

 

sudo find /System/Library/Extensions -type F -name AppleOnboardPCATA*
sudo find /Extra/Extensions -type F -name AppleOnboardPCATA*

 

 

note: filename is case-sensitive

Checking now, thanks @Mac_carol I get an output of "find: -type: F: unknown type

IOATAFamily.kext/Contents/PlugIns maybe...

 

I also checked there, none found. I found you made a SL AppleATIATA kext for 64-bit, would that be something I would need with my ATI chipset?

Share this post


Link to post
Share on other sites

 

Checking now, thanks!

 

 

I also checked there, none found. I found you made a SL AppleATIATA kext for 64-bit, would that be something I would need with my ATI chipset?

If it's not AHCI you can use it, otherwise DSDT edit is preferable...

 

 

Checking now, thanks!

 

 

I also checked there, none found. I found you made a SL AppleATIATA kext for 64-bit, would that be something I would need with my ATI chipset?

If it's not AHCI you can use it, otherwise DSDT edit is preferable...

Share this post


Link to post
Share on other sites

If it's not AHCI you can use it, otherwise DSDT edit is preferable...

 

Ah, I am using AHCI. My board has...issues with DSDT, but I believe I have it..."working" so I can always try enabling it(i have it disabled because I saw no difference with it enabled)

 

EDIT: enabled my DSDT, no change. I might not have it patched right. Where would I find a ATI AHCI patch?

Share this post


Link to post
Share on other sites

Checking now, thanks @Mac_carol I get an output of "find: -type: F: unknown type

 

oops sorry... it's f (lower-case)

 

and also try to add: /Volumes/Lion_hdd_name/ before the full-path

Share this post


Link to post
Share on other sites

oops sorry... it's f (lower-case)

 

and also try to add: /Volumes/Lion_hdd_name/ before the full-path

 

Thanks, I did that. I take it if it doesnt find anything it will just show a new line waiting for input? because its not showing anything. I tried it again to no avail.

Share this post


Link to post
Share on other sites

 

 

Ah, I am using AHCI. My board has...issues with DSDT, but I believe I have it..."working" so I can always try enabling it(i have it disabled because I saw no difference with it enabled)

 

EDIT: enabled my DSDT, no change. I might not have it patched right. Where would I find a ATI AHCI patch?

Modify the SATA section like I did for someone in "Thoughts about Mountain Lion on AMD".

Also add DTGP function

Install iasl and use following command to compile it:

iasl -tc DSDT.dsl

Enable AHCI.

Put new DSDT.aml in /Extra

You should have HD working then and have it recognized like an Apple AHCI used controller ;)

Share this post


Link to post
Share on other sites

hi, i am beginner, i create a bootable mountain lion 10.8.2 with this guide

http://www.insanelymac.com/forum/topic/265839-guida-installare-lion-retail-su-qualunque-pc/

,

 

what kernel should i use and where to put it,thankyou

 

 

processore DualCore AMD Phenom II X2 Black Edition 550, 3067 MHz (15.5 x 198)

 

scheda madre Sapphire PI-AM3RS785G

 

DIMM1: 2 GB DDR3-1333 DDR3 SDRAM (9-9-9-24 @ 666 MHz) (8-8-8-22 @ 592 MHz) (6-6-6-16 @ 444 MHz)

 

video ATI Radeon HD 4800 Series (512 MB

Share this post


Link to post
Share on other sites

Modify the SATA section like I did for someone in "Thoughts about Mountain Lion on AMD".

Also add DTGP function

Install iasl and use following command to compile it:

iasl -tc DSDT.dsl

Enable AHCI.

Put new DSDT.aml in /Extra

You should have HD working then and have it recognized like an Apple AHCI used controller ;)

 

I found your DSDT you provided...I believe it was to The Connactic as the file is labled DSDT_theconn_fixed.zip. So you want me to use this DSDT? well no thats stupid, you want me to reference it? as in copy everything in the Device (SATA) and overwrite whats under my Device(SATA)

Share this post


Link to post
Share on other sites

 

 

I found your DSDT you provided...I believe it was to The Connactic as the file is labled DSDT_theconn_fixed.zip. So you want me to use this DSDT? and add DTGP? is this something I can find a patch for on the net?

No, add the _DSM method of SATA to your own and add the DTGP function.

Then recompile it and use that one...

Share this post


Link to post
Share on other sites

No, add the _DSM method of SATA to your own and add the DTGP function.

Then recompile it and use that one...

 

Sorry I am not so knowledgeable with DSDT edits

 

I did what you said, added the _DSM to my DSDT and the DTGP. Still no change, KP with FakeSMC and dependency:com.apple.iokit.ioacpifamily

 

would you like a screenshot?

Share this post


Link to post
Share on other sites

 

 

I found your DSDT you provided...I believe it was to The Connactic as the file is labled DSDT_theconn_fixed.zip. So you want me to use this DSDT? well no thats stupid, you want me to reference it? as in copy everything in the Device (SATA) and overwrite whats under my Device(SATA)

add the _DSM part of SATA to your SATA part.

Also add DTGP

 

 

 

Sorry I am not so knowledgeable with DSDT edits

 

I did what you said, added the _DSM to my DSDT and the DTGP. Still no change, KP with FakeSMC and dependency:com.apple.iokit.ioacpifamily

 

would you like a screenshot?

Is it OS X 10.8.2?

My kernel is a 10.8.2 kernel...

Share this post


Link to post
Share on other sites

add the _DSM part of SATA to your SATA part.

Also add DTGP

 

 

Is it OS X 10.8.2?

My kernel is a 10.8.2 kernel...

 

Sorry for the confusion, I am using ItzShanes Lion version of your kernel with your .diffs

 

I am using 10.7.5 which they are all saying I should be using.

 

EDIT: tried booting using -f again, this time no KP but it gets to failed to load FakeSMC and failed to load AppleOnboardPCATA error 0xdc008016

"couldnt alloc class AppleOnboardPCATARoot"

 

without -f or if I use "usekernelcache=No" it just KP but doesnt say what for just panic + 0x260 and trap + 0x6fd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×