Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,615 posts in this topic

Recommended Posts

@AJ - to get rid of verbose boot you need to change the nvram var. it keeps the last set used in nvram.

$ sudo nvram -p

to see what is in nvarm
then
$ sudo nvram -d boot-args

which will remove it from nvram and clover will just use what is config.plist

OR next boot go to Options and manually change the boot-args and it will save these next time.

@honeywell.

i would get on vanilla 10.8.3 then push in custom kexts.

the attached clover config+kext bundle will allow you boot totally vanilla with clover - some things wont work. but it will be up and running
if you booting vanilla - mv OEM to OEM-NU for the time being.

after you have boot with vanilla OSX - then copy/install custom kexts from the \EFI\CLOVER\kexts\10.8 and 10.8-SLE into your OSX /S/L/E
change the folder 4236AT9 to your product ID - use Clover GUI/Options/SMBIOS menu to see your ID.

(rename OEM-NU to OEM )
it will then use \EFI\CLOVER\OEM\ProductID\config.plist instead of the default config.plist

I hope this makes sense. sorry in a rush today.

 

Update 06-18-2013 - revised pack - see post #242

Share this post


Link to post
Share on other sites
Advertisement

Thanks tluck, but I'm having problems getting on vanilla 10.8.3. I am unable to boot even in Safe Mode once updated to 10.8.3. It gives me a kernel panic.

Share this post


Link to post
Share on other sites

@honeywell -

 

yes - it does seem to be a bit catch-22. but this bundle will get you running on vanilla 10.8.3. The Clover bundle I just posted will auto-patch the generic DSDT and fix/patch the AppleIntelCPUPM kext that usually causes KPs... then you can complete the hack/installation process to get all the other pieces running!

 

Steps:

1) install clover bundle+kext pack in ESP (\EFI\CLOVER) partition without OEM stuff - it has some kexts required.

2) install/boot vanilla 10.8.3 - clover loads extra kexts from EFI.

3) install custom kexts in /SLE - so audio, sleep, battery, etc all work and then it will build the kernel cache.

4) install \EFI\CLOVER\OEM folder in ESP - so now the extra kexts are not used from ESP. And clover will find and use the matching OEM\Product folder and use that config.plist if its there instead of the default config.plist.

 

since you had a running chameleon version - you should not have install/create a new build for clover. essentially if you copy (Carbon Copy etc) your OSX partition a MBR disk to an OSX partition on a GUID format disk you are ready to go. The key difference is really that you just changing the bootloader - which gets all the config/stuff from the ESP /EFI partition vs the /Extra folder.

Share this post


Link to post
Share on other sites

Trying to attempt this on my T530, but running into problems when trying to boot off the USB with Clover - I'll get the initial boot menu, select the option to boot from the usb, and be prompted with the following screen:

 

install_zpsa04c8484.jpg

 

This is after attempting the "boot in safe mode" from the right click menu in Clover - previous attempts would lock up at the "root device uuid is..." prompt.

 

I've managed to get ML installed previously using the ##### method, but would much rather go the UEFI route with a clean install. I can boot into the previous ML installation with the Clover usb if I select the safe mode option, but otherwise it gets aways into loading drivers and then reboots.

 

Any suggestions?

Share this post


Link to post
Share on other sites

@dirtyMetis - you should not have to boot safe. do you required kexts (fakesmc) on the usb? what is your config.plist look like?

Share this post


Link to post
Share on other sites

update to 10.8.4 with no issue (with Clover 1794)

 

Hi Tetonne-

Can you please describe the process you followed for the update?

 

Thanks,

AJ

Share this post


Link to post
Share on other sites

tluck-

 

I updated to 10.8.4. I am able to boot without -x! I followed your instructions, but some things are still not working. First and foremost, the screen is completely glitchy and stretched. Sound doesn't work, but oddly enough, the battery is detected and I can see the percentage. Is there a way to get everything else I listed to work? Thanks! I will also reread the thread.

 

Oh yea, another thing I forgot to mention - I am still not able to boot without the USB. When I boot to the USB, it allows me to boot into the Clover installed on the hard drive, which is 1794. Then I boot into OS X, and am able to boot without KP. If I boot without the USB, nothing happens - Clover isn't launched or anything. Weird...

Share this post


Link to post
Share on other sites

@honeywell - progress is good!

 

make sure there is /EFI/BOOT/BOOTX64.efi and you have set UEFI First in boot order setting in BIOS Startup menus. Clover can make itself as a boot option. go the clover (command key symbol) in the GUI and make it a boot option.

 

audio - i presume all the kexts from the bundle (both sets from the 10.8. and 10.8-SLE folders) were installed in /S/L/E?

if you dont have 1600x900 screen change DualLink to 0 in both config.plist files in /EFI.

good luck!!!

Share this post


Link to post
Share on other sites

@dirtyMetis - you should not have to boot safe. do you required kexts (fakesmc) on the usb? what is your config.plist look like?

 

Just followed the steps as directed in the first post, created the usb install drive with Lion DiskMaker, then ran Korgen's linked "Clover_v2_r1625k0.pkg" and chose the newly created install usb as the destination. Reboot with usb drive and experience the above-mentioned results.

 

Would it make any difference than I'm creating the USB drive in VirtualMachine on a different sysetm?

Share this post


Link to post
Share on other sites

tluck - gah this is frustrating! I'm pretty sure I followed your instructions perfectly but the screen and audio are still not cooperating. I have the 1600x900 screen.

 

Also, could you explain the folder structure of /EFI/? I have /EFI/BOOT, /EFI/CLOVER/, and /EFI/OEM. However, I also have /EFI/CLOVER/OEM.

 

Another thing - I'm not sure how to find the product ID. When I looked in the Clover menu at boot, I didn't see it. However, if I install Clover 1625, inside /EFI/CLOVER/OEM there is a folder with a product ID (I don't know if it is my product ID). Installing Clover 1794 gives me a generic folder in /EFI/CLOVER/OEM called "Product Name" with some config and other folders in it.

Share this post


Link to post
Share on other sites

@honeywell - yeah understood. just to recap...

you should be able totally replace the contents of /EFI with the zip contents in post 202.

after you install the kexts in your OSX /S/L/E, then the OEM folder comes into play. check/fix perms on the kexts?! the DSDT from the OEM folder will set id 12.

make sure your product number matches the folder name. Note: i have model 4236AT9 - which may match yours (or not?) - it is listed by the clover GUI (hit F1 i think).

Share this post


Link to post
Share on other sites

Hi Tetonne-

Can you please describe the process you followed for the update?

 

Thanks,

AJ

Apple menu update :)

this is ok if you use tluck pack cos no kext is update by 10.8.4

Share this post


Link to post
Share on other sites

I was able to get everything working (audio, battery, usb) except for a perfect screen. I'm still getting frequent ring stalls (graphics lag). I'm using tluck's config.plist and his display overrides. The EDID seems to inject correctly. Anyone know what to do? I'm using the 1600x900 screen.

 

As a side note, and this might be relevant, I was only able to boot successfully by formatting the ESP partition as hfs - not msdos. However, I still need to boot from the USB, and then boot into the SSD's Clover.

 

Here is my boot.log: https://dl.dropboxus...566087/boot.log

and my system.log: https://dl.dropboxusercontent.com/u/66566087/system.log

 

from /Library/Logs/CloverEFI

Share this post


Link to post
Share on other sites

@honeywell - it am not sure what happened to your ESP partition as it should have been automatically be formatted fat32 when you partition the disk as GUID. the reason you cant boot from your HD is because the lenovo UEFI cant read the hfs formatting. does your diskutil output look like this? the EFI partition really should be fat32 formatted.

 

 

$ diskutil list

/dev/disk0

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *750.2 GB disk0

1: EFI 209.7 MB disk0s1

2: Apple_HFS OSX+ 698.3 GB disk0s2

3: Microsoft Basic Data C 51.5 GB disk0s3

 

not sure what to say about your LCD and the EDID that seem to work for me. i did figure out how to make this work on chameleon today. i was able put the working EDID in the dsdt and i dont get ring stalls. I boot the GUID disk with chimera/chameleon on USB. the reason i have explored chimera is that it does loose trackpad after sleep.

Share this post


Link to post
Share on other sites

That is what "diskutil list" in terminal looks like.

 

The reason it isn't fat32 formatted is because when I installed Clover 1794 the first time, it failed and spit out an installation error log that told me that I needed to create the EFI partition myself. It said I could either use msdos or hfs and I chose hfs.

 

Also, I don't know if this is relevant to the graphics thing, but in ioreg -l, under AppleBacklightDisplay, my IODisplayPrefsKey is this: "IODisplayPrefsKey" = "IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IGPU@2/AppleIntelFramebuffer@0/display0/AppleBacklightDisplay-6af-203e"

 

Since is AppleBacklightDisplay-6af-203e, I removed the DisplayVendorID-30e4 override folder from my display overrides and added the 6af one. Still getting ring stalls though.

 

Update: Wow... I am at the white screen error again. When I boot with slide=0 darkwake=10 -v, I get a white screen after I see the verbose print. This happened after I tried sleeping the computer but sleep failed (the power button was rapidly blinking) so I held the power button down to shut down.

Share this post


Link to post
Share on other sites

@honeywell - sorry about your challenges.

 

i have too experience sleep issues (rapid blinking - often) and sometimes the trackpad goes away after wake.

i dont know if this is a Clover problem or config problem (dsdt, options etc). its very frustrating.

 

T420 users - are you seeing the same thing?

Share this post


Link to post
Share on other sites

Still no progress here. The white screen issue is very frustrating. Is it possible for someone to upload their entire EFI folder and for me to replace my EFI with that? Would that work?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slice
      OK, 4988 released.
      Now, @vector sigma, what have we do to update translations?
    • By fusion71au
      Clover r4989 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4989 for VMware.zip". Mount Clover-v2.4k-4989-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By fusion71au
      Run Vanilla OS X El Capitan, Sierra, High Sierra or Mojave in VirtualBox 5.x.x on a Windows Host
      Following on from my previous guide on how to create a VMware virtual machine running Vanilla OS X El Capitan in Windows, I’ve decided to write a similar guide for creating a VirtualBox El Capitan VM. 
       
      The virtual machine should be useful for testing El Capitan and also for creating installers for use on a real machine/hackintosh.
       
      There are other tutorials and videos on the net about running OS X on Windows machines using pre-made VMDK disk images but you can never guarantee what else is in there….
       
      I’ve gathered info for this guide from several threads in the Multibooting and Virtualisation section of this forum and also the wider internet eg
       
      @colt2 HOW TO: Create a bootable El Capitan ISO for VMware
      @dsmccombs comment on faking Ivybridge Processor
      @E:V:A http://forum.xda-developers.com/showpost.php?p=55572430&postcount=6
      @Tech Reviews video tutorial https://www.youtube.com/watch?v=t7X07U63lwg.
      VirtualBox Forum: Status of OSX on OSX
       
      Requirements
         Intel PC with four or more CPU cores running Windows 7 X64 or later OS (2 or more cores needed for OS X)    4GB or more RAM (2GB or more will be needed for OS X)    Hard Disk with at least 40GB free for Virtual Machine    Oracle VM VirtualBox v 5.0.34    Install OS X El Capitan app and Mac or Hack to prepare installation iso <-- Now, no longer necessary to have previous access to a Mac or Hack by building the Installer.app from scratch - see post#75    16GB or larger exFAT formatted USB stick to transfer El Capitan iso from Mac/Hack to Host PC  
      Prepare Installation ISO on your Mac or Hack
      1.  On your Mac or Hack, download "Install OS X El Capitan.app" from the App Store into your Applications folder.
      2.  Download and unzip the CECI.tool (attached to this post) into your ~/Downloads folder. The commands in this executable script are shown below for informational purposes.  Note: you will need approx 16GB of free space on your hard disk for the script to complete.
       
       
       
      3.  Open OS X terminal, then run the following commands to execute the script:
      cd downloads chmod +x CECI.tool ./CECI.tool 4.  At the end of the process, you will have an El Capitan iso on your desktop - copy this onto an exFAT formatted USB for use on the PC Host later.
       
       
      Create an El Capitan Virtual Machine in VirtualBox
      1.  Open the VirtualBox program and click the "New" button to create a new VM.
       

       
      2.  Select Mac OS X and Mac OS X 10.11 El Capitan (64 -bit) for Operating System type and version.  I named my Virtual Machine "El_Capitan", then clicked next...
       

       
      3.  Leave the Memory size at the recommended 2048 MB, then click next.
       

       
      4.  Choose to "Create a virtual hard disk now", then click the create button.
       

       
      5.  For the hard disk file type, the default is VDI (VirtualBox Disk Image) but I have selected VMDK for inter-operability with VMWare.  Click next...
       

       
      6.  For Storage on physical hard disk, I have chosen the default Dynamically allocated (grows larger to a set limit as you need more disk space).
       

       
      7.  On the File location and size screen, you can set the location of the new virtual hard disk and its size - I recommend changing disk size to 40GB or larger.  When you click the create button, you will now see your new VM in the VirtualBox main GUI.
       

       
      8.  Click the settings button on the Main Menu to tweak a few settings....
         a.  On the System/Motherboard tab in Boot Order, you can uncheck the Floppy Drive (who has these now?)
       

       
         b.  On the System/Processor tab, you can increase the allocated CPU cores to 2
       

       
         c.  On the Display tab, you can increase the allocated Video Memory to 128MB
       

       
         d.  On the Storage tab, click on the icon of the Optical Drive and select "Choose Virtual Optical Disk File". 
       

       
      Navigate and select the El Capitan ISO we created earlier...
       

       
         e.  Click the OK button to finalise the VM settings.
       
       
      Patch El Capitan vbox configuration file with DMI Settings from a Mac
      1.  From the start menu, type cmd and click run as administrator to open an administrative command prompt. 
       

       
      2.  Choose a Mac Model similar to your host system, then type the following lines, followed by <enter>  after each line.  Make sure you first close all VirtualBox Windows and the VirtualBox program, otherwise any changes you make won't stick...
       
      Eg iMac11,3
      cd "C:\Program Files\Oracle\VirtualBox\" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemProduct" "iMac11,3" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemVersion" "1.0" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiBoardProduct" "Mac-F2238BAE" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/smc/0/Config/DeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/smc/0/Config/GetKeyFromRealSMC" 1 MacBookPro11,3
      cd "C:\Program Files\Oracle\VirtualBox\" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemProduct" "MacBookPro11,3" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemVersion" "1.0" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiBoardProduct" "Mac-2BD1B31983FE1663" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/smc/0/Config/DeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/smc/0/Config/GetKeyFromRealSMC" 1 Macmini6,2
      cd "C:\Program Files\Oracle\VirtualBox\" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemProduct" "Macmini6,2" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemVersion" "1.0" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiBoardProduct" "Mac-F65AE981FFA204ED" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/smc/0/Config/DeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/smc/0/Config/GetKeyFromRealSMC" 1 3.  Optional- For some host systems eg those with Haswell and newer CPUs, you might have to spoof an older CPU to avoid VirtualBox errors.  You can try from one of the following if this happens:

      To spoof Lynnfield i5 750 CPU
      VBoxManage.exe modifyvm "El_Capitan" --cpuidset 00000001 000106e5 06100800 0098e3fd bfebfbff To spoof IvyBridge CPU
      VBoxManage.exe modifyvm "El_Capitan" --cpuidset 00000001 000306a9 04100800 7fbae3ff bfebfbff or
      VBoxManage.exe modifyvm "El_Capitan" --cpuidset 00000001 000306a9 00020800 80000201 178bfbff 4.  Close the command prompt window.
       
       
      Installation of El Capitan
      We are now ready to start the El_Capitan Virtual Machine....
       



       
      Installation should be relatively straight forward, just following the prompts of the OS X installer:
      1.  Select language, agree to legal terms
       

       
      2.  Use Disk Utility from the Utilities Menu to erase and format the virtual hard drive as a single partition GUID Mac OS X Extended.  I named my drive "Macintosh HD" but you can enter whatever you like eg El_Capitan.
       

       
      3.  Quit DU and choose Macintosh HD to install El Capitan on.
      4.  After 20-30 min (depending on how fast your system is), the installation will complete.  At this point, unmount the El Capitan ISO by clicking the Devices menu from the VM window, click Optical Drives, then choose Remove disk from virtual drive.  The VM is now ready to reboot into OS X from the virtual hard drive.
      5.  At the welcome screen, choose your country and keyboard layout.  You can skip transfer information, location services and logging in with your Apple ID if you wish…
      6.  Create a User Account and select your Time Zone.  You can skip sending diagnostics and usage data to Apple….
      7.  Finally, you will arrive at the El Capitan Desktop.
       

       
      8.  Network/internet and audio should work OOB but on my system, the sounds were distorted.  Unfortunately, there is no QE/CI and the VM resolution will be fixed without the ability to dynamically resize the VM window (no VirtualBox additions for OS X guests atm). 
       
       
      Customization with VBoxManage
      1.  You can change the default resolution of 1024*768 (after shutting down the VM) with the VBoxManage command from the Windows Administrative Command Prompt:
      cd "C:\Program Files\Oracle\VirtualBox\" VBoxManage setextradata "El_Capitan" VBoxInternal2/EfiGopMode N (Where N can be one of 0,1,2,3,4,5) referring to the 640x480, 800x600, 1024x768, 1280x1024, 1440x900, 1920x1200 screen resolution respectively.
       
      Update:  For VirtualBox 5.2.x, the command for changing screen resolution has changed...
       
      VBoxManage setextradata "<MyVM>" VBoxInternal2/EfiGraphicsResolution XxY (where X=Horizontal screen resolution, Y=Vertical screen resolution)
      eg
      VBoxManage setextradata "<MyVM>" VBoxInternal2/EfiGraphicsResolution 1280x1024 2.  Adding serials and other SMBIOS details for the System Information Screen
      VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemSerial" "W8#######B6" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiBoardSerial" "W8#########1A" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemVendor" "Apple Inc." VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiSystemFamily" "iMac" VBoxManage setextradata "El_Capitan" "VBoxInternal/Devices/efi/0/Config/DmiBIOSVersion" "IM112.0057.03B" A listing of known issues with Mac OS X guests can be found in the VirtualBox Manual - link https://www.virtualbox.org/manual/ch14.html.
       
      Vanilla Mavericks and Yosemite, Snow Leopard from Retail DVD
      The same VM settings for El Capitan will also boot and run vanilla installations of OS X Mavericks and Yosemite .  Attached to this post are installer scripts to create bootable Mavericks (CMI.tool) and Yosemite (CYI.tool) ISOs for VirtualBox and VMware.
       
      With the respective OS X installer apps in the Applications folder, download and run the installer tools using terminal ie
       
      To create a Mavericks ISO on your desktop
      cd downloads chmod +x CMI.tool ./CMI.tool To create a Yosemite ISO on your desktop
      cd downloads chmod +x CYI.tool ./CYI.tool Here is a screenshot of the VM running Mavericks 10.9.5...
       

       
      Finally, those without a Mac/Hack to prepare the install media can purchase a retail Snow Leopard DVD directly from Apple and install OSX 10.6.3 on their virtual machines (Snow Leopard, Lion and Mountain Lion run quite happily in VirtualBox with 1 CPU, 1-2 GB of RAM and the rest of the settings unchanged from above).  Once you update by combo update to SL 10.6.8, you can directly download El Capitan from the App Store for free .
       

       
      UPDATE macOS Sierra 10.12 to 10.12.6: For macOS Sierra, use CSI.tool in post#51.
      UPDATE macOS High Sierra 17A365:  For macOS High Sierra, use CHSI.tool in post#73.
      UPDATE macOS Mojave 18A391:  For macOS Mojave or High Sierra, use macOS_iso_creator.tool on page 4 of thread.
      UPDATE macOS Catalina Beta DP3_19A501i:  For Catalina, @jpz4085 has made an automated batch file to create a Catalina VM in Windows with iMac 14,2 SMBIOS.  You can still use my macOS_iso_creator.tool on page 5 to make an installer ISO to attach to the VM.
       
       
       
      Good luck and enjoy
      CECI.tool.zip
      CYI.tool.zip
      CMI.tool.zip
    • By JackBauer24
      Hello,
       
      I have installed OSx86 10.11 (El Capitan) on April 2016 on my Asus Z170 Deluxe system.
       
      For installation I used this Thread.
       
      I used it a lot and it worked well. Meanwhile I switched to Linux and I use Win10 time to time. So OSX was forgotten. Also it did not boot correctly anymore.
       
      Now I wanted to start with a fresh installation and use OSX more often again. I want to use OSX 10.13 High Sierra. Is it working on my Asus Z170 Deluxe? I have the same Hardware as of April 2016 only the graphics card was updated to a Nvidia GTX1080.
       
      My Hardware in detail: Asus Z-170-Deluxe (Bios 3801), i7-6700k, EVGA GeForce GTX 1080 SC GAMING ACX 3.0, Samsung 950 Pro/M2 NVME 512MB, HDD 4 TB)
      Can I use some of support files from the old thread for the installation (see attachment)? Can I still use  Clover 2.3k r3292 Special Edition v2 ? Or do I need a newer version?
       
      Has someone installed High Sierra successfully on the Asus Z170 Deluxe ?
       
      About some hints where to start I would be thankful.
       
      regards
      JackBauer24
       
      Z170DeluxeFiles.zip
    • By ThatsMatt
      Salve, sono nuovo nel forum e mi serviva una mano nell'installazione dell' ultima versione di MacOs sul mio notebook HP Pavilion 15-ak112nl.
      Specifiche Tecniche: 
      CPU: Intel Core i7-6700HQ (2.60 / 3.50 GHz, 4 core, 6 MB CACHE L3). 
      Scheda Grafica: Intel HD Graphics 530 + NVIDIA GeForce GTX 950M 4 GB DDR3.
      Hard Disk: 1 TB SATA 5400 rpm.
      Ram: 8 GB DDR3L-1600.
      Audio: altoparlanti stereo Bang & Olufsen PLAY. 
      Rete: LAN 10/100, WLAN 802.11b/g/n, bluetooth 4.0 (Miracast).
      Grazie in Anticipo a chi mi risponderà
×