Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

4,670 posts in this topic

Recommended Posts

@AJ - to get rid of verbose boot you need to change the nvram var. it keeps the last set used in nvram.

$ sudo nvram -p

to see what is in nvarm
then
$ sudo nvram -d boot-args

which will remove it from nvram and clover will just use what is config.plist

OR next boot go to Options and manually change the boot-args and it will save these next time.

@honeywell.

i would get on vanilla 10.8.3 then push in custom kexts.

the attached clover config+kext bundle will allow you boot totally vanilla with clover - some things wont work. but it will be up and running
if you booting vanilla - mv OEM to OEM-NU for the time being.

after you have boot with vanilla OSX - then copy/install custom kexts from the \EFI\CLOVER\kexts\10.8 and 10.8-SLE into your OSX /S/L/E
change the folder 4236AT9 to your product ID - use Clover GUI/Options/SMBIOS menu to see your ID.

(rename OEM-NU to OEM )
it will then use \EFI\CLOVER\OEM\ProductID\config.plist instead of the default config.plist

I hope this makes sense. sorry in a rush today.

 

Update 06-18-2013 - revised pack - see post #242

Share this post


Link to post
Share on other sites
Advertisement

Thanks tluck, but I'm having problems getting on vanilla 10.8.3. I am unable to boot even in Safe Mode once updated to 10.8.3. It gives me a kernel panic.

Share this post


Link to post
Share on other sites

@honeywell -

 

yes - it does seem to be a bit catch-22. but this bundle will get you running on vanilla 10.8.3. The Clover bundle I just posted will auto-patch the generic DSDT and fix/patch the AppleIntelCPUPM kext that usually causes KPs... then you can complete the hack/installation process to get all the other pieces running!

 

Steps:

1) install clover bundle+kext pack in ESP (\EFI\CLOVER) partition without OEM stuff - it has some kexts required.

2) install/boot vanilla 10.8.3 - clover loads extra kexts from EFI.

3) install custom kexts in /SLE - so audio, sleep, battery, etc all work and then it will build the kernel cache.

4) install \EFI\CLOVER\OEM folder in ESP - so now the extra kexts are not used from ESP. And clover will find and use the matching OEM\Product folder and use that config.plist if its there instead of the default config.plist.

 

since you had a running chameleon version - you should not have install/create a new build for clover. essentially if you copy (Carbon Copy etc) your OSX partition a MBR disk to an OSX partition on a GUID format disk you are ready to go. The key difference is really that you just changing the bootloader - which gets all the config/stuff from the ESP /EFI partition vs the /Extra folder.

Share this post


Link to post
Share on other sites

Trying to attempt this on my T530, but running into problems when trying to boot off the USB with Clover - I'll get the initial boot menu, select the option to boot from the usb, and be prompted with the following screen:

 

install_zpsa04c8484.jpg

 

This is after attempting the "boot in safe mode" from the right click menu in Clover - previous attempts would lock up at the "root device uuid is..." prompt.

 

I've managed to get ML installed previously using the ##### method, but would much rather go the UEFI route with a clean install. I can boot into the previous ML installation with the Clover usb if I select the safe mode option, but otherwise it gets aways into loading drivers and then reboots.

 

Any suggestions?

Share this post


Link to post
Share on other sites

@dirtyMetis - you should not have to boot safe. do you required kexts (fakesmc) on the usb? what is your config.plist look like?

Share this post


Link to post
Share on other sites

update to 10.8.4 with no issue (with Clover 1794)

 

Hi Tetonne-

Can you please describe the process you followed for the update?

 

Thanks,

AJ

Share this post


Link to post
Share on other sites

tluck-

 

I updated to 10.8.4. I am able to boot without -x! I followed your instructions, but some things are still not working. First and foremost, the screen is completely glitchy and stretched. Sound doesn't work, but oddly enough, the battery is detected and I can see the percentage. Is there a way to get everything else I listed to work? Thanks! I will also reread the thread.

 

Oh yea, another thing I forgot to mention - I am still not able to boot without the USB. When I boot to the USB, it allows me to boot into the Clover installed on the hard drive, which is 1794. Then I boot into OS X, and am able to boot without KP. If I boot without the USB, nothing happens - Clover isn't launched or anything. Weird...

Share this post


Link to post
Share on other sites

@honeywell - progress is good!

 

make sure there is /EFI/BOOT/BOOTX64.efi and you have set UEFI First in boot order setting in BIOS Startup menus. Clover can make itself as a boot option. go the clover (command key symbol) in the GUI and make it a boot option.

 

audio - i presume all the kexts from the bundle (both sets from the 10.8. and 10.8-SLE folders) were installed in /S/L/E?

if you dont have 1600x900 screen change DualLink to 0 in both config.plist files in /EFI.

good luck!!!

Share this post


Link to post
Share on other sites

@dirtyMetis - you should not have to boot safe. do you required kexts (fakesmc) on the usb? what is your config.plist look like?

 

Just followed the steps as directed in the first post, created the usb install drive with Lion DiskMaker, then ran Korgen's linked "Clover_v2_r1625k0.pkg" and chose the newly created install usb as the destination. Reboot with usb drive and experience the above-mentioned results.

 

Would it make any difference than I'm creating the USB drive in VirtualMachine on a different sysetm?

Share this post


Link to post
Share on other sites

tluck - gah this is frustrating! I'm pretty sure I followed your instructions perfectly but the screen and audio are still not cooperating. I have the 1600x900 screen.

 

Also, could you explain the folder structure of /EFI/? I have /EFI/BOOT, /EFI/CLOVER/, and /EFI/OEM. However, I also have /EFI/CLOVER/OEM.

 

Another thing - I'm not sure how to find the product ID. When I looked in the Clover menu at boot, I didn't see it. However, if I install Clover 1625, inside /EFI/CLOVER/OEM there is a folder with a product ID (I don't know if it is my product ID). Installing Clover 1794 gives me a generic folder in /EFI/CLOVER/OEM called "Product Name" with some config and other folders in it.

Share this post


Link to post
Share on other sites

@honeywell - yeah understood. just to recap...

you should be able totally replace the contents of /EFI with the zip contents in post 202.

after you install the kexts in your OSX /S/L/E, then the OEM folder comes into play. check/fix perms on the kexts?! the DSDT from the OEM folder will set id 12.

make sure your product number matches the folder name. Note: i have model 4236AT9 - which may match yours (or not?) - it is listed by the clover GUI (hit F1 i think).

Share this post


Link to post
Share on other sites

Hi Tetonne-

Can you please describe the process you followed for the update?

 

Thanks,

AJ

Apple menu update :)

this is ok if you use tluck pack cos no kext is update by 10.8.4

Share this post


Link to post
Share on other sites

I was able to get everything working (audio, battery, usb) except for a perfect screen. I'm still getting frequent ring stalls (graphics lag). I'm using tluck's config.plist and his display overrides. The EDID seems to inject correctly. Anyone know what to do? I'm using the 1600x900 screen.

 

As a side note, and this might be relevant, I was only able to boot successfully by formatting the ESP partition as hfs - not msdos. However, I still need to boot from the USB, and then boot into the SSD's Clover.

 

Here is my boot.log: https://dl.dropboxus...566087/boot.log

and my system.log: https://dl.dropboxusercontent.com/u/66566087/system.log

 

from /Library/Logs/CloverEFI

Share this post


Link to post
Share on other sites

@honeywell - it am not sure what happened to your ESP partition as it should have been automatically be formatted fat32 when you partition the disk as GUID. the reason you cant boot from your HD is because the lenovo UEFI cant read the hfs formatting. does your diskutil output look like this? the EFI partition really should be fat32 formatted.

 

 

$ diskutil list

/dev/disk0

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *750.2 GB disk0

1: EFI 209.7 MB disk0s1

2: Apple_HFS OSX+ 698.3 GB disk0s2

3: Microsoft Basic Data C 51.5 GB disk0s3

 

not sure what to say about your LCD and the EDID that seem to work for me. i did figure out how to make this work on chameleon today. i was able put the working EDID in the dsdt and i dont get ring stalls. I boot the GUID disk with chimera/chameleon on USB. the reason i have explored chimera is that it does loose trackpad after sleep.

Share this post


Link to post
Share on other sites

That is what "diskutil list" in terminal looks like.

 

The reason it isn't fat32 formatted is because when I installed Clover 1794 the first time, it failed and spit out an installation error log that told me that I needed to create the EFI partition myself. It said I could either use msdos or hfs and I chose hfs.

 

Also, I don't know if this is relevant to the graphics thing, but in ioreg -l, under AppleBacklightDisplay, my IODisplayPrefsKey is this: "IODisplayPrefsKey" = "IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/IGPU@2/AppleIntelFramebuffer@0/display0/AppleBacklightDisplay-6af-203e"

 

Since is AppleBacklightDisplay-6af-203e, I removed the DisplayVendorID-30e4 override folder from my display overrides and added the 6af one. Still getting ring stalls though.

 

Update: Wow... I am at the white screen error again. When I boot with slide=0 darkwake=10 -v, I get a white screen after I see the verbose print. This happened after I tried sleeping the computer but sleep failed (the power button was rapidly blinking) so I held the power button down to shut down.

Share this post


Link to post
Share on other sites

@honeywell - sorry about your challenges.

 

i have too experience sleep issues (rapid blinking - often) and sometimes the trackpad goes away after wake.

i dont know if this is a Clover problem or config problem (dsdt, options etc). its very frustrating.

 

T420 users - are you seeing the same thing?

Share this post


Link to post
Share on other sites

Still no progress here. The white screen issue is very frustrating. Is it possible for someone to upload their entire EFI folder and for me to replace my EFI with that? Would that work?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15
      Original link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      For any system kext installation\modification you need to boot with config_debug.plist (or disable SIP manually)
      Also on Catalina the System folder is read-only, so you need to remount in rw. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By camotsuc
      I can't get graphics acceleration work the Lenovo e31-80 
      Shows Intel hd 520 4mb
      Specs:
      intel i3-6006u
      intel hd graphics 520 
      4gb ram
      I tried method on this site(and some other sites), and may be 10 videos on youtube...
      Installed kext's
      Whatevergreen
      Lilu
      Config plist there
      Sorry if the question is stupid
       
       
      config.plist
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      EFI-Clover-X99.zip
       
       
       
       
       
       
      Anyone else I forgot
       
       
×