Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

4,937 posts in this topic

Recommended Posts

Advertisement

@XSmile2008

 

1) wifi replacement - yes whitelist removal is the desired (usual) outcome of using a modded bios in this this situation

2) if you have 1600x900, you can try the attached dsdt that includes the EDID.  

    rename it to dsdt.aml and replace the one in ESP.

dsdt.edid.aml.zip

Share this post


Link to post
Share on other sites

Where I can see whitelist to our notebook model? In BIOS? I do not find it. For example on aliexpress in inforamation to Broadcom BCM94352 I see that this adapter is not supported by Lenovo/IBM notebooks.

 

Broadcom BCM94322HM8L = Dell 1510? Works OBB? Or ar9280 will be best solution?

 

Today I also tried plug VGA projector to notebook and it not works. It just not see projector. In home I tried connect VGA monitor and it same not work. How to enable VGA out?

 

And what about "PrtSc" and "Insert" and two buttons in "arrows zone"? They are not works, but I want bind this buttons in ControllerMate,

Share this post


Link to post
Share on other sites

WiFI:

the modded bios that i have removes the whitelist so any card you put in to replace the intel wifi will not be rejected by the BIOS and allows you boot up.

then you need get a card works well with OSX. the BCM 4322 or Atheros 9280 both work well with OOB support.

i did have to some eeprom flashing in windows on one atheros card i got to get the proper Locale and Country Code. so be prepared to do some research.

 

VGA:

the system will not auto detect a VGA connection to the VGA port.  it will only find external monitor or projector if you start up with them plugged in or do a sleep/wake cycle.

to get a better solution for VGA, i bought a DisplayPort to VGA adaptor which does do auto-detect. 

Share this post


Link to post
Share on other sites

VGA:

the system will not auto detect a VGA connection to the VGA port.  it will only find external monitor or projector if you start up with them plugged in or do a sleep/wake cycle.

to get a better solution for VGA, i bought a DisplayPort to VGA adaptor which does do auto-detect. 

You can detect VGA display using system preferences

Share this post


Link to post
Share on other sites

Hi guys,


thanks a lot for this guide. I managed to get El Capitan running on my T420 although I didn't understand some steps. For example Use the folder with its config.plist with the custom dsdt.aml (as is) to start. - Which folder and to start what?

 

Anyway, OS X seems to be running pretty well.

 

I wonder how I could install a second OS (Ubuntu) and make it dual-boot. Any ideas?

Sorry if this is a noob question. Of course I have searched the Internet, but most guides on this seem to be outdated.

Share this post


Link to post
Share on other sites

I wonder how I could install a second OS (Ubuntu) and make it dual-boot. Any ideas?

 

Create 'ubuntu' directory in EFI partition and copy your kernel there but with name bootx64.efi, for example:

 

 

my example with Gentoo (just rename gentoo -> ubuntu), ls -l /mnt/EFI/EFI/:

~$ mkdir /mnt/EFI/EFI/gentoo

~$ ls -l /mnt/EFI/EFI/

drwxr-xr-x 4 root root  512 Sep 21 05:40 APPLE
drwxr-xr-x 2 root root  512 Sep 21 16:05 BOOT
drwxr-xr-x 6 root root 1024 Sep 21 16:05 CLOVER
drwxr-xr-x 2 root root  512 Oct 16 17:11 gentoo

copy ubuntu kernel and icon to ubuntu dir:

~$ cp /boot/your-kernel-vmlinuz /mnt/EFI/EFI/ubuntu/bootx64.efi

~$ cp /home/user/ubuntu.png /mnt/EFI/EFI/ubuntu/ubuntu.png

config.plist:

	<key>GUI</key>
	<dict>
		<key>Custom</key>
		<dict>
			<key>Entries</key>
			<array>
				<dict>
					<key>Disabled</key>
					<false/>
					<key>FullTitle</key>
					<string>Gentoo</string>
					<key>Hidden</key>
					<false/>
					<key>Ignore</key>
					<false/>
					<key>Image</key>
					<string>EFI\gentoo\gentoo.png</string>
					<key>Path</key>
					<string>EFI\gentoo\bootx64.efi</string>
					<key>Type</key>
					<string>Linux</string>
					<key>VolumeType</key>
					<string>Internal</string>
				</dict>
			</array>
		</dict>

Share this post


Link to post
Share on other sites

So I'm currently on Yosemite. I have the BCM94352HMB combo card installed. Unfortunately it doesn't work for the BT as neither of the MoBos in both of my T420's support the combo cards. Instead BT is provided by the GMYLE BT4LE micro USB dongle (BCM20702 - exactly the same as whats on my combo card lol).

 

I want to upgrade to El Capitan. Is there anything in particular I need to look out for or do prior to the upgrade to ensure nothing breaks?

Share this post


Link to post
Share on other sites

question :

OS X 10.11 is installed on my main HD but Yosemite recovery appear @boot Clover GUI?

my revovery partition seems to be ok

Share this post


Link to post
Share on other sites

 

Create 'ubuntu' directory in EFI partition and copy your kernel there but with name bootx64.efi

 

Thanks, but where should I put the rest of the Ubuntu installation? (Which partition should I choose in Ubuntu installer as "/"?)

 

What if I receive a kernel update? Does this require me to copy the kernel after each update?

Share this post


Link to post
Share on other sites

@emil1532

 

dual boot under Clover is similar no matter what OS.

 

EFI partition is for boot mgrs/loaders and the directory tree will look like this in general

 

/EFI/BOOT <- renamed copy of CloverX64.efi

/EFI/CLOVER  <- boots OSX

/EFI/Microsoft  

/EFI/ubuntu

 

then on the rest of the disk you need to make partition(s) or space for each OS you plan to install.

if OS X is taking up the full space then shrink it to make space. then use the UEFI installation procedure to install Ubuntu. Grub2 may the way to go but its up to you.

 

@Tetonne - run the 10.11 installer from the USB on top of your system install, and it will update the Recovery HD.

 

@AetherTom - just make sure you have the latest Clover pack installed which supports El Capitan. since you replaced your BT - the BluetoothT420 kext will not need to be updated post install.

Share this post


Link to post
Share on other sites

My installer gets finished with loading, I see the language option menu and after a couple of seconds the computer shuts down. I searched through this thread already and I am not seeing a similar problem. Anyone else experience this?

Share this post


Link to post
Share on other sites

I just updated the zip with newer VoodooPS2Controller to 1.8.16. this might help occassional issues. 

 

@XSmile2008 - well. i have seen that every so often the TrackPad is not working. The only way i know is restart or better yet cold start.

 

@DrMechxico - did you set the BIOS for this: Set Security / Memory Protection / Execution Prevention = Enabled

Share this post


Link to post
Share on other sites

@tluck

Could you please let me know the list of patches you used for your T420. I am planning to patch my W520 from raw dsdt and want to get some idea which patches are needed. Thanks. 

Share this post


Link to post
Share on other sites

@superkwn - panel, battery, usb, gfx, audio, wak ... the dsdt.dsl in the zip has comments - look for tjl - where there are changes. many/most were manual edits  vs patchmatic

Share this post


Link to post
Share on other sites

@tluck, thanks for you suggestion it works.


Does anyone have successfully install El Capitan with lenovo W520 (4284-23U)? If you have can you provide instruction. Thanks!

Share this post


Link to post
Share on other sites

@tluck

 

I followed your instructions. I have shrunk the OS X partition from OS X using Disk Utility. Then I started "Ubuntu 14.04, 64-bit" installer from USB drive and created a new partition /dev/sda4 where I installed Ubuntu. The installer also installed Grub on /dev/sda (the hard drive with OS X installation). However, after reboot, Clover boot menu appeared as before. I didn't know from which OS I was supposed to run the commands you listed. So I started Ubuntu live OS from USB drive and mounted /dev/sda4 as /mnt/ubuntu and /dev/sda1 as EFI. From /mnt/ubuntu/boot I copied a file (.bin extension) which contained "vmlinuz" in the name, to /mnt/EFI/EFI/ubuntu as bootx64.efi. Then I copied the icon and edited config.plist like you wrote (with filenames altered).
 

Now I have the Ubuntu entry in Clover after boot. But when I select it, it's doing nothing. Any ideas?

Share this post


Link to post
Share on other sites

I made few changes regarding the keyboard. 

 

The browser forward/back(next to the arrow keys) is mapped to pageup/pagedown. Should be possible to map them to cmd+[ and cmd+] but I don't know how to do...

PrtSc is toggle touchpad by default, since I always use touchpad I assign it to F13 for future use.

Context Menu/Apps key is mapped to right option by default, but as I seldomly use right side modifiers, I change it to F16, then I assign F16 to launchpad.

 

Below is the VoodooPS2Keyboard Info.plist for reference.

 

 

                    <key>ThinkPad</key>
                    <dict>
                        <key>ActionSwipeLeft</key>
                        <string>37 d, 21 d, 21 u, 37 u</string>
                        <key>ActionSwipeRight</key>
                        <string>37 d, 1e d, 1e u, 37 u</string>
                        <key>Custom ADB Map</key>
                        <array>
                            <string>e06a=74;back to pageup</string>
                            <string>e069=79;forward to pagedown</string>

                        </array>
                        <key>Custom PS2 Map</key>
                        <array>
                            <string>e037=64;PrtSc=F13, toggle touchpad by default</string>
                            <string>e05d=67;Apps=F16</string>
                        </array>

                    </dict>
 

 

Another thing worth noting is, starting from Clover r3296 the console output before the Clover GUI can be "officially" hidden now.

 

 
<key>Boot</key>
<dict>
<key>NoEarlyProgress</key>
<true/>
</dict>

Share this post


Link to post
Share on other sites

Hey Guys,

 

My Hackintosh  T420 has been running very well until I have encounter issue after running Kext Utility, after it reboot, i lose the Audio and the USB WIFI not loading. Has anyone seen this type of problem?

 

 

 

 

Lenovo T420 (4236-MBU) -i5, 4GB, 320GB, 1600x900 | USB WIFI chipset RTL8191S | v10.11.1

Share this post


Link to post
Share on other sites

Hi everyone :)

 

I've been happily running Yosemite on my T420 since like a year or so. The last system update that I've done was to 10.10.3, but since installation (around December 2014) I've never touched neither Clover nor any kexts etc.

Everything was up and running so I didn't want to mess it up  :rolleyes:

 

As of today, I need new XCode for new project at work, and therefore I need to update my system either to 10.10.5 or 10.11.1 (so I though I will also update all low-level stuff), and so there goes my questions:

  • What is the correct updating procedure scenario?
  • Should I update first Clover and the whole EFI-partition pack or OS first?
  • Will the OS update overwrite my custom kexts?
  • After updating EFI-part pack, do I need to manually update those kexts on system partition (use your provided script or Kext Utility)?

I have 1:1 backup of my SSD so even when I mess something up, I will be able to get it back to working state.

(but I'd like to avoid this, as this is time-consuming).

 

Any advices will be greatly appreciated  ^_^

 

 

Best regards,

Burag.

Share this post


Link to post
Share on other sites

@ulyjunk - just use the _kext-install.bash script to reinstall the kexts from the zip.

 

@Burag 

1) download the latest zip from the guide and reinstall the pieces. (follow the guide on post install)

2) then download El Capitan to your HD and install it!

 

the custom kexts from step 1 are in /Library/Extensions and will not be bothered.

Share this post


Link to post
Share on other sites

Hi truck, 

 

thank you do a great job.

 

Now my t420 can work perfect on OS X EI . the only issue is the dock speaker seem not work at all.

there is only one device listed in the OutPut of Sound and  indicate the devices  driver not correct installed.

 

I already check below file. the Platforms.xml.lib is renamed from Platforms.xml.lib.dock 

 

 

path /System/Library/Extensions/AppleHDA.kext/Contents/Resources

-rw-r--r--@   1 root  wheel   4782 Feb 20  2014 Platforms.xml.zlib

-rw-r--r--@   1 root  wheel   1237 Oct  6  2013 layout12.xml.zlib

 

and the path /System/Library/Extensions/AppleHDA_20672.kext/Contents/Resources

-rwxr-xr-x@ 1 root  wheel  4782 Nov  6 01:29 Platforms.xml.zlib

-rwxr-xr-x@ 1 root  wheel  4782 Nov  6 01:27 Platforms.xml.zlib.dock

-rwxr-xr-x@ 1 root  wheel  4714 Nov  6 01:27 Platforms.xml.zlib.nodock

-rwxr-xr-x@ 1 root  wheel  1237 Nov  6 01:27 layout12.xml.zlib

 

I don't know anything else need to be checked more.

 

thank you .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By ludufre
      Installing macOS Catalina 10.15.4 on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/24/2020 20:30h GMT-0
      - Added 10.15.3 update instructions.
       
      01/30/2020 23:52h GMT-0
      - Added 10.15.3 update instructions.
       
      12/11/2019 04:24h GMT-0
      - Added 10.15.2 update instructions.
      - Replaced IntelMausiEthernet.kext with IntelMausi.kext.
       
      11/08/2019 20:30h GMT-0
      - Added instructions to swap Command with Option keys in VoodooPS2Controller.kext.
      - Added additional FileVault 2 UEFI drivers be more practical.
       
      10/30/2019 01:42h GMT-0
      - Added 10.15.1 update instructions.
      - Replaced AppleALC.kext with VoodooHDA.kext
      - No more issues after sleep or misconfiguration with jack sense.
       
      10/29/2019 18:18h GMT-0
      - Replaced the config.plist with AppleIntelCPUPM = true.
       
      10/27/2019 05:37h GMT-0
      - Replaced the DW1560 wireless card with BCM94360CS2.
       
      10/20/2019 20:47h GMT-0
      - Removed AppleBacklightFixup.kext.
      - WhateaverGreen now implements backlight since 1.2.5.
       
      10/20/2019 18:10h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 BCM94360CS2 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff and Continuity ->  Work after replaced wireless.
      - Instant Hotspot ->  Not work.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      16GB (2x8GB). No mistery here. Just upgade.
       
      - Wireless upgrade:
      Previously I have the DW1560 working almost perfectly, now replaced with BCM94360CS2 that is full native supported. 
      More info below.
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Make trackpad appear in System Preferences
      - Make Instant Hotspot work.
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the CloverEFI from official repository (used 5097) and install only with these options on "Install macOS Catalina":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - AudioDxe (Just to have nice sound on boot)
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
       
      FileVault 2
       
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
       
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
       
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
       
      That's it! FileVault 2 will work without problems.
       
       

       
       
      Make things works
       
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
       
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below
      - Put SSDT-L440.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.6.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Copy the Clover Configurator to flash drive because you will need later.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC from here. I used all Kexts and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/) from version 1.0.8 (If you followed the steps to enable FileVault 2 above, skip to the next item).
      - Download the Lilu.kext from here. I used the version 1.3.8.
      - Download the VoodooPS2Controller.kext from here. I used version 2.0.4.
      - Download the IntelMausi.kext from here. I used the version 1.0.2.
      - Download the VoodooHDA.kext from here. I used the version 2.9.2. (Need to turn up the volume on Info.plist, more instructions below)
      - Download the WhateverGreen.kext from here. I used the version 1.3.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
       
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
       
       
      Audio volume adjustment
       
      - Open the Info.plist inside VoodooHDA.kext/Contents/ with TextEdit.app or any text editor of your choice.
      - Change:
      <key>PCM</key> <integer>90</integer> to:
      <key>PCM</key> <integer>140</integer> Or, download the versions 2.9.2 attached bellow.
       
       
      Keyboard swap Command with Option (optional)
       
      - If you prefer, you can swap Command and Option keys, to map Win Key - Command and Alt - Option.
      - Change /Volumes/EFI/EFI/CLOVER/OEM/S400CA/UEFI/kexts/10.15/VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist:
      <key>Swap command and option</key> <true/> to:
      <key>Swap command and option</key> <false/> Or, download the version 2.0.4 already adjusted attached bellow.
       
       
      Wifi and Bluetooth (BCM94360CS2 + M2 NGFF adapter)
       
      Recently I replaced the DW1560 with BCM94360CS2. Now I have fully wireless and bluetooth working (including Instant Hotspot) without any kexts.
       
      See: 
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (Ask on UEFI hack forums over there to someone patch for you. Every dump is unique, so mine don't work to you.);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/10.15/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 2.0.3. (To enable Wireless)
      - Download the BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext from here. I used the version 2019-10-17. (To enable Bluetooth)
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.4. (To enable Handoff and Continuity)
       
      Keep in mind that the bluetooth kexts are currently in development and the official releases will be available in future in the repository: https://github.com/acidanthera/BrcmPatchRAM/releases
       
       
      Now you can start the installation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install
       
      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
       
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.

       

      Post installation
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
       
      Copy the EFI folder to desktop.
       
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
       
      Move the EFI folder from Desktop to EFI partition of the internal disk.
       
      Eject the flash drive.
       
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      System Updates
       
      10.15.1
       
      Updated without changing or updating anything.
       

       
       
      10.15.2
       
      Before install, update the following kexts:
      - VirtualSMC.kext and all kexts and VirtualSmc.efi. I used version 1.0.9.
      - Lilu.kext. I used version 1.4.0.
      - WhateverGreen.kext. I used version 1.3.5.
      - AppleALC.kext. I used version 1.4.4.
      - VoodooPS2Controller.kext. I used version 2.1.0.
      (all download links above)
       
      Download the latest CLOVERX64.efi.zip build. I used version 5100.
      Mount EFI partition and unzip to:
      - /Volumes/EFI/EFI/CLOVER/CLOVERX64.efi
      - /Volumes/EFI/EFI/BOOT/BOOTX64.efi (rename the copy of CLOVERX64.efi to BOOTX64.efi
       
      Install update. Will reboot at least four time.
       
       
      10.15.3
       
      Updated with success without changing anything.
       
       
      10.15.4
      Before install, update the following kexts:
      - Lilu.kext. I used version 1.4.2.
      - WhateverGreen.kext. I used version 1.3.7.
      - VirtualSMC.kext. I used version 1.3.7.
      - VoodooP2Controller.kext. I used versions 2.1.2.
      (all download links above)
       
      Download the latest CLOVER installer. I used version 5107.
      - Install respecting the configuration mentioned above in "Install bootloader" section.
       
      Install update. Will reboot at least four time.
       
       
       

      And last but not least

      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @"Sniki", @Mieze, @headkaze and all others members involved directly or indirectly.
       
       
      Attachments
       
       
      SSDT-L440.aml
      config.plist
      VoodooHDA.kext.zip
      VoodooPS2Controller.kext.zip
      Filevault 2 additional drivers.zip
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Latest Release on GitHub (March 2020) Updated to Clover r5105 Updated Lilu based kexts - Lilu, ALC, WEG Added AirportBrcmFixup.kext
        Various Tweaks over Last months The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: The T460 systems used here was configured with: i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (the old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files
      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup
      Notes on Custom Kexts
       
×