Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,323 posts in this topic

Recommended Posts

@jengpeng

 

before i replaced my WiFi card, I used a USB wifi but is was RTL8192?

 

tell me mode of your USB wifi... i want buy one!  Need kext or no?

Share this post


Link to post
Share on other sites
Advertisement

tell me mode of your USB wifi... i want buy one!  Need kext or no?

I recommend Asus N-10 because it works very fine for me (10.9.5). it comes with driver for OS X, so you need not any kext.

Share this post


Link to post
Share on other sites

@tluck
yes, i'm using TP-Link Tl-wn725n usb wifi . Do you recommend compatible kext/drive for my usb wifi on yosemite?

thank you. 

Share this post


Link to post
Share on other sites

Hello jengpeng,

hardware revison v1 and v2 of TL-WN725N are using the RTL8188 chipset which will need a additional kext. I think the kext for mountain lion (10.8.x) will work. You can find it on the official Realtek site. But I'd recommend a internal card. A half mini pcie card that works oob will cost around 10-15 $ or € and you won't have to worry about unplugging while transporting the hackbook. But you will need a bios with removed whitelist (is linked in the guide), 5 minutes of time and a small philipps screwdriver for 3 screws (2 for the service latch and 1 for the wifi card itself).

 

@tluck, pokenguyen and all other contributors

Thanks a lot - the installation of Yosemite on my T420s worked like a charm and was completely hazzlefree done in about 30 min (including 5 min for the HD to SSD swap and switching Intel Centrino N6300 to AR9280). Last thing to fiddle out is the duels of HD3000 and NVS2000M, but that is a project for cold winter evenings ;-)

Share this post


Link to post
Share on other sites

Hi, great guide. I'm retiring my older t60p with the infamous FireGL v5250 that was working well in 10.6.8 but refused to fly higher...

So I bought an used t420 and in 1 hour I was up and running Mavericks. almost hassle free.

Great job.

Share this post


Link to post
Share on other sites

@downlord - glad hear it was smooth! Yosemite is pretty solid these days and the upgrade is seamless! as soon as 10.10.4 is finished (i have been running the public beta 10.10.4 for awhile without issue) I plan to update the zip bundle with the latest Clover and slightly newer FakeSMC/HWSensor pieces.

 

@Laberlohe. welcome to the thread. I could be wrong but there some folks that may be using the NVS2000 - a awhile back there was talk about it  -  working mostly after dropping the SSDT MCFG table by clover.

Share this post


Link to post
Share on other sites

@downlord I remember the painful installation of Lion on the T60p - EDID hardcoding, hex editing the radeon.kext and still some glitches left...

 

@tluck thanks for the welcome. You're wright it's possible to disable the iGPU in order to use constantly the nVidia (some guys at osxlatitude have done that with their DELL laptops). But the battery of the T420s is imho too small for this. At least MBP 15" model year 2011 (early and late) were able to switch automatically between AMD 6xxx and Intel HD3000 - imho this should also be possible with a nVidia gpu. 

Share this post


Link to post
Share on other sites

Hi, I have been using your guide on my T420 and W520. All works brilliantly with the HD3000 Intel Graphic.

I would like to us W520 with Nvidia Quadro 1000 however and to do that I need to switch to smbios MacPro5,1. When I change to MacPro5,1 from MBP8.1 I start having problems with sound, screen is freezing when I connect external display.

How can I tweak your guide and config files so that could work with MacPro5,1?

Share this post


Link to post
Share on other sites

Hi my dear hackintosh friends! I've set up my hackintosh on ThinkPad T420 in Nov 2014 and since then it was running perfectly on 10.10.1. I didn't update any kexts and clover settings since then because its my only one working computer and I was afraid to break the system. I have backups of system HD and EFI partitions, but I didn't want to take a risk. Two days ago I decided to update to 10.10.3 because I wanted Photos app. I updated from App Store flawlessly. But today my thinkpad had two kernel panics with unexpected restarts. Both times OS state was kept and after restart I could keep on working, but anyway I don't like it. Please give me an advice how to fix it, what updates are safe to apply to my system. Now I'm using all configuration files and kexts from nov_2014 package.

 

Here is panic report:

 

 

 

Anonymous UUID:       9F26CFA2-D3CC-37A3-5B2C-3789B9FA7D61

 
Thu Jun 18 21:50:36 2015
 
*** Panic Report ***
panic(cpu 0 caller 0xffffff8000417cc2): Kernel trap at 0xffffff800010e058, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0xffffff8120561000, CR3: 0x00000001f31dd042, CR4: 0x00000000000626e0
RAX: 0x0000000000001558, RBX: 0xffffff8120561000, RCX: 0x00000000000002ab, RDX: 0x0000000000001558
RSP: 0xffffff8108b538e8, RBP: 0xffffff8108b53930, RSI: 0xffffff8120561000, RDI: 0xffffff8237cea000
R8:  0x0000000000001600, R9:  0xffffff8237cea000, R10: 0x0000000000100024, R11: 0x0000000000000000
R12: 0xffffff8237cea000, R13: 0x0000000000000300, R14: 0x0000000000001580, R15: 0x0000000000001600
RFL: 0x0000000000010202, RIP: 0xffffff800010e058, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0xffffff8120561000, Error code: 0x0000000000000000, Fault CPU: 0x0
 
Backtrace (CPU 0), Frame : Return Address
0xffffff8108b53590 : 0xffffff800032bda1 
0xffffff8108b53610 : 0xffffff8000417cc2 
0xffffff8108b537d0 : 0xffffff8000434b73 
0xffffff8108b537f0 : 0xffffff800010e058 
0xffffff8108b53930 : 0xffffff7f82218dd6 
0xffffff8108b539f0 : 0xffffff7f82218ac1 
0xffffff8108b53a60 : 0xffffff7f82203a45 
0xffffff8108b53b30 : 0xffffff80009007a6 
0xffffff8108b53b60 : 0xffffff8000901968 
0xffffff8108b53bc0 : 0xffffff80008ff0c3 
0xffffff8108b53d00 : 0xffffff80003e21e7 
0xffffff8108b53e10 : 0xffffff800033000c 
0xffffff8108b53e40 : 0xffffff80003149f3 
0xffffff8108b53e90 : 0xffffff800032531d 
0xffffff8108b53f10 : 0xffffff80004031ea 
0xffffff8108b53fb0 : 0xffffff8000435396 
      Kernel Extensions in backtrace:
         com.apple.driver.AppleIntelHD3000Graphics(10.0)[7697C02A-66BD-38FA-99A0-37A92B43A968]@0xffffff7f821f0000->0xffffff7f82256fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[52E715FC-521D-3869-B2EA-5228FA4BEA34]@0xffffff7f80bb6000
            dependency: com.apple.iokit.IOGraphicsFamily(2.4.1)[82EAD591-67E3-39CB-A232-A8095CA30E92]@0xffffff7f814ca000
 
BSD process name corresponding to current thread: WindowServer
Boot args: slide=0 kext-dev-mode=1 
 
Mac OS version:
14D136
 
Kernel version:
Darwin Kernel Version 14.3.0: Mon Mar 23 11:59:05 PDT 2015; root:xnu-2782.20.48~5/RELEASE_X86_64
Kernel UUID: 4B3A11F4-77AA-3D27-A22D-81A1BC5B504D
__HIB  text base: 0xffffff8000100000
System model name: MacBookPro8,1 (Mac-94245B3640C91C81)
 
System uptime in nanoseconds: 13283647780227
last loaded kext at 81964987208: com.apple.filesystems.msdosfs 1.10 (addr 0xffffff7f8102d000, size 69632)
loaded kexts:
com.tuxera.filesystems.tufsfs.fusefs_txantfs 2013.3.14
com.paragon-software.kext.VDMounter 36.1
com.darwin.driver.ACPIBacklight 2.0.3
org.rehabman.voodoo.driver.PS2Mouse 1.8.13
org.rehabman.voodoo.driver.PS2Trackpad 1.8.13
org.rehabman.voodoo.driver.PS2Keyboard 1.8.13
at.obdev.nke.LittleSnitch 4228
org.hwsensors.driver.LPCSensors 1328
com.insanelymac.driver.AppleIntelE1000e 2.4.14
org.rehabman.voodoo.driver.PS2Controller 1.8.13
org.hwsensors.driver.ACPISensors 1328
org.hwsensors.driver.CPUSensors 1328
org.rehabman.driver.AppleSmartBatteryManager 1.53
org.netkas.driver.FakeSMC 1328
com.apple.filesystems.msdosfs 1.10
com.apple.filesystems.autofs 3.0
com.apple.driver.AudioAUUC 1.70
com.apple.driver.AppleHWSensor 1.9.5d0
com.apple.driver.AGPM 110.19.5
com.apple.driver.AppleTyMCEDriver 1.0.2d2
com.apple.iokit.IOBluetoothSerialManager 4.3.4f4
com.apple.driver.AppleHDAHardwareConfigDriver 272.18
com.apple.driver.AppleHDA 999.99
com.apple.iokit.IOUserEthernet 1.0.1
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.driver.AppleOSXWatchdog 1
com.apple.driver.AppleHWAccess 1
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 999.99
com.apple.driver.AppleSMCPDRC 1.0.0
com.apple.driver.AppleHV 1
com.apple.driver.ApplePolicyControl 3.10.22
com.apple.driver.AppleUpstreamUserClient 3.6.1
com.apple.driver.ACPI_SMC_PlatformPlugin 1.0.0
com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0
com.apple.driver.AppleLPC 1.7.3
com.apple.driver.AppleIntelHD3000Graphics 10.0.0
com.apple.driver.AppleIntelSNBGraphicsFB 10.0.0
com.apple.driver.AppleFIVRDriver 4.1.0
com.apple.driver.AppleMuxControl 3.10.22
com.apple.driver.AppleBacklight 170.7.4
com.apple.driver.AppleMCCSControl 1.2.11
com.apple.iokit.SCSITaskUserClient 3.7.5
com.apple.driver.AppleFileSystemDriver 3.0.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 36
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCIBlockStorage 2.7.1
com.apple.iokit.IOAHCIPassThrough 1.0.3
com.apple.driver.AppleUSBHub 705.4.2
com.apple.driver.AppleFWOHCI 5.5.2
com.apple.driver.AirPortBrcm43224 700.36.24
com.apple.driver.AirPort.Brcm4331 800.20.24
com.apple.driver.AppleAHCIPort 3.1.2
com.apple.driver.AppleUSBEHCI 705.4.14
com.apple.driver.AppleHPET 1.8
com.apple.driver.AppleRTC 2.0
com.apple.driver.AppleACPIButtons 3.1
com.apple.driver.AppleSMBIOS 2.1
com.apple.driver.AppleACPIEC 3.1
com.apple.driver.AppleAPIC 1.7
com.apple.driver.AppleIntelCPUPowerManagementClient 218.0.0
com.apple.nke.applicationfirewall 161
com.apple.security.quarantine 3
com.apple.security.TMSafetyNet 8
com.apple.driver.AppleIntelCPUPowerManagement 218.0.0
com.apple.kext.triggers 1.0
com.apple.AppleGraphicsDeviceControl 3.10.22
com.apple.iokit.IOSerialFamily 11
com.apple.driver.DspFuncLib 272.18
com.apple.kext.OSvKernDSPLib 1.15
com.apple.iokit.IOSurface 97.4
com.apple.iokit.IOFireWireIP 2.2.6
com.apple.iokit.IOBluetoothHostControllerUSBTransport 4.3.4f4
com.apple.iokit.IOBluetoothFamily 4.3.4f4
com.apple.iokit.IOUSBUserClient 705.4.0
com.apple.driver.IOPlatformPluginLegacy 1.0.0
com.apple.driver.AppleHDAController 272.18
com.apple.iokit.IOHDAFamily 272.18
com.apple.iokit.IOAudioFamily 203.3
com.apple.vecLib.kext 1.2.0
com.apple.driver.AppleSMBusPCI 1.0.12d1
com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0
com.apple.driver.IOPlatformPluginFamily 5.9.1d7
com.apple.driver.AppleGraphicsControl 3.10.22
com.apple.driver.AppleBacklightExpert 1.1.0
com.apple.driver.AppleSMC 3.1.9
com.apple.iokit.IONDRVSupport 2.4.1
com.apple.driver.AppleSMBusController 1.0.13d1
com.apple.iokit.IOGraphicsFamily 2.4.1
com.apple.iokit.IOSCSIBlockCommandsDevice 3.7.5
com.apple.iokit.IOUSBMassStorageClass 3.7.2
com.apple.iokit.IOSCSIArchitectureModelFamily 3.7.5
com.apple.driver.AppleUSBMergeNub 705.4.0
com.apple.iokit.IOUSBHIDDriver 705.4.0
com.apple.driver.AppleUSBComposite 705.4.9
com.apple.iokit.IOFireWireFamily 4.5.6
com.apple.iokit.IO80211Family 730.60
com.apple.iokit.IONetworkingFamily 3.2
com.apple.iokit.IOAHCIFamily 2.7.5
com.apple.iokit.IOUSBFamily 720.4.4
com.apple.driver.AppleEFINVRAM 2.0
com.apple.driver.AppleEFIRuntime 2.0
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.iokit.IOSMBusFamily 1.1
com.apple.security.sandbox 300.0
com.apple.kext.AppleMatch 1.0.0d1
com.apple.driver.AppleKeyStore 2
com.apple.driver.AppleMobileFileIntegrity 1.0.5
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.DiskImages 396
com.apple.iokit.IOStorageFamily 2.0
com.apple.iokit.IOReportFamily 31
com.apple.driver.AppleFDEKeyStore 28.30
com.apple.driver.AppleACPIPlatform 3.1
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOACPIFamily 1.4
com.apple.kec.Libm 1
com.apple.kec.pthread 1
com.apple.kec.corecrypto 1.0
Model: MacBookPro8,1, BootROM MBP81.0047.B27, 2 processors, Intel Core i7, 2.79 GHz, 8 GB, SMC 1.68f99
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK0/DIMM0, 4 GB, DDR3, 1333 MHz, Ramaxel Technology, RMT3020EC58E9F1333A
Memory Module: BANK0/DIMM1, 4 GB, DDR3, 1600 MHz, Ramaxel Technology, RMT3160ED58E9W1600A
AirPort: Third-Party Wireless Card
Bluetooth: Version 4.3.4f4 15601, 3 services, 18 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Network Service: Wi-Fi, AirPort, en2
PCI Card: Intel E1000e, Ethernet, PCI Slot 1638400
Serial ATA Device: C400-MTFDDAK128MAM, 128,04 GB
Serial ATA Device: HGST HTS721010A9E630, 1 TB
USB Device: Hub
USB Device: Broadcom Bluetooth Device
USB Device: Integrated Camera
USB Device: Hub
USB Device: USB Optical Mouse
USB Device: USB to ATA/ATAPI bridge
USB Device: Hub
USB Device: Wired Keyboard 600
Thunderbolt Bus: 

 
Thanks in advance and sorry for being such n00b =)

Share this post


Link to post
Share on other sites

@rolitab. well - what is app running at the time that is causing the GFX crash? the backtrace is saying a core gfx HD3000 kext is crashing.

 

you could certainly download the more recent zip bundle. and reinstall the clover and the kexts from that pack. a few of the kexts have been updated since Nov. newer HWMonitor too.

 

I see a few other non-apple things installed. but many don't have any sort of GUI or gfx interaction. perhaps it is the LitleSnitch GUI causing it. or some other app?

 

 

com.tuxera.filesystems.tufsfs.fusefs_txantfs 2013.3.14

com.paragon-software.kext.VDMounter 36.1

com.darwin.driver.ACPIBacklight 2.0.3

org.rehabman.voodoo.driver.PS2Mouse 1.8.13

org.rehabman.voodoo.driver.PS2Trackpad 1.8.13

org.rehabman.voodoo.driver.PS2Keyboard 1.8.13

at.obdev.nke.LittleSnitch 4228

org.hwsensors.driver.LPCSensors 1328

com.insanelymac.driver.AppleIntelE1000e 2.4.14

org.rehabman.voodoo.driver.PS2Controller 1.8.13

org.hwsensors.driver.ACPISensors 1328

org.hwsensors.driver.CPUSensors 1328

org.rehabman.driver.AppleSmartBatteryManager 1.53

org.netkas.driver.FakeSMC 1328

Share this post


Link to post
Share on other sites

I don't think it's LittleSnitch-GUI. I'd guess there was some attempt to patch/modify use vga-out and/or hdmi audio out...

 

You should be able to safe mode (with out graphics kext/only generic graphics) by using additional boot flag "-x", so the reinstallation of the latest kext pack will it easier than doing it via terminal. Maybe deleting kext caches and repairing permissions by running kext utility could help also.

Share this post


Link to post
Share on other sites

hey guys, i installed maverick in my T420 with no problems and i'm using a tp-link tl-wn725n that its working with the app wireless network utility. i have actually one problem and a couple of request, my problem is that i have some random restarts as i have an error:

Anonymous UUID:       9359F3AC-8C70-8A15-A0B1-4CF1FBE350C0

Sat Jun 20 11:04:58 2015
panic(cpu 3 caller 0xffffff8000236a36): "thread_invoke: preemption_level 1, possible cause: blocking while holding a spinlock, or within interrupt context"@/SourceCache/xnu/xnu-2422.110.17/osfmk/kern/sched_prim.c:2231
Backtrace (CPU 3), Frame : Return Address
0xffffff8099c83a20 : 0xffffff8000222f79 
0xffffff8099c83aa0 : 0xffffff8000236a36 
0xffffff8099c83b30 : 0xffffff8000235d5c 
0xffffff8099c83b70 : 0xffffff80002d6370 
0xffffff8099c83bc0 : 0xffffff80002d170d 
0xffffff8099c83be0 : 0xffffff7f80cb7bc2 
0xffffff8099c83c00 : 0xffffff7f821042d2 
0xffffff8099c83c40 : 0xffffff7f80cdd7cd 
0xffffff8099c83d40 : 0xffffff7f8110a103 
0xffffff8099c83e00 : 0xffffff7f8110b9bc 
0xffffff8099c83ea0 : 0xffffff7f8110b9fa 
0xffffff8099c83ec0 : 0xffffff7f81105959 
0xffffff8099c83ef0 : 0xffffff80006b07f0 
0xffffff8099c83f30 : 0xffffff80006af292 
0xffffff8099c83f80 : 0xffffff80006af367 
0xffffff8099c83fb0 : 0xffffff80002d7417 
      Kernel Extensions in backtrace:
         com.apple.iokit.IOUSBFamily(683.4)[7595281D-D047-3715-9044-98F46B62F845]@0xffffff7f80cda000->0xffffff7f80d46fff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[4662B11D-2ECA-315D-875C-618C97CDAB2A]@0xffffff7f808be000
         com.apple.driver.AppleUSBEHCI(660.4)[E0A4E9ED-3D9A-30C8-95F5-6CF0EDE02DCB]@0xffffff7f81102000->0xffffff7f81119fff
            dependency: com.apple.iokit.IOUSBFamily(683.4.0)[7595281D-D047-3715-9044-98F46B62F845]@0xffffff7f80cda000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[4662B11D-2ECA-315D-875C-618C97CDAB2A]@0xffffff7f808be000
         com.apple.iokit.IONetworkingFamily(3.2)[6777EB73-6474-3540-8CAB-B8A1C06D1CD9]@0xffffff7f80ca6000->0xffffff7f80cd9fff
         com.realtek.driver.RTL8188EU(1008.0)[A13B9FF5-795D-3B78-8193-D7D8F7AFE5AA]@0xffffff7f820b3000->0xffffff7f821defff
            dependency: com.apple.iokit.IONetworkingFamily(3.2)[6777EB73-6474-3540-8CAB-B8A1C06D1CD9]@0xffffff7f80ca6000
            dependency: com.apple.iokit.IOUSBFamily(683.4.0)[7595281D-D047-3715-9044-98F46B62F845]@0xffffff7f80cda000

BSD process name corresponding to current thread: kernel_task
Boot args: slide=0 kext-dev-mode=1 

Mac OS version:
13E28

Kernel version:
Darwin Kernel Version 13.3.0: Tue Jun  3 21:27:35 PDT 2014; root:xnu-2422.110.17~1/RELEASE_X86_64
Kernel UUID: BBFADD17-672B-35A2-9B7F-E4B12213E4B8
System model name: MacBookPro8,1 (Mac-94245B3640C91C81)

System uptime in nanoseconds: 8064811643623
last loaded kext at 7091430523853: com.apple.driver.AppleUSBCDC	4.2.1b5 (addr 0xffffff7f821df000, size 20480)
last unloaded kext at 7223247344229: com.apple.driver.AppleIntelMCEReporter	104 (addr 0xffffff7f820a7000, size 32768)
loaded kexts:
com.realtek.driver.RTL8188EU	1008
com.darwin.driver.ACPIBacklight	2.0.3
org.rehabman.voodoo.driver.PS2Trackpad	1.8.14
org.rehabman.voodoo.driver.PS2Keyboard	1.8.14
com.insanelymac.IntelMausiEthernet	2.0.0
org.hwsensors.driver.ACPISensors	1364
org.rehabman.voodoo.driver.PS2Controller	1.8.14
org.hwsensors.driver.CPUSensors	1364
org.rehabman.driver.AppleSmartBatteryManager	1.55
org.netkas.driver.FakeSMC	1364
com.apple.filesystems.autofs	3.0
com.apple.driver.AppleHWSensor	1.9.5d0
com.apple.driver.AudioAUUC	1.60
com.apple.iokit.IOBluetoothSerialManager	4.2.6f1
com.apple.driver.AGPM	100.14.28
com.apple.iokit.IOUserEthernet	1.0.0d1
com.apple.driver.AppleHDA	999.99
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport	4.2.6f1
com.apple.driver.ApplePolicyControl	3.6.22
com.apple.driver.AppleUpstreamUserClient	3.5.13
com.apple.driver.AppleSMCPDRC	1.0.0
com.apple.driver.AppleHWAccess	1
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleMCCSControl	1.2.5
com.apple.driver.AppleLPC	1.7.0
com.apple.driver.AppleIntelHD3000Graphics	8.2.4
com.apple.driver.AppleIntelSNBGraphicsFB	8.2.4
com.apple.iokit.SCSITaskUserClient	3.6.6
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeLZVN	1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0d1
com.apple.BootCache	35
com.apple.driver.XsanFilter	404
com.apple.iokit.IOAHCIBlockStorage	2.6.0
com.apple.driver.AppleUSBHub	683.4.0
com.apple.driver.AppleFWOHCI	5.0.2
com.apple.driver.AppleAHCIPort	3.0.5
com.apple.driver.AppleUSBEHCI	660.4.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleACPIButtons	2.0
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleACPIEC	2.0
com.apple.driver.AppleAPIC	1.7
com.apple.driver.AppleIntelCPUPowerManagementClient	217.92.1
com.apple.nke.applicationfirewall	153
com.apple.security.quarantine	3
com.apple.driver.AppleIntelCPUPowerManagement	217.92.1
com.apple.kext.triggers	1.0
com.apple.AppleGraphicsDeviceControl	3.6.22
com.apple.iokit.IOSurface	91.1
com.apple.driver.DspFuncLib	2.6.3f4
com.apple.vecLib.kext	1.0.0
com.apple.iokit.IOAudioFamily	1.9.7fc2
com.apple.kext.OSvKernDSPLib	1.14
com.apple.iokit.IOBluetoothFamily	4.2.6f1
com.apple.iokit.IOBluetoothHostControllerUSBTransport	4.2.6f1
com.apple.driver.AppleGraphicsControl	3.6.22
com.apple.iokit.IOFireWireIP	2.2.6
com.apple.driver.AppleHDAController	2.6.3f4
com.apple.iokit.IOHDAFamily	2.6.3f4
com.apple.driver.Apple16X50Serial	3.1
com.apple.iokit.IOSerialFamily	10.0.7
com.apple.driver.AppleSMBusPCI	1.0.12d1
com.apple.driver.AppleSMC	3.1.8
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.driver.AppleSMBusController	1.0.12d1
com.apple.driver.IOPlatformPluginFamily	5.7.1d6
com.apple.iokit.IONDRVSupport	2.4.1
com.apple.iokit.IOGraphicsFamily	2.4.1
com.apple.driver.AppleUSBComposite	656.4.1
com.apple.iokit.IOSCSIMultimediaCommandsDevice	3.6.6
com.apple.iokit.IOBDStorageFamily	1.7
com.apple.iokit.IODVDStorageFamily	1.7.1
com.apple.iokit.IOCDStorageFamily	1.7.1
com.apple.iokit.IOAHCISerialATAPI	2.6.1
com.apple.iokit.IOSCSIArchitectureModelFamily	3.6.6
com.apple.iokit.IOFireWireFamily	4.5.5
com.apple.iokit.IOUSBUserClient	660.4.2
com.apple.iokit.IONetworkingFamily	3.2
com.apple.iokit.IOAHCIFamily	2.6.5
com.apple.iokit.IOUSBFamily	683.4.0
com.apple.driver.AppleEFINVRAM	2.0
com.apple.driver.AppleEFIRuntime	2.0
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.iokit.IOSMBusFamily	1.1
com.apple.security.sandbox	278.11.1
com.apple.kext.AppleMatch	1.0.0d1
com.apple.security.TMSafetyNet	7
com.apple.driver.AppleKeyStore	2
com.apple.driver.DiskImages	371.1
com.apple.iokit.IOStorageFamily	1.9
com.apple.iokit.IOReportFamily	23
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleACPIPlatform	2.0
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.pthread	1
com.apple.kec.corecrypto	1.0
Model: MacBookPro8,1, BootROM MBP81.0047.B27, 2 processors, Intel Core i5, 2.49 GHz, 4 GB, SMC 1.68f99
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 384 MB
Memory Module: BANK0/DIMM0, 4 GB, DDR3, 1333 MHz, Samsung, M471B5273CH0-CH9
Bluetooth: Version 4.2.6f1 14216, 3 services, 15 devices, 1 incoming serial ports
PCI Card: Intel 82579LM PCI Express Gigabit Ethernet, Ethernet, PCI Slot 1638400
Serial ATA Device: HITACHI HTS723232A7A364, 320.07 GB
Serial ATA Device: HL-DT-STDVDRAM GT33N
USB Device: Hub
USB Device: Broadcom Bluetooth Device
USB Device: Integrated Camera
USB Device: Hub
USB Device: 802.11n NIC
USB Device: Integrated Smart Card Reader
Thunderbolt Bus: 

that's the biggest problem, my secondary questions are about how to upgrade to osx 10.9.5 and have a working app store... thank you in advice

Share this post


Link to post
Share on other sites

@filfromearth

1) USB WIFI

well you can try to use usb/wifi kexts that are a little newer. the link below might work for as they seem to support RTL8188-RTL8192 - i have 3 different USB wifi sticks that this driver set works. download v2.0.1.

http://support.asus.com/Download.aspx?SLanguage=en&m=USB-N10&p=11&s=1

 

2) i am not sure what this issue is all about -  app store is not working.  but maybe you don't have your ethernet device as en0? and wifi and en1

I just posted a new zip bundle today - and fixed the install scripts.  so you can open you system preferences and remove your network devices. and then run _post_install_network_reset.bash script (in the /EFI/CLOVER/kexts/Other folder) (assumes you put the kexts in /S/L/E and in particular InterMausiEthernet.kext 

Share this post


Link to post
Share on other sites

You can run the combo update, but patched kexts in S/L/E maybe overwritten by newer versions of the Apple stock kext. So you will have to reinstall them.

 

When updating from 10.10.0 to 10.10.3 (and to 10.10.4beta) via AppStore there where no kexts to reinstall or something to worry about like doing some stuff before a restart.

 

Good luck!

Share this post


Link to post
Share on other sites

just to reiterate... with this new kext scheme i.e. the custom kext installed from the zip (that use links to standard AppleHDA and Bluetooth kexts), there should be no need to reinstall kexts once you have them installed in /S/L/E - regardless of whether you use a combo/update or you create/use a full installer. So again assuming have installed all the custom kexts into /S/L/E, you can even use the app store to download and update from 10.9.x to 10.9.5 or from 10.9.x to 10.10.x - all without reinstalling any custom kexts. kinda works just like a mac :)

Share this post


Link to post
Share on other sites

ok i solved 2 problems on 3. app store is working and i'm currently running 10.9.5 with no problems! the only problem is that i still have this random restarts, i think it may be a kext conflict or something like that

Share this post


Link to post
Share on other sites

@filfromearth - glad to hear it. hmm haven't had any randomness like that in a long time. But I have been on Yosemite since last fall so may you want test 10.10.x out . 10.10.4 beta has been very solid for me. maybe reseat memory for the heck of it.

Share this post


Link to post
Share on other sites

@downlord - glad hear it was smooth! Yosemite is pretty solid these days and the upgrade is seamless! as soon as 10.10.4 is finished (i have been running the public beta 10.10.4 for awhile without issue) I plan to update the zip bundle with the latest Clover and slightly newer FakeSMC/HWSensor pieces.

 

Working smooth, thank you for you work. I'm now trying HW optimization, got already a msata SSD and waiting for a new wifi adapter. Using the modded 1.46 BIOS, I had to turn off the Security features to get rid of 5 beeps on bootup. Maybe when I have some time I get into the BIOS mods and can disable the annoying warning that I'm a bad guy.

 

 

@downlord I remember the painful installation of Lion on the T60p - EDID hardcoding, hex editing the radeon.kext and still some glitches left...

 

"Painful" is a very gentle description. I finally gave up on Lion, but had a very stable 10.6.8 system, using just evoenabler and stock graphic kexts (some plist tampering though). The only problem was that

mozilla's last versions crashed some GL framework, so it was more and more a problem of security. But I believe that spending just some nights more, and maybe with Clover 

combined with evoenabler we would have got there.

Share this post


Link to post
Share on other sites

Hi guys, 

First thanks to tluck for the wonderful guide. I'm running 10.10.3 on a T420 successfully with a BIOS whitelist. I swapped out the Intel Wifi for a Dell DW1510 purchased off ebay. However, even though the card is detected in OSX and Windows, it fails to detect any networks on the T420 or a T410 (also BIOS whitelist) I also have. Is there any additional steps I need to take to make the card work or is it borked? I have tried turning the card on through Lenovo's Access software to no success. 

Share this post


Link to post
Share on other sites

There are some problems with BCM94322 based half mini pcie cards, but toleda provides a fix on github Maybe using these kexts/patches will fix your problem...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MikixIT
      Ciao ragazzi! Grazie a questo forum con gente fantastica, sono riuscito a installare OS X e in seguito Win 10 su Clover SULLO STESSO HARD DISK
      Ho un problema, di solito utilizzo Kali Linux, la famosa versione di linux in usb in live
      Ora avrei la necessita di dedicargli 15gb di partizione del mio Hard Disk PER INSTALLARLA, e l'ho fatto effettivamente creando una partizione VUOTA tramite utility disco di Sierra.
      Il problema sorge quando io vado a riavviare il pc e quindi ritrovandomi nella schermata di clover, e vedo sempre il solito OSX e il recovery Osx e al posto di Windows 10, mi trovo la partizione di 15gb che avevo creato per windows(con l'icona di windows)
      Siccome ho paura di perdere i dati importanti che avevo su windows, non ho continuato installando Kali, ma mi sono fermato e ho eliminato la partizione sempre da utility di Sierra e come per magia, riavvio e Win10 è di nuovo lì dove dovrebbe stare
      Appena creo la partizione vuota, clover me la sostituisce
      Che devo fare raga?
      Io voglio OSX,Win10 (Che già ho) e Kali(Solo 15gb) sullo stesso hard disk
      Senza perdere dati di Win o Mac
      Gengik ho visto in precedenti discussioni tue, di andare in GUI da clover config . e togliere Windows da quelli nascosti e l'ho fatto, ma il risultato non cambia.
      Grazie per la lettura
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
    • By thomaspetersen
      Hi All
       
      I'm trying to start a Hackintosh High Sierra 10.13.5 installation:
      - MSI B350 PC Mate
      - Ryzen 5 - 2600
      - Radeon Pro 580 GPU
      - 4 x 8GB DDR4
      (Have a working clover bootloader for HS 10.13.3 - but for some reason, I can't use that setup with the 10.13.5) 
       
      Have tried different bootloader setup, with different outcomes...
      ATM. I get this error/hang - "Unknown CPU: family = 0x17, model = 0x8, Stepping = 0x2"
      Have search google, and can see that the threads ppl. are getting this, is when they look at "About this mac", I haven't yet installed the OSX.
       
      So can someone help...

      I'm running the newest Kexts: AppleALC, FakeSMC, Lilu, RealtekRTL8111, USBInjectAll and WhateverGreen.
      In Bootloader setup, i'm running: -v, -s, -f, -no_compat_check, busratio=34, PCIRootUID=1, npci=0x2000, dart=0 and nv_disable=1
      In SMBIOS i'm using the iMac18,2 and in RT i'm using BooterConfig: 0x28 and CsrActiveConfig: 0x67
      In installed drivers i'm using: AptioMemoryFix, EmuVariableUefi-64, OsxAptioFixDrv-64 (Have tried Fix2 as well)
       
      But i'm, keep getting the Unknown CPU hang/error, can someone help...
      Or do someone have a setup with the same CPU and GPU, that can show me his/her setup for Bootloader/Kexts...
    • By Teress
      I get a lot of questions about HOW TO BACKUP A HACKINTOSH. So I decided to create Complete Guide with 5 methods described in detail, how to easily make bootable clones of Hackintosh system disks, or backup your data. Full step by step tutorial is here:
       
       
×