Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,544 posts in this topic

Recommended Posts

@ag6952563 - If you are using Clover r1597 in old folder structure, this can only mean that developers made Clover backwards compatible - interesting.

Anyways if you plan to still use chameleon - keep your kexts in /S/L/E (cause those injected by Clover won't be loaded). But I suggest you to move all your custom kexts from /S/L/E to /E/E and use myHack to deal with installing custom kexts, rebuilding system and kernel caches, fixing permissions etc.

I'm guessing that tluck is using "CLOVER/kexts/10.8" folder to share his custom kexts with others but he still have them installed in /S/L/E, cause not all kexts can be injected by Clover (and work). As for default partition for booting you can set it just like on normal mac using System preferences > Startup disk but for this to work nvram.plist file is needed cause we are using EmuVariableUefi-64.efi driver for settings storage (just install clover rc-scripts).

I'll soon finish my latest Clover custom build that will install config files compatible with our lenovos, themes, drivers, rc-scripts, etc. Stay tuned.

 

@all - I was thinking about adding custom OEM folders. For those that have HD (not HD+) displays that need DualLink = 0 or t420s series that have USB3 or maybe other models like x220, t520 etc. I just need people with supported hardware to step in and share details about their setup (what is different from t420, what needs to be added/removed). We could make one Combo EFI package that will work for all UEFI enabled ThinkPads.

 

UPDATE: I have just finished my custom build mentioned above (no OEM folders yet -actualy there is one for 4180A32 that includes dsdt and ssdt from tluck). This one is based on Clover r1625 and has all the stuff Lenovo UEFI user needs. This one is enabled to install to ESP by default with ThinkPad Theme and RC scripts. User has choice to install Clover Preference PaneI and Optional RC scripts. I have modified touchpad driver default pseudo-multigestures actions as follows:

4 fingers down - shows desktop (F11)

4 fingers up - shows mission control (Ctrl + Up)

4 fingers right - shows widgets (Ctr + Left)

4 fingers left - shows fullscrean apps (Ctrl + Right)

Again this one is for HD+ LCD by default - so HD (low res.) users change DualLink from 1 to 0 in config.plist

post-112035-0-29947700-1368404003_thumb.pngpost-112035-0-53522000-1368404018_thumb.pngpost-112035-0-60204500-1368404031_thumb.pngpost-112035-0-56752300-1368404042_thumb.png

Clover_v2_r1625k0.pkg.zip

Edited by Kogen Mantis

Share this post


Link to post
Share on other sites
Advertisement

Hey guys! Clover sounds amazing, especially with the elimination of graphics hangs. I actually have a couple of questions regarding how to get a working Clover + 10.8.3 working. Right now I'm using Chameleon and 10.8.3 with tluck's kext pack. Does booting with UEFI decrease boot time? Does Clover use kexts? If I were to do a clean install with Clover, will using a UniB34st USB work (instead of a Lion DiskMaker USB)? Actually, is anyone willing to type up very detailed step-by-step instructions on how to do this from the beginning? I'm just a bit confused as to where to place all the files you guys have kindly uploaded. Lastly, is there some sort of updated pack for all of this? The Combo EFI package Kogen describes sounds great. Thanks for working on all of this, everyone.

Share this post


Link to post
Share on other sites

regarding directory structure. Clover expects to find stuff in /EFI/CLOVER as of build 1287 or something close to that. i would try to make that work as that is consistent with the installer etc.

/EFI/BOOT

/EFI/CLOVER

/EFI/Microsoft

 

 

Personally, I just kept the same structure as i had with chameleon - so i put custom kexts in /S/L/E as i dont use the myHack method of merging /E/E and /S/L/E . Clover does not use or read anything from /Extra. but i can see the merit of the myhack method. but yes you want to have the custom kexts in OSX (i.e. /S/L/E) vs EFI so you can boot from the cached versions. Clover is a faster boot - from Clover GUI to login prompt is like 15-20 seconds.

 

clover looks for /EFI/CLOVER/OEM/<PRODUCTMODEL> for your model specific files: config.plist and other stuff like dsdt.aml ssdt.aml etc.

if it cant find OEM, then it uses /EFI/CLOVER/config.plist. kogen is correct. i keep a copy of the custom kexts in /EFI/CLOVER/kexts/10.8.

This allows it to boot a vanilla install of 10.8.3 (this config.plist has extra options - WithKexts NoCaches) clover injects these (custom) kexts from the EFI partition in first and then any dupes in /S/L/E are ignored. since this very slow booting - i dont use these options for my production OSX.

 

@honeywell. it is really pretty simple frankly given you have a working hack on chameleon.

 

make sure bios is set to use UEFI boot.

format disk GUID

install or copy OSX to disk0s2 (2nd partition).

install clover stuff in EFI (1st partition). kogens installer is very easy to use. however, his dsdt.aml did not work for me. so i just used what i was using before.

 

Note: i have packaged and posted my /EFI/CLOVER folder - see #115 to offer some alternatives - which include tweaks to config.plist that i found make my box work better. i find that clover does not compute C-states or clockspeed for my box well. so i reverted to ssdt.aml and override busspeed etc.

Share this post


Link to post
Share on other sites

@honeywell - we won't support software you are mentioning so I suggest you use Lion DiskMaker (it's nice and easy - just like on real mac). I'll update first post soon to reflect changes and interesting info found in this thread. But in general the steps you need to take is:

1. Create install media using Lion DiskMaker

2. Use my custom Clover pkg to install Clover on install media

3. Boot from prepared pen-drive and install OS X

4. Repeat step 2 this time pointing to your hard drive

5. Start making your CLOVER/OEM/<PRODUCTMODEL> based on 4180A32

6. Install missing kexts using myHack (Sound, Battery, ACPI-1.3.5 and others if you need them)

 

@tluck - actually the new installer includes your dsdt and ssdt. I didn't have time to touch my dsdt and because yours works for others I've decided to use it :)

Share this post


Link to post
Share on other sites

regarding directory structure. Clover expects to find stuff in /EFI/CLOVER as of build 1287 or something close to that. i would try to make that work as that is consistent with the installer etc.

/EFI/BOOT

/EFI/CLOVER

/EFI/Microsoft

 

 

Personally, I just kept the same structure as i had with chameleon - so i put custom kexts in /S/L/E as i dont use the myHack method of merging /E/E and /S/L/E . Clover does not use or read anything from /Extra. but i can see the merit of the myhack method. but yes you want to have the custom kexts in OSX (i.e. /S/L/E) vs EFI so you can boot from the cached versions. Clover is a faster boot - from Clover GUI to login prompt is like 15-20 seconds.

 

clover looks for /EFI/CLOVER/OEM/<PRODUCTMODEL> for your model specific files: config.plist and other stuff like dsdt.aml ssdt.aml etc.

if it cant find OEM, then it uses /EFI/CLOVER/config.plist. kogen is correct. i keep a copy of the custom kexts in /EFI/CLOVER/kexts/10.8.

This allows it to boot a vanilla install of 10.8.3 (this config.plist has extra options - WithKexts NoCaches) clover injects these (custom) kexts from the EFI partition in first and then any dupes in /S/L/E are ignored. since this very slow booting - i dont use these options for my production OSX.

 

@honeywell. it is really pretty simple frankly given you have a working hack on chameleon.

 

make sure bios is set to use UEFI boot.

format disk GUID

install or copy OSX to disk0s2 (2nd partition).

install clover stuff in EFI (1st partition). kogens installer is very easy to use. however, his dsdt.aml did not work for me. so i just used what i was using before.

 

Note: i have packaged and posted my /EFI/CLOVER folder - see #115 to offer some alternatives - which include tweaks to config.plist that i found make my box work better. i find that clover does not compute C-states or clockspeed for my box well. so i reverted to ssdt.aml and override busspeed etc.

 

Thanks tluck, Kogen.

You are right about the structure, the new release is looking into /EFI/CLOVER. Since I tried different things, I ended up installing an older version of CLOVER, and that's why it was using the old file structure. I reinstalled the latest version, and indeed, it looks at /EFI/CLOVER.

 

Regards,

AJ

Share this post


Link to post
Share on other sites

Hello I have install on my Lenovo T420 with 1366x768 pixel screen (Product ID: 4236JY2) OS X 10.8.3

I have use your last tutorial @Kogen message : #155

I Have rename my /EFI/CLOVER/OEM/4236JY2 and i have changed DualLink from 1 to 0 in config.plist

All work except I have a screen problem (i have 4 Screen on the desktop)

Did you have a solution ?

 

Sorry for my English i'm French

Share this post


Link to post
Share on other sites

@360game360

 

do you know to edit the dsdt.aml? the one packaged has DualLink set to 1

 

change 0x01 to 0x00 or remove this section in red.

 

 

Device (IGPU)

{

Name (_ADR, 0x00020000)

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0C)

{

"AAPL00,DualLink",

Buffer (0x04)

{

0x01, 0x00, 0x00, 0x00

},

PS votre anglais est plus meilleur que mon français!

 

 

@kogen - perhaps DualLink should be removed from dsdt.aml, and let people set this config.plist?

Share this post


Link to post
Share on other sites

@360game360

 

do you know to edit the dsdt.aml? the one packaged has DualLink set to 1

 

change 0x01 to 0x00 or remove this section in red.

 

 

Device (IGPU)

{

Name (_ADR, 0x00020000)

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0C)

{

"AAPL00,DualLink",

Buffer (0x04)

{

0x01, 0x00, 0x00, 0x00

},

PS votre anglais est plus meilleur que mon français!

 

 

@kogen - perhaps DualLink should be removed from dsdt.aml, and let people set this config.plist?

tluck dsdt.aml with duallink to 0

can be found here :

 

 

<key>DualLink</key>

<string>0</string> in config

all thnaks to tluck

 

some OEM

may be use by

Kogen Mantis' installer :)

 

dsdt.aml is tluck production :)

Share this post


Link to post
Share on other sites

@tluck - Yes I was thinking about the same thing. Now that Clover is doing DualLink patching for us we don't need it in dsdt.aml. I'll change that in the next release.

 

BTW: how should we call the Installer?

 

- ThinkPad EFI Pack

- Clover for ThinkPads

- Clover ThinkPad Edition

- other? (add your suggestions)

Share this post


Link to post
Share on other sites

Good Idea for

Clover EFI ThinkPad Edition

 

 

Thanks to @Kogen,@Tluck and Tetonne my screen work good now

I've install Kext Blutooth by Tetonne with Kext Wizard But my Bluetooth doesn't work :/ I can't activate with Fn + F5 and i didn't show on the panel bluetooth :/

 

and my Imessage doesn't work too i have a connection impossible

 

My config.plist on EFI/Clover/OEM/4236JY2 :

 

 

 

<dict>

<key>BiosReleaseDate</key>

<string>04/22/11</string>

<key>BiosVendor</key>

<string>Apple Inc.</string>

<key>BiosVersion</key>

<string>MBP81.88Z.0047.B0E.1104221557</string>

<key>BoardSerialNumber</key>

<string>CMX77JGTPUT354126</string>

<key>Manufacturer</key>

<string>Apple Inc.</string>

<key>ProductName</key>

<string>MacBookPro8,1</string>

<key>SerialNumber</key>

<string>CMX77JGTPUT354126</string>

<key>Version</key>

<string>1.0</string>

</dict>

<key>SystemParameters</key>

<dict>

 

Thank you in advance I shall like I can pay you a beer so much your help is precious

Share this post


Link to post
Share on other sites

@360game360 - bluetooth works OOB you just need to activate it using Linux or Windows. I have used latest ubuntu for that.

As for iMessage make sure your ethernet is en0 also try adding MLB full (17 digit) number in RtVariables to config.plist

 

@all - slightly updated first post.

Share this post


Link to post
Share on other sites

Hi Kogen-

What do the RC scripts do if you install them with Clover?

 

Thanks,

AJ

RC scripts are quite important, especially for us UEFI users. Essential are:

rc.local - is responsible for saving boot.log and mounting EFI partition

rc.shutdown.local deals with storing nvram settings

 

You can add your custom scripts with actions like: fixing permissions, patching kexts like AppleHDA, etc

Share this post


Link to post
Share on other sites

Thanks Kogen.

 

One more question, when upgrading Clover, I normally just copy to my EFI partition the BOOT folder. Should I also replace other files or folders? Like CLOVERIA32.efi, CLOVERX64.efi, and folders like drivers64UEFI, etc?

Share this post


Link to post
Share on other sites

@ag6952563- Clover installer will automatically install what it needs in your EFI system partition (ESP). it will mount /Volumes/ESP and copy the stuff in if you select the checkbox at the top. (Note: i uncheck themes since i use ThinkPad)

 

i then remove *32* from /EFI/BOOT and /EFI/CLOVER /EFI/CLOVER/tools

 

i use these options:

post-954945-0-91942100-1370356432_thumb.png

 

then if i look at /Volumes/ESP i have this:

 

 

$ cd /Volumes/ESP/EFI

$ ls -1 .

 

APPLE

BOOT

CLOVER

Microsoft

 

 

$ ls -1 BOOT CLOVER

BOOT:

BOOTX64.efi

 

CLOVER:

ACPI

CLOVERX64.efi

OEM

config.plist

doc

drivers64UEFI

kexts

misc

refit-default.conf

refit.conf

themes

tools

Share this post


Link to post
Share on other sites

Hi again-

Today I went to software update, and I see there is a new update for "Thunderbolt Firmware Upgrade 1.0".

Did you guys get this update? It's firmware... Should I install it?

 

Thanks,

AJ

Share this post


Link to post
Share on other sites

@AJ -

 

i just hid the thunderbolt FW upgrade - there isn't an SMC to actually update!

 

@all -

 

btw, if anyone moves up to the Clover ~1654+, they merged refit.conf into config.plist and the theme settings.conf became theme.plist.

 

Note: GUI section in config.plist for OEM\<product> - and then theme.plist for ThinkPad.

 

this is example for i5-2520m and 1600x900 LCD (injects EDID)

- change speeds freqs, as well the name of your default Volume.

if you have low res LCD remove/replace the EDID and change DualLink to 0.

 

See post #174

Share this post


Link to post
Share on other sites

Automatic Config.plist Generator (thanks to Slice)

 

 

You have to boot with Clover rev.1672+ with some minimum config.plist then type in terminal

 

./getconfig >config.plist

 

Then look into and think about.

GetCloverConfig.zip

Share this post


Link to post
Share on other sites

Hi guys-

I still have some issues with sleep/shutdown with my new UEFI setup.

Sometimes, the laptop does not go to sleep or even shutdown. For shutdown, since I have verbose boot, I see the daemons are killed, the cpu halted, but the power button stays on and the bluetooth light is also on... and it doesn't shut down. I assume it is the same issue when going to sleep.

Also, when it does go to sleep, I have noticed the touchpad is not working after resuming... but I guess this is a different issue.

 

Any ideas?

 

Thanks,

AJ

Share this post


Link to post
Share on other sites

@AJ - i have seen this same thing from time to time. sometimes the system will shutdown cleanly all the way to everything off. and sometimes it will shutdown OSX and then the laptop has a blackscreen with powerlight on.

 

@tetonne - i updated to r1690 and tried the genconfig. pretty cool. shows a lot of keys that one may not know about!

 

 

Note: Now that I trust Clover ;) I replaced the AppleRTC.kext and AppleIntelCPUPowerManagement.kext with the vanilla versions and let clover do the work! i still have other some other modified kexts in /S/L/E but that is 2 less to worry about!

 

here is what i am using now... I trimmed out some of the extra variables so its easier to see what is set and what is not.

OEM/4236AT9 config.plist:

 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
       <key>ACPI</key>
       <dict>
               <key>DropOemSSDT</key>
               <true/>
               <key>FixDsdtMask</key>
               <string>0x0000</string>
               <key>GenerateCStates</key>
               <false/>
               <key>GeneratePStates</key>
               <false/>
       </dict>
       <key>CPU</key>
       <dict>
               <key>BusSpeedkHz</key>
               <string>99700</string>
               <key>Comment</key>
               <string>i5 2520m</string>
               <key>CpuFrequencyMHz</key>
               <string>2500</string>
               <key>Turbo</key>
               <true/>
       </dict>
       <key>GUI</key>
       <dict>
               <key>DefaultBootVolume</key>
               <string>OSX+</string>
               <key>Mouse</key>
               <dict>
                       <key>DoubleClick</key>
                       <integer>500</integer>
                       <key>Enabled</key>
                       <true/>
                       <key>Speed</key>
                       <integer>8</integer>
               </dict>
               <key>ScreenResolution</key>
               <string>960x600</string>
               <key>Theme</key>
               <string>ThinkPad</string>
               <key>Timeout</key>
               <integer>8</integer>
               <key>Volumes</key>
               <dict>
                       <key>Legacy</key>
                       <false/>
               </dict>
       </dict>
       <key>Graphics</key>
       <dict>
               <key>Comment</key>
               <string>LCD 1600x900</string>
               <key>CustomEDID</key>
               <data>
               AP///////wAw5OICAAAAAAAUAQOAHxF4CkNFl1lXjighUFQAAAABAQEBAQEB
               AQEBAQEBAQEBgCVAgGCEGjAwIDUANq4QAAAZAAAAAAAAAAAAAAAAAAAAAAAA
               AAAA/gBMRyBEaXNwbGF5CiAgAAAA/gBMUDE0MFdEMi1UTEIxADg=
               </data>
               <key>DualLink</key>
               <string>1</string>
               <key>GraphicsInjector</key>
               <true/>
               <key>InjectEDID</key>
               <true/>
       </dict>
       <key>KernelAndKextPatches</key>
       <dict>
               <key>AppleRTC</key>
               <true/>
               <key>AsusAICPUPM</key>
               <true/>
               <key>Debug</key>
               <false/>
               <key>Comment</key>
               <string>Replace 4th port with VGA</string>
               <key>KextsToPatch</key>
               <array>
                       <dict>
                               <key>Find</key>
                               <data>
                               AQIEABAHAAAQBwAABQMAAAIAAAAwAAAAAgUAAAAEAAAH
                               AAAAAwQAAAAEAAAJAAAABAYAAAAEAAAJAAAA
                               </data>
                               <key>Name</key>
                               <string>AppleIntelSNBGraphicsFB</string>
                               <key>Replace</key>
                               <data>
                               AQIEABAHAAAQBwAABQMAAAIAAAAwAAAAAgUAAAAEAAAH
                               AAAAAwQAAAAEAAAJAAAABgIAABAAAAAJAAAA
                               </data>
                       </dict>
               </array>
       </dict>
       <key>PCI</key>
       <dict>
               <key>InjectClockID</key>
               <true/>
               <key>USBFixOwnership</key>
               <true/>
               <key>USBInjection</key>
               <true/>
       </dict>
       <key>SMBIOS</key>
       <dict>
               <key>Trust</key>
               <true/>
       </dict>
       <key>SystemParameters</key>
       <dict>
               <key>InjectSystemID</key>
               <true/>
               <key>boot-args</key>
               <string>slide=0</string>
               <key>prev-lang:kbd</key>
               <string>en:0</string>
       </dict>
</dict>
</plist>

Share this post


Link to post
Share on other sites

Thansk tluck. Can you please post the 2 Vanilla kexts? I only have the patched ones, and I cannot find them in the 10.8.2 or 10.8.3 combo updates... I guess they have not changed.

Or, do you know where I can get them?

 

Update: I guess in the 10.8 install iso if they have not changed. Sorry, you can see how the mind of a amateur works... how I make important deductions with the passing of time... hehe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By Slice
      Since rev 4844 Vector Themes are supported and there are ready-to-use Clovy by Clovy, cesium by Slice and BGM_SVG by Blackosx.
      You may see it's structure to create own theme
      -------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
      What application in macOS can create SVG graphics?
      Inkscape is not working in macOS 10.11+. Pity.
      LibreOffice Draw works with SVG but buggy.
      Boxy SVG cost 10$ but looks good enough. It creates the best in simplicity files and have more then enough features.
      Illustrator is good but expensive.
       
      How to improve SVG file?
      Clover has restricted support for SVG. It is your job to make compatible file and as small as possible to speedup rendering.
      Some helps:
      Help:Inkscape – From invalid to valid SVG Inkscape files
      From invalid to valid SVG Adobe Illustrator files
      From invalid to valid SVG files of other editors: BKchem, ChemDraw and CorelDRAW
      Help:Illustrator – Assistance with creating and saving SVG images in Adobe Illustrator that will pass W3C validation
      User:Quibik/Cleaning up SVG files manually
      Later I will write own instructions specific to Clover abilities.
       
      How to create SVG fonts?
      You can google to find ready-to-use SVG fonts.  I found some problems with too beaty fonts: slow rendering and overflow crash. Be careful.
      You can get ttf or otf fonts and convert them into svg by using online WEB services. Not a problem to google.
      But then I want to find a way to simplify the font to reduce a size and speedup rendering.
      You can create own font by FontForge It is opensource and available for Windows, Mac and GNU+Linux. It creates otf font which you can convert to svg font.
       
      Pictures from Badruzeus
      https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=301597
    • By ludufre
      Installing macOS Mojave on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      02/05/2019 18:47h GMT-0
      - Updated info about CPU replacement and 4G LTE modem.
       
      02/04/2019 15:24h GMT-0
      - Sometimes the VoodooHDA.kext doesn't work.
      - Added AppleHDADisabler.kext to fix that (attached bellow).
       
      01/24/2019 14:42h GMT-0
      - Added more adjustments to use of VoodooHDA.
      - Updated VoodooHDA links to 2.9.1 official (without installer).
      - Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)
      - Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).
      - Updated config.plist (Changed to user Audio layout to 1).
       
      01/22/2019 20:47h GMT-0
      - I gave up on the AppleALC.
      - Headset does not work.
      - Now with VoodooHDA is perfect and the sound even louder.
       
      01/22/2019 14:37h GMT-0
      - Add info about update 10.14.3. 
       
      01/22/2019 13:46h GMT-0
      - Add link to BIOS reassing guide.
       
      01/20/2019 11:49h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible)
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       

      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP and I have overheating issues)
      - Replace touchpad with T460 model (Ordered. It's on the way)
      - Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ) Done, but not work. Do not even recognize in LSPCI...
      - Upgrade to 16GB RAM Done
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the RehabMan's CloverEFI fork (used 4701) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop.
      - Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below
                    If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip
                    If no, then use 32MB_DRAM-prealloc_config.plist.zip
      - Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.3.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915.
      - Download the VoodooPS2Controller.kext from here. I used version 2018-1008.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.
      - Download the Lilu.kext from here. I used the version 1.3.1.
      - Download the AppleALC.kext from here. I used the version 1.3.4.
      - Download the VoodooHDA from here. I used the version 2.9.1.
      - Download the WhateverGreen.kext from here. I used the version 1.2.6.
      - Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (In addition to removing the whitelist, add the advanced menu);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      Soon, I'll provide step by step in this process. Probably until end of this week.
      In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.
      I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.
      - Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.
       
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.3
       
      - Updated with success;
      - Everything works perfectly after reboot;
       

       
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.
       
       
       
       
       
       
      32MB_DRAM-prealloc_config.plist.zip
      128MB_DRAM-prealloc_config.plist.zip
      SSDT-L440.aml
      VoodooHDA.kext.zip
      AppleHDADisabler.kext.zip
×