Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

4,865 posts in this topic

Recommended Posts

 

Report: I've done changes you've recommended and sound is working. Thanks! Also I have change IOBluetoothFamily.kext with Product ID and Vendor ID of T530 bluetooth card and bluetooth now is working as well.
 
However I've faced problem with iMessage. I had making tests with changing of the hardware UUID and serial number and after tests the iMessages stoped working. Cannot activate account "Apple ID "can't be used to set up iMessage at this time"". Is any solution or recommedations for that?

 

I am not complete sure, but what, what I have read til now is, that your en0 has to be the first device in your networking preferences for using Apple services. For Chameleon there is a nvram module, which is helping in this case. There should also be an emulation for Clover. I for myself do not use Apple services on a hack, I have a MBP 4,1 for this.

 

Have fun.

Share this post


Link to post
Share on other sites
Advertisement

Hey guys. Still having troubles with sleep, shutdown, and changing sound (even booting from a USB Clover). Sleep usually works, but touchpad and pointer stick are dead on wake. Changing sound with hardware buttons will sometimes freeze the system. Shutdown still hangs about 50% of the time. At least no more graphics glitches though! :)

Share this post


Link to post
Share on other sites

@honeywell - is your USB MBR or GUID? i ask because I only get these systems when using UEFI boot from my HD vs boot from MBR. glad the EDID fixed your glitches.

Share this post


Link to post
Share on other sites

Hi at all,

 

I've Mac OS X 10.8 and 10.8.3 Mountain Lino successful on my Lenovo Thinkpad T420 Type 4236-023 with Install Guide from Post #1.

 

Installation instructions: 

1. Create USB-Stick via DiskMakerX

2. Add Clover r1625 to USB-Stick or install on separate USB-Stick

3. Start up T420 via USB-Stick

3.1 Choose "Boot UEFI boot menu from EFI" -> Menu point disappeared

3.2 CHoose "Boot Mac OS from"

4. Mac OS Installer start

 

My Problem is that can't start the Mac OS X 10.9 Mavericks Installer via Clover!

- Clover r1625 - only Black Screen

- Clover r2298 (UEFI, Themes, without 64Bit Drivers)

-- Mac OS X 10.8 Mac Grey Background starts only

-- Mac OS X 10.9 don't start

- Clover r2353 (UEFI, Themes, without 64Bit Drivers) 

-- Mac OS X 10.8 Mac Grey Background starts only

-- Mac OS X 10.9 don't start   

 

Share this post


Link to post
Share on other sites

@Calle_2007 - the guide is post # 1 is pre-mavericks... a more recent guide on Clover v2 is what you need. 

 

copy the EFI/CLOVER folder from the zip in the Guide in my signature to your USB. 

then follow the instructions. 

you need to be using 64Bit drivers.

 

If your USB is MBR, you need to install the boot stuff in the USB MBR with the pkg installer (search back a few posts to see discussion). otherwise mount the ESP on the USB and put in there.

Share this post


Link to post
Share on other sites

@Calle_2007 - the guide is post # 1 is pre-mavericks... a more recent guide on Clover v2 is what you need. 

 

copy the EFI/CLOVER folder from the zip in the Guide in my signature to your USB. 

then follow the instructions. 

you need to be using 64Bit drivers.

 

If your USB is MBR, you need to install the boot stuff in the USB MBR with the pkg installer (search back a few posts to see discussion). otherwise mount the ESP on the USB and put in there.

 

Thanks a lot.

 

1. Format a USB-Stick  in GUID and Mac OS Extended

2. Install Clover r2298 with following properties:

 

 

j6qz9mktukhe.png

 

3. Remove EFI Folder from EFI-Partition
4. Copy EFI-Folder from ZIP to EFI-Partition
 
If i want boot from USB-Stick it appears a Blue Screen with all menu points.
So I select "Boot UEFI external from EFI" -> menu point don't disappeared.
When I select "Boot OS X Install from OS X 10.9 Install Disk - 10.9" --> I get a grey window with apple icon --> after that log stop by "System uptime in nanoseconds: 201691144"
 
This the same for "Boot OS X Install from OS X Mountain Lion Install Disk - 10.8". But this works with Clover r1625

Share this post


Link to post
Share on other sites

@Calle_2007 -

what else did you do after you copied the zip folder to /EFI?

did you rename the config.1366x768.plist to config.plist?

Share this post


Link to post
Share on other sites

@Calle_2007 -

what else did you do after you copied the zip folder to /EFI?

did you rename the config.1366x768.plist to config.plist?

Thanks a lot.

I've forget to change the filename to config.pist. I've prepare a lot of sticks to install clover and forget to change the filename.

I test the Installation on my t420 an tell my experience.

Share this post


Link to post
Share on other sites

be careful if you try to upgrade clover - i just tried to install b2352 - it crashes the GUI if you have CustomEDID in config.plist. but b2330 is OK.

Share this post


Link to post
Share on other sites

be careful if you try to upgrade clover - i just tried to install b2352 - it crashes the GUI if you have CustomEDID in config.plist. but b2330 is OK.

I've install Clover r2330 und r2352 on Speedloop 8GB via PKG-Install with same settings above.

But if I boot from Stick nothing appears.

Share this post


Link to post
Share on other sites

@Calle_2007

 

well not sure what is not happening!?

 

if nothing appears then you may have a theme issue. what theme did you select when you installed? the zip bundle has ThinkPad.

Note: b2352 has an issue with config.plist with CustomEDID - resets graphics to a white blinking cursor.

 

i find that using an MBR USB easier to use than GUID -  don't have to mount the hidden ESP.  just format with 1 fat32 partition - with clover pkg uncheck first two items (for UEFI) and check 2nd option in boot loader. then copy the Clover folder from the zip into /EFI

Share this post


Link to post
Share on other sites

be careful if you try to upgrade clover - i just tried to install b2352 - it crashes the GUI if you have CustomEDID in config.plist. but b2330 is OK.

Using 2352 with CustomEDID in /OEM without issue

Share this post


Link to post
Share on other sites

@Calle_2007

 

well not sure what is not happening!?

 

if nothing appears then you may have a theme issue. what theme did you select when you installed? the zip bundle has ThinkPad.

Note: b2352 has an issue with config.plist with CustomEDID - resets graphics to a white blinking cursor.

 

i find that using an MBR USB easier to use than GUID -  don't have to mount the hidden ESP.  just format with 1 fat32 partition - with clover pkg uncheck first two items (for UEFI) and check 2nd option in boot loader. then copy the Clover folder from the zip into /EFI

 

I've install an USB-Stick (MBR , FAT32) via PKG-Installer and following properties:

 

bildschirmfoto20.png

Then I copy clover folder from zip into EFI on USB-Disk. 

With this Stick i can start Mac OS X 10.9 installer also.

When I Install Windows 8.1 on first partition I can't boot Windows 8.1 over Clover. Only a Windows XP logo appears.

Share this post


Link to post
Share on other sites

@Calle_2007

 

so now you have OSX Mavericks installed? correct?

but you want to get windows running too? 

 

my /EFI looks like this. as you can see there are 2 key folders in EFI

 

Clover boots OSX

Microsoft boots Windows.

 

Note: I copied the bootmgfw.efi and bootmgr.efi from the Windows partition. since i already had windows installed on an MBR disk. but if you use the UEFI version of the  Windows installer it will create/install these files for you. windows 8 is really good in this area. Windows 7 is a bit trickier. it should not matter what partition you install windows on ... as long as bcd matches the microsoft efi file will boot up the windows OS. if microsoft creates the /EFI/boot/ folder, then this boot folder must be move/renamed to /EFI/Microsoft/boot/ since Clover installs a copy of cloverx86.efi in boot/bootx64.efi as this is the default file name. 

 

post-954945-0-32116600-1386254188_thumb.png

 

my main disk has these partitions. 

 

/dev/disk0

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *750.2 GB   disk0

   1:                        EFI EFI                     209.7 MB   disk0s1

   2:                  Apple_HFS OSX+                    697.7 GB   disk0s2

   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

   4:       Microsoft Basic Data C                       51.5 GB    disk0s4

Share this post


Link to post
Share on other sites

@tluck

 

Yes I've installed Mac OS X Mavericks.

Before that I've Windows 8.1.

 

I can start Mac OS over Clover-Stick an Windows 8.1 over Install-DVD.

 

1. So now I've an USB-Stick via PKG-Installer with properties from post 732.

2. I copy Boot and Clover folder from Zip to USB-Stick EFI-Partition (Mac OS X 10.7.5 replace folders).

3. Rename /EFI/EFI/CLOVER/config.1366x768.plist to config.plist.

4. Rename /EFI/EFI/CLOVER/OEM/ProductID.1366x768 to 4236AT9.

5. Create folder /EFI/EFI/Windows.

6. Copy folder C:/Boot to /EFI/EFI/Windows/Boot.

7. Copy folder C:/bootmgr to /EFI/EFI/Windows/Boot/bootmgr.

8. Copy folder C:/Windows/Boot/EFI/bootmgr.efi to /EFI/EFI/Windows/Boot/bootmgr.efi.

9. Copy folder C:/Windows/Boot/EFI/bootmgrfw.efi to /EFI/EFI/Windows/Boot/bootmgrfw.efi.

 

How can I find cloverx86.efi (in ZIP) for copy to boot/bootx64.efi?

I /EFI/BOOT/ is a BOOTX64.efi from ZIP.

 

My partition schema is :

 

screenshot2013-1.png

 

My USB-Stick:

 

bildschirmfoto20.png

Now when I start Windows 8.1 the Windows XP logo appears and after 5 seconds logo disappears but Windows 8 doesn't start. 

Share this post


Link to post
Share on other sites

@calle_2007.

 

rename /EFI/Windows to /EFI/Microsoft

rename /EFI/Clover/OEM/4236AT9 to  4236O23 (your productID not mine!)

if you want to use the OEM config.plist - set up to NOT inject kexts - expects you installed them in /S/L/E of your HD

 

The Clover should see the 2 partitions and allow you to pick one.

Share this post


Link to post
Share on other sites
Hello, everybody. I have an x220 and am trying to install 10.9. I used the Clover from post # 481. But when I open the installer, the message "CPU Halted" appears and the notebook shuts down. Any help?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

@Safsprin - 

 

not much info to go on???

 

are you using your own dsdt ? did you remove the one from the clover zip? which config plist are you using?

Share this post


Link to post
Share on other sites

No DSDT. Using the original from the zip. With the NullCPU kext the installer shows up. Using the HD (768) Plist.

 

EDIT: I finally reached the installer. But I'm stuck in disk partitioning. I shrunk my C: drive and formated the unallocated  space with exFat format. In Disk Utility, I cann't format the partition due to lack of free space. What can I do?

Share this post


Link to post
Share on other sites

off topic but insterresting

this is a native efi32 bootloader, instead of a CSM loader
it built a thunk between EFI64 and EFI32, forwarding EFI64 call from kernel to EFI32 firmware.

so those programs using EFI runtime services, such as bless, nvram will be run without any problem. 

Share this post


Link to post
Share on other sites

@safsprin - is your HD MBR or GPT/GUID? can't you leave the space unformatted? or is the plan to reformat the exfat partition with HFS?

 

i vaguely recall having format issues aloooong time ago... i ended up backing up my C drive and then repartition/reformatting my entire drive by Disk Utility and then restoring my C drive afterwards.  if you have 2 drives this is a lot easier!

 

@tetonne - there is never any shortage of cleverness to be discovered! thanks for sharing. 

Share this post


Link to post
Share on other sites

HD in GUID built by Windows 8 installation (i guess this is the issue). I cann't format to HFS (no free space message), or delete the partition (clicking on the minus sign, apply - progress bar spinnig forever).

 

EDIT: HD formatted in GPT by OSX DIsk Utility. Windows 8.1 and Mavericks installed. Boot from internal EFI partition (with clover files). 

 

What's the next steps (sound, DSDT)?? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By TomZanna
      Hi, I'm trying to install Mac Os Catalina on a HP 550-132NL.
      The system has:
      i7-6700
      RAM 12 GB
      GT 730
      LAN Realtek RTL8161
      ALC3863
       
      It passes the verbose phase but after the Apple logo goes away, it gets stuck on a grey screen and I can only move the pointer.
      Can I try to boot with the iGPU?
       
      origin.zip
      CLOVER_dGPU_USB_3.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By mikezexter
      (Dear moderators please replace this topic to another category if I made a mistake in choosing it)
       
      Hello everybody. I need some help in trying to fix native AppleHDA sound on my X230T.
      VoodooHDA works perfectly but without needed HDMI audio channel so I need to try fix my sound in native mode.
       
      AppleALC told us here (README) that in v1.2.1 Added ALC269 layout-id 18 for Thinkpad X230 by Hypereitan. And if it works I didn't need to create this topic.  Unfortunately layout ids 1,2,3,18 and 55 didn't help me to fix sound issue.
       
      My Clover: https://drive.google.com/open?id=1FuGS7iE59ydgiMsxZcDMarlAFH3FliNE (it's 2 MB bigger than I could upload for now)
      I've also uploaded some screenshots of what I've seen after 5 reboots in a row changing layout ids. Please help me to fix this issue.
       
    • By MaLd0n
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×