Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

5,059 posts in this topic

Recommended Posts

Just now, freddie said:

Yes, I had "Auto-apply" patch option activated when I created the bootable USB. I think it is due to the fact that I installed the latest update of Catalina 10.15.4. Which one do you have?

 

i just reinstalled 10.15.4 (i say that because i must do it from the USB installer)

Share this post


Link to post
Share on other sites
Advertisement
1 minute ago, tluck said:

i just reinstalled 10.15.4 (i say that because i must do it from the USB installer)

Very strange... then I don't understand it.

I will reinstall Catalina and see how it goes. Did you do anything different, comparing to the Mojave installation?

Share this post


Link to post
Share on other sites
2 hours ago, freddie said:

Very strange... then I don't understand it.

I will reinstall Catalina and see how it goes. Did you do anything different, comparing to the Mojave installation?

no.

I used the latest dosdude1 1.3.1 which now supports 10.15.4

with full install downloaded from the app store

 

 

 

Share this post


Link to post
Share on other sites
6 hours ago, tluck said:

try running this:

 

sudo spctl --master-disable

 

Thanks tluck.

It seems that dosdude1 reverted the macOS Catalina version back to 10.15.3 due to issues with the patches not working.

I will download it and reinstall it to see if my problems are gone.

Share this post


Link to post
Share on other sites
Posted (edited)

I've reinstalled macOS Catalina 10.15.3 using dosdude1 patcher and now it is working fine. Some minor glitches, but no freezes up to now. Mostly using Chrome, Mail, Music (with AirPlay), Word, Excel, Preview and Atom.

 

I'm using config.EDID-2e2.plist with the 1024 VRam kexts. I'm on a T420s, 1600x900, i7, SSD and 8GB RAM.

 

Chrome was glitching a lot and I have changed the following parameters in chrome://flags/  in order to get rid of these annoying glitches:

  • Disabled "GPU rasterization"
  • Disabled "Partial swap"
  • Disabled "Zero-copy rasterizer"

 

Hope this helps Chrome users.

 

Edited by freddie

Share this post


Link to post
Share on other sites
20 minutes ago, tluck said:

cool. what is the version number on the gfx kext you are using?

 

The kexts I've replaced in /System/Library/Extensions to have 1024VRam are the ones I have posted earlier:

https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=345125

 

Their versions are:

  • AppleIntelFramebufferCapri.kext v10.12.13
  • AppleIntelHD3000Graphics.kext v10.0.40
  • AppleIntelSNBGraphicsFB.kext v10.0.40

Share this post


Link to post
Share on other sites
3 minutes ago, freddie said:

 

The kexts I've replaced in /System/Library/Extensions to have 1024VRam are the ones I have posted earlier:

https://www.insanelymac.com/forum/applications/core/interface/file/attachment.php?id=345125

 

Their versions are:

  • AppleIntelFramebufferCapri.kext v10.12.13
  • AppleIntelHD3000Graphics.kext v10.0.40
  • AppleIntelSNBGraphicsFB.kext v10.0.40

ok. i just realized Chrome is not working for me either on 10.15.4... so will have to wait and see what patches are in the works for this.

Share this post


Link to post
Share on other sites
3 minutes ago, tluck said:

ok. i just realized Chrome is not working for me either on 10.15.4... so will have to wait and see what patches are in the works for this.

 

Yes. The only way is to go back to 10.15.3 for the moment. Or wait ;)

Share this post


Link to post
Share on other sites

What are you needing Chrome for, after all?

I´m using Brave Browser - Chromium engine - no glitches, just working.

No unwanted stuff, no tracking…

Share this post


Link to post
Share on other sites
14 minutes ago, goodguess said:

What are you needing Chrome for, after all?

I´m using Brave Browser - Chromium engine - no glitches, just working.

No unwanted stuff, no tracking…

Well, if it is a Chromium engine, it should give the same glitches... for example, I have the same problems with Atom, which has also beneath its skin a Chromium based engine. I don't have the glitches only in Chrome... they're all over the OS as soon as you have several apps opened and/or if you demand the CPU to stretch a bit more.

I think it is impossible to get rid of these glitches, but we can try to live with them.

 

I will give a try to Brave anyway. The design looks sleek!

 

Share this post


Link to post
Share on other sites

Hey, so I know this is not strictly thread releated, but I own X220 Thinkpad and I tried to get keyboard/touchpad working on it, but it's not.

I know there are ready files but I am trying to get it working fully on OpenCore, and I got running fine almost everything (even battery status and brightness control!) but even, I can't get VoodooPS2 to work.
I tried PS2 kexts from many sources (this thread, VoodooPS2/VoodooInput from acidanthera, and also from X220 kext pack). And it's even loading (I see it in kextstat).

Probably some patch is not included in OpenCore or I miss some DSDT/SSDT.

Share this post


Link to post
Share on other sites
2 hours ago, Hoshi Yamazaki said:

Hey, so I know this is not strictly thread releated, but I own X220 Thinkpad and I tried to get keyboard/touchpad working on it, but it's not.

I know there are ready files but I am trying to get it working fully on OpenCore, and I got running fine almost everything (even battery status and brightness control!) but even, I can't get VoodooPS2 to work.
I tried PS2 kexts from many sources (this thread, VoodooPS2/VoodooInput from acidanthera, and also from X220 kext pack). And it's even loading (I see it in kextstat).

Probably some patch is not included in OpenCore or I miss some DSDT/SSDT.

 

Hi Hoshi, never tried OpenCore. What are the advantages?

My T420s is working fine with Clover. 

Share this post


Link to post
Share on other sites
14 minutes ago, freddie said:

 

Hi Hoshi, never tried OpenCore. What are the advantages?

My T420s is working fine with Clover. 

I want just do it for sake of achievement and because I report bugs to Open-Source projects like OpenCore, thus I want to get it working.
Seems that OpenCore is faster, more stable, and for me iMessage started working out-of-box. Previously I had an problem because Wi-Fi card was never an en0.
If we want to move on, why support Clover?

Share this post


Link to post
Share on other sites
13 minutes ago, Hoshi Yamazaki said:

I want just do it for sake of achievement and because I report bugs to Open-Source projects like OpenCore, thus I want to get it working.
Seems that OpenCore is faster, more stable, and for me iMessage started working out-of-box. Previously I had an problem because Wi-Fi card was never an en0.
If we want to move on, why support Clover?

 

Totally agree with you! Thanks for your effort.

I think that speed is not an issue with Clover, but stability yes. If OpenCore proves to be more stable, then it's a win!

 

I think the best guy to help you is @tluck

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Hoshi Yamazaki said:

Hey, so I know this is not strictly thread releated, but I own X220 Thinkpad and I tried to get keyboard/touchpad working on it, but it's not.

I know there are ready files but I am trying to get it working fully on OpenCore, and I got running fine almost everything (even battery status and brightness control!) but even, I can't get VoodooPS2 to work.
I tried PS2 kexts from many sources (this thread, VoodooPS2/VoodooInput from acidanthera, and also from X220 kext pack). And it's even loading (I see it in kextstat).

Probably some patch is not included in OpenCore or I miss some DSDT/SSDT.

 

does the 1.9.2 VoodooPS2 work for you under clover? you need the SSDT-PS2K to create some properties etc.   the newer VoodooPS2 2.x from acidanthera will not work well give the physical buttons etc. iMessage works with Clover too.?

 

and Clover is super stable... for example, it been working on this box since 2013? i have NOT seen a KP in ages.

but sure have fun with OpenCore. its fun to hack these boxes!

 

and with the latest 1.3.5 dosdude1 patcher - catalina 10.15.4 is working fine for me. 

Edited by tluck

Share this post


Link to post
Share on other sites
Posted (edited)
13 hours ago, tluck said:

 

does the 1.9.2 VoodooPS2 work for you under clover? you need the SSDT-PS2K to create some properties etc.   the newer VoodooPS2 2.x from acidanthera will not work well give the physical buttons etc. iMessage works with Clover too.?

 

and Clover is super stable... for example, it been working on this box since 2013? i have NOT seen a KP in ages.

but sure have fun with OpenCore. its fun to hack these boxes!

 

and with the latest 1.3.5 dosdude1 patcher - catalina 10.15.4 is working fine for me. 

 

@tluck 10.15.4 is still not good for me. I've used the last patch of dosdude1 for 10.15.4 (v1.3.5) but several apps still get blocked and I get momentary freezes all over the OS. Even after doing the "sudo spctl --master-disable" command. I did the exact same installation I did for 10.15.3, same config.plist and same kexts. 

10.15.3 was very smooth and stable after I upgraded to 16GB RAM and patched my VRAM to 1024MB. No freezes and no glitches at all (during 2 consecutive days).

 

Do you confirm that you can use 10.15.4 without any issue? If yes, what did you do differently from the 10.15.3 installation?

Edited by freddie

Share this post


Link to post
Share on other sites
11 hours ago, freddie said:

 

@tluck 10.15.4 is still not good for me. I've used the last patch of dosdude1 for 10.15.4 (v1.3.5) but several apps still get blocked and I get momentary freezes all over the OS. Even after doing the "sudo spctl --master-disable" command

 

Do you confirm that you can use 10.15.4 without any issue? If yes, what did you do differently from the 10.15.3 installation?

 

I booted the dosdude1 1.3.5 patched USB installer and ran the post-install for MBP8,1 (the only thing i dont install is legacyUSB). and then Chrome started working again. i dont have a lot of 3rd party apps istalled beside VMware Fusion and Chrome. but for me 10.15.4 seems as good as the 10.15.3.

Share this post


Link to post
Share on other sites
1 hour ago, _Cute_Kitty_ said:

Are any of you guys using the 1366x768 display with Catalina? If so, how's it working?

have you tried injecting the say the EDID 366 or 2e2 EDID even though those were made for 1600x900. I seem to recall Tetonne may have done that? just make sure you set DualLink to 0 if copy the pre-built config.plist to try.

Share this post


Link to post
Share on other sites
20 hours ago, tluck said:

 

I booted the dosdude1 1.3.5 patched USB installer and ran the post-install for MBP8,1 (the only thing i dont install is legacyUSB). and then Chrome started working again. i dont have a lot of 3rd party apps istalled beside VMware Fusion and Chrome. but for me 10.15.4 seems as good as the 10.15.3.

 

It seems dosdude1 just issued another fix:

1.3.6 - 3/31/2020

• Fixed an issue where AMFI may prevent some third-party applications from launching in 10.15.4.

 

I think I will give it another try. 

Share this post


Link to post
Share on other sites
55 minutes ago, freddie said:

 

It seems dosdude1 just issued another fix:

1.3.6 - 3/31/2020

• Fixed an issue where AMFI may prevent some third-party applications from launching in 10.15.4.

 

I think I will give it another try. 

i am updating my USB right now! thanks.

Share this post


Link to post
Share on other sites
2 hours ago, tluck said:

i am updating my USB right now! thanks.

The issue is still not solved unfortunately :wacko:

I think we will see another patch from dosdude1 (I hope he can solve this).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By cvad
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
    • By mavifree
      Sir 
      I am new in this, i try to make my hp laptop in hackintosh but i facing some error in clover boot manager while installing but unable to understand it. I really try hard but not able to get there, something i noticed that i facing same kind of error every time. I just watched youtube and visitied so forum like tonymac86, InsanelyMac, Noobsplanate and so on but nothing solved. So Please Please I Request All of You If you can help me to resolve my problem.
      Here Is my Laptop Specs:
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      I even don't is my laptop is compatible or not, and don't have MacBook or Mac Desktop so if you can provide important driver and other stuff for installation. I really be very thankful to you.
      Please Reply me if any other information about my laptop hardware i will attached it i only have this info right now. 
       
      and i here attached my screenshot while installation error in clover.
      Sorry for my English.
       
      Please Help Me 
       



    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://tinyurl.com/rkqmpd9
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By STLVNUB
      Script file to clone and help build Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
×