Jump to content

Lenovo ThinkPad T420 with UEFI Only

4,718 posts in this topic

Recommended Posts

4 hours ago, tluck said:



the HD3000 kext set really need to be in the OS (/S/L/E) as they don't seem to work properly from the ESP.  


but now you are saying it wont boot into graphics mode at all?


you can try to boot up in non-HD3000 by setting the GFX ID in the Clover Options menu. then you go to graphics sub menu to set the product id to 0x12345678 - then it should boot up in basic mode. this way you can remove stuff from the ESP and and validate stuff in /S/L/E 



Yes, unfortunately it won’t boot into graphics mode at all now. 

In the meantime I’ve deleted the 10.14 folder from the ESP (ultrabay hdd has windows 10, used it for deletion ). So conflict shouldn’t be an issue in any case now. 

I’ve tried to boot with product id 0x12345678, but sadly it didn’t make any difference. 

I’m pretty confident that the HD3000 and SNB kext is in the right place, even checked permissions with “ls -l” after all the previously ran commands in /S/L/E. 

Tried again with -v, -x, nv disabled, injection of edid , without injecting intel , without injecting any kext and the combinations of all of the above. 

Its all lead to the same result. 


Edited by tasteTheBacon

Share this post

Link to post
Share on other sites

tluck-  I'll try an installation of High Sierra. I do have an untouched USB stick of that ready to go. If I have any sort of success, I'll let you know.


Regarding a rollback to an earlier version of Clover.. There might be a way to do it from the Windows side but I'm far too much of a novice to know how to do that. I could roll back if I could get into OSX, but obviously that isn't happening at the moment :)


Let me try an HS install and go from there.





Edited by skoon432

Share this post

Link to post
Share on other sites

Well this didn't take long at all!


High Sierra is suffering the same problem as Yosemite.  It tries to start and it simply stalls out. OSX is seeing something it doesn't like, period.  At this point, I give up.  Whatever is wrong is far beyond my scope of understanding but I still firmly believe the fault lies in a bad version of Clover. I'm convinced that it had some sort of very bad bug in this specific version and it totally trashed up the OSX partition in some weird way. Oh how I wished I had just left it all alone and not tried upgrading to a newer Clover release. A lesson learned and now its too late! :(




Share this post

Link to post
Share on other sites
21 hours ago, tasteTheBacon said:


Its all lead to the same result. 


To be pro-active: I've tried everything, even reset my bios settings, deleted and re-copied everything to the SSD ESP.
None of these helped. 

But fortunately, I figured it out, sort of. 

The solution for me was to go in to the Clover Options menu while booting up and manually select a different config.plist and then re-select the default one (Which was highlighted by default).

Without this manual step the boot hangs.

With it it boots fine.

I've even got the HD3000 kext loaded and brightness working with this step.

If you ask me it doesn't make any sense to me. Can this be a Clover bug? 


Not sure if you have any tip on how to skip this manual step, but either way, thank you for the support @tluck , and also @goodguess for the tip. It's all highly appreciated.


Screenshot 2018-12-14 at 20.26.20.png

Share this post

Link to post
Share on other sites

great. so which config file worked? I think you are saying use used the default config.plist but you manually selected it? 

Edited by tluck

Share this post

Link to post
Share on other sites
On 12/16/2018 at 12:33 AM, tluck said:

great. so which config file worked? vs the default config.plist


So this is what I've done :

When I created the USB installer for Mojave I've renamed the Mojave 1600x900 config plist to config.plist in the USB EFI / Clover folder.

My intention was to convert it to become the default config that clover selects.
While installing MacOS from the USB this setup worked.

Once MacOS finished install to the SSD I've copied everything from the USB EFI to the SSD EFI.

When I tried to boot from the SSD it failed as detailed in previous comments. 
Clover properly highlighted my config.plist (which was originally the 1600x900 Mojave config) as the selected one, despite this I had to manually select a different config and re-select the default one to make a successful boot attempt.
I suspect that if I delete all other config.plist it will boot just fine and this is a Clover bug, but I didn't have the time to check this yet.



Share this post

Link to post
Share on other sites
On 11/3/2018 at 9:59 PM, goodguess said:

I still have the BIOS/UEFI stuff on a 1GB thumb drive.

My BIOS was at 1.48 with my last T420, lets hope the downgrade still works via DOS with BIOS 1.5.2

The bootable thumb drive is 1 GB, I´ll copy the needed files to a folder.

You will need to make a bootable volume from them to get into DOS for downgrading BIOS.


Here are the files: https://www.magentacloud.de/lnk/fvStA9ob

Good luck!


hi goodguess

sorry to bother you,

i must be stupid, cos i don't know how to do :(

there're 2 readme.txt (in TP and in root level)

i'm under w10 and my bios is 1.52 i want to wl to use my new wifi card

what must i do cos the stuff un-zip on USB doesn't boot my t420

can you please give step by step how to

Thanks for your help

best regards

Share this post

Link to post
Share on other sites

so i figured out why the Panel LCD brightness slider is missing for some folks. WhateverGreen conflicts with the AppleBackupLightInjector so it is not setting the ApplePanel property correctly. it is missing F10Txxxx in its Info.plist 


So for now remove WhatheverGreen.kext from your ESP or /L/E

or add this to the Info.plist








to the WhateverGreen.kext/Contents/Info.plist right above F14Txxxx

Edited by tluck

Share this post

Link to post
Share on other sites
23 hours ago, Tetonne said:

hi goodguess

sorry to bother you,

i must be stupid, cos i don't know how to do :(

there're 2 readme.txt (in TP and in root level)

i'm under w10 and my bios is 1.52 i want to wl to use my new wifi card

what must i do cos the stuff un-zip on USB doesn't boot my t420

can you please give step by step how to

Thanks for your help

best regards


It has been some time since I downgraded my second T420, memory does not better with age either. :)

Basically you have to create a thumb drive which boots into DOS.

As you got that, you copy over the files I pointed to, onto that thumb drive.

Then after DOS boot, you downgrade with the DOS utility (everything else failed on my side)

At last you flash the patched 1.46 (with whitelist removed) in Windows.


I´ll look through my writing to check what still makes sense to me.

Share this post

Link to post
Share on other sites

So yeah, the procedure seems to be still doable.

Looks like I did not want to delete anything I had found, though it is not needed to get the downgrade done.

Follow these simple steps:

1. Grab a USB stick and format it FAT32 with the hidden DOS system files on it.

I think I used HPUSBDisk.exe and the files from usbdos.zip while running some Windows OS.

2. Copy over all needed files.

 You will need at least PFLASH.exe, B146.FL1, B146M.FL1 and the TP directory with the winflash.exe.

3. Boot from your USB device into DOS.

4. Type in: PFLASH /sa B146.FL1 (This should downgrade your T420 to BIOS 1.46)

5. Boot into Windows again, open a DOS window and navigate to USB/TP/bios_mod.

6. Type in: winflash /sa B146M.FL1

From the winflash GUI, select "Flash BIOS only" then click on the "Flash" button.

That should be it - reboot and enjoy your modded BIOS.

You may have guessed that M stands for the modded BIOS you finally want.

Besides the whitelist removal, some AMT features are also disabled with the mod.


Good luck!


For the rare possibility that you already ditched all your Windows installer DVDs:

The Internet Archive has one here: https://archive.org/details/HPOperatingSystemDVDWindows7ProfessionalSP164-bit650434-DN32012

No serial needed, but the install is not a "genuine" W7 of course. ;)





Edited by goodguess

Share this post

Link to post
Share on other sites
On 12/6/2018 at 4:31 PM, tluck said:



hmm. i just went through creating a HighSierra and Sierra Installer to validate the process not long ago.


so for you, it seems like the installer runs and started to do the install - without black screen when you removed ScreenResolution 900x600?

 did it complete install?

 is there a microsoft install on the disk?


Yeah once, I removed the default 900x600 resolution and adjusted it to fit mine, I was able to get it to the point where it allowed me to use the diskutility tool in order to repartition and whatnot. Once I created the base partition and it copied the files over from the USB to the installation partition, and I'd boot into it, it got about midway before stopping and telling me the `NSLocalizedDescription` error as seen in the following JSON response:

2018-12-05 11:35:49+00 MacBook-Pro OSInstaller[552]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=110 "An error occurred while extracting files from the package “Core.pkg”." UserInfo={PKInstallPackageSHA256Digest=f6947c0c5ae5d2bd3bf90a557647131c186627831e182a624c8239b5ed9cd2c4, NSLocalizedDescription=An error occurred while extracting files from the package Core.pkg”., NSFilePath=/Volumes/macOS/.OSInstallSandboxPath/Root, NSURL=Core.pkg -- file:///Volumes/InstallESD/Packages/OSInstall.mpkg, PKInstallPackageIdentifier=com.apple.pkg.Core, NSUnderlyingError=0x7fba4786a1f0 {Error Domain=PKXARArchiveErrorDomain Code=101 "archive verify failed" UserInfo={NSURL=file:///Volumes/InstallESD/Packages/Core.pkg#Payload, NSFileOwnerAccountID=0, NSFileHFSTypeCode=0, NSFileSystemFileNumber=462, NSFileExtensionHidden=false, NSFileSystemNumber=16777245, NSFileSize=4460809648, NSFileGroupOwnerAccountID=0, NSFileOwnerAccountName=root, NSFilePosixPermissions=420, NSFileHFSCreatorCode=0, NSFileCreationDate=2018-07-04 19:40:30 +0000, NSFileType=NSFileTypeRegular, NSFileGroupOwnerAccountName=wheel, NSFileReferenceCount=1, NSFileModificationDate=2018-07-04 19:42:05 +0000, NSLocalizedDescription=archive verify failed}}} {
	    NSFilePath = "/Volumes/macOS/.OSInstallSandboxPath/Root";
	    NSLocalizedDescription = "An error occurred while extracting files from the package \U201cCore.pkg\U201d.";
	    NSURL = "Core.pkg -- file:///Volumes/InstallESD/Packages/OSInstall.mpkg";
	    NSUnderlyingError = "Error Domain=PKXARArchiveErrorDomain Code=101 \"archive verify failed\" UserInfo={NSURL=file:///Volumes/InstallESD/Packages/Core.pkg#Payload, NSFileOwnerAccountID=0, NSFileHFSTypeCode=0, NSFileSystemFileNumber=462, NSFileExtensionHidden=false, NSFileSystemNumber=16777245, NSFileSize=4460809648, NSFileGroupOwnerAccountID=0, NSFileOwnerAccountName=root, NSFilePosixPermissions=420, NSFileHFSCreatorCode=0, NSFileCreationDate=2018-07-04 19:40:30 +0000, NSFileType=NSFileTypeRegular, NSFileGroupOwnerAccountName=wheel, NSFileReferenceCount=1, NSFileModificationDate=2018-07-04 19:42:05 +0000, NSLocalizedDescription=archive verify failed}";
	    PKInstallPackageIdentifier = "com.apple.pkg.Core";
	    PKInstallPackageSHA256Digest = f6947c0c5ae5d2bd3bf90a557647131c186627831e182a624c8239b5ed9cd2c4;

 There was no prior microsoft install, I had some partition table that wasn't the GPT, on which I had a main partition with a Fedora LLVM partition and an extended partition that contained Gentoo and Ubuntu. When I was going through the install I wiped the entire disk, created a GPT table, and made two formatted HFS+ filesystem partitions from an Ubuntu Live USB, which I later deleted and reformatted from the disk utility tool found in the HighSierra install.


After making these posts, I tried to obtain a legitimate MacOS HS installer which I had my friend download for me (since it wasn't letting me do it), verified it, and repeated the process. Got the same result as before.

Note: Since I don't have a Mac myself, I used VirtualBox on Ubuntu 18.04 to run the latest Sierra to create the USB installer for part 1. 


Apologies for the late response, I gave up on hackintosh and just installed Windows and ElementaryOS. I'd be willing to give it another shot but at the moment I don't see the sensibility if I can't create a proper installer without having access to a Mac. 

Share this post

Link to post
Share on other sites

Sorry to hear about your mischief MikeDece.

As you mentioned your T60, mine is still running Snow Leopard 10.6.7.

I recall installation was brain dead simple with the use of Nawcoms Mod CD and a SL retail DVD.

You may know that Internet Archive is hosting SL retail DVDs:


I could dig out Nawcoms Mod CD for sure.

Note that Nawcoms Mod will only work with a 10.6.0 or 10.6.3 retail DVD - not with the grey DVDs.

Such install would give you basic Intel "Mac" sort of. ;)

From there, you could follow the guide to set up a bootable thumb drive with Clover / Sierra.


Other than using your T60, setting up 10.6 Server via virtualisation is possible too.

I cant tell how to do that in GNU/Linux.

Its easy enough on a Mac with VMWare Fusion, but thats another hen-egg problem for you. :(

Edited by goodguess

Share this post

Link to post
Share on other sites
On 12/19/2018 at 6:06 PM, goodguess said:

1. Grab a USB stick and format it FAT32 with the hidden DOS system files on it.

I think I used HPUSBDisk.exe and the files from usbdos.zip while running some Windows OS.

2. Copy over all needed files.

 You will need at least PFLASH.exe, B146.FL1, B146M.FL1 and the TP directory with the winflash.exe.

3. Boot from your USB device into DOS.

4. Type in: PFLASH /sa B146.FL1 (This should downgrade your T420 to BIOS 1.46) 


on W10 : These 4 first steps are OK but they bring me back from 1.52 to 1.49 (not 1.46).

I suppose i have to test it again on W7 :(


Step 3 with : No GUI, no Windows (10), just the DOS prompt A:∖ on an empty black screen.

Edited by Tetonne
add info about step 3

Share this post

Link to post
Share on other sites

Tetonne, did you really boot into DOS?

No GUI, no Windows (10), just the DOS prompt A:∖ on an empty black screen.

Its a miracle to me how you should have got 1.49 when you had 1.52.

When I tried (long ago) PFLASH from DOS was the only way to downgrade BIOS.

Usually you could only upgrade to a higher version from the Windows command line.

As I never had BIOS 1.52 things may be different by now or something is locked.


Please bear with me asking the above, maybe I got something wrong. :)

Edited by goodguess

Share this post

Link to post
Share on other sites

Some sort of off topic, but I saw the T420s being sold at affordable prices.

Did anybody succeed with a T420s hackintosh?

The specs are looking similar, except for USB3, there also seems to be modded BIOS available for whitelist removal.

Share this post

Link to post
Share on other sites

@goodguess - yes T420s is very similar hack as T420. i am not sure if the USB3 is still supported and working though. 

Edited by tluck

Share this post

Link to post
Share on other sites

Thanks tluck, I was thinking of the T420S, USB3 will be an issue there too.

Also I´m curious whether somebody succeeded flashing BIOS for whitelist removal. 

Presumably PFLASH (DOS) would do the job.

Share this post

Link to post
Share on other sites

found on bios-mods.com thanks to zmb :


Here are some additional modifications to the bios modded some time ago (I think everything that people usually want):
- No whitelist
- AES-NI lock removed
- MSR 0xE2 unlocked
- Added advanced menu
- Memory lock to 1333 removed (now supports DDR3 1600 and 1866)
- Intel vbios updated from 2089->2170
- Re-signed with custom key to get rid of 5 beeps on boot (Does anybody have these beeps? If you get the error 1901: or some nonsense about security after this, you need to reset bios settings to defaults)

In the folder mod, there are bioses with different number of modification. It is possible to know what modification is applied from the name of the file: NWL - no whitelist, NWL_ADV - no whitelist + advanced menu etc. if you need to apply specific bios from the list, you need rename it to $01C8000.FL1 and place it to the folder 83ET82WW.

All credit goes to the TimeWalker and ValdikSS from the folowing posts:
1. https://www.bios-mods.com/forum/Thread-T...#pid114437 (this post has nice descriptions how to implement all the modifications)
2. https://www.bios-mods.com/forum/Thread-R...#pid141098
 (the re-signing thing)

Every modification is tested on my t420. But as always, use it at your own risk.

Link: http://rgho.st/private/7DYcBR7MF/7572e9d...8da07b25e0


found on bios-mods.com thanks to zmb :
When the newer version of the bios will be available (if at all) you could try change yourself. There is an easy way to apply modifications to the new bios version without disassemblers or any such fancy tools.

For this you need one external tool: UEFItool 

This tool could be used to extract some specific module from the bios image (*.FL1 - file) and then to replace it with the modified one. Each module is a program, which performs some functions. For example the whitelist check is done in the module "LenovoWmaPolicyDxe.efi"

The idea is that for the minor bios changes the modules in the bios-image of different versions are the same. And it is possible to replace the original module in the newer version of the bios with patched module from the older one. (see pic1)pic1.jpg.3c85e61c4fd656ed73d6deaecc55a432.jpg

For example if I extract the "LenovoWmaPolicyDxe.efi" from 1.51 bios and from 1.52 and compare them in binary mode, then I will see that the modules are the same. (command for binary compare: fc /b file1 file2 - see pic2)pic2.JPG.8f387e02bd193f82fe238da326e542df.JPG

This means, that I could take the patched module from the v1.52 ("LenovoWmaPolicyDxe_modded.efi") and replace the original module in the v1.51. This way I would get the whitelist free version of the bios v1.51.

The example above may be true for the next version of the bios v1.53 and for other models of thinkpads as well.

Of course If the extracted module is not the same and the binary compare shows differences, then bad luck and it is better not to touch it.



Share this post

Link to post
Share on other sites

so back to 1.52 after downgrade to 1.49.

but i did not success to apply mod with "run WINUPTP.EXE /S from this folder"

WINUPTP.EXE dosen't seem to be recognised :(

from this 1.52mod: http://rgho.st/private/7DYcBR7MF/7572e9d...8da07b25e0

pain in the neck

can someone help

i now know how to downgrade from 1.52 to 1.49 (not 1.46)

back to 1.52 ok

i tant to WL this {censored}... T420 (1.52 or previous lol)



Share this post

Link to post
Share on other sites

Hi T420 peeps!  I'm a first time hackintosh builder and I could use some help getting my machine off the ground.  I've researched for about a week and I've spent a couple days just trying to get a mountable USB to use (and I'm not even sure if I did that correctly).  To some extent I followed TLuck's guide, but I had to create some workarounds for limitations - I'm not sure if maybe I skipped something vital that is creating my current road block.


Pertinent information

83ET79WW  BIOS 1.49

intel i5-2520 2.5ghz
Intel HD 3000 x Nvidia NVS 4200m


BIOS settings Album



Creating the USB... After many attempts to create a working USB install directly from my windows desktop using things like R-drive, rufus, win32diskimager, etc., I ended up creating a Mojave environment in VM Workstation.  However, I cannot download a copy of Mac OS from the app store, for some reason it keeps returning with an 'incomplete' error even though it's up-to-date.  At any rate, I downloaded a .raw file from olarila and used etcher to flash it to my USB.  I then ran Clover r4726 pkg from the 10-31-2018 utilities and plugged it into the T420. 


USB finally working... I boot to clover and the initialization scripts run - I finally see the "Install Mac OS" and disk utility.  Which brings me to my current road block: I cannot write to my internal disk.  I have unplugged it and swapped it into my desktop to reformat to no avail.  I also swapped in a spare clean drive with no luck.  My gut feeling is that something in the BIOS is stopping the USB installer from speaking to the hard disk.  Any ideas?




I'm so dumb.  "diskutil eraseDisk JHFS+ disknamehere disk0" formatted it with no issues.  However now it says that I can't install 10.14 on this computer...








When I run "diskutil list", I'm met with about 30 "drives" including my 160gb install drive and the USB, but also ~28 weird drives of varying sizes.


Attempted First aid:

Running First Aid on "" (disk0s1)

Repairing file system.
volume is already unmounted.
performing fsck_exfat -y -x /dev/rdisk0s1
checking volume.
checking main boot region.
main boot region is invalid. trying alternate boot region.
checking alternate boot region.
alternate boot region is invalid. 
the volume could not be verified completely.
file system check exit code is 1.
restoring the orignal state found as unmounted
file system verify or repair failed

Operation failed...

Attempting to format/erase:





Edited by namisloc

Share this post

Link to post
Share on other sites

Hi namisloc.

I would assume that you did hit several obstacles at one time.

My thoughts:

- A macOS Hackintosh can not boot with two active GPU. Did you disable the NV graphics in BIOS?

- HD 3000 IvyBridge laptops are incompatible with 10.14 Mojave.

- Your boot volume should be empty and clean for installation. Best use a Gparted Live CD to swipe clean your HDD/SSD.


If I was in your place, I would step back to a Snow Leopard machine and prepare a bootable USB device for 10.11/10.12/10.13 from there.

Snow Leo still runs fine on Core2Duo rigs. You may install with Nawcoms Mod CD and a SL retail DVD from the Internet Archive.

A virtual machine running 10.6 Server is another option of course.


As you got macOS on your boot USB device with tlucks EFI package, you may install on your T420.

Of course tluck´s EFI package has to be copied to your HDD/SSD to boot from it.

Remember that the Clover package must be installed onto the hidden EFI partition EFI/EFI/Clover.

The EFI partition is automatically created by macOS DiskUtility when initialising your HDD/SSD as HFS drive.

(Use a GPT partition table at this step.)

As you got e.g 10.12 on your T420 and booting with tlucks EFI package, you may DL 10.14 from the app store,

as the T420 pretends to be a MBP late 2013 which is supported for Mojave upgrades.


Mojave will only work with the new APFS file system.

You can only format your HDD as APFS as you already got Mojave.

When upgrading to Mojave from an earlier macOS, your HDD/SSD will be converted to APFS by force.

The procedure may fail for several reasons: Too little room on the given device, Mojave dislikes the drive, its a Monday, etc. ;)

Either way, be aware that the upgrade will take a really long time and may fail several times.


It may be recommendable to start a new thread for your work.

Most of us here already had several macOS versions on their T420 and do read here only for fine tuning.


Share this post

Link to post
Share on other sites

Hi, first of all thanks to everyone keeping this alive.


I recently upgraded to Mojave after having El Capitan installed for more than 2 years without any serious problems, but it was time to upgrade... Install went smooth but I'm having same issues with black screen as @tasteTheBacon . His solution to remove all configs and use default config.plist worked and now I can boot fine, but there are some problems: brightness adjustment doesn't work - I guess it will work with the 1600x900 mojave config.plist if the booting problem is fixed. I've also noticed that I'm sometimes getting system freezes for few seconds if I click on some items in the menu bar (Apple logo for example) or when I use Preview app or similar image viewers (Xee^3), it is very random and difficult to reproduce as it didn't happen during writing of this post when I tried to randomly click on items in the menu bar. Is anyone else having same problems? I might try to downgrade to High Sierra, but dark mode feature is great.


Also my T420 configuration is: i5 2520M CPU, 1600x900 resolution, 16GB RAM if that helps.


Edit: Now it froze completely and had to reboot when I tried to open video with Quicktime, also now I've noticed that I can move cursor around while it is frozen.

Edited by bxe

Share this post

Link to post
Share on other sites

Hi bxe!

Got exactly the same T420 config as the one you posted.

Did you install Mojave over your existing El Cap?

I recall some black screens and freezes during the Mojave upgrade, but things are working fine since (booting with -v).

I´m using tluck´s 1600x900config.plist renamed to config.plist.

The only issue I found so far is Preview not opening jpg files.

I did assign jpg files to "XnView MP MacOSX" but Finder displays the ever spinning cartwheel when clicking a jpg just the same.

I had a system freeze yesterday after inserting a SD card from a camera - tons of JPEG on it of course.

My guess is that Finder/Preview tries to access the metal API, which is unsupported by our SandyBridge iGPU.

Other apps may call for metal too, thus freezing the hack, could you share the QT file in question eventually?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.



      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
      Case dimensions: 431 mm x 342 mm x 177 mm
      XCPM OFF

      XCPM ON






      Win 10 x64 v1809
      AIDA64 - Cache & Memory

      Download:  https://github.com/xe97/X99-8D3-Clover
      Anyone else I forgot
    • By digivish
      Hi All - quick thing - I have a NUC 8i7BEH with 32GB RAM and 2 x 1TB SSD drives. Each drive has its own OS - Windows 10 and Catalina 10.15.
      Clover works well - Catalina Boots, so does Windows.
      Catalina - has sound over HDMI (to my monitor's speakers)
      Windows - no audio device found - It does show Realtek and Intel Display Drivers - but the speaker has a red"x" and in Devices, there is no entry for Microphone Array under Audio Input/Output. It does, however, show Intel display over the HDMI - but actually no sound.
      I have tried reinstalling Realtek drivers - now here's the thing...when it installs, it first uninstalls existing Realtek drivers - at this stage (and it's important) the sound starts working - as if uninstalling did the trick. As part of the installing, I have to reboot and upon reboot, it actually reinstalls the Realtek drivers. After that, I'm back to square 1. Unsure if it's the config.plist or boot args in clover. But something with Clover for sure.
      I have tested this by removing the Mac Drive with clover and just booting directly to Windows 10 bootloader and everything works as it should, I have sound over HDMI and the audio device shows. Just not when I boot with Clover.
      has anyone experienced this and have thoughts or pointers.
      Thanks a ton!
    • By MaLd0n

      --Original Post--
      --Bios/UEFI Settings--
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
      Extreme Memory Profile (X.M.P.) - Profile 1
      2- Go to BIOS tab
      CSM Support - Disabled
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
      4- Go to Chipset tab
      Internal Graphics - Enable
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
      *Use this folder with FULL DSDT PATCHED
      ---Extract one Full dump for DSDT edits, post files---



      Intel Core i9-9900K


      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler


      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)


      MSI RX Vega 64 AIR Boost 8G OC


      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND


      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 


      TP-Link Archer T9E


      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing

      --DSDT Patches--

      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kelvin henrique
      Faz pouco menos de uma semana que estou tentando dar boot usando um pendrive no lenovo g40-80, mas todas as vezes que tento algum kernel panic diferente acontece, não entendo tanto de hackintosh mas pelo que li tanto aqui no forum quanto em outros sites me fizeram constatar que talvez o erro seja falta de kexts, alguem possui os kexts para esse notebook ??
      primeiro erro que tive era porque estava usando um pendrive de 8gb, o recomendado é 16 no minimo pelo oque vi, fui la, comprei um de 32, mudou o kernel panic mas era só um dos erros resolvidos.
      especificações dele:
      Processador: Intel Core i3-5005U
      Grafico: Intel HD Graphics 5500
      originalmente ele vinha com um hd de 500gb e 4gb de ram, mudei pra um ssd de 128gb e 8 gb de ram
      ja percebi que unico problema desse notebook é que a placa de wifi não vai funcionar, mas quanto a isso não tem problema pois se conseguir mesmo instalar o mac eu comprou outra
    • By ludufre
      Installing macOS Catalina on Lenovo ThinkPad L440

      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...

      11/08/2019 20:30h GMT-0
      - Added instructions to swap Command with Option keys in VoodooPS2Controller.kext.
      - Added additional FileVault 2 UEFI drivers be more practical.
      10/30/2019 01:42h GMT-0
      - Added 10.15.1 update instructions.
      - Replaced AppleALC.kext with VoodooHDA.kext
      - No more issues after sleep or misconfiguration with jack sense.
      10/29/2019 18:18h GMT-0
      - Replaced the config.plist with AppleIntelCPUPM = true.
      10/27/2019 05:37h GMT-0
      - Replaced the DW1560 wireless card with BCM94360CS2.
      10/20/2019 20:47h GMT-0
      - Removed AppleBacklightFixup.kext.
      - WhateaverGreen now implements backlight since 1.2.5.
      10/20/2019 18:10h GMT-0
      - First version.
      What works and what does not
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 BCM94360CS2 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff and Continuity ->  Work after replaced wireless.
      - Instant Hotspot ->  Not work.
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
      - RAM upgrade:
      16GB (2x8GB). No mistery here. Just upgade.
      - Wireless upgrade:
      Previously I have the DW1560 working almost perfectly, now replaced with BCM94360CS2 that is full native supported. 
      More info below.
      - Make DP audio work.
      - Make Card Reader work.
      - Make trackpad appear in System Preferences
      - Make Instant Hotspot work.
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Catalina install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches

      How create create the install flash drive
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.

      Install bootloader

      Download the CloverEFI from official repository (used 5097) and install only with these options on "Install macOS Catalina":
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - Recommended Drivers - AudioDxe (Just to have nice sound on boot)
      - UEFI Drivers - Recommended Drivers - FSInject (I still don't know if it's really necessary)
      - UEFI Drivers - File System drivers - ApfsDriverLoader (Support to APFS partitions)
      - UEFI Drivers - File System drivers - VBoxHfs (Support HFS/HFS+ partitions)
      - UEFI Drivers - Memory fix drivers - AptioMemoryFix (Fix the memory management of de UEFI/BIOS)
      FileVault 2
      If you plan to use FileVault 2, you need to download additional drivers, since what comes with Clover is not up to date and use VirtualSMC instead of FakeSMC.
      Follow instructions bellow:
      From current Clover installation, check these options to USB keyboard/mouse work on password screen:
      - UEFI Drivers - Human Interface Devices - UsbKbDxe
      - UEFI Drivers - Human Interface Devices - UsbMouseDxe
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
      Download the versions 2.1.0 and 2.0.9 of AppleSupportPkg from: https://github.com/acidanthera/AppleSupportPkg/releases
      We need the last version of AppleGenericInput.efi that is inside 2.1.0 and last version of AppleUiSupport.efi that is inside 2.0.9.
      OR download attached bellow.
      Put in /Volumes/EFI/EFI/CLOVER/drivers/UEFI/
      That's it! FileVault 2 will work without problems.

      Make things works
      After Clover install will be created a partition named EFI and mounted in Desktop. Usually the path is /Volumes/EFI/.
      - Replace the /Volumes/EFI/EFI/CLOVER/config.plist with mine attached below
      - Put SSDT-L440.aml attached below in /Volumes/EFI/EFI/CLOVER/ACPI/patched/
      Generate your Serial, MLB and SmUUID
      - Open the replaced config.plist with Clover Configurator (used
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
      Copy the Clover Configurator to flash drive because you will need later.
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
      - Download the VirtualSMC from here. I used all Kexts and UEFI driver (put VirutalSmc.efi inside /Volumes/EFI/EFI/drivers/UEFI/) from version 1.0.8 (If you followed the steps to enable FileVault 2 above, skip to the next item).
      - Download the Lilu.kext from here. I used the version 1.3.8.
      - Download the VoodooPS2Controller.kext from here. I used version 2.0.4.
      - Download the IntelMausiEthernet.kext from here. I used the version 2.5.0.
      - Download the VoodooHDA.kext from here. I used the version 2.9.2. (Need to turn up the volume on Info.plist, more instructions below)
      - Download the WhateverGreen.kext from here. I used the version 1.3.3.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      Important! If you are coming from my previous Mojave guide, please note that I am using some kexts from other repositories / authors.
      Audio volume adjustment
      - Open the Info.plist inside VoodooHDA.kext/Contents/ with TextEdit.app or any text editor of your choice.
      - Change:
      <key>PCM</key> <integer>90</integer> to:
      <key>PCM</key> <integer>140</integer> Or, download the versions 2.9.2 attached bellow.
      Keyboard swap Command with Option (optional)
      - If you prefer, you can swap Command and Option keys, to map Win Key - Command and Alt - Option.
      - Change /Volumes/EFI/EFI/CLOVER/OEM/S400CA/UEFI/kexts/10.15/VoodooPS2Controller.kext/Contents/PlugIns/VoodooPS2Keyboard.kext/Contents/Info.plist:
      <key>Swap command and option</key> <true/> to:
      <key>Swap command and option</key> <false/> Or, download the version 2.0.4 already adjusted attached bellow.
      Wifi and Bluetooth (BCM94360CS2 + M2 NGFF adapter)
      Recently I replaced the DW1560 with BCM94360CS2. Now I have fully wireless and bluetooth working (including Instant Hotspot) without any kexts.
      Wifi and Bluetooth (DW1560 / BCM94352Z)
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (Ask on UEFI hack forums over there to someone patch for you. Every dump is unique, so mine don't work to you.);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
      After replaced the wireless card. Download those Kexts and put in /Volumes/EFI/EFI/CLOVER/kexts/10.15/
      - Download the AirportBrcmFixup.kext from here. I used the version 2.0.3. (To enable Wireless)
      - Download the BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext from here. I used the version 2019-10-17. (To enable Bluetooth)
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.4. (To enable Handoff and Continuity)
      Keep in mind that the bluetooth kexts are currently in development and the official releases will be available in future in the repository: https://github.com/acidanthera/BrcmPatchRAM/releases
      Now you can start the installation without problem (I guess).
      How install
      UEFI Setup Configuration and Installation

      UEFI configuration
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
      - Now, hold the F12
      - In the list, select your flash drive.
      - Choose the flash drive (white icon).
      The installer will start. 
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install
      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      Choose the internal disk (gray hdd icon) if not already selected.

      The second part of the installation will begin. This will take 16 minutes.


      Post installation
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to make the system disk bootable.

      Open the Clover Configurator from flash drive that you copied before.

      Mount and open the flash drive EFI partition. (Inside Clover Configurator, Mount EFI -> Select flash drive in Efi Partitions list -> Mount Partition -> Open Partition)
      Copy the EFI folder to desktop.
      Go back to Clover Configurator, unmount the EFI partition of the flash drive and mount and open the EFI partition of internal disk.
      Move the EFI folder from Desktop to EFI partition of the internal disk.
      Eject the flash drive.
      Move all Kexts from EFI partition of internal disk to /Library/Extensions and make kext cache, with those commands in Terminal:
      sudo mv -R /Volumes/EFI/EFI/CLOVER/kexts/10.15/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
      It's done!
      System Updates
      Updated without changing or updating anything.


      And last but not least

      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @"Sniki", @Mieze, @headkaze and all others members involved directly or indirectly.
      Filevault 2 additional drivers.zip