Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,440 posts in this topic

Recommended Posts

On 10/30/2018 at 8:46 PM, goodguess said:

Thanks tluck.

As I was uncertain how to get back the trackpad function, installed from scratch again on the USB2 volume.

Until right now trackpad, trackpoint and keyboard do work. Same for sound, volume keys and camera.

Why the kexts were no loaded last time remains the question.

I´ll try some more, than replacing HS with Mojave will be on schedule.


I´m getting system crashes in an early stage, three out of four times.

I´ll try with my other T420, as there may be a ACPI issue as seen before.

The crash report (first lines) is attached.


For the lost trackpad and sound, could HWSensors be the culprit?

The devices did work on my second trial until installation.

Afterwards Trackpad and sound are missing and HWSensors are not loaded either - strange.



I've got the same problem, after HS/Mojave install laptop keyboard/trackpad/sound/network was working, but on some subsequent boot not anymore.. I only realized this later at some point, since I'm using usb keyboard/mouse while docked, and usb speakers..

Gonna try a reinstall also, and try to pay attention at when/what's happening.


Share this post

Link to post
Share on other sites

@davidian: Did you install the HWSensors package too, from tluck´s repository?

Is 10.14 booting flawlessly on your side - without KP?

I could not make HiDPI work either, not that I would need it actually.


@Tetonne: I seem to recall that there was no valid whitelist removal after 1.46, things may have changed meanwhile.

Downgrading BIOS from Windows did not work for me back in the days either.

The DOS flash solution did work as described, see my txt file included with the upload.

Best stay with the patched 1.46 with WL removal, I think that the spyware Intel AMT function is disabled that way too. ;)


Share this post

Link to post
Share on other sites
3 minutes ago, goodguess said:

@davidian: Did you install the HWSensors package too, from tluck´s repository?

Is 10.14 booting flawlessly on your side - without KP?

I could not make HiDPI work either, not that I would need it actually.


@Tetonne: I seem to recall that there was no valid whitelist removal after 1.46, things may have changed meanwhile.

Downgrading BIOS from Windows did not work for me back in the days either.

The DOS flash solution did work as described, see my txt file included with the upload.

Best stay with the patched 1.46 with WL removal, I think that the spyware Intel AMT function is disabled that way too. ;)



I did install it, yes. Are you suggesting not to install it after a fresh install? I like having that, would be good to know if that affects things somehow.


Another thing that I noticed with HS was that I could not boot a lot of times. After selecting to boot HS in clover, my laptop would reboot as soon as the boot process started. Then I would switch on verbose logging, and it would boot all the way.. This seems sporadic, because sometimes I could boot normally. I did not have this issue with Mojave though.

I didnt check back the logs, so I do not know for sure if I had KPs or not.

I also need to do a compare between tluck's patched DSDT and my own, as some things (addresses) might be different, so I need to keep only the patched bits. I assume (maybe wrongly) most people don't do this if things work out of the box, but sometimes the problem lies there, some things might not work, because someones T420 DSDT is a bit different than the patched one posted in the guide. A compare of the decompiled DSDT's would show of there's some difference there besides the patches.



Share this post

Link to post
Share on other sites

@davidianI have not been installing kexts to my HD OS for awhile now - I just leave them in the ESP. so the _kext-install.command is optional in that regard. in fact needs to be updated for use with Mojave to perhaps install gfx kexts in /S/L/E vs /L/E. 


i compared the 1.52 DSDT to the 1.46 DSDT and i could not find any differences that would matter for macOS. The fix-region clover patch may make a change so i always use that option.


My 8GB/AUO LCD system has 2 disks, Disk0 (main disk) is Mojave and Windows10 and Disk1 (in my expansion bay) is a backup Mojave and HighSierra. So in essence has 3 OS.

i use the same config.plist kexts to boot Mojave and HighSierra - and I cannot see any difference in performance etc. otherthan some minor issues with Mojave LightMode etc.

both 10.13 and 10.14 have random glitches.

Share this post

Link to post
Share on other sites

@tluck thanks for the info!

I have not run the kext install command either, just wondering.. I know that I did when installing El Capitan, but it was not written as mandatory in the current guide, so I didn't.


What I meant about the DSDT file, was sthing like this:

OperationRegion (MNVS, SystemMemory, 0xDAF9D018, 0x1000)


OperationRegion (MNVS, SystemMemory, 0xBAF9D018, 0x1000)


On my Fujitsu Laptop I had differences like this in my old and new DSDT after a motherboard replacement.

I only checked for that because some of the things did not work after mobo replacement, like battery, sound...

Maybe it was because it came with a newer BIOS, but I didn't check.

Is it correct to assume that if people use the same BIOS like yours, differences like this one should not be present?

It might not be relevant here, I don't know, but since then, I check for things like this :)


I just tried to boot now with the mojave plist in high sierra, and it worked. First time I tried it didnt, donno why.


EGPU also works in High Sierra with the appropriate nvidia web drivers, and reverting your SLOT1 modification in DSDT for EXP4, thats where is connected. Unfortunately no web drivers yet for Mojave..


Edited by davidian

Share this post

Link to post
Share on other sites

Comrades, I got a fresh small SSD today and let CCC do its job to clone from my USB-2 external.

10.14 is booting without crashing/lagging now. Could have very well been the old pATA drive via USB having issues.


The 10.14.1 upgrade did work without issues, a couple of boot trials were needed though.

GPU support did persist after upgrading.


Thanks all for keeping the T420 alive and updated!


Edit: KP got even worse now. I can boot MJ maybe 1 out of 8 times.

Don´t know whether I´d better give up and be content with Windows 10 / Sierra / HS.

The few times 10.14 boots, everything seems to be OK (except Preview) but a OS not booting can really become annoying. :(


I´m attaching my latest KP, hoping that someone finds the issue.


Edited by goodguess

Share this post

Link to post
Share on other sites

@goodguess Does it happen also if you boot with -v flag (verbose)? It's just a curiosity, shouldn't have any effect unless it's maybe a timing issue or sthing I have no idea about. Everytime I couldn't boot and I tried to do a verbose boot after, to see what's what, it booted (for me it was High Sierra, Mojave didn't do this so far)..

Edited by davidian

Share this post

Link to post
Share on other sites

I tried with both my T420, the usual 16GB rig and the 8GB Windows machine.

As expected its not a -v issue. Both Thinkpads do have kernel panics, the Windows flavour maybe a bit less.

The KP always is like this, cpu 1 caller or cpu 2 caller do change. I never saw such in Sierra or HS.



*** Panic Report ***
panic(cpu 1 caller 0xffffff80084d84dd): Kernel trap at 0xffffff8008a067a0, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0xffffff8008f6342d, CR3: 0x000000000bfb6000, CR4: 0x00000000000626e0
RAX: 0x0000000000000000, RBX: 0xffffff801997a8c0, RCX: 0x0000000000000000, RDX: 0x000000000000c7c8
RSP: 0xffffff81093abb10, RBP: 0xffffff81093abb10, RSI: 0xffffff8008fb46ea, RDI: 0xffffff8008f6342d
R8:  0x0000000000005cee, R9:  0x000000000000b9dc, R10: 0x0000000000000001, R11: 0x0000000000000000
R12: 0x0000000000000853, R13: 0x0000000000000853, R14: 0xffffff801997a968, R15: 0xffffff801997a968
RFL: 0x0000000000010246, RIP: 0xffffff8008a067a0, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0xffffff8008f6342d, Error code: 0x0000000000000000, Fault CPU: 0x1, PL: 0, VF: 2

Edit1: I´m booting with -v in the config.plist meanwhile, and don´t see KP right now.

Whether this is some voodoo, or related to swapping SSD/HDD I can´t tell.

Maybe the T420´s sATA connectors degrade too over decades.


Edit2: Does anybody else have the issue with Preview (Mojave HD3000) not opening .jpg files?

PNG files do work as expected. Not a big issue, just wondering whether it´s a problem on my side.

Edited by goodguess

Share this post

Link to post
Share on other sites


Finally got Mojave working on the T420 (HD300 1600X900).

Noticed that the Brightness keys were not working. But then I see that the brightness slider is missing from the System Pref --> Display option. I thought we did have a brightness slider there.


Not sure where to look, is it a problem with the keyboard mapping or is some kext not working as it should.


I have done the Mojave Hack and also updated to the 10-31 zip. 

Share this post

Link to post
Share on other sites



i have a question again... i am running 10.13.6 and just bought a new wifi card: AR9280 AR5BHB92. it should be able to do 5GHZ, but i cannot see any network! The only think wich looks strange to me is, that the profiler just sais it can do up to channel 140 - and shuldnt be there 160 channels for 5GHZ? So if anyone knows how to fix that it would be just awesome!!!!


So my goal is to have it running in 300mbit 5hgz. Any chance to do that?






Share this post

Link to post
Share on other sites



Im kinda new to the hackintosh community and i have been trying to get OS X High sierra 10.13.6 to work on my T420 (2436)

So the problem that im facing is the graphics, i cant seem to get any higher resolutions than 960x600 with HD3000.

I have done everything as instructed in the tutorial, yet cant make it work?

Share this post

Link to post
Share on other sites

@goodguess I also have problems with Preview (Mojave) opening pictures, don't know why and didn't think to mention it here or check for different formats, but glad that you did!


As for the sATA connector degrade hunch, my gut tells me it can't be that, because then ElCapitan should do that too.. and for me it never did, it's the most stable Hackintosh I had so far on T420.

Edited by davidian

Share this post

Link to post
Share on other sites

@ snike: Not sure what you did, actually. The Mojave Hack is for Macs afaik.

Are you using the pre-build EFI folder, tluck posted at GitHub?

I have the slider and the brightness keys with my T420.



@ pcace: Thats really weird. You will hardly need channels above 140 though. :)

Ch 100 to 140 may run with 1000 mW, Ch 149 to 165 may only output 25 mW !

As a lazy guy, I´m using a DELL 1510 WiFi card, as I wanted a Broadcom chip.




@Arttu: Did you select the correct config.plist in EFI/EFI/Clover from the package tluck offers?

A small screen lets me assume that your HD3000 kexts did not load correctly and/or that your T420 is running without GPU hardware acceleration.

Does Alt-Shift-3 work for taking a screenshot on your side?

Does your Graphics/Display section look like this?





Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4747 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
      1. Download and unzip "EFI_Clover_r4747 for VMware.zip". Mount Clover-v2.4k-4747-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By superdooper71
      Hi all,
      I hope someone can help me as I am struggling with this bloody installation.
      I am running on several problems that I can't face : (
      First of all my config:
      Mobo: ASROCK H81M-DGS R2
      CPU: Intel Xeon E3-1220 v3 @3.10ghz
      RAM: 16gb DDR3 1600Mhz
      SSD: Crucial BX100 120Gb SSD
      Monitor: Hp 27w Hdmi
      POST Installation CLOVER
      Current Issues:
      • System will not boot (clover boot loader do not shows up) from SSD
         - System boot only with USB stick
      • Screen Resolution is only 1024x768
      • Monitor recognised as 17" instead of 24"
      • Monitor identified as secondary
      • Grafic Card Geforce GT710 shows 0 Mb
      • System info do not match Config.plistin Clover
      I attach screenshot of System Info, Kext in Clover, Resolution etc etc.
      Please can someonhelp me?
      Please can you tell me what is the Clover Parameter to activate when installing Clover  (Clover_v2.4k_r4722) into Boot Disk?
      I hope someone can help me out of this little troble: )
      system info.tiff
    • By Entropi
      I’ve used a 2015 15” MBP as my main system since it was released. I do photo and video editing in the Adobe suite regularly and have been eyeballing the performance of the latest MBP models. I’m on the road all the time, so a laptop is basically my only option.

      After the whole mess with the CPU VRM hardware flaws being made apparent by the poor power management profile shipped at release with the 2018 i9 MBP I’ve been more weary of the hardware design of MacBooks. That’s before I account for losing all USB-A ports, losing the SD card slot (‽), losing reliability and tactility of the keyboard, and losing the ESC key to the touchbar; if I compare the 2018 MBP to my current 2015.
      Given these flaws, I have been researching the performance situation comparing the 2018 MBP to the X1 Extreme, XPS 15 9570, and the Razer Blade 15 2018.  These are essentially the only options for a road warrior that needs a high quality panel and the best CPU and GPU that can be crammed into around 4lbs (1.8kg).  
      I used to use a ThinkPad T42p and loved it when it was new. So fast forward to now and the release of the ThinkPad X1 Extreme. It’s a truly tempting machine for an artist, given that the 4K UHD version offers just about the best color gamut available on any laptop panel. I get back the USB-A ports, get one of the fastest SD slots on any laptop, and get one of the best laptop keyboards on the market. That’s before even considering power management and modularity. I’ve been dabbling in learning Machine Learning, so a system with an nVidia GPU (CUDA) is a bonus on that front as well.
      For me the best color reproduction on a high resolution display panel was most important. The X1 Extreme has that, so I’ve ordered one. I got it with the fastest i7, base SSD and memory, and have separately purchased two 1TB Samsung 970 Pro M.2 SSDs and 2x16GB DDR4-3200MHz memory (just in case it’s possible to overclock the memory on the X1 Extreme). I got the system for $2,100 from Lenovo USA, and the SSDs ($390 x 2) and memory ($330) from Amazon US for a total of ~$3200.  These are easy to install on the X1 Extreme as the bottom cover is easily removed to reveal the M.2 and SODIMM slots. To compare, the 2018 MBP with the fastest i7, 32GB memory, and 2TB SSD is $4400. So I can save $1200 and get a faster system (on all counts) with a better panel and better connectivity by going with the X1 Extreme.
      The only thing I’m compromising is losing the big beautiful haptic touchpad and a bit more refined hardware aesthetic. Though, to be honest, I’ve kept a big thick dual-layer Tech21 case on my 2015 MBP. So I’ll actually be going down in volume and weight by moving to the more rugged ThinkPad. I think I can live without the touchpad.

      Oh, by the way, the 4K UHD panel of the X1 Extreme has touch and decent pen support! Another bonus vs. the MacBook. Though I keep a 12.9” iPad Pro around for my pen work and can’t imagine using a laptop similarly. It’s still nice to have a laptop screen actually respond when I go poke at it accidentally after switching back and forth between laptop and iPad.
      So I want macOS with proper discrete GPU support on a 2018 MacBook class laptop.  That’s not possible on a pure Hackintosh as things stand, but via a macOS virtual machine it looks like it could work with what looks like some relatively bleeding edge support of PCIe UEFI passthrough.

      People have been doing this on Linux hosts to Windows VMs with some great success recently: https://gist.github.com/Misairu-G/616f7b2756c488148b7309addc940b28
      And it looks like that’s coming for macOS VMs as well: https://github.com/kholia/OSX-KVM/blob/a4fb2fd5aae871bdbc371b0cd31d4d8129d0f9ac/UEFI/README.md

      The X1 Extreme, XPS 15 9570, and Razer Blade 15 (2018) are essentially direct competition to the 2018 15” MBP. I would really like to see these three systems get some nicely fleshed out guides for getting maxed out compatibility and performance in macOS running in a VM for these systems. When I get my X1 Extreme I’ll start working on it for that one. I will post updates here. I hope to inspire others with the other two systems (or looking to get them) to do similarly.
      I chose the X1 Extreme largely because of the excellent 4K UHD HDR panel (100% of 2D AdobeRGB and 85.5% of 3D AdobeRGB, basically unparalleled), good mix of thermal performance and noise management, and overall ruggedness and connectivity.  If I were a gamer I would go with the Razer 15, but the fast low-gamut 1080p panel just doesn’t work for my purposes. If I were most concerned with aesthetics or battery life (97Wh battery for it vs 80Wh for X1E) I would go with the XPS 15.
      I am aware that the second 2018 refresh of the MBP is coming ~Nov 14, with the new AMD Radeon Pro Vega 16 and Vega 20 GPUs, and it looks like the latter might offer up to a 60% performance boost over the Radeon 560X. Maybe it has even given Apple enough time to update the CPU VRM along the way. This could make the performance picture more comparable for the 1050 Ti based X1E and XPS 15. I believe the 1070 Ti based Razer 15 will still win out though.
      Still, if you compare the fan and heat pipe solution put into the X1E vs the MBP the MBP just looks wimpy in comparison. MBP has smaller fans, less venting, and only one (smaller, thinner) heatpipe. It’s also more difficult to access if you want to put a better thermal paste or liquid metal on it.  Put simply, the thermal hardware on the MBP is basically the same design for the last 3 years and it can’t keep up with the hex-core processors. So even with the Volta 20 GPU making the MBP competitive again on the graphics end, the MBP will still be falling short on the CPU performance plane. This is before we even look at tuning options.
      Getting into tuning, it’s possible to improve thermal performance of all the laptops in this class by around 15-20% by using either a best in class thermal paste like Thermal Grizzly Kryonaut or (if you’re willing to deal with all the caveats that come with using a conductive fluid that permeates other metals) a liquid metal interface like Thermal Grizzly Conductonaut. The liquid metal gives you the best possible conducting interface, and the paste is more forgiving and easier to apply.  Further, it is often possible to stably undervolt the Coffee Lake i7/i9 available in this class of systems to further improve performance, thermals, and power consumption (generally another 10+%).
      Apple has deliberately made it impossible to undervolt the CPU on the MBP! This has been true since the first Skylake CPUs a few years ago. You used to be able to use a program called Volta to undervolt your CPU on macOS. This is a huge peeve for me and, combined with the general power and thermal underdevelopment, is one of the main reasons I want to get a competitor’s hardware. As a primer, the default voltage of modern CPUs is typically set conservatively high for the sake of production efficiency.  With the current generation Coffee Lake CPUs it is commonly possible to set the CPU voltage about 100 to 150mv lower safely.  This allows the CPU to run cooler and consume less power. For laptops which are thermally limited (basically everything in this new 6-core 14nm era), this also translates into better performance. It’s a tweak that actually improves reliability of your CPU. So it’s just stupid that Apple has deliberately made this impossible. Shame on them, someone else take my money.
      Wrapping up, my biggest quibbles with the X1E (before actually getting it) are that the 4K panel’s responsiveness is about the slowest I’ve seen on a modern panel, and it’s just really not suitable for gaming. There’s also what I consider an annoyingly high level of backlight corner bleed that I’m sure will be distracting during blackboxed video viewing. Hopefully these two issues will be fixed in next year’s iteration.
      MacBook i9 Thermal / VRM (below-baseline throttling/thrashing) Issue:
      This was mitigated with software that works around the poor hardware design, but the system would still ultimately perform better if the CPU VRM were redesigned. Non Mac systems with the similar CPUs don’t have this issue and get better sustained performance.
      MacBook Nov 2018 Refresh with Radeon Vega 16 and Vega 20:
      MacBook Class Laptop Reviews:
      Lenovo ThinkPad X1 Extreme, 4K: https://www.notebookcheck.net/Lenovo-ThinkPad-X1-Extreme-i7-4K-HDR-GTX-1050-Ti-Max-Q-Laptop-Review.335608.0.html
      Dell XPS 15 9570, 4K: https://www.notebookcheck.net/Dell-XPS-15-9570-i7-UHD-GTX-1050-Ti-Max-Q-Laptop-Review.332758.0.html
      Razer Blade 15 2018, 1070 Ti FHD 144Hz: https://www.notebookcheck.net/Razer-Blade-15-i7-8750H-GTX-1070-Max-Q-FHD-Laptop-Review.305426.0.html
      Best Undervolting Guide (keywords: ThrottleStop, Intel XTU):
      Undervolting Coffee Lake i7/i9 (2018 MacBook class CPU):
      Replacing Thermal Paste with Liquid Metal on 2018 MBP:
      https://youtu.be/iw4gqfrBN4c ... and follow up: https://youtu.be/JNoZNzOQpVw
      Replacing Thermal Paste with Kryonaut on X1E:
      Replacing Thermal Paste and Undervolting X1 Carbon:
      Replacing Thermal Paste and Undervolting XPS 15 9570:
      Possibly over-conservative BIOS update for thermal throttling on X1E:
      High Sierra (10.13) drivers only for now:
      nVidia “waiting for Apple’s approval” for Mojave (10.14) macOS driver web release:

      Breadcrumb Links (other things I found researching this):
    • By gengik84
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.

      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  selezionate OsxAptioFixDrv-64
                             *  :Se nel vostro sistema è presente una scheda grafica (discreta) della serie 9xx nVidia selezionate OsxAptioFix2Drv-64 al posto di  OsxAptioFixDrv-64 *
      ** OsxAptioFix2Drv :E' necessario per poter impostare CsrActiveConfig= 0x3 **
      ***OsxAptioFix3Drv oppure AptioMemory --> (consigliato) devono essere usati su hardware Skylake o successivi perché permettono alla nvram di lavorare correttamente
           (mi raccomando o uno o l'altro)
      Proseguite con l’installazione.
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      Per installazione Legacy
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      7) Sezione System Parameters: Su inject kext mettete YES
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto-Fake+Sensors 6.26.1440.zip

    • By fagner_sbs
      Hello! Sorry for the way of writing in English, I'm using google translator.
      I am several days trying to make my Mojave hakintosh work perfectly. However, I have reached a point where I can no longer proceed without help.
      Almost all hardawares were installed and recognized (using the clover). However, still have a panic kernel (capture attached). Every time, when connecting the MAC it restarts 2 or 3 times to be able to show the dekstop and to function normal. I also think that having problem with video graphics sometimes freezes the entire display system if video appears on a web page.
      I've attached a file with used files: clover, bios capture, complete hardware information, error capture(https://1drv.ms/u/s!AvhW45_HBY8zgfsySZPWZ-SZXFiMfA). Can someone help me?
      Mobile DualCore Intel Core i7-3537U, 2000 MHz (20 x 100), 4 threads
      Asus K46CB Series Notebook
      Intel Panther Point HM76, Intel Ivy Bridge-MB
      16269 MB  (DDR3 SDRAM)
      BIOS AMI (05/17/2013)
      Intel(R) HD Graphics 4000               
      NVIDIA GeForce GT 740M