Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

4,983 posts in this topic

Recommended Posts

28 minutes ago, tluck said:

but you are able to boot Snuk's 1.52 DSDT right? (other than the ACPIBatteryManager issue?)

Ah, I can use your aml with lower version of clover, and when I use Snuk aml it KP about 2 times then It can boot into OS normaly, and it loop that progress again and again after every restart or start up! So strange!

Edited by SuperReaper

Share this post


Link to post
Share on other sites
Advertisement
4 hours ago, SuperReaper said:

Ah, I can use your aml with lower version of clover, and when I use Snuk aml it KP about 2 times then It can boot into OS normaly, and it loop that progress again and again after every restart or start up! So strange!

can you try this one? what is KP all about?

DSDT.zip

Share this post


Link to post
Share on other sites
4 hours ago, tluck said:

can you try this one? what is KP all about?

DSDT.zip

KP like this

Anonymous UUID:       2D6AEB3B-6313-385A-93E9-DF44519B0F33

Sun Sep  9 12:38:13 2018

*** Panic Report ***
panic(cpu 1 caller 0xffffff800838776f): Kernel trap at 0xffffff7f8aeec5d5, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x000000000bce3000, CR4: 0x00000000000626e0
RAX: 0x0000000000500000, RBX: 0xffffff801979e0c0, RCX: 0xffffff801a9a4c80, RDX: 0xffffff801b87d480
RSP: 0xffffff91139b3eb0, RBP: 0xffffff91139b3eb0, RSI: 0x0000000000000000, RDI: 0x0000000000000000
R8:  0x0000000000000001, R9:  0x0000000000000030, R10: 0x0000000000000110, R11: 0x0000000000000008
R12: 0xffffff801a9a4cd0, R13: 0xffffff801b87d480, R14: 0xffffff801b87d480, R15: 0xffffff801a9a4c80
RFL: 0x0000000000010246, RIP: 0xffffff7f8aeec5d5, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x1, PL: 0, VF: 1

Backtrace (CPU 1), Frame : Return Address
0xffffff91139b3980 : 0xffffff800826c1c6 
0xffffff91139b39d0 : 0xffffff8008395274 
0xffffff91139b3a10 : 0xffffff8008387544 
0xffffff91139b3a80 : 0xffffff800821e1e0 
0xffffff91139b3aa0 : 0xffffff800826bc3c 
0xffffff91139b3bd0 : 0xffffff800826b9fc 
0xffffff91139b3c30 : 0xffffff800838776f 
0xffffff91139b3da0 : 0xffffff800821e1e0 
0xffffff91139b3dc0 : 0xffffff7f8aeec5d5 
0xffffff91139b3eb0 : 0xffffff800886f6d5 
0xffffff91139b3f00 : 0xffffff80088723ab 
0xffffff91139b3f50 : 0xffffff80088740c6 
0xffffff91139b3fa0 : 0xffffff800821d557 
      Kernel Extensions in backtrace:
         org.rehabman.driver.AppleSmartBatteryManager(1.81.4)[E65767C3-A35F-348A-89CF-C6FAA44C5C6F]@0xffffff7f8aeeb000->0xffffff7f8aef3fff
            dependency: com.apple.iokit.IOACPIFamily(1.4)[95DA39BB-7C39-3742-A2E5-86C555E21D67]@0xffffff7f88ff2000

BSD process name corresponding to current thread: kernel_task
Boot args: slide=64 -no_compat_check -lilubetaall -alcbeta -v 

Mac OS version:
17G65

Kernel version:
Darwin Kernel Version 17.7.0: Thu Jun 21 22:53:14 PDT 2018; root:xnu-4570.71.2~1/RELEASE_X86_64
Kernel UUID: 1AE5ACFD-3B6F-3D74-AD52-31F1430DBC6F
Kernel slide:     0x0000000008000000
Kernel text base: 0xffffff8008200000
__HIB  text base: 0xffffff8008100000
System model name: MacBookPro8,1 (Mac-94245B3640C91C81)

System uptime in nanoseconds: 41034020254
last loaded kext at 40669556317: com.apple.driver.AppleHDA	281.52 (addr 0xffffff7f8a935000, size 958464)
loaded kexts:
com.paragon-software.lvm-for-mac	1
org.rehabman.voodoo.driver.PS2Mouse	1.8.34
org.rehabman.voodoo.driver.PS2Trackpad	1.8.34
org.rehabman.voodoo.driver.PS2Keyboard	1.8.34
VoodooSDHC	1.1d1
com.insanelymac.IntelMausiEthernet	2.3.0d0
com.rehabman.driver.ACPIPoller	0.8.1
org.rehabman.voodoo.driver.PS2Controller	1.8.34
org.hwsensors.driver.ACPISensors	1443
org.rehabman.driver.AppleSmartBatteryManager	1.81.4
org.hwsensors.driver.CPUSensors	1443
as.vit9696.AppleALC	1.3.1
org.netkas.driver.FakeSMC	1443
com.rehabman.driver.USBInjectAll	0.6.5
as.vit9696.WhateverGreen	1.2.2
science.firewolf.NightShiftUnlocker	2.2.1
as.vit9696.Lilu	1.2.7
com.apple.driver.AppleHDA	281.52
com.apple.driver.ApplePolicyControl	3.20.13
com.apple.driver.AppleUpstreamUserClient	3.6.5
com.apple.driver.AppleMCCSControl	1.5.5
com.apple.driver.AppleGraphicsDevicePolicy	3.20.13
com.apple.AGDCPluginDisplayMetrics	3.20.13
com.apple.driver.pmtelemetry	1
com.apple.iokit.IOUserEthernet	1.0.1
com.apple.iokit.IOBluetoothSerialManager	6.0.7f10
com.apple.Dont_Steal_Mac_OS_X	7.0.0
com.apple.driver.AppleHV	1
com.apple.driver.AppleOSXWatchdog	1
com.apple.driver.AppleLPC	3.1
com.apple.driver.ACPI_SMC_PlatformPlugin	1.0.0
com.apple.driver.AppleIntelSlowAdaptiveClocking	4.0.0
com.apple.driver.AppleSMCPDRC	1.0.0
com.apple.driver.AppleFIVRDriver	4.1.0
com.apple.driver.AppleIntelSNBGraphicsFB	10.0.4
com.apple.iokit.SCSITaskUserClient	404.30.2
com.apple.driver.AppleFileSystemDriver	3.0.1
com.apple.filesystems.apfs	748.51.0
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless	1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib	1.0.0
com.apple.AppleSystemPolicy	1.0
com.apple.BootCache	40
com.apple.filesystems.hfs.kext	407.50.6
com.apple.driver.AirPort.Atheros40	700.74.5
com.apple.driver.AppleFWOHCI	5.5.9
com.apple.driver.AppleIntelHD3000Graphics	10.0.4
com.apple.driver.AppleAHCIPort	329.50.2
com.apple.driver.AppleBacklight	170.12.6
com.apple.driver.AppleRTC	2.0
com.apple.driver.AppleHPET	1.8
com.apple.driver.AppleACPIButtons	6.1
com.apple.driver.AppleSMBIOS	2.1
com.apple.driver.AppleACPIEC	6.1
com.apple.driver.AppleAPIC	1.7
com.apple.driver.AppleIntelCPUPowerManagementClient	220.50.1
com.apple.nke.applicationfirewall	183
com.apple.security.quarantine	3
com.apple.security.TMSafetyNet	8
com.apple.driver.AppleIntelCPUPowerManagement	220.50.1
com.apple.driver.DspFuncLib	281.52
com.apple.kext.OSvKernDSPLib	526
com.apple.driver.AppleGraphicsControl	3.20.13
com.apple.iokit.IOSurface	211.15
com.apple.iokit.IOAVBFamily	680.2
com.apple.plugin.IOgPTPPlugin	680.15
com.apple.iokit.IOEthernetAVBController	1.1.0
com.apple.driver.AppleSMBusController	1.0.18d1
com.apple.driver.AppleSSE	1.0
com.apple.driver.AppleSMBusPCI	1.0.14d1
com.apple.iokit.IOFireWireIP	2.2.9
com.apple.AppleGPUWrangler	3.20.13
com.apple.AppleGraphicsDeviceControl	3.20.13
com.apple.driver.AppleHDAController	281.52
com.apple.iokit.IOHDAFamily	281.52
com.apple.iokit.IOAudioFamily	206.5
com.apple.vecLib.kext	1.2.0
com.apple.driver.Apple16X50Serial	3.2
com.apple.iokit.IOSerialFamily	11
com.apple.driver.IOPlatformPluginLegacy	1.0.0
com.apple.iokit.IOSlowAdaptiveClockingFamily	1.0.0
com.apple.driver.IOPlatformPluginFamily	6.0.0d8
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport	6.0.7f10
com.apple.iokit.IOBluetoothHostControllerUSBTransport	6.0.7f10
com.apple.iokit.IOBluetoothHostControllerTransport	6.0.7f10
com.apple.iokit.IOBluetoothFamily	6.0.7f10
com.apple.driver.usb.cdc	5.0.0
com.apple.driver.usb.networking	5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice	1.2
com.apple.driver.usb.AppleUSBHub	1.2
com.apple.iokit.IOSCSIMultimediaCommandsDevice	404.30.2
com.apple.iokit.IOBDStorageFamily	1.8
com.apple.iokit.IODVDStorageFamily	1.8
com.apple.iokit.IOCDStorageFamily	1.8
com.apple.driver.AppleXsanScheme	3
com.apple.iokit.IOAHCISerialATAPI	267.50.1
com.apple.iokit.IOAHCIBlockStorage	301.40.2
com.apple.filesystems.hfs.encodings.kext	1
com.apple.iokit.IO80211Family	1200.12.2
com.apple.driver.corecapture	1.0.4
com.apple.iokit.IOFireWireFamily	4.7.2
com.apple.driver.usb.AppleUSBEHCIPCI	1.2
com.apple.driver.usb.AppleUSBEHCI	1.2
com.apple.iokit.IOAHCIFamily	288
com.apple.driver.AppleEFINVRAM	2.1
com.apple.driver.usb.AppleUSBHostPacketFilter	1.0
com.apple.iokit.IOUSBFamily	900.4.1
com.apple.driver.AppleBacklightExpert	1.1.0
com.apple.iokit.IONDRVSupport	519.20
com.apple.iokit.IOGraphicsFamily	519.20
com.apple.driver.AppleEFIRuntime	2.1
com.apple.driver.AppleUSBHostMergeProperties	1.2
com.apple.iokit.IOSMBusFamily	1.1
com.apple.iokit.IOHIDFamily	2.0.0
com.apple.security.sandbox	300.0
com.apple.kext.AppleMatch	1.0.0d1
com.apple.driver.AppleFDEKeyStore	28.30
com.apple.driver.AppleEffaceableStorage	1.0
com.apple.driver.AppleKeyStore	2
com.apple.driver.AppleUSBTDM	439.70.3
com.apple.driver.AppleMobileFileIntegrity	1.0.5
com.apple.iokit.IOUSBMassStorageDriver	140.70.2
com.apple.iokit.IOSCSIBlockCommandsDevice	404.30.2
com.apple.iokit.IOSCSIArchitectureModelFamily	404.30.2
com.apple.driver.AppleCredentialManager	1.0
com.apple.driver.KernelRelayHost	1
com.apple.iokit.IOUSBHostFamily	1.2
com.apple.driver.usb.AppleUSBCommon	1.0
com.apple.driver.AppleBusPowerController	1.0
com.apple.driver.AppleSEPManager	1.0.1
com.apple.driver.IOSlaveProcessor	1
com.apple.driver.DiskImages	480.60.1
com.apple.iokit.IOStorageFamily	2.1
com.apple.iokit.IOReportFamily	31
com.apple.iokit.IOTimeSyncFamily	680.15
com.apple.iokit.IONetworkingFamily	3.4
com.apple.driver.AppleACPIPlatform	6.1
com.apple.driver.AppleSMC	3.1.9
com.apple.iokit.IOPCIFamily	2.9
com.apple.iokit.IOACPIFamily	1.4
com.apple.kec.Libm	1
com.apple.kec.pthread	1
com.apple.kec.corecrypto	1.0

EOF
Model: MacBookPro8,1, BootROM MBP81.004E.B00, 2 processors, Intel Core i5, 2.59 GHz, 8 GB, SMC 1.68f99
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, Samsung, M471B5273DH0-CH9
Memory Module: BANK 0/DIMM1, 4 GB, DDR3, 1333 MHz, Samsung, M471B5273CH0-CH9
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9287: 4.0.74.0-P2P
Bluetooth: Version 6.0.7f10, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
PCI Card: Intel 82579LM PCI Express Gigabit Ethernet, Ethernet, PCI Slot 1638400
Serial ATA Device: HGST HTS725050A7E630, 500.11 GB
Serial ATA Device: Optiarc DVD RW AD-7710H
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Integrated Camera
USB Device: Broadcom Bluetooth Device
USB Device: Biometric Coprocessor
USB Device: USB 2.0 Bus
USB Device: Hub
Thunderbolt Bus: 

It seem dsdt conflict with ACPIBatteryManager.kext

Share this post


Link to post
Share on other sites

Hello together,

 

last weekend I tried around 12h to boot up, always with the similar faults as shown on the picture, just the first message changes:

screenshot_42.png.f07a22d074a93a2763f76405e9fd0c53.png

 

What I did so far:

 

- use clover 4542 and 4509

- use my DSDT

- use DSDT from @tluck 

- use the package from tluck dated August, with my DSDT

- use bios default settings and make changes according to this guide

- save ACPI tables again and compared with my 1.52: same

 

Always the same result... argh.. The crazy thing is it was working before...

 

The only way to boot into macOS is without DSDT.. then of course nothing is working.

 

Somewhere else I read that macOS has sometimes problem with the installed RAM. So I will organize a few other modules and try again.

 

Keep you updated...

 

UPDATE:

Just tried DSDT_1.52_hs from @tluck , same result, see above picture.

 

UPDATE 2:

new RAM, same problem

Edited by SnuK
another test

Share this post


Link to post
Share on other sites
36 minutes ago, SnuK said:

Hello together,

 

last weekend I tried around 12h to boot up, always with the similar faults as shown on the picture, just the first message changes:

screenshot_42.png.f07a22d074a93a2763f76405e9fd0c53.png

 

What I did so far:

 

- use clover 4542 and 4509

- use my DSDT

- use DSDT from @tluck 

- use the package from tluck dated August, with my DSDT

- use bios default settings and make changes according to this guide

- save ACPI tables again and compared with my 1.52: same

 

Always the same result... argh.. The crazy thing is it was working before...

 

The only way to boot into macOS is without DSDT.. then of course nothing is working.

 

Somewhere else I read that macOS has sometimes problem with the installed RAM. So I will organize a few other modules and try again.

 

Keep you updated...

 

UPDATE:

Just tried DSDT_1.52_hs from @tluck , same result, see above picture.

 

did you set a serial number by any chance? if yes try to boot with it removed

Edited by n0xius
more info

Share this post


Link to post
Share on other sites

Hmm. can you try with the DSDT most recently provided and this config.plist which will disable all the Clover DSDT edits except fix regions.

rename it config.plist or select during Clover startup. note: i forget to mention - this most recent DSDT needs ACPIPoller.kext to handle FAN speed.

Obviously this DSDT works for me.

@Snuk i took your nicely patched DSDT.dsl and added a few more changes/fixes. then compiled it.

 

 

config.1600x900.2e3.plist

Edited by tluck

Share this post


Link to post
Share on other sites

The Mojave config, used in High Sierra, with the graphics tweak for 1600 x 900 display is working fantastic for me. I've also upgraded RAM to 16GB and graphics glitches are pretty much a thing of the past.

Share this post


Link to post
Share on other sites
22 hours ago, n0xius said:

did you set a serial number by any chance? if yes try to boot with it removed

 

Do you mean the serial number inside the config.plist?

Share this post


Link to post
Share on other sites

Hello again,

 

today I made some more tests, here are the results:

 

- put in another RAM, same problem as described 9/11/2018 at 8:31 PM

- boot with my dsdt_1.52 and the config from @tluck actual bundle,  same problem as described 9/11/2018 at 8:31 PM

- boot with my dsdt_1.52 and tlucks new config config.1600x900.2e3.plist, kernel panic (see attached picture, related to AppleIntelCPUPowerManagement, maybe same problem as @SuperReaper reported)

- boot with tlucks dsdt_1.52 and the config from @tluck actual bundle,  same problem as described 9/11/2018 at 8:31 PM

- boot with tlucks dsdt_1.52 and tlucks new config config.1600x900.2e3.plist, successfully boot into macOS HS, looks good

- boot with tlucks dsdt_1.52_hs and the config from @tluck actual bundle, kernel panic (see attached picture, related to AppleIntelCPUPowerManagement, maybe same problem as @SuperReaper reported)

- boot with tlucks dsdt_1.52_hs and tlucks new config config.1600x900.2e3.plist, kernel panic (see attached picture, related to AppleSmartBatteryManager, maybe same problem as @SuperReaper reported as well)

 

So again, for me the following is working: tlucks dsdt_1.52 and tlucks new config config.1600x900.2e3.plist!

 

 

P.S. sorry for the bad pictures, they are captured from slo-mo videos

dsdt_1.52 and tlucks new config config.1600x900.2e3.plist

tlucks dsdt_1.52_hs and tlucks new config config.1600x900.2e3.plist

Edited by SnuK
typo

Share this post


Link to post
Share on other sites
4 hours ago, SnuK said:

Hello again,

today I made some more tests, here are the results:

...

So again, for me the following is working: tlucks dsdt_1.52 and tlucks new config config.1600x900.2e3.plist!

 

Great news. That points to the recent version of Clover breaking the DSDT for some reason (and not for everyone!?) ... as this "working" config.1600x900.2e3.plist has the ACPI DSDT fixes turned off except Fix_regions. But everything is already in the pre-made DSDT except a few things. I will make a few appropriate changes and repost the zip.

 

Note: i found very little difference between the 1.46 DSDT and 1.52 DSDT.

 

Share this post


Link to post
Share on other sites
10 hours ago, maihoward1985 said:

Hey guys. I would ask you how to "whitelist" my T420 Bios. I got this machine with Bios 1.49 and I don't know where to do it.

 

Hi, it's not a question of where but how to do it.

You need to flash a bios with whitelist mod, for example v1.52 with whitelist mod: T420 BIOS v1.52 mod

 

Use it on your own risk, the T420 here already had this bios.

Edited by SnuK

Share this post


Link to post
Share on other sites
On 9/13/2018 at 6:06 AM, SnuK said:

 

Hi, it's not a question of where but how to do it.

You need to flash a bios with whitelist mod, for example v1.52 with whitelist mod: T420 BIOS v1.52 mod

 

Use it on your own risk, the T420 here already had this bios.

 

Thank you Snuk. I will do it.

Share this post


Link to post
Share on other sites

@Tluck, @Snuk,


How to resolve this problem without remove USB Inject All Kext while using Config Mojave?. I am too curious how exactly Mac OS Mojave looked like to that I've decided to give my computer a try by using Mojave Config in Tluck Package. After boot, the MacOS High Sierra recognize my system as MacBook Pro 2013 and also allow me upgrade direct via Apple Store. 

Besides that, something really strange happened. I can't open Config Mojave Plist file by Clover then I've tried several times before using Plist Edit Pro to check what wrong with it. When Plist Edit Pro opened the config file, there few main information inside has been deleted ( Kext to Patch ... System ... etc )
  

 

IMG_1621.thumb.jpg.8b66e9c8249a99cdeb8eeb711b630898.jpg

Share this post


Link to post
Share on other sites
42 minutes ago, maihoward1985 said:

@Tluck, @Snuk,


How to resolve this problem without remove USB Inject All Kext while using Config Mojave?. I am too curious how exactly Mac OS Mojave looked like to that I've decided to give my computer a try by using Mojave Config in Tluck Package. After boot, the MacOS High Sierra recognize my system as MacBook Pro 2013 and also allow me upgrade direct via Apple Store. 

 

Are you saying that if mojave.plist is used, then it's possible to update to mojave via Apple Store?

 

I use mojave.plist on a High Sierra install and get the same USB Accessory Needs Power if more than one USB device is plugged in.

Edited by bedfellow

Share this post


Link to post
Share on other sites

@bedfellow Yes. When my machine was identified as Macbook Pro 13, it’s allowed me to update like this way. ( But make sure you already install apple beta or developers profile into your system ). 

 

I used same config, same packages i have downloaded from Tluck but i dont know why only X220 was recognized as Macbook Pro 2013. My “new” T420 wasn’t.

2B8AEF63-FA64-47CC-95E8-57BEF658196F.jpeg

Edited by maihoward1985

Share this post


Link to post
Share on other sites
53 minutes ago, maihoward1985 said:

@bedfellow Yes. When my machine was identified as Macbook Pro 13, it’s allowed me to update like this way. ( But make sure you already install apple beta or developers profile into your system ). 

 

I used same config, same packages i have downloaded from Tluck but i dont know why only X220 was recognized as Macbook Pro 2013. My “new” T420 wasn’t.

 

It allows you to update, but did you perform the update?

 

My T420 identifies as MacBook Pro (Retina, 13-Inch, Late 2013)

Share this post


Link to post
Share on other sites
1 hour ago, bedfellow said:

 

It allows you to update, but did you perform the update?

 

My T420 identifies as MacBook Pro (Retina, 13-Inch, Late 2013)


Yes. I did. While I was writing reply comments here, my machine was updating by that way. Here is my very first impressions since I was able to update by this way. 

- Trackpad, Wifi, Speaker ... etc. Still recognized like Native machine. I don't see any problems. 
- Still able to keep some patched I had used like Night Shift .... 
- Due to HD3000 is non-metal supporting, there have major lagging. I hope Tluck or anyone else could find away to patch frame or something like this to make the system run more smoothly. 
- Tluck config Mojave is so amazing !!!!


 

 

35FFB5EA-DFEC-45DA-A613-E58C1E84DF0D.jpeg

Edited by maihoward1985

Share this post


Link to post
Share on other sites
26 minutes ago, bedfellow said:

I performed the update and now in Mojave, but have lost wifi. Any advice on getting it working?

 


Which brand of Wifi card do you use in your machine?. 

I use Broadcom and I also have to put bunch of patches into my config's kexts-to-patch in order to make it work in MacOS.  
Here is what I have collected for a long time since El Cap til now.

wifi.plist


Hopefully it will help you. I have no knowledge about coding so that I have copy-paste and then messing my machine until I see which works for me lol.
Besides that, how do your machine graphics work? any lag? 
 

Edited by maihoward1985

Share this post


Link to post
Share on other sites
7 hours ago, bedfellow said:

I performed the update and now in Mojave, but have lost wifi. Any advice on getting it working?

 

If you have Atheros, bad news: Apple removed the support in Mojave completely.

But you can use the kext of HighSierra, see also here.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, SnuK said:

If you have Atheros, bad news: Apple removed the support in Mojave completely.

But you can use the kext of HighSierra, see also here.

 

Thanks for the link but unfortunately I don't understand what I need to do. Is there a kext I need to put somewhere?

Share this post


Link to post
Share on other sites

I had tried copying over High Sierra IO80211Family.kext, but that didn't work, even after several reboots, so thought I would give an external USB wifi dongle a try whilst trying to work out how to get the internal card working.

 

The USB dongle didn't work so I went searching for drivers for that and discovered https://github.com/chris1111/WIFI-Network-macOS-High-Sierra, which I installed. On reboot I had wifi, so assumed it was the dongle, but surprisingly it is actually the built in wifi card. Not sure if it's c combination of both the kext and driver, or whether just the driver.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By anokic
      I have been using clover to install and configuration my Hackintosh High Sierra 10.13.6. It's been a struggle and a pain. Can't restart/shutdown/wake from sleep. Random freezes. When freeze happens mouse works but in loading state. UI and open apps freeze not the mouse. I can make the apps smaller and move them.

      I haven't used any DSDT nor SSDT. Tried 5 or 6 of them from others but sometimes i end up not booting. Could someone explain me do i even need them and why? Do i need DSDT or SSDT or both?

      I'm going to try to install everything OpenCore. The first thing is i can't use a method that needs an internet while installing MacOS cause my ethernet/internet only works when i install MacOS. So i can't use the images i need full installation. Okay i have the full installation for 10.13.6. I need to use a version 10.13.4-6 versions cause application Sketch needs the newer one High Sierra 10.13.4++ version.

      Can you tell me? Can i use same kexts from Clover on OpenCore? Secondly how can i install full USB MacOS installer? (High Sierra 10.13.6 version i have is 7gb i think thats it)
      Is there a version of AMDHigh Sierra version made from the community for 10.13.4++ version?
      If i use the normal 10.13.6 High Sierra should i use this AMD 10.13.6 Kernel when i have installed the MacOS or some other kernel that's better for my system? https://github.com/Shaneee/AMD-High-Sierra-XNU/releases
      Whats the best version of High Sierra to use for Ryzen and Nvidia system?

      Will it be better to use OpenCore?

      Specs:
      Mortar Max B450M
      Ryzen 2600x
      Nvidia GTX 1060
      16gb DDR4 2400mhz
    • By TimothyF
      My steps so far:
      Set up Catalina install USB exactly according to Plain Vanilla guide. Disconnect my Windows drive in PC, so that only the empty Hard Drive is connected to Motherboard. Boot to USB, select Install Catalina option. BIOS set to UEFI, Safe mode Off. Always get stuck at the same IOconsoleUsers: GIOScreenLockState point. Tried -radvesa, -radoff, nv-disable=0 boot options (separately), and disabling BIOS virtualization (vt-d) -> NO luck. This from the top search result https://www.reddit.com/r/hackintosh/comments/b5a6ry/ioconsoleusersgioscreenlockstate_3_blackscreen/  
      Screen pics attached. Here are the last couple of lines that could be important:
      GTrace synchronization point 4
      Unsupported CPU
      Unsupported PCH
      Adding ADGP mode validate property
      hmm.. mismatch sizes 3100 vs 20
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOconsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
       
      Please give me some ideas what else might work. Thank you.


       
       
      Other details of Clover and Desktop PC below:
       
      Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: config.plist ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)  
    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By STLVNUB
      Script file to clone Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By TimothyF
      My PROBLEM: I followed the Plain Vanilla guide (https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/) to a T in creating the OS X Catalina installer USB. I'm totally new to Hackintosh, and just want an Apple environment to Time Machine migrate my files and system from my ageing MacBook Pro. When I start to use the USB on the target PC (Dell Inspiron 3847 desktop), I ONLY see the Microsoft (which is the original OS, and on a SEPARATE Hard drive from where I want to install Mac OS), ZERO option for installing the OSX Catalina! Please SEE PICTURE link: https://imgur.com/a/FnLB2Q9   I'm a beginner, but I tried to google my problem. The answers were either incomplete, hard for me to understand and put into action, or were outdated and applied to older OSXs. I appreciate any help in diagnosing and solving this problem!   Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: see attached ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)   ------------------------------------ Attached:
      Screenshot of Clover installer not showing the Mac OSX option
      config.plist of my installer USB
      Clover_Install_Log.txt (not sure if this is relevant)   THANK YOU VERY MUCH!     config.plist
      Clover_Install_Log.txt
×