Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,321 posts in this topic

Recommended Posts

Posted (edited)

10.13.5 and sound works for me? I will push a new zip out when i get home later today. 

The latest zip contains a cleaned-up/fixed AppleALC.kext. 

Edited by tluck

Share this post


Link to post
Share on other sites
Advertisement

Anyone who knows if the T420 is MacOS 10.14 Mojave capable?

Share this post


Link to post
Share on other sites
On 5/16/2018 at 1:06 AM, zarere said:

1.Is there an option to create bootable flash without using mac computer?

2.If i do not need wifi connection do i need to use modded bios?

3.What is the preffered bios version that  I can use on my laptop since for t420 I see version  from 1.46 and above but what about W520?

@zarere

1) there is a tool to create a bootable flash - see rufus  IIRC runs on windows.

2/3) the modded bios is really about removing whitelist for WIFI chip - no idea about W520.

 

Share this post


Link to post
Share on other sites
29 minutes ago, jboeren said:

Anyone who knows if the T420 is MacOS 10.14 Mojave capable?

Nop. Needs a Metal capable GPU.

Share this post


Link to post
Share on other sites

thanks for last pack tluck :)

did someone test this : clover-genconfig is able to produce all your injection keys used at last successful boot including automatic properties when inject=YES. But not including _DSM methods.?

 

Share this post


Link to post
Share on other sites
15 hours ago, tluck said:

@zarere

1) there is a tool to create a bootable flash - see rufus  IIRC runs on windows.

2/3) the modded bios is really about removing whitelist for WIFI chip - no idea about W520.

 

Great,thank you very much tluck.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

 

Do you have any video tutorial?

 

Also my bios version is 1.49. Will it work?

 

I am not that much techy. Please help....

 

Thanks a lot!

Edited by murad12s

Share this post


Link to post
Share on other sites

I have installed the mac perfectly.

 

But after trying to boot from SSD, I see the following screen.

 

@tluck could you please help?

IMG_4423.JPG

Share this post


Link to post
Share on other sites

Finally, I have installed 10.12.6

 

But sound & keyboard is not working now after booting from hdd.

 

Still looking for the solution.

Share this post


Link to post
Share on other sites
On 6/6/2018 at 3:39 PM, trifero said:

Nop. Needs a Metal capable GPU.

 

Unless it is patched, for which I read some work is being done to make Mojave run on HD3000.

Share this post


Link to post
Share on other sites
On 6/13/2018 at 5:22 PM, murad12s said:

I have installed the mac perfectly.

 

But after trying to boot from SSD, I see the following screen.

 

@tluck could you please help?

I have the exact same output on a T420 trying to boot the 10.13.5 installer. Already tried to remove FakeSMC' plugins in the subfolder but no luck...

Any advice? Thanks

Share this post


Link to post
Share on other sites

According to macrumors.com there is a way to run Mojave on HD3000:

 

https://forums.macrumors.com/threads/macos-10-14-mojave-on-unsupported-macs-thread.2121473/page-36#post-26177370

Share this post


Link to post
Share on other sites

Hey guys!

 

It seems my random freezes are back :(

Have you been able to solve it? I moved to the latest package and to 10.13.5, freezes remain.

 

Thank you.

Share this post


Link to post
Share on other sites
13 hours ago, Somez said:

Hey guys!

 

It seems my random freezes are back :(

Have you been able to solve it? I moved to the latest package and to 10.13.5, freezes remain.

 

Thank you.

 

I’m still on Sierra with no freezes at all. Just running smooth!

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/13/2018 at 8:22 AM, murad12s said:

I have installed the mac perfectly.

 

But after trying to boot from SSD, I see the following screen.

 

@tluck could you please help?

IMG_4423.JPG

I used the 1600x900 alt .kext. You can re-load your other kexts to solve your problem by the by. Kext Utility is your friend!

Edited by SabithaSuki

Share this post


Link to post
Share on other sites

Hi guys, I need help!

I tried fresh installing 10.13.5 on my T420 with tluck's Lenovo-T420-Clover-2018.06.04 pack.  Booting from the USB get stuck at this screenshot attached below.  I tried a few things and figured out that if the patched/dsdt.aml is removed, then it loads fine.  So I went ahead and installed 10.13.5.  Now I have the same problem with booting from the SSD.  It gets stuck with the patched\dsdt.aml and boots to MacOS without it.  Same problem with dsdt.edid-hs.aml. I have attached my ACPI/original folder here if you could help.

I installed AppleHDA_20672.kext to S/L/E but sound doesn't work.

 

Lenovo T420 i5 8GB 128G SSD Intel HD3000 1600x900

 

Thanks!

origin.zip

IMG_2762.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

@jgn123 hmm odd that to be a problem with DSDT since you seem to have the same base DSDT as me. 1.46.  i dont know why it doesnt work with an SSD? my system has one?

Edited by tluck

Share this post


Link to post
Share on other sites

Hi tluck,

 

I've read somewhere that disabling ALPM in the BIOS (Aggressive Link Power Management) could solve the freezing issues so I'm testing that now. However that topic also said we should try disabling trim with the command trimforce disable. I disabled the TRIM but now I want to turn it back. However I'm not sure whether it's disabled or enabled by default for the T420. Before disabling I tried trimforce help hoping it will tell me the current status (enabled/disabled) but it did not. So I'm not sure whether TRIM must be enabled using this command or not.

 

Thank you.

Share this post


Link to post
Share on other sites

Well, this is interesting. The freezes have not gone util I removed my HDD which was sitting in the optibay caddy. Now the system is running on purely SSD and no freezes so far. The problem is, I need that HDD :)

I'm going to be testing this further with SSD only and will report back.

Share this post


Link to post
Share on other sites
5 hours ago, Somez said:

Well, this is interesting. The freezes have not gone util I removed my HDD which was sitting in the optibay caddy. Now the system is running on purely SSD and no freezes so far. The problem is, I need that HDD :)

I'm going to be testing this further with SSD only and will report back.

 

Update: Still getting freezes. The only way prevent freezing is when I stop at the logon screen and don't login. So I now need to figure out the reason behind.

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/24/2018 at 10:36 AM, Sherlocks said:

yes. i already use mojave beta2 with HD3000

 


나의 LG-F800S 의 Tapatalk에서 보냄
 

 

@Sherlockscool! it seem like the "trick' is to use the High Sierra Gfx kexts? is there more to it than that? that sounds easy to do! any other tips?

Update:

so i tried Mojave with my T420 and it is working. i copied the all HD3000 and SNB kexts, bundles and plugins over from High Sierrra. i had to copy the Atheros kext to get WiFi working. at first copied the HD3000 to /Library/Extensions and i wasnt getting full 3D graphics - so then copied everything to /S/L/E and then full GFX!!!

Pretty much all I had to do was update Lilu and AppleALC to the latest revs then added 3 boot args: -no_compat_check -lilubetaall -alcbeta

 

 

 

Edited by tluck

Share this post


Link to post
Share on other sites
On 7/8/2018 at 4:28 AM, tluck said:

@Sherlockscool! it seem like the "trick' is to use the High Sierra Gfx kexts? is there more to it than that? that sounds easy to do! any other tips?

Update:

so i tried Mojave with my T420 and it is working. i copied the all HD3000 and SNB kexts, bundles and plugins over from High Sierrra. i had to copy the Atheros kext to get WiFi working. at first copied the HD3000 to /Library/Extensions and i wasnt getting full 3D graphics - so then copied everything to /S/L/E and then full GFX!!!

Pretty much all I had to was update Lilu and AppleALC the latest revs then added 3 boot args: -no_compat_checkd -lilubetaall -alcbeta

 

 

 

 

sorry for late reply. good :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MikixIT
      Ciao ragazzi! Grazie a questo forum con gente fantastica, sono riuscito a installare OS X e in seguito Win 10 su Clover SULLO STESSO HARD DISK
      Ho un problema, di solito utilizzo Kali Linux, la famosa versione di linux in usb in live
      Ora avrei la necessita di dedicargli 15gb di partizione del mio Hard Disk PER INSTALLARLA, e l'ho fatto effettivamente creando una partizione VUOTA tramite utility disco di Sierra.
      Il problema sorge quando io vado a riavviare il pc e quindi ritrovandomi nella schermata di clover, e vedo sempre il solito OSX e il recovery Osx e al posto di Windows 10, mi trovo la partizione di 15gb che avevo creato per windows(con l'icona di windows)
      Siccome ho paura di perdere i dati importanti che avevo su windows, non ho continuato installando Kali, ma mi sono fermato e ho eliminato la partizione sempre da utility di Sierra e come per magia, riavvio e Win10 è di nuovo lì dove dovrebbe stare
      Appena creo la partizione vuota, clover me la sostituisce
      Che devo fare raga?
      Io voglio OSX,Win10 (Che già ho) e Kali(Solo 15gb) sullo stesso hard disk
      Senza perdere dati di Win o Mac
      Gengik ho visto in precedenti discussioni tue, di andare in GUI da clover config . e togliere Windows da quelli nascosti e l'ho fatto, ma il risultato non cambia.
      Grazie per la lettura
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
    • By thomaspetersen
      Hi All
       
      I'm trying to start a Hackintosh High Sierra 10.13.5 installation:
      - MSI B350 PC Mate
      - Ryzen 5 - 2600
      - Radeon Pro 580 GPU
      - 4 x 8GB DDR4
      (Have a working clover bootloader for HS 10.13.3 - but for some reason, I can't use that setup with the 10.13.5) 
       
      Have tried different bootloader setup, with different outcomes...
      ATM. I get this error/hang - "Unknown CPU: family = 0x17, model = 0x8, Stepping = 0x2"
      Have search google, and can see that the threads ppl. are getting this, is when they look at "About this mac", I haven't yet installed the OSX.
       
      So can someone help...

      I'm running the newest Kexts: AppleALC, FakeSMC, Lilu, RealtekRTL8111, USBInjectAll and WhateverGreen.
      In Bootloader setup, i'm running: -v, -s, -f, -no_compat_check, busratio=34, PCIRootUID=1, npci=0x2000, dart=0 and nv_disable=1
      In SMBIOS i'm using the iMac18,2 and in RT i'm using BooterConfig: 0x28 and CsrActiveConfig: 0x67
      In installed drivers i'm using: AptioMemoryFix, EmuVariableUefi-64, OsxAptioFixDrv-64 (Have tried Fix2 as well)
       
      But i'm, keep getting the Unknown CPU hang/error, can someone help...
      Or do someone have a setup with the same CPU and GPU, that can show me his/her setup for Bootloader/Kexts...
    • By Teress
      I get a lot of questions about HOW TO BACKUP A HACKINTOSH. So I decided to create Complete Guide with 5 methods described in detail, how to easily make bootable clones of Hackintosh system disks, or backup your data. Full step by step tutorial is here:
       
       
×