Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

5,059 posts in this topic

Recommended Posts

10.13.5 and sound works for me? I will push a new zip out when i get home later today. 

The latest zip contains a cleaned-up/fixed AppleALC.kext. 

Edited by tluck

Share this post


Link to post
Share on other sites
Advertisement
On 5/16/2018 at 1:06 AM, zarere said:

1.Is there an option to create bootable flash without using mac computer?

2.If i do not need wifi connection do i need to use modded bios?

3.What is the preffered bios version that  I can use on my laptop since for t420 I see version  from 1.46 and above but what about W520?

@zarere

1) there is a tool to create a bootable flash - see rufus  IIRC runs on windows.

2/3) the modded bios is really about removing whitelist for WIFI chip - no idea about W520.

 

Share this post


Link to post
Share on other sites

thanks for last pack tluck :)

did someone test this : clover-genconfig is able to produce all your injection keys used at last successful boot including automatic properties when inject=YES. But not including _DSM methods.?

 

Share this post


Link to post
Share on other sites
15 hours ago, tluck said:

@zarere

1) there is a tool to create a bootable flash - see rufus  IIRC runs on windows.

2/3) the modded bios is really about removing whitelist for WIFI chip - no idea about W520.

 

Great,thank you very much tluck.

Share this post


Link to post
Share on other sites

Hi,

 

Do you have any video tutorial?

 

Also my bios version is 1.49. Will it work?

 

I am not that much techy. Please help....

 

Thanks a lot!

Edited by murad12s

Share this post


Link to post
Share on other sites

Finally, I have installed 10.12.6

 

But sound & keyboard is not working now after booting from hdd.

 

Still looking for the solution.

Share this post


Link to post
Share on other sites
On 6/6/2018 at 3:39 PM, trifero said:

Nop. Needs a Metal capable GPU.

 

Unless it is patched, for which I read some work is being done to make Mojave run on HD3000.

Share this post


Link to post
Share on other sites
On 6/13/2018 at 5:22 PM, murad12s said:

I have installed the mac perfectly.

 

But after trying to boot from SSD, I see the following screen.

 

@tluck could you please help?

I have the exact same output on a T420 trying to boot the 10.13.5 installer. Already tried to remove FakeSMC' plugins in the subfolder but no luck...

Any advice? Thanks

Share this post


Link to post
Share on other sites

According to macrumors.com there is a way to run Mojave on HD3000:

 

https://forums.macrumors.com/threads/macos-10-14-mojave-on-unsupported-macs-thread.2121473/page-36#post-26177370

Share this post


Link to post
Share on other sites

Hey guys!

 

It seems my random freezes are back :(

Have you been able to solve it? I moved to the latest package and to 10.13.5, freezes remain.

 

Thank you.

Share this post


Link to post
Share on other sites
13 hours ago, Somez said:

Hey guys!

 

It seems my random freezes are back :(

Have you been able to solve it? I moved to the latest package and to 10.13.5, freezes remain.

 

Thank you.

 

I’m still on Sierra with no freezes at all. Just running smooth!

Share this post


Link to post
Share on other sites
On 6/13/2018 at 8:22 AM, murad12s said:

I have installed the mac perfectly.

 

But after trying to boot from SSD, I see the following screen.

 

@tluck could you please help?

IMG_4423.JPG

I used the 1600x900 alt .kext. You can re-load your other kexts to solve your problem by the by. Kext Utility is your friend!

Edited by SabithaSuki

Share this post


Link to post
Share on other sites

Hi guys, I need help!

I tried fresh installing 10.13.5 on my T420 with tluck's Lenovo-T420-Clover-2018.06.04 pack.  Booting from the USB get stuck at this screenshot attached below.  I tried a few things and figured out that if the patched/dsdt.aml is removed, then it loads fine.  So I went ahead and installed 10.13.5.  Now I have the same problem with booting from the SSD.  It gets stuck with the patched\dsdt.aml and boots to MacOS without it.  Same problem with dsdt.edid-hs.aml. I have attached my ACPI/original folder here if you could help.

I installed AppleHDA_20672.kext to S/L/E but sound doesn't work.

 

Lenovo T420 i5 8GB 128G SSD Intel HD3000 1600x900

 

Thanks!

origin.zip

IMG_2762.jpg

Share this post


Link to post
Share on other sites

@jgn123 hmm odd that to be a problem with DSDT since you seem to have the same base DSDT as me. 1.46.  i dont know why it doesnt work with an SSD? my system has one?

Edited by tluck

Share this post


Link to post
Share on other sites

Hi tluck,

 

I've read somewhere that disabling ALPM in the BIOS (Aggressive Link Power Management) could solve the freezing issues so I'm testing that now. However that topic also said we should try disabling trim with the command trimforce disable. I disabled the TRIM but now I want to turn it back. However I'm not sure whether it's disabled or enabled by default for the T420. Before disabling I tried trimforce help hoping it will tell me the current status (enabled/disabled) but it did not. So I'm not sure whether TRIM must be enabled using this command or not.

 

Thank you.

Share this post


Link to post
Share on other sites

Well, this is interesting. The freezes have not gone util I removed my HDD which was sitting in the optibay caddy. Now the system is running on purely SSD and no freezes so far. The problem is, I need that HDD :)

I'm going to be testing this further with SSD only and will report back.

Share this post


Link to post
Share on other sites
5 hours ago, Somez said:

Well, this is interesting. The freezes have not gone util I removed my HDD which was sitting in the optibay caddy. Now the system is running on purely SSD and no freezes so far. The problem is, I need that HDD :)

I'm going to be testing this further with SSD only and will report back.

 

Update: Still getting freezes. The only way prevent freezing is when I stop at the logon screen and don't login. So I now need to figure out the reason behind.

Share this post


Link to post
Share on other sites
On 6/24/2018 at 10:36 AM, Sherlocks said:

yes. i already use mojave beta2 with HD3000

 


나의 LG-F800S 의 Tapatalk에서 보냄
 

 

@Sherlockscool! it seem like the "trick' is to use the High Sierra Gfx kexts? is there more to it than that? that sounds easy to do! any other tips?

Update:

so i tried Mojave with my T420 and it is working. i copied the all HD3000 and SNB kexts, bundles and plugins over from High Sierrra. i had to copy the Atheros kext to get WiFi working. at first copied the HD3000 to /Library/Extensions and i wasnt getting full 3D graphics - so then copied everything to /S/L/E and then full GFX!!!

Pretty much all I had to do was update Lilu and AppleALC to the latest revs then added 3 boot args: -no_compat_check -lilubetaall -alcbeta

 

 

 

Edited by tluck

Share this post


Link to post
Share on other sites
On 7/8/2018 at 4:28 AM, tluck said:

@Sherlockscool! it seem like the "trick' is to use the High Sierra Gfx kexts? is there more to it than that? that sounds easy to do! any other tips?

Update:

so i tried Mojave with my T420 and it is working. i copied the all HD3000 and SNB kexts, bundles and plugins over from High Sierrra. i had to copy the Atheros kext to get WiFi working. at first copied the HD3000 to /Library/Extensions and i wasnt getting full 3D graphics - so then copied everything to /S/L/E and then full GFX!!!

Pretty much all I had to was update Lilu and AppleALC the latest revs then added 3 boot args: -no_compat_checkd -lilubetaall -alcbeta

 

 

 

 

sorry for late reply. good :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By STLVNUB
      Script file to clone and help build Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
       
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By cvad
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
    • By mavifree
      Sir 
      I am new in this, i try to make my hp laptop in hackintosh but i facing some error in clover boot manager while installing but unable to understand it. I really try hard but not able to get there, something i noticed that i facing same kind of error every time. I just watched youtube and visitied so forum like tonymac86, InsanelyMac, Noobsplanate and so on but nothing solved. So Please Please I Request All of You If you can help me to resolve my problem.
      Here Is my Laptop Specs:
      --------------------------------------------------------------------
      Laptop : HP cs2082tx
      Mobo : HP84C1
      Southbridge : Coffee Lake-U/Y PCH
      CPU : Intel Core i5 8265U @ 1.60GHz Kaby Lake- U/Y
      Ram : 8 Gb
      HDD : 256GB SSD & 1TB HDD
      Graphics : Intel UHD Graphic 620 with nvidia MX250
      ----------------------------------------------------------------------
       
      I even don't is my laptop is compatible or not, and don't have MacBook or Mac Desktop so if you can provide important driver and other stuff for installation. I really be very thankful to you.
      Please Reply me if any other information about my laptop hardware i will attached it i only have this info right now. 
       
      and i here attached my screenshot while installation error in clover.
      Sorry for my English.
       
      Please Help Me 
       



    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      -Donation with Mercado Livre 
      https://tinyurl.com/y9evkj5u
       
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://tinyurl.com/rkqmpd9
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
×