Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,442 posts in this topic

Recommended Posts

If you were having the IOAHCIBlockStorage timing issue from this: http://www.insanelymac.com/forum/topic/280062-waiting-for-root-device-when-kernel-cache-used-only-with-some-disks-fix/ thread, then the workaround of booting with UseKernelCache=no or -f should have worked. Otherwise, you were having one of the more mundane waiting-for-root-device issues, such as those mentiond in this thread: http://www.insanelymac.com/forum/index.php?showtopic=278075


With version 0.4 of my patch-ahci-mlion script, you can specify the kext directory to patch. So patch-ahci-mlion.pl -s /Volumes/whatever/System/Library/Extensions -o osx-release-number to patch some partition other than the one you're running. Or simply run the script with no options to patch the current running os (after booting with the kext cache turned off, as shown above).


I kind of doubt you were having the IOAHCIBlockStorage problem. If you were, then everyone with that laptop would be.


Maybe you just failed to set your disks to AHCI mode per post #18?

Share this post

Link to post
Share on other sites

Thanks Bcc,


I was so tired last night, I was up almost till 5am EDT. I actually made more progress and figured a few more things out. So here's my status: 


OS X install was successful. I mentioned the extra steps I took including mounting the drive externally to finish the install. Turns out it does boot when the drive is installed internally as was my goal. However it only boots about every other time. This morning I even had to cycle it 3 times before it boots. When it hangs, the console doesn't always stop at exactly the same spot, but after the hang, wait 1 min and it confirms still waiting for root device. Now, on the next boot or maybe the third boot after this, It boots right up. My observation is that it's random. I make absolutely no changes yet one time it'll boot and the second it won't.


My next idea is to dump and patch my own dsdt instead of using Gendalo's. Reason being that I've worked with T430's for a long time now and I know that the the 2349 is the (correct) model number for the T430, but the last 3 numbers/letters, 2349XXX correspond to package configuration. It may very well be that Gendalo has totally different hardware from me.


I read the second link you provided, but it doesn't apply. To answer your questions:


1. I am running in AHCI

2. booting with caches off is not any more effective, though theoretically it's supposed to give more time for the disk to detect.

3. I successfully ran your script, within the functional system, not the pre-installed environment. And it quit without patching. I believe the line goes something like nothing to patch or patch already applied.


Wether or not the problem is widespread I don't know. I turn up hardly any results searching for anything T430 and OS X related. So apart from Gendalo and myself, I daresay we're the only ones ever trying this. Or at least the only ones who've documented. When I saw that the issue is intermittent, that's when I got a little upset. I still think it's kext related, but I need to rethink my approach. I've covered a lot of ground in just a few nights, but I didn't envision being a pioneer, I thought someone else will have already done this.


I've burned through your suggestions Bcc, but I invite you and everyone else to throw more ideas at me. I'll investigate them thoroughly.


My other alternative would include switching to an SSD. Gendalo had success with his, but I was hoping to use the resources I have available rather than spend money on this.

I'm also interested in modding my bios to whitelist. This intel 6205 is amazing, but I can't use it in OSX. Ironically, Lenovo flashed a custom part number on the wlan card so even if I take it out, I can't use it in any other computer anyways. I tried. Under windows, I can download the Microsoft driver or the intel one but the inf's have lines in them that specifically exclude this part number. What a racket. So now I have another project open to modify intel's driver and then self sign it somehow, so I can use it. I'm getting really deep with what little I know, but I need all the help I can get.

Share this post

Link to post
Share on other sites

Turns out it does boot when the drive is installed internally as was my goal. However it only boots about every other time. This morning I even had to cycle it 3 times before it boots. When it hangs, the console doesn't always stop at exactly the same spot, but after the hang, wait 1 min and it confirms still waiting for root device.

That is the behavior you'd see with the AHCI driver timing bug. Why don't you try my fix and see if it works for you? It doesn't hurt. Or just upgrade to 10.8.4 and you shouldn't see the problem anymore if it is the AHCI driver timing issue.

Share this post

Link to post
Share on other sites

Thanks again Bcc,


I did try your script:


3. I successfully ran your script, within the functional system, not the pre-installed environment. And it quit without patching. I believe the line goes something like nothing to patch or patch already applied.


But I like your suggestion about upgrading. I hadn't thought of that. I will try this next. I will post back with my results.

Share this post

Link to post
Share on other sites

So success. Updating to 10.8.4 solved my hit-or-miss booting situation. My Lenovo T430 (2349GCU) Hackintosh is a success.


Thanks to bcc9 for providing some much needed assistance in understanding my startup issue. Thanks to Gendalo for his original DSDT and EFI folder. Thanks to the developers of Clover EFI, whom I don't know first-hand, but without whose bootloader I would not have been successful. And of course thanks to all of you in this thread whose discussion on T420's was what originally motivated me to try this on my T430.


Also, if it makes you guys feel any better, This thread is the only thread of value on the entire internet that provided the information i needed to get this project off the ground. I'n not joking, I spent days Googling my fingers raw for tangible information on T430's or 420's for that matter before I came accross this little gem.


Working: (Tested)



Graphics (QE/CI)

Software Updates

TrackPad (MButton Scrolling) [it's inverted, but I think Mac is this way on purpose]




Not Working:



WiFi (Buying http://www.monoprice.com/Product/Index?p_id=8072) [At least temporarily]


System Specs:

Intel® Core™ i5-3320M (2.60GHz) processor with dual-cores

Intel Turbo Boost 2.0 (3.30GHz), Hyper-Threading, 3MB cache

2 x 4GB PC3-12800 SO-DIMM's

320GB 7.2Krpm SATAII (3Gb/s) Seagate Momentus Thin (7mm) HD

14in 1600x900 HD+ LED-Backlit LCD

Intel® HD 4000 Graphics

Ultrabay enhanced DVDRW/CD-RW rambo drive

Intel® Centrino® Advanced-N 6205 (AGN)

Bluetooth 4.0

Intel® 82579LM 1Gb Ethernet


Secure Chip

Fingerprint reader

720p Front-Facing Wide-Angle Low-Light Camera

6c Li-Ion Battery Rated at 3-5.5 Life-Hours

Mac OS X (10.8.4) / Windows 8 / Ubuntu GNU/Linux

Share this post

Link to post
Share on other sites

Great news.

Not sure about restart issue. where does it hang?
Sound - should be easy to solve with voodoohda or there is alc269 codec applehda.kext available.
Wifi - have to get usb wifi (like the one you selected). it probably is RTL8191 or RTL8192 based. I have 3 of these in various sizes. they work ok.

or get apple-compatible internal wifi express card  - but then this gets a bit more tricky - first you have to replace the card and 2nd you must use a BIOS with WL removed 

Glad to see new things on this thread!

Share this post

Link to post
Share on other sites

@okcakep - as artur-pt points out, the lack of KP on the USB boot is probably due to having nullcpupm kext there.


are you booting your HD with Clover or Chameleon. either way, on your HD, you will need to make sure you patch AppleIntelCPUPowerManagement. Clover can do it automatically. 

related to this issue, is making sure you have a proper SSDT - are you dropping the SSDT table and having the bootloader generate a proper table? 


you did not give any details on what system your are running on, what OS, what boot loader.  as many of us do, please add a signature to help set the context for the problem.

Share this post

Link to post
Share on other sites

Dear Expert thanks for your fast answer,


@artur-pt thanks...i'll check..


@tluck thanks for your answer,


This is my step :


My system T420 4236CTO


100G HD

VGA Intel 3000 no dual, intel 3000 only

Bios 1.46 version


From Kogen Mantis setting BIOS


Config > Serial ATA (SATA) > SATA Controller Mode Option [AHCI]
Security > Memory Protection > Execution Prevention [Enabled]

Security > Intel ® VT-d Feature [Disabled] ---> i dont have this setting

My other settings:
Security > Security Chip > Security Chip [Disabled]
Startup > UEFI/Legacy Boot [Both]
Startup > UEFI/Legacy Boot Priority [UEFI First]



From your guide in post #1


- 8GB+ USB pen-drive
- Legal copy of Mountain Lion install app ( 10.8.3 Golden )
- and an app called Lion Disk Maker
- my custom Clover Package: zip.gif  Clover_v2_r1625k0.pkg.zip 

- Till Making install media bootable on your ThinkPad

- Im replace EFI on pen-drive with T420-EFI-Clover-b1972

- Success, pen-drive ready for the boot


After that


- Boot from pen-drive -succes with lenovo logo, lion logo

- Format HD with GUID partition ( 2 partition - LION & DATA )

- Install Mountain Lion to -> LION Partition

- +_ 10 minute done

- Reboot

- Chose Mountain Lion from

- No Luck !!!

- Hard shutdown !!! with press shutdown button more than 5 time !!! :)

- Try boot with NoCaches, PCIRootUID=1/0, GraphicsEnabler=No/Yes, npci=0x3000/2000 no luck..!!!

- Hard shutdown, unplug power ( cable & battery ) wait 5 minute

- Luck...can boot to Installation process...:)

What the problem in this part ?????? pls help...

- Installation process +_ 20 minute, chose country, keybord, etc

- Yess...ML 10.8.3 on display


Step make booting from HD


-Using - Clover Package: zip.gif  Clover_v2_r1625k0.pkg.zip

-Install clover on LION partition

-Mounting EFI,

 - mkdir /Volumes/efi

 - mount -t /dev/disk0s1 /Volumes/efi

-Replace CLOVER in /EFI/CLOVER directory with packet CLOVER in T420-EFI-Clover-b1972




-Rename on directory OEM with 4236CTO

-Install dsdt.aml ( from Kogen Mantis ) on EFI/OEM/4236CTO/ACPI/patched/

-Using KextWizard install package from 1. Download Extra Folder: zip.gif  Extra.zip  post #1




No Luck !!! :D


-No Luck boot from HD with anything parameter :)

-Luck boot from Pen-Drive with parameter NoCaches

-But glitch still appear

-No sound -->> Kogen Mantis patch post #22




I hope can solve :)


Thank you...



Share this post

Link to post
Share on other sites



the T420-EFI-Clover zip file should have everything you need to get up and running - custom kexts matching the included newer dsdt.aml.  you wont need to install kogens package or extra zip files.

i had some problems with kogens dsdt when i tested it at one point (audio issues primarily)


you should be able to get running with slight modification in your steps 3 and 4 above. reread my post (closely at bottom) -            #241             it has some instructions on how to install/replace your ESP (/Volumes/EFI) entirely /EFI/Boot /EFI/Clover (need both inititially) - instead of using the older 1625 version kogen packaged up.


without the OEM folder matching,  this should allow you to boot up using a totally vanilla OSX. (not everything works of course). But from there, then you can complete the customization - install/replace the kexts in the zip 10.8-SLE into your /S/L/E directory. (i have all the kexts in /EFI zip kext folder in my /S/L/E.)

then you can rename the 4236AT9 and make any mods to match your CPU and display -  1600x900 vs low-res. 


do you have 2.5Ghz i5 CPU? if not, you need modify the config.plist CPU section to match in the OEM folder.

Share this post

Link to post
Share on other sites

10.8.5 ok here.


Install, before reboot, put kexts in SLE





to update config

in the OS start the Terminal and enter:

/usr/local/bin/clover-genconfig >config.plist
new config structure config is required 
not so easy to update
here is mine

Share this post

Link to post
Share on other sites


10.8.5 ok here



to update config

in the OS start the Terminal and enter:

/usr/local/bin/clover-genconfig >config.plist
new config structure config is required 
not so easy to update
config configurator doesn't allow to import config.plist to customize it


Hi Tetonne-

Any special instructions to upgrade to 10.8.5? Did you have to restore any of the custom kexts?




Share this post

Link to post
Share on other sites

Done...using chrome for MAC

Using 10.8.4 ( after upgrade ) no issue


@Tluck, how to get VGA out ?

I'll try with your post #325 :)

Wait for update

Share this post

Link to post
Share on other sites

T420 users. 


2 quick things .... and will update a final/new 10.8.5 zip using clover 2082 later on when I get it stabilized.


1) 10.8.5 Update: took awhile but building a successful 10.8.5 installer was not obvious! (vs using the combo update process).  There is an issue with BlueTooth that kept hanging me up. In the end, i was successful in making a Clover UEFI ML Disk tool (Lion Disk Maker) installer for 10.8.5 as well as a "you-nibeest" MBR installer. essentially I had to disable BT in the BIOS to get these to work. Then later on reenable BT and then I had to edit the BT kext (which seems to change in 10.8.5)

/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Info.plist - change 8532 to 8575. 


2) Clover 2082 Update: quite a bit changed in the layout of the config.plist structures, so i will repost with this version soon too! They moved and expanded some of the variable structures. i still seem to need to need a custom ssdt.aml but it does a lot better job on figuring out the CPU and and bus speeds automatically. i now get SpeedSteps 31x and 32x! (dont recall those from before).


Bottom line. 10.8.5 does replace a few of the custom kexts so be prepared to replace them. I will look at patching up the AppleHDA for 10.8.5 as well. but for a quick fix, rollback works.

Share this post

Link to post
Share on other sites



I'm interested in testing both the 10.8.5 update and the Clover update on my T430. So It you have something I can test, please let me know. I tried using a plain install of the new Clover but was unable to boot with my current config. I haven't applied the 10.8.5 update either. I don't have any custom kexts loaded in OSX so I don't think that the update will break it, but how does it affect the custom kexts I load through clover? I'm still figuring out clover.

Great news.

Not sure about restart issue. where does it hang?
Sound - should be easy to solve with voodoohda or there is alc269 codec applehda.kext available.
Wifi - have to get usb wifi (like the one you selected). it probably is RTL8191 or RTL8192 based. I have 3 of these in various sizes. they work ok.

or get apple-compatible internal wifi express card  - but then this gets a bit more tricky - first you have to replace the card and 2nd you must use a BIOS with WL removed 

Glad to see new things on this thread!

Also @Tluck


It hangs after the system unloads. the console outputs all of the kill messages and then the console itself unloads, but then it hangs at the black. Backlight's still on, and the fan's running but I assume that the system is down at that point. I remember someone mentioning something about this earlier in the thread, but it might have been related to a different machine. How would I log the events at the end of system life? I'm sure there is some additional output after the display output unloads but before the full system shutdown. I have no experience in system shutdown process. I'm operating on the assumption that it's opposite of the boot process.

Share this post

Link to post
Share on other sites

It hangs after the system unloads. the console outputs all of the kill messages and then the console itself unloads, but then it hangs at the black. Backlight's still on, and the fan's running but I assume that the system is down at that point. I remember someone mentioning something about this earlier in the thread, but it might have been related to a different machine. How would I log the events at the end of system life? I'm sure there is some additional output after the display output unloads but before the full system shutdown. I have no experience in system shutdown process. I'm operating on the assumption that it's opposite of the boot process.

It's a bug with UEFI firmware (Tiano) that only happens when booting UEFI Clover. The bug is as old as the option to boot UEFI Clover (dating all the way back to June 2012). There wasn't any solution to this problem and more and more people (even on desktop machines) are getting this issue. One of the developers (apianti) has promised to look into the issue, but without logs and memmap dumps (DarwinDumper) from both CloverEFI and UEFI Clover from same machine there is no way it can be solved. Developers need debug material to work with (this is how immediate restart after sleep issue on AMI Aptio was solved on desktop boards).

Share this post

Link to post
Share on other sites

Thanks TimeWalker,


I wish people were this helpful offline as well  :lol:


Now pardon my ignorance:

What is the difference between CloverEFI and UEFI Clover? I was not aware of the distinction. Are you referring to Clover being able to boot in both EFI mode and legacy mode? Or am I way off the mark here?


Sorry in advance...



I've noticed significant differences between UEFI vendors. I am wondering if others have had similar encounters. The UEFI on my ASUS K55A allows me to directly boot from any fat32 partition where it finds /boot/EFI/bootx64.efi or /EFI/bootx64.efi Boot sectors are not required at all. I first noticed this when I converted a Win8 install from MBR with BIOS boot to GPT with UEFI boot. It was super simple and didn't require copying boot sectors. I can also add UEFI boot options to my Boot menu as I want. I can actually install multiple bootx64.efi's in the same partition and create a separate Boot option for each one. I thought this was pretty cool. However, on my T430 which presumably is more advanced, has no such options.


Any thoughts?

Share this post

Link to post
Share on other sites

@bryan G - 


CloverEFI means essentially booting by MBR to the Clover GUI vs using UEFI directly to bring up the Clover GUI



(BIOS MBR -> boot0->boot1->boot->CloverX64.efi) versus

 direct UEFI (UEFI -> CloverX64.efi). 


on the laptop, if i select a GPT disk to boot, it will scan the ESP partition and look for /EFI/Boot/bootx64.efi - which is exactly the same thing as /EFI/CLOVER/Cloverx86.efi. 

however, if i select boot from a MBR formatted disk, then it will look in the MBR for boot0. 

Share this post

Link to post
Share on other sites

Updated 8-Oct-2013 - This old and pretty out of date -  moved on to Mavericks and Yosemite (10.9 and later) here Clover UEFI on T420 Guide


Attached is a current full /EFI pack for T420 on Clover and OSX 10.8.5 (12F45)


see instructions from post 486


Update 4-Oct-2013

  • Revised DSDT
    • for Shutdown hang (thanks to TimeWalker75a)
    • for native ACPIPlatform kext - no need to rollback or patch AppleACPIPlatform.kext - can use unmodified v1.8 from 10.8.5 (see notes below).
    • made a change/fix to reset LEDs upon wakeup.
  • Updated Clover to b2165 b2184
  • Updated AppleIntelE1000e.kext
  • Updated FakeSMC
  • Updated VoodooPS2Controller
  • Added Patched AICPUPM kext for Chameleon compatibility.

Attached is a current full /EFI pack for T420 on Clover and OSX 10.8.5 (12F45)

  • Updated config.plist for Clover 2k
  • OEM 4236AT9 is for 1600x900 i5-2520M (with ssdt.aml)
  • OEM 4236Y33 is for 1366x768 
  • Removed CPU sections from the config.plist (as Clover compute Bus Speed ok now - check it though! should be around 99676 - 99700 
  • Kext Bundle for 10.8.4 is post #241

ACPI Notes:

  • the new DSDT conforms (more) to the native unmodified kexts ACPI spec... so dont have to replace the AppleACPIPlatform.kext. 
  • native AppleACPIPlatform.kext v1.8 (10.8.5)  some issues with Power button lights after wake. - fixed with new DSDT.
  • native AppleACPIPlatform.kext v1.7 (10.8.4) works but does not wake as well when you have external eSATA/USB drives. 


there are 2 kext folders 

10.8 (which are good for vanilla boot) before using OEM folder and/or modified kexts are in place.

  • FakeSMC.kext (v5.2.877) - Kozlek's core hack mechanism + plugins - Note: Follow link to download full package - so you can install HWMonitor.app etc (just select Plugins ACPI and CPU)
  • VoodooPS2Controller.kext (v1.8.8) - RehabMans's PS2 Keyboad/Trackpad -   Note: Follow link to get full package and installation instructions to install daemon may still be subject to random sleep/wake issues... versions 1.8.5+ are proving to be more reliable.
  • AppleIntelE1000e.kext (v2.5.4) - gigE - goes in /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns

10.8-SLE which can be combined with above and will replace your /S/L/E versions.

  • AppleHDA.kext (v2.4.7 patched from 10.8.5)- for full audio support - note: requires matching DSDT sections using Conexant Codec and layoutID 12.
  • AppleACPIPlatform.kext (v1.7) - upgraded to ErmaC's Patched ML kext for sleep/wake + battery
  • ACPIBatteryManager.kext (v1.40) VoodooBattery.kext - Rehabman's kext configured for v3 ACPI per his instructions to show/track battery info on menu bar - requires rollback AppleACPIPlatform.kext
  • BroadcomBluetoothHostControllerUSBTransport.kext (v4.1.7 with patched Info.plist from 10.8.5) - adds ProductID 8575 to make BT work! Put/replace one in /S/L/E/IOBluetoothFamily.kext/Contents/PlugIns
  • IOAHCIBlockStorageInjector.kext -  makes DVD an internal device so iDVD player works. 

​10.8-Chameleon - extra patched kexts for use with Chameleon 

  • AppleIntelCPUPM.kext (patched v214.0.0 from 10.8.5) - not really necessary to install/replace with clover since it does the patching. Optional Install in /S/L/E for Chameleon compatibility.


The DSDT (in OEM) has some new mods in the IGPU are that seem to remove glitches/hangs on either Clover or Chameleon - go figure?! And there is generic/low-res dsdt for non-1600x900 users to try.


Basic instructions and notes:

  1. install vanilla 10.8.5 to GUID formated disk - use USB or other method
    1. You can use this zip to build a clover based USB built by Lion Disk Maker - or other method create an Installer
    2. Note: you may need to disable BlueTooth in the BIOS to install 10.8.5 directly. Enable later when you boot up.
  2. install standard Clover into ESP - use link to download from sourceforge.
  3. mount ESP on /Volumes/ESP and replace /Volume/ESP/EFI with contents in zip
  4. boot up vanilla 10.8.5 with clover - this will use the kexts and "top" level config.plist (rename OEM to OEM.NU for now)
  5. now install kexts from ESP or zip to boot drive into /S/L/E (from /EFI/CLOVER/kexts/10.8 and 10.8-SLE) or use myhack method. see notes above
  6. here is the tricky part - fix OEM folder to match your system 
  7. DO NOT just hastily rename the folder OEM to match your productID -  you may need to modify some things to make it compatible with your specific model details.
    • If you have 1600x900 LCD, you can probably just use items as is - that is rename 4236AT9 to match your product name.
    • If you have 1366x768 LCD, you can probably just use items as is - that is rename 4236Y33 to match your product name.  Note: if you have similar CPU as i5-2520, the SSDT.aml from 4236AT9 may work for you (copy from 4326AT9/ACPI/patched)

Update: There is just a slight differences between these 2 config.plist files now - really just about the LCD resolution and EDID injection for high-res.


Edited by tluck

Share this post

Link to post
Share on other sites

Thanks, so far everything T420 related has been useful in figuring out T430 stuff. So anything I can use from you guys is always helpful.


Also, I believe that I've just confirmed that Gendalo's and my DSDT's are identical. Unless I did something wrong: I dumped my DSDT.aml using Clover. I decompiled it and Gendalo's with a DSDT utility, and then made plain text's from them so I could plug them in to a text file comparator and they came up equal. So, unless I did something wrong, for which there is lately a large possibility, I think they are the same. Both of our machines are 2349XXX so is it likely that they would share the same DSDT?

Share this post

Link to post
Share on other sites

@Bryan - good to know! generally the dsdt will be similar on each model. each BIOS update may tweak minor stuff.


Note: the source dsdt.dsl from the T420 is in the zip - marked with comments (look for tjl )


yeah I too used Clover and its capability to patch the DSDT. I booted up without my custom DSDT using fixmask 0xFFFF and extracted the DSDT using EVO DSDT. then hand edited/retrofitted some other fixes from other folks. many of the edits/fixes etc in the T420 dsdt should apply.


The zip is back on the post above.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By vanadium
      I'm having annoying graphical artifacts / glitches with the following configuration on apps like Firefox. The screen flickers when scrolling. Everything else is working properly. (Brightness, graphical acceleration, battery, etc)
      - Thinkpad T440P
      - Intel Core I7 Haswell 4712MQ + Intel HD4600, (no Nvidia)
      - 16GB RAM,
      - 500GB SSD Western Digital,
      - MacOS 10.13.6 (but affects also 10.13.1 before update),
      - FHD LG IPS 14" Panel 1920x1080.
      I'm using the attached config.plist with patched framebuffer using Intel FB Patcher. I initially followed the T440P guide on TonyMacOSx86, but it looks somehow outdated since it doesn't use Whatevergreen and other old kexts (as well as kext framebuffer patching).
      I'm using the following kexts in Clover/Other:
      - Lilu,
      - Whatevergreen,
      - FakeSMC,
      - IntelMausiEthernet,
      - USBInjectAll,
      - VoodooPS2Controller (from tluck T460 topic to support trackpad),
      - ACPIBatteryManager.
      ACPI is patched using SSDT-T440P.aml provided by tonymacosx86 topic on T440P:
      Attached IOReg Dump, config.plist and screenshot of kexts used. Kextstat output:
      MacBook-Pro:~ christine$ kextstat Index Refs Address Size Wired Name (Version) UUID <Linked Against> 1 97 0xffffff7f80a00000 0x9e30 0x9e30 com.apple.kpi.bsd (17.2.0) 6504FC08-D78E-44E8-945B-44B0D314DAFE 2 10 0xffffff7f80f0d000 0x3960 0x3960 com.apple.kpi.dsep (17.2.0) 13A888C7-BC6B-4942-BFFB-4B367603EE36 3 119 0xffffff7f80a29000 0x21160 0x21160 com.apple.kpi.iokit (17.2.0) 81225EB2-256A-4131-AB1F-BA743CFA100D 4 126 0xffffff7f80a0a000 0xd360 0xd360 com.apple.kpi.libkern (17.2.0) 8B104C85-FB17-4131-9565-C5C0AE03C102 5 111 0xffffff7f80a18000 0x3f30 0x3f30 com.apple.kpi.mach (17.2.0) 44D6EE39-4F9E-496A-A47E-266FD7C02050 6 70 0xffffff7f80a1c000 0xccd0 0xccd0 com.apple.kpi.private (17.2.0) 9A4D3A3C-C58A-4923-9287-7DE2039B7885 7 75 0xffffff7f80a8e000 0x5a30 0x5a30 com.apple.kpi.unsupported (17.2.0) B8DD5671-D21E-43E5-8866-38FF6E91FBAE 8 8 0xffffff7f81145000 0xae000 0xae000 com.apple.kec.corecrypto (1.0) 0C6635A4-47EA-3A47-8D33-CB3769579F4F <7 6 5 4 3 1> 9 1 0xffffff7f81904000 0x10000 0x10000 com.apple.kec.Libm (1) 45DD5F54-77FD-356C-94EB-41114B65027E <4> 10 0 0xffffff7f81f94000 0xf000 0xf000 com.apple.kec.pthread (1) 573AF44A-8E0B-3246-AB52-346D5363F589 <7 6 5 4 1> 11 24 0xffffff7f80fa2000 0x9000 0x9000 com.apple.iokit.IOACPIFamily (1.4) 8794C760-FDD9-3664-ADED-4A9BBEC6E517 <7 6 4 3> 12 29 0xffffff7f80a94000 0x35000 0x35000 com.apple.iokit.IOPCIFamily (2.9) 1A5661CA-0F8F-3EC1-B3B4-5A9ADDAE360F <7 6 5 4 3> 13 9 0xffffff7f80fab000 0x1d000 0x1d000 com.apple.driver.AppleSMC (3.1.9) 631D2C99-C8C2-3272-84FC-C49338D09C31 <12 11 7 6 5 4 3 1> 14 1 0xffffff7f81fb8000 0x7000 0x7000 com.apple.driver.AppleSMCRTC (1.0) 3F01C7A4-754F-39DD-A872-B4FAF0442276 <13 11 5 4 3 1> 15 2 0xffffff7f82053000 0x9c000 0x9c000 com.apple.driver.AppleACPIPlatform (6.1) 33FE0184-9235-32DF-8BC2-0B2B11971EDB <14 13 12 11 7 6 5 4 3 1> 16 5 0xffffff7f81323000 0x7000 0x7000 com.apple.iokit.IOReportFamily (31) D2F2FBDF-4EE4-38BA-99F5-B699F886F413 <5 4 3> 17 3 0xffffff7f82224000 0x7000 0x7000 com.apple.driver.IOSlaveProcessor (1) 582BDE04-9EB3-3A87-8842-4FF06D1F72C6 <4 3> 18 2 0xffffff7f82400000 0x17000 0x17000 com.apple.driver.AppleSEPManager (1.0.1) 3E8C2C34-9808-3BE1-9BF6-D2C7287F0A1F <17 12 8 7 6 5 4 3 1> 19 1 0xffffff7f80fca000 0x8000 0x8000 com.apple.driver.AppleBusPowerController (1.0) 58E0BB1C-1D50-37DE-973E-3842F948F62D <13 11 6 5 4 3> 20 7 0xffffff7f80fd2000 0x8000 0x8000 com.apple.driver.usb.AppleUSBCommon (1.0) 2D48059E-4165-3187-BF34-E76480927E09 <5 4 3 1> 21 14 0xffffff7f80fda000 0x78000 0x78000 com.apple.iokit.IOUSBHostFamily (1.2) 8AB83332-86B6-3DD3-8F1D-DC669DFDAE65 <20 19 7 6 5 4 3 1> 22 3 0xffffff7f81aa3000 0x1b000 0x1b000 com.apple.driver.KernelRelayHost (1) 5C8F8DDD-12A4-3A3D-8764-DD214D53EBE0 <21 5 4 3> 23 1 0xffffff7f8242c000 0x28000 0x28000 com.apple.driver.AppleCredentialManager (1.0) 055288D3-A4E8-34A6-9D3D-ED03EF6E3226 <22 18 17 8 7 6 5 4 3 1> 24 12 0xffffff7f80c46000 0x27000 0x27000 com.apple.iokit.IOStorageFamily (2.1) 4416D94C-E168-3987-B9F5-5767E3933D12 <7 6 5 4 3 1> 25 6 0xffffff7f80a4b000 0x2b000 0x2b000 com.apple.iokit.IOSCSIArchitectureModelFamily (404.20.1) 2A918E3B-00A2-3A8B-8F7E-0DBCE387C42A <6 5 4 3 1> 26 1 0xffffff7f81fbf000 0x19000 0x19000 com.apple.iokit.IOSCSIBlockCommandsDevice (404.20.1) 983B3D78-6110-3A0D-B4F0-3C798DC7DB3A <25 24 6 5 4 3 1> 27 1 0xffffff7f81fdc000 0x2d000 0x2d000 com.apple.iokit.IOUSBMassStorageDriver (140) 0F57FB92-342C-3FF3-87C0-55C2A0158AFF <25 24 21 6 5 4 3 1> 28 4 0xffffff7f811f9000 0x15000 0x15000 com.apple.driver.AppleMobileFileIntegrity (1.0.5) EA558F59-BDB8-3BE0-A77E-231D62054A1D <8 7 6 5 4 3 2 1> 29 1 0xffffff7f82010000 0x12000 0x12000 com.apple.driver.AppleUSBTDM (439.20.7) 9F09CC9C-7B98-3AE5-B30B-153D3D22BDBD <28 27 26 25 24 21 7 6 5 4 3 1> 30 0 0xffffff7f82454000 0x62000 0x62000 com.apple.driver.AppleKeyStore (2) 297BC17D-41F9-3BCB-8848-B15A8D20CF9A <29 28 23 22 18 17 8 7 6 5 4 3 1> 31 0 0xffffff7f824df000 0xb000 0xb000 com.apple.driver.AppleFDEKeyStore (28.30) 88B93EF8-2472-3A39-926D-BD8B364DF65C <8 7 6 5 4 3 1> 32 0 0xffffff7f828e0000 0x19000 0x19000 com.apple.driver.DiskImages (480.1.2) 18572923-BAEF-3106-B205-299EA989B1B5 <24 7 6 5 4 3 1> 33 2 0xffffff7f8165d000 0xc000 0xc000 com.apple.iokit.IOBufferCopyEngineFamily (1) B882E495-534B-3845-8F58-27DAA652CCA2 <5 4 3 1> 34 0 0xffffff7f82a17000 0xc000 0xc000 com.apple.IOBufferCopyEngineTest (1) CE28F2D9-3D09-3428-9FD7-023941B584F0 <33 5 4 3 1> 35 1 0xffffff7f82a26000 0x21000 0x21000 as.vit9696.Lilu (1.2.7) 4EA74271-18D4-38CC-AAD2-03F2875BCF14 <7 5 4 3 2 1> 36 0 0xffffff7f82a47000 0x60000 0x60000 as.vit9696.WhateverGreen (1.2.3) 6450D5EB-5E30-3640-BE41-3FDFEF7737A0 <35 12 7 5 4 3 2 1> 37 0 0xffffff7f82aa7000 0x5000 0x5000 com.rehabman.driver.USBInjectAll (0.6.9) D0CD1F99-95F2-3151-8A16-00767C52F740 <12 11 4 3> 38 0 0xffffff7f82aac000 0x11000 0x11000 org.netkas.driver.FakeSMC (1800) FC7031CC-C949-35D1-AC1A-CA8DB349793E <11 7 5 4 3 1> 39 2 0xffffff7f814a5000 0x5000 0x5000 com.apple.kext.AppleMatch (1.0.0d1) 2D2996CA-A15E-39E6-9D6B-2BE6DF131972 <4 1> 40 1 0xffffff7f814aa000 0x20000 0x20000 com.apple.security.sandbox (300.0) C0EDB0F6-B11E-3ACB-8041-F38AA158CDC8 <39 28 24 7 6 5 4 3 2 1> 41 0 0xffffff7f817fe000 0xa000 0xa000 com.apple.security.quarantine (3) 80C4548A-999E-3F96-85B0-6C6F95A542A7 <40 39 7 6 5 4 2 1> 42 0 0xffffff7f828dd000 0x3000 0x3000 com.apple.security.TMSafetyNet (8) 5B78C369-AA3C-326F-8AE3-C200955DD9A7 <7 6 5 4 2 1> 43 0 0xffffff7f829ac000 0xa000 0xa000 com.apple.nke.applicationfirewall (183) 5B56B039-C437-3000-ABE5-FC336BEB07FC <7 6 5 4 3 1> 44 0 0xffffff7f829fc000 0x5000 0x5000 com.apple.driver.AppleAPIC (1.7) 9E5B1713-854A-32DC-89E7-E1765F4B3AE3 <12 4 3> 45 2 0xffffff7f81fa3000 0x4000 0x4000 com.apple.iokit.IOSMBusFamily (1.1) 9CFF73D8-2872-3FC0-AEE5-334587EAA4D0 <5 4 3> 46 0 0xffffff7f820f8000 0xa000 0xa000 com.apple.driver.AppleACPIEC (6.1) F7750192-B6D9-3B77-84A0-646A892F4F04 <45 15 11 5 4 3> 47 0 0xffffff7f823e4000 0x6000 0x6000 com.apple.driver.AppleSMBIOS (2.1) 93D205A0-CB89-3661-9164-52C412DF576C <7 4 3> 48 5 0xffffff7f80f11000 0x7b000 0x7b000 com.apple.iokit.IOHIDFamily (2.0.0) 3C4FDA72-E266-3573-9874-5E4905DF5F61 <7 6 5 4 3 2 1> 49 0 0xffffff7f82102000 0x8000 0x8000 com.apple.driver.AppleACPIButtons (6.1) 758B3D2E-6636-3978-9BEC-DB1852D9CE82 <48 16 15 11 7 6 5 4 3 1> 50 0 0xffffff7f82abd000 0xc000 0xc000 org.rehabman.driver.AppleSmartBatteryManager (1.90.1) 704B9E4D-F72F-358C-B0AD-F7C91A415398 <11 4 3> 51 0 0xffffff7f826fb000 0x5000 0x5000 com.apple.driver.AppleHPET (1.8) 53185B91-044A-3437-BCB4-DA18945A2BB9 <11 7 5 4 3> 52 0 0xffffff7f81a98000 0xb000 0xb000 com.apple.driver.AppleRTC (2.0) 3FB7DA57-3262-3F2F-9246-4E9268A45AB7 <11 5 4 3 1> 53 2 0xffffff7f82ac9000 0xb000 0xb000 org.rehabman.voodoo.driver.PS2Controller (1.8.28) 0660CBA6-F8C4-3750-A534-513E8729C362 <11 7 5 4 3 1> 54 2 0xffffff7f81073000 0x5000 0x5000 com.apple.driver.AppleEFIRuntime (2.1) CB8CE325-E9F9-3CA5-95A6-85B9E3FFBD22 <7 6 5 4 3> 55 1 0xffffff7f81078000 0xb000 0xb000 com.apple.driver.AppleEFINVRAM (2.1) 79C21A42-B04F-314F-BA88-F221F3D54094 <54 7 6 5 4 3 2 1> 56 0 0xffffff7f81655000 0x4000 0x4000 com.apple.driver.AppleUSBHostMergeProperties (1.2) AE59079F-4FA4-33E9-8634-0EF309683DE3 <4 3 1> 57 2 0xffffff7f81083000 0x9b000 0x9b000 com.apple.iokit.IOUSBFamily (900.4.1) 0F89E3BF-F847-3EA4-A225-122067B47673 <21 20 12 7 5 4 3 1> 58 0 0xffffff7f816a9000 0x5000 0x5000 com.apple.driver.usb.AppleUSBHostPacketFilter (1.0) DDB1258B-DFD7-3687-928A-ABBFA36CF582 <21 20 7 6 5 4 3 1> 59 1 0xffffff7f81597000 0x4c000 0x4c000 com.apple.driver.usb.AppleUSBXHCI (1.2) B34A9110-B3AB-3236-942C-81979734E71C <21 20 11 7 6 5 4 3 1> 60 0 0xffffff7f816ae000 0x31000 0x31000 com.apple.driver.usb.AppleUSBXHCIPCI (1.2) 7F0839A6-E825-3CF5-BB41-AD880F885B97 <59 21 20 12 11 7 6 5 4 3 1> 62 3 0xffffff7f821c1000 0x1a000 0x1a000 com.apple.iokit.IOAHCIFamily (288) F3AC999A-975D-3D01-82D4-8ACCB4A885B1 <5 4 3 1> 63 0 0xffffff7f828ba000 0x1c000 0x1c000 com.apple.driver.AppleAHCIPort (329) 652FD118-63AE-38F4-860F-13FBEC2FF9E5 <62 12 5 4 3 1> 64 3 0xffffff7f80e07000 0x30000 0x30000 com.apple.iokit.IONetworkingFamily (3.4) 05BC317E-CDDB-37A2-89D4-FA4451C2B472 <7 6 5 4 3 1> 65 0 0xffffff7f82ad4000 0x21000 0x21000 com.insanelymac.IntelMausiEthernet (2.4.0d0) 6FDD7FE8-3965-3DAC-8997-8F76D32D99E5 <64 12 5 4 3 1> 66 0 0xffffff7f821eb000 0x27000 0x27000 com.apple.iokit.IOAHCIBlockStorage (301.20.1) 5343A8B6-FB10-331C-B015-D73603B2AA7F <62 24 6 5 4 3 1> 67 0 0xffffff7f821de000 0xd000 0xd000 com.apple.iokit.IOAHCISerialATAPI (267) BA23AC56-7AB4-3898-A468-B18B1550E039 <62 25 5 4 3 1> 69 1 0xffffff7f8113d000 0x8000 0x8000 com.apple.filesystems.hfs.encodings.kext (1) 7CC455ED-D7F1-3AD4-B362-4A974AFD0991 <7 6 5 4 3 1> 70 0 0xffffff7f814f4000 0x8000 0x8000 com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0) 4D3D3A5A-FE34-3CA7-A4E6-787918AFAB34 <6 4 3 2 1> 71 0 0xffffff7f8192e000 0xf000 0xf000 com.apple.BootCache (40) 205A2C43-6E4A-36A3-B4A5-5BDEE72B9669 <7 6 5 4 3 1> 72 0 0xffffff7f823dd000 0x4000 0x4000 com.apple.AppleFSCompression.AppleFSCompressionTypeDataless (1.0.0d1) 5FFFCA61-0CB0-305C-965F-1C8BF0889122 <7 6 4 3 2 1> 73 0 0xffffff7f82700000 0x6e000 0x6e000 com.apple.filesystems.hfs.kext (407.1.3) F1CDFC19-49BF-35BC-8038-B82DF8C30BDE <69 7 6 5 4 3 1> 75 1 0xffffff7f8176b000 0xc000 0xc000 com.apple.driver.AppleEffaceableStorage (1.0) B38C757D-22EC-3DD8-AF7F-AE9E16C1DEB2 <7 5 4 3 1> 76 1 0xffffff7f81817000 0xe7000 0xe7000 com.apple.filesystems.apfs (748.21.6) A7F589DD-C64A-360A-94CF-696189954A9F <75 24 8 7 6 5 4 3 1> 77 0 0xffffff7f82af5000 0x7000 0x7000 org.rehabman.voodoo.driver.PS2Keyboard (1.8.28) CD8964D4-6CEB-3B98-BCA0-713C1C883A60 <53 48 16 7 6 5 4 3 1> 78 0 0xffffff7f82afc000 0x9000 0x9000 org.rehabman.voodoo.driver.PS2Trackpad (1.8.28) 9F96E8A0-6A5D-368F-980E-AA639E5E978D <53 48 16 7 6 5 4 3 1> 80 3 0xffffff7f8216d000 0xe000 0xe000 com.apple.iokit.IOCDStorageFamily (1.8) 10D6835C-B1AC-355F-A550-EE1EF94C5DFF <24 5 4 3 1> 81 2 0xffffff7f8217e000 0xb000 0xb000 com.apple.iokit.IODVDStorageFamily (1.8) B68029BC-17A8-386F-B3B3-84ADF3A194BE <80 24 5 4 3 1> 82 1 0xffffff7f8218c000 0x9000 0x9000 com.apple.iokit.IOBDStorageFamily (1.8) AE09847F-632A-3265-94B4-9C008420CDA1 <81 80 24 5 4 3 1> 83 0 0xffffff7f82198000 0x1a000 0x1a000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (404.20.1) A9498A9C-C5D9-33B3-8FE2-959ECBC4E68A <82 81 80 25 24 6 5 4 3 1> 84 0 0xffffff7f821b6000 0xb000 0xb000 com.apple.iokit.SCSITaskUserClient (404.20.1) B2D51EE7-E0ED-375D-B8C1-D387DFEC9172 <25 24 5 4 3 1> 85 0 0xffffff7f8105a000 0x8000 0x8000 com.apple.driver.usb.AppleUSBHostCompositeDevice (1.2) 6CDFA719-FE6F-3B31-9034-4B18A96337D9 <21 20 6 5 4 3 1> 86 0 0xffffff7f814fc000 0x8000 0x8000 com.apple.driver.usb.networking (5.0.0) AF394B0D-0B97-39E8-9681-5A2B25034DBE <21 6 5 4 3 1> 88 0 0xffffff7f81062000 0xc000 0xc000 com.apple.driver.usb.IOUSBHostHIDDevice (1.2) 338AA7B1-D0BF-3349-B460-829CCC50A3D0 <48 21 20 5 4 3 1> 89 15 0xffffff7f8122a000 0x46000 0x46000 com.apple.iokit.IOGraphicsFamily (517.17) 05FC87E8-B78E-319E-AF08-0EBDA16094CE <12 7 5 4 3 1> 90 1 0xffffff7f826a0000 0xf000 0xf000 com.apple.driver.AppleSMBusController (1.0.18d1) 42F7ACFC-82B8-3A3C-9C1D-B2EEBDE3680B <45 12 11 5 4 3> 91 0 0xffffff7f826b2000 0x18000 0x18000 com.apple.driver.AppleMCCSControl (1.5.3) B67DD3A1-E616-3B32-A6FC-4E37F56493E9 <90 89 13 12 11 7 5 4 3 1> 92 4 0xffffff7f81798000 0x10000 0x10000 com.apple.iokit.IONDRVSupport (517.17) 65CF8366-5909-3674-9557-075FE1439A25 <89 12 7 5 4 3> 93 1 0xffffff7f817a8000 0x5000 0x5000 com.apple.driver.AppleBacklightExpert (1.1.0) CB5847C6-936A-37C0-9C50-EE24A118D0EF <92 89 13 12 5 4 3> 94 0 0xffffff7f8287d000 0x8000 0x8000 com.apple.driver.AppleBacklight (170.10.1) 1859FB2A-0AC1-3C29-8C86-2C3377A03B6C <93 92 89 12 5 4 3> 95 5 0xffffff7f8132a000 0xb000 0xb000 com.apple.AppleGraphicsDeviceControl (3.16.19) 35BE1077-5D56-3353-BFC5-F6026B931F81 <89 12 7 6 5 4 3 1> 98 0 0xffffff7f81f6b000 0xa000 0xa000 com.apple.iokit.IOUSBHIDDriver (900.4.1) 6455F1D1-2194-3B7A-A41A-DD0153264284 <57 48 5 4 3 1> 99 3 0xffffff7f8210a000 0xa000 0xa000 com.apple.driver.IOPlatformPluginFamily (6.0.0d8) A231E6AF-88ED-34AA-8D30-C0087CA78FD1 <11 7 6 5 4 3> 100 1 0xffffff7f8213f000 0x17000 0x17000 com.apple.driver.X86PlatformPlugin (1.0.0) F24D0962-9E84-301F-8639-48900D78DC60 <99 57 21 13 11 7 6 5 4 3 1> 103 0 0xffffff7f82a0e000 0x9000 0x9000 com.apple.driver.AppleSMCLMU (211) 8CD5D253-5FB2-33B7-A2FE-9BB15D95ED1D <89 13 5 4 3> 104 1 0xffffff7f814ca000 0x5000 0x5000 com.apple.iokit.IOSlowAdaptiveClockingFamily (1.0.0) CBE56568-AC91-3F56-A06E-9A29D6F70BDA <7 6 5 4 3 1> 105 0 0xffffff7f82640000 0x4000 0x4000 com.apple.driver.AppleIntelSlowAdaptiveClocking (4.0.0) 7DFBC6BB-39A0-3639-9683-99472E9AAC69 <104 4 3> 106 0 0xffffff7f82629000 0x7000 0x7000 com.apple.AVEBridge (1.0.0) E8DC2496-ACB5-32FB-B0FB-58BA8EC104FD <33 5 4 3> 107 0 0xffffff7f817b5000 0xd000 0xd000 com.apple.AppleGPUWrangler (3.16.19) 5602E00C-2CED-3C15-A626-74D91362C87F <95 89 12 7 6 5 4 3 1> 108 0 0xffffff7f811f3000 0x6000 0x6000 com.apple.driver.eficheck (1) A356A074-17E4-3021-A2E9-E9AB52B98BC8 <54 12 4 3 1> 109 2 0xffffff7f82268000 0xe7000 0xe7000 com.apple.iokit.IOBluetoothFamily (6.0.1f1) 6EF17563-55A9-31EE-92A2-EFFF72F8E806 <21 16 11 7 6 5 4 3 1> 110 1 0xffffff7f82644000 0xb000 0xb000 com.apple.iokit.IOBluetoothHostControllerTransport (6.0.1f1) 30546CA4-862F-317B-8308-0D90F640FD10 <109 21 12 11 7 6 5 4 3 1> 111 0 0xffffff7f8264f000 0x20000 0x20000 com.apple.iokit.IOBluetoothHostControllerUSBTransport (6.0.1f1) 738E3B1E-7189-3AAF-88CE-84185079FAFF <110 109 21 12 11 7 6 5 4 3 1> 112 2 0xffffff7f8120e000 0x1a000 0x1a000 com.apple.iokit.IOSurface (209) 9D4ADF2A-E6F7-3BFE-B5FF-8C7317DF164B <7 6 5 4 3 1> 113 2 0xffffff7f8127d000 0x96000 0x96000 com.apple.iokit.IOAcceleratorFamily2 (374.1) 1A14B541-7F4E-3D7A-B279-43185331BB30 <112 89 28 12 7 6 5 4 3 1> 114 0 0xffffff7f81337000 0x164000 0x164000 com.apple.driver.AppleIntelFramebufferAzul (10.2.8) 3FECF0D5-B843-331B-A70C-AF4007131B35 <113 95 89 16 12 11 7 6 5 4 3 1> 115 0 0xffffff7f825cb000 0x7000 0x7000 com.apple.driver.AppleOSXWatchdog (1) 2F19A24F-F7AE-3635-8BB5-404557A79322 <12 7 6 5 4 3 1> 117 0 0xffffff7f82780000 0x6000 0x6000 com.apple.Dont_Steal_Mac_OS_X (7.0.0) 6F899B4B-5B97-3559-85B1-7798E34AE7EE <13 8 7 4 3 1> 118 0 0xffffff7f826cd000 0x16000 0x16000 com.apple.driver.pmtelemetry (1) 9160DD41-35A5-37B5-A7F5-58D8863FAECA <7 6 5 4 3> 119 2 0xffffff7f81b69000 0xab000 0xab000 com.apple.vecLib.kext (1.2.0) 25E40952-8944-3C02-8224-C5E9C174B065 <9 6 5 4 3> 120 3 0xffffff7f81c14000 0x3f000 0x3f000 com.apple.iokit.IOAudioFamily (206.5) 2F090399-C028-3F14-AE4F-BF49A3D602E5 <119 5 4 3 1> 121 2 0xffffff7f81c5b000 0xc000 0xc000 com.apple.iokit.IOHDAFamily (280.12) 26C4B27D-C27B-3948-9C65-597E631291B6 <5 4 3 1> 122 1 0xffffff7f81c6a000 0x1d000 0x1d000 com.apple.driver.AppleHDAController (280.12) 55162F3D-B7E9-315C-A7E1-C5C4C02F03EC <121 120 89 12 7 6 5 4 3 1> 123 0 0xffffff7f81ac1000 0x99000 0x99000 com.apple.driver.AppleIntelHD5000Graphics (10.2.8) D9688F73-A7F3-3D99-9552-7BA7B5B9D1C5 <113 112 89 12 7 6 5 4 3 1> 124 1 0xffffff7f8267f000 0xe000 0xe000 com.apple.iokit.IOSerialFamily (11) 6FE74518-ECD9-32D6-88BE-8F5BCAC911D4 <7 6 5 4 3 1> 125 0 0xffffff7f82690000 0xe000 0xe000 com.apple.iokit.IOBluetoothSerialManager (6.0.1f1) 74339DA7-0327-38FF-9C7C-EF924A7BA23B <124 7 5 4 3 1> 126 0 0xffffff7f824b6000 0xb000 0xb000 com.apple.driver.AppleSSE (1.0) 29B1CF46-578E-33D4-9CD3-41FDA30B0A15 <22 7 5 4 3 1> 127 0 0xffffff7f823ea000 0xa000 0xa000 com.apple.iokit.IOUserEthernet (1.0.1) E2480916-E5D9-36B9-8573-25E1134F99A7 <64 6 5 4 3 1> 128 0 0xffffff7f82251000 0xf000 0xf000 com.apple.driver.AppleHV (1) 1B4F136C-9465-379A-8D80-878A4AA2AF87 <7 6 5 4 3 1> 129 0 0xffffff7f80e3e000 0x25000 0x25000 com.apple.iokit.IOTimeSyncFamily (600.15) ACE5FAE7-6762-3B1A-B091-56A611D2D34E <64 5 4 3 1> 130 0 0xffffff7f81777000 0x5000 0x5000 com.apple.AGDCPluginDisplayMetrics (3.16.19) 28EBFAA2-166F-368C-8A2E-E2A0B5312425 <95 7 6 5 4 3 1> 131 1 0xffffff7f8177c000 0x3000 0x3000 com.apple.driver.AppleGraphicsControl (3.16.19) 50A642BF-B1E3-3F41-B211-70EFAE5BE872 <7 5 4 3 1> 132 0 0xffffff7f8177f000 0x19000 0x19000 com.apple.driver.AppleGraphicsDevicePolicy (3.16.19) 3CFB1891-D7AC-3BE4-8DF8-47675AF9F95F <131 95 89 12 11 7 6 5 4 3 1> 133 1 0xffffff7f82156000 0x9000 0x9000 com.apple.driver.X86PlatformShim (1.0.0) 3C45984F-888B-3EED-B2A3-76A277D1D72A <100 99 13 7 4 3> 134 0 0xffffff7f8261d000 0x7000 0x7000 com.apple.driver.ApplePlatformEnabler (2.7.0d0) 97EF1457-0154-3395-B680-F6D499EE8EB8 <7 5 4 3> 135 0 0xffffff7f824ea000 0x1f000 0x1f000 com.apple.driver.AGPM (110.23.24) F00AE848-ADD1-378F-8576-2D312C49D458 <99 95 92 89 12 6 5 4 3> 136 2 0xffffff7f82630000 0x5000 0x5000 com.apple.kext.triggers (1.0) 11BEF14E-27F2-3BD9-8810-F11A908D2DC6 <7 6 5 4 3 1> 137 0 0xffffff7f82635000 0xb000 0xb000 com.apple.filesystems.autofs (3.0) 6B23747D-D072-3862-9DC1-A56D7E0185DB <136 7 6 5 4 3 1> 138 1 0xffffff7f81c8d000 0x13000 0x13000 com.apple.kext.OSvKernDSPLib (526) C618CB87-7AA5-3DAE-9399-1CC9D9447F06 <5 4> 139 1 0xffffff7f81ca0000 0x143000 0x143000 com.apple.driver.DspFuncLib (280.12) 5CFA635F-C9CC-3F92-9D62-6479D8CC4382 <138 120 119 55 6 5 4 3 1> 140 0 0xffffff7f81dee000 0xea000 0xea000 com.apple.driver.AppleHDA (280.12) 7FC2BABA-4D4F-34FC-93E2-3E3244DEB73D <139 122 121 120 92 89 6 5 4 3 1> 142 0 0xffffff7f824d0000 0x9000 0x9000 com.apple.driver.AppleUpstreamUserClient (3.6.4) 994E78AE-AAD1-3435-8002-E906AF0416FE <89 12 11 7 5 4 3 1> 143 0 0xffffff7f82b0a000 0x6a000 0x6a000 com.apple.filesystems.smbfs (3.2) BC87B0FF-8711-3620-BC89-4A2232723CEA <136 8 7 6 5 4 3 1> 144 1 0xffffff7f82b74000 0x11000 0x11000 com.apple.filesystems.msdosfs (1.10) 0D5408E8-0AFE-3D82-AE82-B8FA25EF4760 <7 5 4 1>  
      I'm really out of clue.


    • By fusion71au
      Clover r4747 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
      1. Download and unzip "EFI_Clover_r4747 for VMware.zip". Mount Clover-v2.4k-4747-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By superdooper71
      Hi all,
      I hope someone can help me as I am struggling with this bloody installation.
      I am running on several problems that I can't face : (
      First of all my config:
      Mobo: ASROCK H81M-DGS R2
      CPU: Intel Xeon E3-1220 v3 @3.10ghz
      RAM: 16gb DDR3 1600Mhz
      SSD: Crucial BX100 120Gb SSD
      Monitor: Hp 27w Hdmi
      POST Installation CLOVER
      Current Issues:
      • System will not boot (clover boot loader do not shows up) from SSD
         - System boot only with USB stick
      • Screen Resolution is only 1024x768
      • Monitor recognised as 17" instead of 24"
      • Monitor identified as secondary
      • Grafic Card Geforce GT710 shows 0 Mb
      • System info do not match Config.plistin Clover
      I attach screenshot of System Info, Kext in Clover, Resolution etc etc.
      Please can someonhelp me?
      Please can you tell me what is the Clover Parameter to activate when installing Clover  (Clover_v2.4k_r4722) into Boot Disk?
      I hope someone can help me out of this little troble: )
      system info.tiff
    • By Entropi
      I’ve used a 2015 15” MBP as my main system since it was released. I do photo and video editing in the Adobe suite regularly and have been eyeballing the performance of the latest MBP models. I’m on the road all the time, so a laptop is basically my only option.

      After the whole mess with the CPU VRM hardware flaws being made apparent by the poor power management profile shipped at release with the 2018 i9 MBP I’ve been more weary of the hardware design of MacBooks. That’s before I account for losing all USB-A ports, losing the SD card slot (‽), losing reliability and tactility of the keyboard, and losing the ESC key to the touchbar; if I compare the 2018 MBP to my current 2015.
      Given these flaws, I have been researching the performance situation comparing the 2018 MBP to the X1 Extreme, XPS 15 9570, and the Razer Blade 15 2018.  These are essentially the only options for a road warrior that needs a high quality panel and the best CPU and GPU that can be crammed into around 4lbs (1.8kg).  
      I used to use a ThinkPad T42p and loved it when it was new. So fast forward to now and the release of the ThinkPad X1 Extreme. It’s a truly tempting machine for an artist, given that the 4K UHD version offers just about the best color gamut available on any laptop panel. I get back the USB-A ports, get one of the fastest SD slots on any laptop, and get one of the best laptop keyboards on the market. That’s before even considering power management and modularity. I’ve been dabbling in learning Machine Learning, so a system with an nVidia GPU (CUDA) is a bonus on that front as well.
      For me the best color reproduction on a high resolution display panel was most important. The X1 Extreme has that, so I’ve ordered one. I got it with the fastest i7, base SSD and memory, and have separately purchased two 1TB Samsung 970 Pro M.2 SSDs and 2x16GB DDR4-3200MHz memory (just in case it’s possible to overclock the memory on the X1 Extreme). I got the system for $2,100 from Lenovo USA, and the SSDs ($390 x 2) and memory ($330) from Amazon US for a total of ~$3200.  These are easy to install on the X1 Extreme as the bottom cover is easily removed to reveal the M.2 and SODIMM slots. To compare, the 2018 MBP with the fastest i7, 32GB memory, and 2TB SSD is $4400. So I can save $1200 and get a faster system (on all counts) with a better panel and better connectivity by going with the X1 Extreme.
      The only thing I’m compromising is losing the big beautiful haptic touchpad and a bit more refined hardware aesthetic. Though, to be honest, I’ve kept a big thick dual-layer Tech21 case on my 2015 MBP. So I’ll actually be going down in volume and weight by moving to the more rugged ThinkPad. I think I can live without the touchpad.

      Oh, by the way, the 4K UHD panel of the X1 Extreme has touch and decent pen support! Another bonus vs. the MacBook. Though I keep a 12.9” iPad Pro around for my pen work and can’t imagine using a laptop similarly. It’s still nice to have a laptop screen actually respond when I go poke at it accidentally after switching back and forth between laptop and iPad.
      So I want macOS with proper discrete GPU support on a 2018 MacBook class laptop.  That’s not possible on a pure Hackintosh as things stand, but via a macOS virtual machine it looks like it could work with what looks like some relatively bleeding edge support of PCIe UEFI passthrough.

      People have been doing this on Linux hosts to Windows VMs with some great success recently: https://gist.github.com/Misairu-G/616f7b2756c488148b7309addc940b28
      And it looks like that’s coming for macOS VMs as well: https://github.com/kholia/OSX-KVM/blob/a4fb2fd5aae871bdbc371b0cd31d4d8129d0f9ac/UEFI/README.md

      The X1 Extreme, XPS 15 9570, and Razer Blade 15 (2018) are essentially direct competition to the 2018 15” MBP. I would really like to see these three systems get some nicely fleshed out guides for getting maxed out compatibility and performance in macOS running in a VM for these systems. When I get my X1 Extreme I’ll start working on it for that one. I will post updates here. I hope to inspire others with the other two systems (or looking to get them) to do similarly.
      I chose the X1 Extreme largely because of the excellent 4K UHD HDR panel (100% of 2D AdobeRGB and 85.5% of 3D AdobeRGB, basically unparalleled), good mix of thermal performance and noise management, and overall ruggedness and connectivity.  If I were a gamer I would go with the Razer 15, but the fast low-gamut 1080p panel just doesn’t work for my purposes. If I were most concerned with aesthetics or battery life (97Wh battery for it vs 80Wh for X1E) I would go with the XPS 15.
      I am aware that the second 2018 refresh of the MBP is coming ~Nov 14, with the new AMD Radeon Pro Vega 16 and Vega 20 GPUs, and it looks like the latter might offer up to a 60% performance boost over the Radeon 560X. Maybe it has even given Apple enough time to update the CPU VRM along the way. This could make the performance picture more comparable for the 1050 Ti based X1E and XPS 15. I believe the 1070 Ti based Razer 15 will still win out though.
      Still, if you compare the fan and heat pipe solution put into the X1E vs the MBP the MBP just looks wimpy in comparison. MBP has smaller fans, less venting, and only one (smaller, thinner) heatpipe. It’s also more difficult to access if you want to put a better thermal paste or liquid metal on it.  Put simply, the thermal hardware on the MBP is basically the same design for the last 3 years and it can’t keep up with the hex-core processors. So even with the Volta 20 GPU making the MBP competitive again on the graphics end, the MBP will still be falling short on the CPU performance plane. This is before we even look at tuning options.
      Getting into tuning, it’s possible to improve thermal performance of all the laptops in this class by around 15-20% by using either a best in class thermal paste like Thermal Grizzly Kryonaut or (if you’re willing to deal with all the caveats that come with using a conductive fluid that permeates other metals) a liquid metal interface like Thermal Grizzly Conductonaut. The liquid metal gives you the best possible conducting interface, and the paste is more forgiving and easier to apply.  Further, it is often possible to stably undervolt the Coffee Lake i7/i9 available in this class of systems to further improve performance, thermals, and power consumption (generally another 10+%).
      Apple has deliberately made it impossible to undervolt the CPU on the MBP! This has been true since the first Skylake CPUs a few years ago. You used to be able to use a program called Volta to undervolt your CPU on macOS. This is a huge peeve for me and, combined with the general power and thermal underdevelopment, is one of the main reasons I want to get a competitor’s hardware. As a primer, the default voltage of modern CPUs is typically set conservatively high for the sake of production efficiency.  With the current generation Coffee Lake CPUs it is commonly possible to set the CPU voltage about 100 to 150mv lower safely.  This allows the CPU to run cooler and consume less power. For laptops which are thermally limited (basically everything in this new 6-core 14nm era), this also translates into better performance. It’s a tweak that actually improves reliability of your CPU. So it’s just stupid that Apple has deliberately made this impossible. Shame on them, someone else take my money.
      Wrapping up, my biggest quibbles with the X1E (before actually getting it) are that the 4K panel’s responsiveness is about the slowest I’ve seen on a modern panel, and it’s just really not suitable for gaming. There’s also what I consider an annoyingly high level of backlight corner bleed that I’m sure will be distracting during blackboxed video viewing. Hopefully these two issues will be fixed in next year’s iteration.
      MacBook i9 Thermal / VRM (below-baseline throttling/thrashing) Issue:
      This was mitigated with software that works around the poor hardware design, but the system would still ultimately perform better if the CPU VRM were redesigned. Non Mac systems with the similar CPUs don’t have this issue and get better sustained performance.
      MacBook Nov 2018 Refresh with Radeon Vega 16 and Vega 20:
      MacBook Class Laptop Reviews:
      Lenovo ThinkPad X1 Extreme, 4K: https://www.notebookcheck.net/Lenovo-ThinkPad-X1-Extreme-i7-4K-HDR-GTX-1050-Ti-Max-Q-Laptop-Review.335608.0.html
      Dell XPS 15 9570, 4K: https://www.notebookcheck.net/Dell-XPS-15-9570-i7-UHD-GTX-1050-Ti-Max-Q-Laptop-Review.332758.0.html
      Razer Blade 15 2018, 1070 Ti FHD 144Hz: https://www.notebookcheck.net/Razer-Blade-15-i7-8750H-GTX-1070-Max-Q-FHD-Laptop-Review.305426.0.html
      Best Undervolting Guide (keywords: ThrottleStop, Intel XTU):
      Undervolting Coffee Lake i7/i9 (2018 MacBook class CPU):
      Replacing Thermal Paste with Liquid Metal on 2018 MBP:
      https://youtu.be/iw4gqfrBN4c ... and follow up: https://youtu.be/JNoZNzOQpVw
      Replacing Thermal Paste with Kryonaut on X1E:
      Replacing Thermal Paste and Undervolting X1 Carbon:
      Replacing Thermal Paste and Undervolting XPS 15 9570:
      Possibly over-conservative BIOS update for thermal throttling on X1E:
      High Sierra (10.13) drivers only for now:
      nVidia “waiting for Apple’s approval” for Mojave (10.14) macOS driver web release:

      Breadcrumb Links (other things I found researching this):
    • By gengik84
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.

      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  selezionate OsxAptioFixDrv-64
                             *  :Se nel vostro sistema è presente una scheda grafica (discreta) della serie 9xx nVidia selezionate OsxAptioFix2Drv-64 al posto di  OsxAptioFixDrv-64 *
      ** OsxAptioFix2Drv :E' necessario per poter impostare CsrActiveConfig= 0x3 **
      ***OsxAptioFix3Drv oppure AptioMemory --> (consigliato) devono essere usati su hardware Skylake o successivi perché permettono alla nvram di lavorare correttamente
           (mi raccomando o uno o l'altro)
      Proseguite con l’installazione.
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      Per installazione Legacy
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      7) Sezione System Parameters: Su inject kext mettete YES
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto-Fake+Sensors 6.26.1440.zip