Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,550 posts in this topic

Recommended Posts

no it's new it belong to my company

ssd use bitlocker

upgrade or update of bios can't be imagine it's a work tool ;)

 

 

can't do that cos

Esc@boot give me :

Startup menu: 

continue boot

system information F1 (available)

System diag (available too)

 

Boot menu (F9) ask for a password

No   F10

Share this post


Link to post
Share on other sites
Advertisement

No   F10

BIOS admin password asked too

boot menu is F9

bios setup F10

in both case BIOS admin password asked too (must have been locked by IT teams)

Share this post


Link to post
Share on other sites

At first I wanted to say, thank you very much for the great guide @tluck!

I installed El Capitan on my Lenovo W520 just fine and it is running very smooth. Now I have some questions left where I hope you can help:

 

  • As my real Mac is pretty old, El Capitan is the latest OS I can get from the AppStore... The Hackintosh just downloaded the High Sierra Installer and I am wondering if I can do the Upgrade safely, since all Kexts are already prepared for High Sierra as far as I have understood?

 

  • I ordered a mini PCI-Express half size card with Atheros AR 9281 Chipset... This will work out of the box, right? (I flashed version 1.43 BIOS so I guess withlisting has been disabled?)

 

  • Since the card is on its way, do I need to prepare something before installing? I read something about installing an ...80211 kext ?

 

  • What I further could not find out, will there also be bluetooth support provided by the wifi card?

 

  • And last but not least, is it generally possible to clone the HDD (with dd and Linux e.g.) to an SSD of same size!?

 

Thank you very much for your help!

 

Best
Hook

Share this post


Link to post
Share on other sites

welcome hook-knocker

i think you can upgrade to HS but i would advice you to set kext in the EFi partition (better than in /L/E)

HD can be use to boot a mac and your Hack

for last point use Carbon Copy cloner for mac partition only

Share this post


Link to post
Share on other sites

At first I wanted to say, thank you very much for the great guide @tluck!

I installed El Capitan on my Lenovo W520 just fine and it is running very smooth. Now I have some questions left where I hope you can help:

 

  • As my real Mac is pretty old, El Capitan is the latest OS I can get from the AppStore... The Hackintosh just downloaded the High Sierra Installer and I am wondering if I can do the Upgrade safely, since all Kexts are already prepared for High Sierra as far as I have understood?

 

  • I ordered a mini PCI-Express half size card with Atheros AR 9281 Chipset... This will work out of the box, right? (I flashed version 1.43 BIOS so I guess withlisting has been disabled?)

 

  • Since the card is on its way, do I need to prepare something before installing? I read something about installing an ...80211 kext ?

 

  • What I further could not find out, will there also be bluetooth support provided by the wifi card?

 

  • And last but not least, is it generally possible to clone the HDD (with dd and Linux e.g.) to an SSD of same size!?

 

Thank you very much for your help!

 

Best

Hook

 

 

May I ask which one is your old mac?

 

Regards

Share this post


Link to post
Share on other sites

@hook-knocker

 

to upgrade to High Sierra you can typically download and install directly if you are running the lastest clover zip etc. 

i recommend making a usb installer too.

you can clone with dd if you know what you are doing - i used to copy my windows stuff using dd. i use carbon copy for my macOS copy

if you have modded your bios, you may be able to just put in the chip and go.

i use Atheros AR5BHB92 aka 9280 and it works OOTB - no extra kexts etc.

but it is just wifi. bluetooth is a separate chip .

Share this post


Link to post
Share on other sites

May I ask which one is your old mac?

 

Regards

iMac 24" early 2009 , why?

 

welcome hook-knocker

i think you can upgrade to HS but i would advice you to set kext in the EFi partition (better than in /L/E)

HD can be use to boot a mac and your Hack

for last point use Carbon Copy cloner for mac partition only

As far as I've understood the basic kext are already stored in the EFI partition when following tlucks guide?

 

 

@hook-knocker

 

to upgrade to High Sierra you can typically download and install directly if you are running the lastest clover zip etc. 

i recommend making a usb installer too.

you can clone with dd if you know what you are doing - i used to copy my windows stuff using dd. i use carbon copy for my macOS copy

if you have modded your bios, you may be able to just put in the chip and go.

i use Atheros AR5BHB92 aka 9280 and it works OOTB - no extra kexts etc.

but it is just wifi. bluetooth is a separate chip .

Alright! I will try :)

Another thing I just found out: What about the USB3 ports? They are currently dead... is there a kext for that, too?

 

Thank you all,

 

best hook

Share this post


Link to post
Share on other sites

^yes, kexts are in Efi partition.

 

FYI I always follow tluck's recommandations 

kexts were in /L/E before and for unknown reason if my FakeSMC.kext was not in /L/E i had to boot with inject kext at boot GUI

if it was it directly boot

Share this post


Link to post
Share on other sites

iMac 24" early 2009 , why?

 

As far as I've understood the basic kext are already stored in the EFI partition when following tlucks guide?

 

 

Alright! I will try :)

Another thing I just found out: What about the USB3 ports? They are currently dead... is there a kext for that, too?

 

Thank you all,

 

best hook

Just in case it can be of any help...

 

http://dosdude1.com/highsierra/

Share this post


Link to post
Share on other sites

Hi!

I can't seem to boot into the installer itself for some reason....

 

When i launch the clover USB in UEFI or LEGACY mode, I see my "Winodws 10" but not the "Boot MacOS Installer"

 

Does anyone know what to do in this case?

 

Never experienced this before :-/

Share this post


Link to post
Share on other sites

@RedTailSan

 

so do you see the windows option in Clover or does it just move on to boot windows?

if you can get to the ESP on that disk, temporarily move the Microsoft directory out of the picture.

or reorder your boot priority list in bios.

Share this post


Link to post
Share on other sites

@tluck

 

I found the problem.

 

Multiple people has this problem when they used the "dosdude1 High Sierra Patcher" to download the installer app.

I managed to download the app from the app store, and are currently installing macOS 10.13.2

 

Sorry for the confusion :-)

Share this post


Link to post
Share on other sites

Hi All,

 

I've decided to update my installation (I'm still on Sierra, and not planning to upgrade to HS yet).

I was following the steps in the post installation section (as usual), downloaded the latest tluck package from github and upgraded to Clover r4392 (I couldn't find r4391 on github).

 

When I reach the step

 

cd ~/Downloads/Lenovo-T420-Clover-YYYY.MM.DD/EFI/CLOVER/kexts/

sudo ./_kext-install.command

 

 

I get weird errors:

 

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext PinConfigs.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext AppleALC.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIPoller.kext

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBatteryManager.kext

kxld[org.netkas.driver.FakeSMC]: The following symbols are unresolved for this kext:

kxld[org.netkas.driver.FakeSMC]: ___strlcpy_chk

kxld[org.netkas.driver.FakeSMC]: ___strncpy_chk

Link failed (error code 5).

Prelink failed for org.netkas.driver.FakeSMC; omitting from prelinked kernel.

Can't use FakeSMC.kext - not linked.

Prelink failed for org.hwsensors.driver.CPUSensors; omitting from prelinked kernel.

Can't use FakeSMC.kext - not linked.

Prelink failed for org.hwsensors.driver.ACPISensors; omitting from prelinked kernel.

KernelCache ID: 03796B34B5BA3E5A42EB511B45F36931

… done!

 

I have not yet rebooted my machine, being afraid of it will not boot into Sierra successfully. Do you guys have any idea what went wrong and how can I fix it?

Thank you.

Share this post


Link to post
Share on other sites

Hey guys,

 

my system is running almost fine now, but I'm having some minor issues... maybe you can help:

I tried to install the latest HS update from the Appstore, but the installer failed saying that "MacOs could not be installed on your computer". Before I see it failing it seems that there is some graphic issue, I see some white lines on a black background...

I also have some horizontal pink/white lines in some videos in photos app, so I suspect there is something going on with the graphic card?

 

Another thing is, that I want to use the laptop on a dock with DVI connector. I read something about disabling some kext, but I cannot find it?

 

Third is the USB 3 Port... any chance to get it working?

 

Thank you in advance!

Best

hook

Share this post


Link to post
Share on other sites

darn. i thought i had recompiled and posted the sierra compatible kexts. but i guess not. i will post revised kexts

Np, tluck and thanks in advance for fixing it.

 

By the way, I’ve found an incorrect path for the ACPIpoller.kext installation guide.

In your package it has been moved to a sub-folder which is deeper than what the guide says.

 

I’m on iPhone now so I can’t give you the exact path at the moment. It’s not a dealbreaker but I thought it’s worth mentioning.

 

Thanks again!

Share this post


Link to post
Share on other sites

@Somez

 

I reposted the release on GitHub and it seems to work for both Sierra and High Sierra

And fixed up the Guide for ACPIPoller.kext path etc. 

 

Thanks.

 

@hook-knocker 

perhaps move the ESP/EFI/Microsoft folder temporarily out of the way. this may lead to that install error.

 

DVI on Dock - check the Guide for Framebuffer edits, one of patches is probably putting VGA on that port?

Share this post


Link to post
Share on other sites

@Somez

 

I reposted the release on GitHub and it seems to work for both Sierra and High Sierra

And fixed up the Guide for ACPIPoller.kext path etc. 

 

 

Hi tluck,

 

Works fine now.

Minor correction for the ACPIpoller guide:

 

correct path should be

 

cd ~/Downloads/Lenovo-T420-Clover-2018.01.28/EFI/CLOVER/kexts/Misc/

 

(your path is missing the 's' for the folder name kexts)

 

Thanks.

Share this post


Link to post
Share on other sites

@somez - thanks - fixed the guide (again).

 

Note: i have been put all the custom kexts only in ESP - and not installing them /Library/Extensions - but this is up the end-user to decide.

Share this post


Link to post
Share on other sites

@somez - thanks - fixed the guide (again).

 

Note: i have been put all the custom kexts only in ESP - and not installing them /Library/Extensions - but this is up the end-user to decide.

 

Which step is this in the guide?

Is it this one?

 

sudo mkdir /Volumes/ESP

sudo mount -t msdos /dev/disk0s1 /Volumes/ESP

cp -a ~/Downloads/Lenovo-T420-Clover-YYYY.MM.DD/EFI/ /Volumes/ESP/EFI

 

cd /Volumes/ESP/EFI/CLOVER

mv config.1600x900.plist config.plist

 

What are the pros and cons of putting the kexts into the /Library/Extensions folder?

If I have copied them there before so would it matter if I remove them now?

 

Thanks.

Share this post


Link to post
Share on other sites

Hi All!

 

Since upgrading to High Sierra (or to Clover 4394?) I experience random freezes when I leave the machine alone for a while. When I come back the screen is black and nothing happens, I cannot wake the LCD up or test if the system is running in the background and only my screen is frozen. Sometimes the screen freezes with the windows open, so it's not black.

 

Any tips?

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Leinad12
      Olá a todos.
      Estou com o macOS Mojave instalado num Lenovo 305 (com um i3 5005 e uma HD 5500) porém tou com um problema.
      Sempre que o computador entra em pausa (Sleep) não consigo voltar a "acordar" (Wake).
      Alguém pode me ajudar pf?
    • By ludufre
      Installing macOS Mojave on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/13/2019 13:15h GMT-0
      - Updated info about touchpad replacement and CPU and 4G LTE modem.
       
      02/05/2019 18:47h GMT-0
      - Updated info about CPU replacement and 4G LTE modem.
       
      02/04/2019 15:24h GMT-0
      - Sometimes the VoodooHDA.kext doesn't work.
      - Added AppleHDADisabler.kext to fix that (attached bellow).
       
      01/24/2019 14:42h GMT-0
      - Added more adjustments to use of VoodooHDA.
      - Updated VoodooHDA links to 2.9.1 official (without installer).
      - Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)
      - Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).
      - Updated config.plist (Changed to user Audio layout to 1).
       
      01/22/2019 20:47h GMT-0
      - I gave up on the AppleALC.
      - Headset does not work.
      - Now with VoodooHDA is perfect and the sound even louder.
       
      01/22/2019 14:37h GMT-0
      - Add info about update 10.14.3. 
       
      01/22/2019 13:46h GMT-0
      - Add link to BIOS reassing guide.
       
      01/20/2019 11:49h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP, with good paste I have no overheating)
      - Replace touchpad with T460 model (Ordered. It's on the way) Done. Sensitivity and perception of quality much better. I recommend 100%!
      - Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ) Done, but not work. Recognize but not connect. I already gave up...
      - Upgrade to 16GB RAM Done
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the RehabMan's CloverEFI fork (used 4701) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop.
      - Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below
                    If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip
                    If no, then use 32MB_DRAM-prealloc_config.plist.zip
      - Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.3.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915.
      - Download the VoodooPS2Controller.kext from here. I used version 2018-1008.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.
      - Download the Lilu.kext from here. I used the version 1.3.1.
      - Download the AppleALC.kext from here. I used the version 1.3.4.
      - Download the VoodooHDA from here. I used the version 2.9.1.
      - Download the WhateverGreen.kext from here. I used the version 1.2.6.
      - Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (In addition to removing the whitelist, add the advanced menu);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      Soon, I'll provide step by step in this process. Probably until end of this week.
      In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.
      I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.
      - Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.
       
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.3
       
      - Updated with success;
      - Everything works perfectly after reboot;
       

       
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.
       
       
       
       
       
       
      32MB_DRAM-prealloc_config.plist.zip
      128MB_DRAM-prealloc_config.plist.zip
      SSDT-L440.aml
      VoodooHDA.kext.zip
      AppleHDADisabler.kext.zip
    • By Reel
      All work except camera
      You need SwitchResX that the screen does not freeze
         


    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      My USB 3 ports seem to suffer from low power output, and I don't know why.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
×