Jump to content
Kogen Mantis

Lenovo ThinkPad T420 with UEFI Only

4,529 posts in this topic

Recommended Posts

@tluck

 

Hi, testing new voodoops2controller you make great job, almost perfect for me but in voodoops2 there is no touchpad side scroll function.

 

Also can someone upload original sierra touchpad prefpanel?

Share this post


Link to post
Share on other sites
Advertisement

@gpspl - i believe the side scroll  (aka vertical scroll region) function is available if you configure it properly in the Info.plist. 

Share this post


Link to post
Share on other sites

@tluck Hello!

 

I installed on MacOs Sierra Thinkpad t420 with intel graphic and 1366 * 768. After load the GUI screen resolution is equal to its size. Dock for predeleami screen. Config used to 1366x768, 2 times checked.

 

ScreenShot

 

Prior to that, it was your assembly for mountain lion and there were 2 folders acpi Screenshot
 

Help please understand

Share this post


Link to post
Share on other sites

@tluck Hello!

 

I installed on MacOs Sierra Thinkpad t420 with intel graphic and 1366 * 768. After load the GUI screen resolution is equal to its size. Dock for predeleami screen. Config used to 1366x768, 2 times checked.

 

ScreenShot

 

Prior to that, it was your assembly for mountain lion and there were 2 folders acpi Screenshot

 

Help please understand

Open Terminal via Spotlight search, type

sudo killall Dock

then type your password

Share this post


Link to post
Share on other sites

Open Terminal via Spotlight search, type

sudo killall Dock

then type your password

 

Why would I kill the Dock? It works, just outside the screen, beyond, as seen in the screenshot is not hours. It seems that the screen should be 15 inches

 

The problem is that the image gets off the screen

Share this post


Link to post
Share on other sites

@tluck,

First time setting up a system like this. I followed your guide the best I could, but I'm also working with a T420s. I seem to be up and running quite well. Sometimes the trackpoint won't work on a restart, but returns after another restart. My main issue is the audio doesn't work. I tried installing an old AppleHDA kext and it got my speaker and headphone working, but the volume seemed about half of what it should be, so I reverted to the kext in your installation package. Not really sure what to do.

Share this post


Link to post
Share on other sites

@kanabiol - not sure what is going on with part of the display not on the LCD? did you try other resolutions?

 

@Subscryber - the did you install the kexts (AppleHDA_20672.kext) with the included script? and left /S/L/E/AppleHDA.kext in place?

Share this post


Link to post
Share on other sites

I'm trying to reinstall OS X but I can't get the resolution working right.

I have a 1920x1080 display but it seems that the files have been updated and 1080p no longer works with the 1366x768 plist with Duallink enabled.

Neither does the 1600x900 plist

 

Any ideas?

 

EDIT: FIXED

I used the 1366x768 plist

enabled Duallink (changed from 0 to 1)

and removed the <data>

	<dict>
		<key>DualLink</key>
		<integer>1</integer>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<false/>
		</dict>
		<key>InjectEDID</key>
		<false/>
	</dict>

Share this post


Link to post
Share on other sites

@kanabiol - ah yes - i see what is going on. sorry.

-- the EDID data is injected anyway - i will remove the EDID from the 1368 config.plist - i seem to recall this is a clover bug in some versions - meaning it will inject it even if Inject EDID = false.

 

ill redo the zip package shortly.

 

@gpspl - 

tell me more about AppleALC...

 

ASPM -- seems ok as is? shows true? - interesting on my t440 it shows false.

tluck@Toms-Mac ~
$ log show|grep ASPM
2016-11-23 11:02:39.370269-0500 0x530      Default     0x0                  0      kernel: (AppleLPC) AppleLPC::notifyPlatformASPM - registering with plugin with ASPM Support true
Edited by tluck

Share this post


Link to post
Share on other sites

 

@kanabiol - ah yes - i see what is going on. sorry.

-- the EDID data is injected anyway - i will remove the EDID from the 1368 config.plist - i seem to recall this is a clover bug in some versions - meaning it will inject it even if Inject EDID = false.

 

ill redo the zip package shortly.

 

@gpspl - 

tell me more about AppleALC...

 

ASPM -- seems ok as is? shows true? - interesting on my t440 it shows false.

tluck@Toms-Mac ~
$ log show|grep ASPM
2016-11-23 11:02:39.370269-0500 0x530      Default     0x0                  0      kernel: (AppleLPC) AppleLPC::notifyPlatformASPM - registering with plugin with ASPM Support true

I have been working with the AppleALC creator to provide many patches for many codecs. If you want I can create a custom AppleALC ( unofficial support ) for this T420 and possibly the T460 too

Share this post


Link to post
Share on other sites

@vusun123 - ok - sure.

 

i have 3 Lenovo ThinkPads now! - just got a T440s to replace my T420 - which i like way more than the T440. the audio on the T440 and T460 goes to sleep and its is garbled for 1/2 second until it wakes up... i use this pop thing to keep it awake but there must be a better way? it makes a really loud crunching on reboot.

 

 

T420 - Conexant 20672/20590

AppleHDA_20672.kext seems to work fine. 

Codec: Conexant CX20590
Vendor Id: 0x14f1506e
Subsystem Id: 0x17aa21ce

T440s - Realtek ALC292

 

so i created AppleHDA_ALC292.kext - which i was lucky to find shmilee's ALC3232 AppleHDA kext which works just fine. i compared the codec dumps and they are pretty much the same.

Codec: Realtek ALC3232
Vendor Id: 0x10ec0292
Subsystem Id: 0x17aa220c

T460 - Realtek ALC293

codec: Realtek ALC293
Vendor Id: 0x10ec0293
Subsystem Id: 0x17aa5053

Share this post


Link to post
Share on other sites

 

@kanabiol - ah yes - i see what is going on. sorry.

-- the EDID data is injected anyway - i will remove the EDID from the 1368 config.plist - i seem to recall this is a clover bug in some versions - meaning it will inject it even if Inject EDID = false.

 

ill redo the zip package shortly.

 

@gpspl - 

tell me more about AppleALC...

 

ASPM -- seems ok as is? shows true? - interesting on my t440 it shows false.

tluck@Toms-Mac ~
$ log show|grep ASPM
2016-11-23 11:02:39.370269-0500 0x530      Default     0x0                  0      kernel: (AppleLPC) AppleLPC::notifyPlatformASPM - registering with plugin with ASPM Support true

Hello Friend,

 

I just upgraded to Sierra and everything seems fine except for the 1366 LCD ..... I can only see it through another connected monitor.

Lenovo T420, clover, Sierra.

The screen of the laptop is black and the brightness to the maximum. But the system is ok.

 

Can it be the config.plist ?? Or any idea ??

Share this post


Link to post
Share on other sites

@Angelogtc - could be the EDID in config.plist - remove it. i just posted a new zip where i removed that mistake. 

 

I have replaced all EFI content and restarted. Still the same. Maybe I miss something.

 

I do not understand very well why but adding the ssdt has been fixed. Thank you.

Share this post


Link to post
Share on other sites

@vusun123 - ok - sure.

 

i have 3 Lenovo ThinkPads now! - just got a T440s to replace my T420 - which i like way more than the T440. the audio on the T440 and T460 goes to sleep and its is garbled for 1/2 second until it wakes up... i use this pop thing to keep it awake but there must be a better way? it makes a really loud crunching on reboot.

 

 

T420 - Conexant 20672/20590

AppleHDA_20672.kext seems to work fine. 

Codec: Conexant CX20590
Vendor Id: 0x14f1506e
Subsystem Id: 0x17aa21ce
T440s - Realtek ALC292

 

so i created AppleHDA_ALC292.kext - which i was lucky to find shmilee's ALC3232 AppleHDA kext which works just fine. i compared the codec dumps and they are pretty much the same.

Codec: Realtek ALC3232
Vendor Id: 0x10ec0292
Subsystem Id: 0x17aa220c
T460 - Realtek ALC293

codec: Realtek ALC293
Vendor Id: 0x10ec0293
Subsystem Id: 0x17aa5053

I did make an AppleALC patch for Lenovo T440 a few months ago, base on the actual laptop's codec dump itself, works perfectly using layout 28. Give it a try. Remove all dummy kext and all kext to patch, keep vanilla AppleHDA and install AppleALC, use layout 28

Share this post


Link to post
Share on other sites

I have replaced all EFI content and restarted. Still the same. Maybe I miss something.

 

I do not understand very well why but adding the ssdt has been fixed. Thank you.

 

With me on the new .zip everything works perfectly but does not work Caps lock (El Capitan 10.11.6) :( :( :(

Share this post


Link to post
Share on other sites

Hi, can the voodoo kext do tap-drag instead of left trackpad button click? Love this kext smooth and slow scroll (but I have to use smartscroll to make it fast)

 

Thanks

Share this post


Link to post
Share on other sites

@x4080 - yes - tap and drag is set by setting in prefs Accessibility/Mouse & TrackPad/TrackPad Options/ then check the box for enabling dragging.

you can change the speeds by editing the Plugin VoodooTrackPad.kext Info.plist.

i posted the code - my fork of user-sse2's fork of Rehabmans fork on http://github.com/tluck

Share this post


Link to post
Share on other sites

I have a T520 with Intel HD3000 and Nvidia NVS4200M graphics cards.

The integrated HD3000 works perfectly with the files posted here.

The discrete card also works after disabling "Inject Intel" and enabling "Inject Nvidia" in Clover and changing SMBios to 10,1 (MacBook Pro (Retina, Mid 2012).

 

However I can't change the screen brightness. I get that this problem is related to some backlight kexts.

Anyone know how to fix this?

Share this post


Link to post
Share on other sites

I have a T520 with Intel HD3000 and Nvidia NVS4200M graphics cards.

The integrated HD3000 works perfectly with the files posted here.

The discrete card also works after disabling "Inject Intel" and enabling "Inject Nvidia" in Clover and changing SMBios to 10,1 (MacBook Pro (Retina, Mid 2012).

 

However I can't change the screen brightness. I get that this problem is related to some backlight kexts.

Anyone know how to fix this?

Look at the W520 DSDT files I posted a while back, there should be some info that might interest you

Share this post


Link to post
Share on other sites

@x4080 - yes - tap and drag is set by setting in prefs Accessibility/Mouse & TrackPad/TrackPad Options/ then check the box for enabling dragging.

you can change the speeds by editing the Plugin VoodooTrackPad.kext Info.plist.

i posted the code - my fork of user-sse2's fork of Rehabmans fork on http://github.com/tluck

 Thanks tluck, good help

 

I wondered if there's something essential with the usrsse2 version, since when I compile his version, keyboard and touchpad is not working, but when I use your kext it just works (I'm using xps 13)

 

Edit : Hmm, I tried your source it still cannot run, but I think Im getting somewhere, your kext size is 296kb, but if i compile it in xcode, only 81 kb, is there something I'm missing?

 

What I did :

- download your git zip

- extract

- double click the xcode project

- Cmd-B, and in the Products - VoodooPS2Controller.kext, open in finder and put it in S/L/E using KextUtility

 

Solved :

- Target in xcode must change to All/All Kext

 

BTW tluck, do you know how to enable 4finger gestures ? Now it resulting the same gestures as 3finger gestures

Edited by x4080

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Abhiabhash
      I have a lenovo laptop with pentium 2020M 2.4ghz with 4gb ddr3 ram intel graphics and 500gb wd hdd i wanted to install hackintosh on my pentium for editing purposes beacuse windows sucks so can you please tell me how can i install it and which version should i install
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  AptioMemory --> (consigliato) 
                               : Driver64UEFI  ApfsDriverLoader --> (consigliato) --> sostituisce l'uso del driver apfs.efi
                               : Selezionate l'altri driver come da successiva immagine,
       
      *Nota: Altri driver che si possono usare  al suo posto  sono:
       informazioni 
       
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      apfs.efi-10.13-NoLog.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      apfs.efi-10.13.1-No_LOG.zip
      apfs.efi-10.13.2_No_Log.zip
      apfs.efi-10.13.3-No_Log.zip
      apfs.efi-10.13.4-No_Log.zip
      apfs.efi-10.13.5_No_Log.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip






    • By tbianco
      Ho comprato da poco un Acer Aspire 5750G e girando su internet ho trovato la cartella efi che garantiva quasi tutto funzionante perfino il wifi (https://github.com/zipippino/HighSierraAspire5750G).
      Allora felicissimo installo macOS e a parte incappare in errori stupidi, riesco a fare tutto, ma quando sono riuscito ad installare clover Legacy e sostituendo la roba con la 'mia' efi clover si avvia ma macOS no, semplicemente non carica (si nota anche pk la spia dell'hdd che dice se è in attivitá è spenta.
      Qualcuno può aiutarmi?
    • By RougeOne
      Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630
      flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000
       
      I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.
       
      EFI DIRECTORY
      http://s000.tinyupload.com/index.php?file_id=97606131925137056003
       
      HARDWARE
      CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)
      CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)
      Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)
      RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)
      GFX Card: Sapphire RX 580 NITRO+ SE
      SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)
      HDD: generic
      DVD Drive: generic
      PSU: EVGA 500W Semi Modular (but you should get 650W!)
      Case: CoolerMaster CM590 III
      Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.
       
      ADVICE
      With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.
       
      I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not get iMessage to work properly. It worked precisely once, on my first installation attempt. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - if you can get NVRAM/PRAM working properly on this hardware, please do edit the config as you see fit.
       
      Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.
       
      Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.
       
      With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.
       
      Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.
       
      Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.
    • By JLMOX
      I think, at this point converting to hfs+ is out of the question, Apple has been pushing the apfs file policy very aggressively, so does anybody solved the missing "Boot macOS from Mojave " (this last word may be different). I have installed the latest clover in HDD and USB, but I can only see 3 Mac Os related tabs but not the one for actually loading the Mojabe mac OS. I updated high sierra to Mojave and everything went fine. My laptop (Dell E6530) booted up normally, Mojave system loaded up, I finished the setup and spent sometime exploring. I updated clover to the latest version and turned of machine. When I restarted, I noticed Clover did not have an option for booting into the system like High sierra had it. I tried adding the apfs.efi or the ApfsDriverLoader-64.efi driver to the clover efi folder in the HDD and also tried with a USB clover installation and the result is the same: No boot option for the Mojave OS. I used the recovery option and I was able to explore the partion where the system is located but that´s as far as I could go. Does anybody has an idea of what happened?

×