Jump to content
K0gen

Lenovo ThinkPad T420 with UEFI Only

4,865 posts in this topic

Recommended Posts

Updated the zip with Michael Belyaev's latest addition for VoodooPS2Trackpad and smooth scrolling in Sierra.

So TrackPad PrefPane and Accessibility/TrackPad for drag is working and not jittery/jump when scrolling in browsers.

3 finger swipe back and forth is working nicely too.

Share this post


Link to post
Share on other sites
Advertisement

Updated the zip with Michael Belyaev's latest addition for VoodooPS2Trackpad and smooth scrolling in Sierra.

So TrackPad PrefPane and Accessibility/TrackPad for drag is working and not jittery/jump when scrolling in browsers.

3 finger swipe back and forth is working nicely too.

 

 

Thanks for the update tluck.

I confirm the trackpad scrolling is smooth now. However swipes and gestures other 2 finger right click does not work.

On top of that after installing the new package and rebooting I got the below screen. Powering off and on solved it for now, but I'm still worried.

post-1647866-0-99110500-1478551730_thumb.jpg

What does this error mean?

 

Thank you.

Share this post


Link to post
Share on other sites

I interpret it to mean macOS has random bugs and is not as stable as El Capitan.

 

usr-sse2 added capslock fix.

 

did you check it?

 

https://github.com/RehabMan/OS-X-Voodoo-PS2-Controller/commits/69f6c413364d95861afd53e4772be329b1ab0c07

 

 

capslocks finally get work

 

thanks to usr-sse2

VoodooPS2Keyboard.kext.zip

Share this post


Link to post
Share on other sites

I updated the zip with the latest VoodooPS2Controller kext from Michael Belyaev that has Sierra PrefPane and caps lock fix.

@tluck, does this voodooPS2Controller.kext solve the issue of auto opening webpages when scrolling through web Links?

Share this post


Link to post
Share on other sites

Got my new 9 cell battery recently, and I've been getting 3 hours of battery life with it. It's a huge improvement over my last battery, but it is still far from the 9hrs the battery was supposed to give according to other forums.

 

Is this normal, or is there really something wrong about battery usage?

 

If it is of any use, I changed my WiFi card for a Broadcom one and am sporting double drives (ssd+hdd) with no DVD drive.

Share this post


Link to post
Share on other sites

Hi tluck,

 

I can also confirm that caps lock works well. Thanks for the update.

What does not work for me at all are the touchpad gestures, except the double finger tap right-click. Is there a method to find out the root cause behind this?

Thank you.

Share this post


Link to post
Share on other sites

@cyndonia - how long you can work on battery depends on what processes are running. are you using a custom SSDT - created by the script in the zip? that may help?

 

@Somez - there are just few gestures available

 

2 finger scroll - obvious

 

 

on the more gestures page in the pref pane

 

Mission Control and App Expose - 3 finger swipe up/down - these actions are mapped to control up/down arrow - then you need to check if you have up/down arrow mapped for Mission Control and Application Windows in the Mission Control PrefPane instead of F9 F10

 

Swipe between full-screen app - 3 finger swipe left/right - I mapped the action to command [ and command ] instead of control left/right arrow. this will give you back/forward in app windows such as safari.  i changed this from default map - which is space or full screen app switching back and forth. you can change this in the Info.plist by removing the T420 swipe maps.

Share this post


Link to post
Share on other sites

^installation done

trackpoint ok but no scroll here (must i do something to make it work)

thanks for the time you spend for the community :)

Share this post


Link to post
Share on other sites

TrackPoint users:

 

Please try this VoodooPS2Contoller kext to test for TrackPoint scrolling without all the clicks. Seems to work for me in Safari etc. if it looks good for folks, i will add to the zip file.

@tluck, just installed it. Working perfectly. I will test a little more and report back. Thanks for the file.

Share this post


Link to post
Share on other sites

Is the WWAN F5521gw working on Sierra? On 10.11.6 not, even if I modify the CellPhoneHelper.kext :/

 

I got it working in 10.10.5 but haven't been able to get it working on Sierra. I never updated to El Capitan. It seems the way usb ports are handled has been changed since El Capitan and that you should use USB injector kext and do some DSDT patching. There's more info here:

 

http://forum.osxlatitude.com/index.php?/topic/6556-using-ericsson-f5521gw-hp-hs2340-hspa-dell-dw5550-in-os-x/

 

and here:

 

http://forum.osxlatitude.com/index.php?/topic/9275-problems-with-ericsson-f5521gw-under-10116/

 

It seems it's possible to get it working, I haven't had time to give it a try, I actually got Sierra kind of working with minor issues on a external HD and haven't check it again in weeks since I'm still using Yosemite on my X220.

 

I hope it helps, let me know if you make any progress. 

Share this post


Link to post
Share on other sites

@Espamac - does your system (X220?) have USB3 ports? or non-intel USB ports? if not, otherwise El Cap and Sierra should be fine on it?

Share this post


Link to post
Share on other sites

I updated the Zip with a new VoodooPS2Controller kext that will help with TrackPoint scrolling. if MiddleMouseScroll is set to true - then the middle button (cut/paste) is ignored. So it means middle button is just for Scrolling with TrackPoint in this mode.

Share this post


Link to post
Share on other sites

(I clean installed Sierra on my T420 this past weekend)

 

I just got an notification through the App Store for an MacBook Pro EFI Firmware Update 2.7.   Is it kosher to install or will possibly cause my Thinkpad to self destruct?

Share this post


Link to post
Share on other sites

you can install it. It will update the /EFI/APPLE folder with stuff - it won't do anything bad since there isn't an actual SMC chip to get upgraded. the good is it will quiet the notices etc.

tluck@Toms-Mac /Volumes/ESP/EFI/APPLE
$ ls -l
total 2
drwxrwxrwx  1 tluck  staff  512 Aug 15 10:55 EXTENSIONS
drwxrwxrwx  1 tluck  staff  512 Nov 11 00:35 FIRMWARE

Share this post


Link to post
Share on other sites

 

you can install it. It will update the /EFI/APPLE folder with stuff - it won't do anything bad since there isn't an actual SMC chip to get upgraded. the good is it will quiet the notices etc.

tluck@Toms-Mac /Volumes/ESP/EFI/APPLE
$ ls -l
total 2
drwxrwxrwx  1 tluck  staff  512 Aug 15 10:55 EXTENSIONS
drwxrwxrwx  1 tluck  staff  512 Nov 11 00:35 FIRMWARE

  Awesome, thanks!

 

I'm a little gunshy when it comes to updates (especially when everything is working).  I remember completely wrecking my Lenovo U530-Touch hack not to long ago after an update.  :lol:

Share this post


Link to post
Share on other sites

@Espamac - does your system (X220?) have USB3 ports? or non-intel USB ports? if not, otherwise El Cap and Sierra should be fine on it?

@tluck my x220 has one usb3 port (which I never managed to get working under Yosemite) and, as far as I know, no non-intel ports. I have to play more with Sierra, though not being able to use the WWAN module is a big disadvantage for me. Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By TomZanna
      Hi, I'm trying to install Mac Os Catalina on a HP 550-132NL.
      The system has:
      i7-6700
      RAM 12 GB
      GT 730
      LAN Realtek RTL8161
      ALC3863
       
      It passes the verbose phase but after the Apple logo goes away, it gets stuck on a grey screen and I can only move the pointer.
      Can I try to boot with the iGPU?
       
      origin.zip
      CLOVER_dGPU_USB_3.zip
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
    • By mikezexter
      (Dear moderators please replace this topic to another category if I made a mistake in choosing it)
       
      Hello everybody. I need some help in trying to fix native AppleHDA sound on my X230T.
      VoodooHDA works perfectly but without needed HDMI audio channel so I need to try fix my sound in native mode.
       
      AppleALC told us here (README) that in v1.2.1 Added ALC269 layout-id 18 for Thinkpad X230 by Hypereitan. And if it works I didn't need to create this topic.  Unfortunately layout ids 1,2,3,18 and 55 didn't help me to fix sound issue.
       
      My Clover: https://drive.google.com/open?id=1FuGS7iE59ydgiMsxZcDMarlAFH3FliNE (it's 2 MB bigger than I could upload for now)
      I've also uploaded some screenshots of what I've seen after 5 reboots in a row changing layout ids. Please help me to fix this issue.
       
×