Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


HP ProBook 4710s - Lion 10.7.5 - problems

5 posts in this topic

Recommended Posts

Hi Everyone.


I am an owner of a HP Probook 4710s. It is now 2 years old and I decided to upgrade it with Mac's system.

I've already installed Lion 10.7.5 (I had a lot of problems with making a Bootable USB flash drive with Lion. But now it's done. So, I installed it totally clean, without any Bootloaders.


Now, I have problems with almost all of the hardware inside it.

I managed to activate laptop's keyboard and trackpad. I have also managed my screen resolution in com.apple.Boot.plist but I have problems with Graphics, Sound, Ethernet controller and WIFI.


Here are the specs of the laptop:

HP Probook 4710s


CPU: Intel® Core™2 Duo CPU T5870 @ 2.00GHz 64bit


RAM: 2x 2Gb 400Mhz

GPU: ATI HD Mobility Radeon 4300 series - 4330 with 512Mb (Not recognized and showing only 5MB of VRAM)

Sound: AMD HIGH DEFINITION AUDIO WORKING - but problems with microphone - hearing myself and if too loud speaker it starts making annoying sound - tried input gain and monitor to 0 - nothing better. Anybody?

Ethernet controller: Marvell Yukon 88e8072 (not working)

WIFI: Broadcom BCM4310 USB Controller (not working)


Yeah and also the speed of a fan is at low speed that is why laptop is extremlly hot. Also sleep mode is not working.

I'll be very happy and grateful if someone could help me with those drivers.


Thank you.


Edited by teddy81t

Share this post

Link to post
Share on other sites

Honestly man, that's a mess.


All Intel-based laptops today use Intel HD graphics, or can from dedicated graphics. You have an ATI Mobility Radeon setup, which I'd Google along with "hackintosh", but I wouldn't hold my breath for something that old and foreign to Macs. Like if a real Mac used that, you'd have a fighting chance of getting it working... Sound is AMD-based, so I'm not expert but I haven't heard of that specifically working.... You might try VoodooHDA.kext, that's a pretty universal kext. As for Ethernet, most setups are Realtek, again, give it a Google with "hackintosh", but I'm not sure on support... And WiFi... Google Google Google! The whole post should be Googled! But the AR5B195 is a known compatible WiFi N/Bluetooth (3.0) card for hackintoshes, it's about $10 on eBay and is half-height PCIe, your laptop may be full-height PCIe...


Frankly... It's far from the ideal hackintosh laptop, you'd be better off with a laptop, used or new, with an Intel Core i5 or i7 processor, doesn't really matter if it's 1st gen, Sandy Bridge or Ivy Bridge, but Ivy Bridge runs 10.8 Mountain Lion with the least hassle/setup. It helps to have HD4000 graphics, HD3000 doesn't play nice with 10.8, or at least last I heard it doesn't.... I would go ahead and buy that AR5B195 card, make sure your laptop does not have a whitelist, because whatever laptop you get (assuming you're going to get a new laptop for this), it almost certainly won't have a supported WiFi/Bluetooth card, if it even has Bluetooth at all.


As for everything else.... I think it's just that your laptop is on the older side.... Also, use myHack on a Mac or OS X VM to make the USB installer, it uses Chameleon for the bootloader, and I think that'll help you out a bit.

Share this post

Link to post
Share on other sites

Thank you Jimmy for this reply. Well I thought so that that this laptop is not entirely made for a Hackintosh. I wanted to install xOS because I wanted to see how it is with its functionality. Well, I got AUDIO working now with VOODOO 2.6 - everything works great. But everything else remains unrevealed secret, I guess. I was googling a lot and trying different solutions even for graphic and for ethernet adapter, but of cours... always with zero success. For wireless I am using D-LINK USB WIFI adapter... that is fully functionally :) I am actually writing this from my H(P)ackintosh.


I have actually bought a new laptop already and I think it is going to be more xOS friendly. I don't have it yet, but it is on its way. It's Sony Vaio S1512 with i7 3rd gen Ivy bridge, INTEL HD4000 & GeForce GT 640 (2GB), 8GB RAM, SSD Drive, Full HD IPS Screen, I really don't know what kind of ethernet, wifi, bluetooth and other peripherals uses it. But I'll see very soon. I hope that there will be everything easier, because I just love Mac's OS. It's only one thing that bothers me... it's the price of MacBook Pros with Retina display.

Share this post

Link to post
Share on other sites

Well... today my hackintosh managed to recognize AT MOBILITY RADEON HD 4330 but it says only 5 MB vram. What have I done:








I have in CHameleon boot file:







<key>Graphics Mode</key>




<key>Kernel Flags</key>

<string>npci=0x2000 darkwake=0 -force64</string>

<key>Legacy Logo</key>







Any ideas perhaps?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By End3rPwr50
      Hi, I wanted to install macOs 10.13 on my notebook.
      Here are the technical specifications:
      -Intel i7 6500U 2.50GHz Skylake (CPU)
      -12GB ram dd4 (RAM)
      -hp 81EC (MOTHERBOARD) with BIOS insyde F09
      -Intel HD Graphics 520 - AMD Radeon R7 M440 (Graphics cards)
      -Realtek PCIe FE Family Controller (Ethernet)
      -Broadcom BCM43142 802.11 bgn Wi-Fi M.2 Adapter (Wifi and Bluetooth)
      -Realtek High Definition Audio - Audio Intel® per schermi(HDMI)
      Thanks in advance

    • By hopoc
      Hi Guys,
      I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!
      System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB​

    • By sergymac
      Ciao a  tutti sono nuovo di questo forum o meglio seguo con piacere e già ho alle spalle diversi progetti hackintosh ma la prima volta che mi cimento con i portatili.
      Il laptop in questione è il Pavilion 15-cb028nl e per tutti quelli che intendono acquistarlo posso dire che è abbastanza hackintosh compatible!
      Ho installato Sierra tramite immagine per laptop presa da un sito turco e dopo varie ricerche sono riuscito a far funzionare le seguenti cose:
      Audio e mic
      CPU e mobo sensors
      Video ma riconosce solo la scheda intel non la GTX1050
      Touchpad con multi gestures
      Stop e reboot 
      Adesso viene la parte complicata, vorrei effettuare la patch del DSDT per avere anche la batteria, la luminosità dello schermo de ottimizzare un po' meglio il sistema.
      Ma purtroppo è la prima volta che mi imbatto nel patchare il dsdt e qui mi fermo perchè anche seguendo le guide sia in italiano che in inglese non riesco a risolvere gli errori nella compilazione.
      Sono riuscito ad estrarre e decompilare con iasl il file originale creato da clover (F4).
      Qualcuno molto più pratico, gentile e disponibile potrebbe risolvere gli errori del dsdt, ve ne sarei grato!!!
      Per chi avesse il mio stesso portatile allego la cartella clover con tutti i kexts e il lavoro fatto fino ad ora. 
      Grazie mille!!
    • By giacomo.dessi2303
      Salve a tutti, possiedo il laptop dell vostro 15 3549 con le seguenti specifiche: Scheda Madre: Dell 07X77G Processore: Intel core i5-5200U RAM: DDR3 4GB Scheda Video: Intel HD Graphics 5500 Scheda di rete: Dell wireless 1705.802.11 Scheda audio: Realtek High Definition ALC3234
      Attualmente ciò è quello che funziona e che non funziona: Audio (OK) WebCam (OK)
      Graphics (OK)
      Touchpad (OK)
      Keyboard (OK)
      WiFi (OK)
      USB (OK)
      Bootloader (OK)
      Battery (NO)
      Microphone (NO)
      Brightness (NO)
      Bluetooth (NO)
      SD Card Reader (NO)
      Penso di aver bisogno di un dsdt.. qualcuno di voi potrebbe aiutarmi? Grazie in anticipo
      Cartella Clover attuale: https://drive.google.com/open?id=1TQk-z2hWfNMZgmrj_xY5ZdA-1gtfNKB2
      DSDT Vergine: https://drive.google.com/open?id=1HPFVYRVWGzj92bM_tFa0YvhioAISAiFF
      Hack Info: https://drive.google.com/open?id=1DjP_ngYBdenkZYBqaEZ8NK3EPcjbsV8M
      IOREG: https://drive.google.com/open?id=1RJSjj-LkYyV5483pDvWMqKLM0D0iOmEM
    • By giacomo.dessi2303
      Salve a tutti, in sostanza hp installato sierra col metodo vanilla e funziona tutto abbastanza bene, tranne il touchpad. se non metto nessun kext il touchpad funziona, anche se va un po' lento e non ho le gesture, se metto il kext voodoo ps2 il puntatore . è come se impazzisse e sono costretto a riavviare . e utilizzare un mouse usb. Non riesco a capire che modello è  perchè da windows mi dice semplicemnte asus touchpad. che faccio?