Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

instant idiot

Database of Current Working AMD Kernels

Which Kernel Are You Using?  

40 members have voted

  1. 1. 10.8

    • AnV's latest kernel
    • Sinetek's mach_sse42_only
    • One of Sinetek's other kernels
    • other
    • Sinetek's test 1 (for Bulldozer)
  2. 2. 10.7

    • IiTz ShAnE's legacy_kernel
    • theconnactic's kernel
    • other
    • R:A:W:X86's kernel
    • BronzovkAnVoodoo
    • Bronzovka v4
    • Bronzovka v5
    • Bronzovka v6
    • Bronzovka 32/64-bit kernel
  3. 3. 10.6

    • Sinetek's full 64-bit kernel
    • AnV's 32-bit kernel space 64-bit userland kernel
    • One of Nawcom's older kernels
    • other
    • Nawcom's 10.6.8 legacy_kernel

76 posts in this topic

Recommended Posts

OS X 10.9 - Mavericks


10.9.0 - mach_10.9_beta_rc3 (XNU - 13.0.0)

10.9.0 - mach_10.9_beta_rc4_fix (XNU - 13.0.0)

10.9.0 - bronya_anv_sinetek_R6_bsa_kernel (XNU - 13.0.0)

10.9.0 - bronya_anv_sinetek_R7_bsa_kernel (XNU - 13.0.0)

10.9.0 - bronya_anv_sinetek_R8_bsa_kernel (XNU - 13.0.0)

10.9.0 - bronya_anv_sinetek_R9_bsa_kernel (XNU - 13.0.0)


10.9.2 - bronya_fx_rc1 (XNU - 13.1.0)

10.9.2 - bronya_fx_rc2 (XNU - 13.1.0)

10.9.2 - bronya_fx_rc3 (XNU - 13.1.0)

10.9.2 - bronya_fx_rc4 (XNU - 13.1.0)

10.9.2 - bronya_anv_sinetek_R10_bsa_kernel

10.9.2 - bronya_rc4_test (XNU - 13.1.0)

10.9.2 - bronya_rc5 (XNU - 13.1.0)

10.9.2 - bronya_fx_rc6 (XNU - 13.1.0)

10.9.2 - bronya_rc6_fixed (XNU - 13.1.0)

10.9.2 - bronya_rc7_fixed (XNU - 13.1.0)


10.9.4 - bronya_rc1 (XNU - 13.3.0)

10.9.4 - bronya_rc2 (XNU - 13.3.0)

10.9.4 - bronya_rc3 (XNU - 13.3.0)


10.9.5 - spakk_rc1 (XNU - 13.4.0)

10.9.5 - spakk_FX_rc1 (XNU - 13.4.0)

10.9.5 - spakk_FX_rc1_a (XNU - 13.4.0)

Share this post

Link to post
Share on other sites

spakk your the only person to have a 10.9.5 kernelk up! :guitar::yoji::guitar::thumbsup_anim:

Share this post

Link to post
Share on other sites

The thanks goes to the team Bronya, Andy Vandijk, Sinetek and all others who had been involved. I was just a tool :)


but now we need our greatest effort with, the focus to building a running yosemite amd kernel.

Edited by spakk

Share this post

Link to post
Share on other sites

The thanks goes to the team Bronya, Andy Vandijk, Sinetek and all others who had been involved. I was just a tool :)


but now we need our greatest effort with, the focus to building a running yosemite amd kernel.


Share this post

Link to post
Share on other sites

11 March 2015 Bronya - mach_10.10_all_amd_rc7

09 March 2015 Tora Chi Yo - 1010-kernel-REV-8N + pthread.kext for unofficial supported updating of 10.10.2/3/4


05 Aug 2015 - xnu-2782.10.72_SSEPlus (10.10.2)


To use this kernel for the update 10.10.5 Build 14F19a, please read instructions!)

for update 10.10.5 Build 14F22a read these Instruction!

Edited by spakk
edited further new kernel and update instructions

Share this post

Link to post
Share on other sites
27 August 2015 - y2k4u - 10103R1


27 August 2015 - Bronya - kernel_10.10.3_rc1

P.S, in to bootloader has Bronya added pseudo code "disable c1e" if in bios enabled c1e!  - this now works sound without squeaks !
TEST sound with  this boot_c1e_amd ! This version 2715 ! this is only beta, created by Bronya ! )

more details on kernel and boot files see here:



01 Sept. 2015 - spakk - xnu-2782.20.48_SSEPlus_V2 (10.10.3)


compatible with clean Install Yosemite 10.10.5 Build 14F27a, replace these contents from package 10.10.5

Edited by spakk

Share this post

Link to post
Share on other sites
if someone should be interested, I have added the entry to the Legacy Kernel for Tiger 10.4.11 , see here
Although the kernel is not up to date, but without this development we would not be here today, thanks to Andy


Share this post

Link to post
Share on other sites
17 Sept. 2015 - y2k4u - 10104R1


17 Sept. 2015 - y2k4u - 10105R1


19 Sept. 2015 - spakk - 10.10.5_SSEPlus_V2


25 Oct. 2015 - spakk - 10.10.5_SSEPlus_V3    ( The thanks goes to DJ PhoeniX)


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By haegar33
      I have browsed thru all forums and all threads for this card but apparently my system is still something special. With some cumbersome effort (none of the simple one-click ##### and other USB-Installers methods ever worked for me) I managed to install Sierra 10.12.5. However when booting is nearly finsihed I get the famous black screen which can be recovered by quickly unplug/plug the DP monitor cable leading finally to a proper initialisation of my 290X. 

      1.) RadeoDeInit is on, without this patch the screens stays dark forever
      2.) Booting with iGFX never works for me, I always get memory allocation errors during boot until I disable the Intel graphics completely.
      3.) I am on Clover 4318, newer version do not make any differences.
      4.) I am using a System Configuration for an Imac 14,2. Most other configs do not make difference either.

      I have not started again the nightmare of Framebuffer patching (as I remember from Yosemite) and I think it will not help as the card is recognised by Sierra but just not initialised.
    • By TheBloke
      Hi all
      I currently use an NVidia 760 with four displays: 1 x 4K; 2 x 1920x1200; 1 x 1920x1080.   This mostly works, but I am considering replacing it with an AMD GPU - likely a Radeon 7970 - for two reasons:
      I would like to add a fifth monitor, maybe even a sixth; I get small stutters and slowdowns with my NVidia, using both Native and NVidiaWeb drivers.  It is a lot better than it was with my NVidia 980Ti, but it's still not perfectly smooth as it should be, especially when I have a full screen video playing while also doing UI movements like Swipe Left A Space or Mission Control.  
      I have just been told that it should be possible to access all display outputs on an AMD 79XX GPU, possibly requiring a custom SSDT and/or radeonDeInit?  I've only ever had one AMD GPU and that was 8 years ago so I am not experienced with them.  My NVidia 980Ti has five outputs, but can only use four at once.  But I believe AMD's EyeFinity does allow it to use them all as separate displays.
      Before I buy the GPU, I'd be most grateful if anyone could confirm that it should be possible to run five or six simultaneous displays on a card such as the ASUS HD 7970 DirectCU II (6 x DP outputs) or XFX AMD Radeon HD 7970 (2 x mini-DP; 1 x HDMI; 2 x DVI).  With one display being 4K @ 60fps and the rest 1920x1200 or 1080P.
      I have Googled on this a while but haven't yet found anyone discussing connecting more than four monitors to an AMD Hack  I did see that the late-2013 Mac Pro (which uses 2 x AMD FirePro GPUs) states it can support "up to 6 Thunderbolt displays".  So I know the OS can do it, it's just a question of whether a particular GPU can, and in a Hack setup.
      Thanks very much
    • By Angelo_
      Hi guys, i'm trying to help a friend of mine trying to install osx(possibly high sierra) on his pc with the following specs: 
      Amd fx8350 
      Asrock 990fx extreme 3
      8gb of fury Kingston ddr3 ram(2x4)
      Radeon hd 7950
      128gb ssd( crucial m550)
      A couple of hdds I don't remember the brand(maybe a seagate barracuda and a dumb old disk for data)
      We tried to install it using the regular clover+high showers installer but we couldn't get it to reach the installer, then we tried osx-amd(don't know if i can talk about it there, sorry if i can't) and we still couldn't get to the installer.
      Is there a guide i can use to install osx in that machin, i tried to search in the forum but i couldn't find it.
    • By hopoc
      Hi Guys,
      I’m stuck with 3mb VRAM, and can’t get my screen resolution! I’ve tried to reinstall 18 times with different configurations but I can’t seem to get it right! PLEEEEASE HELP I really don’t know what to do now. I've tried Enoch but still no success!
      System Model: HP EliteBook 8570p Processor: i7-3520M CPU @ 2.90GHz, 2901 Mhz, 2 Cores GPU:  AMD Radeon HD 7570M RAM: 12GB​

    • By macinsane
      What works? Everything. Sleep/Wake, NVMe, Airport, Spotlight, AMD-graphics

      ASUS Prime B250M-C µATX-board
      Intel Core i5 7500 (Kaby Lake)
      Gigabyte Radeon RX560 4GB
      Airport-compatible PCIe-Card for Wifi and Bluetooth (BCM943602CS)
      2 NVMe drives: Samsung P961 with 1 TB and 256 GB

      Installed mac OS: 10.13.2
      Clover: 4334
      *Update 10.13.3*
      Added new config.plist and ssdt for AMD injection (config_amd_ssdt_10133.zip). With this config and Intel IGPU activated you'll get Metal2 (macOS GPUFamily1 v3). What did I do? Had to fake Skylake graphics or to prevent apps like iMovie or FinalCut from crashing. With Kabylake kexts loaded and IGPU as secondary graphics card, the computer will hard reset whenever the Intel GPU is utilised. Only Skylake kexts and activated IGPU will give you working Metal2 for the RX560.  
      *Update 10.13.2*
      Since this update a new approach is advisable to get the RX560 up and running (works for 10.13.1 and GM as well). I've added a working SSDT and injector kext that gives you graphics and HDMI audio. Sleep works fine too if you add the DSDT I compiled.  
      Credits go to @Toledo @Mork vom Ork and @Mieze because their work made this possible.
      *Update* I've added NEW config.plist and DSDT. For proper graphics power management you have to activate onboard graphics in BIOS but make PCIE the primary display. Furthermore you have to inject ig-platform-id 0x59120003 and let Clover patch GFX0 to IGPU. This is the only way to avoid crashes of iMovie, FinalCut or slowdowns after video playback.

      This may be the smoothest Hackintosh of my life. It is easier than Sierra install due to native support for most of the used hardware in High Sierra. Not much to do, using an up-to-date Clover version like 4184. Make sure you have apfs.efi in /Clover/drivers64UEFI/ on your EFI partition and that you delete EmuVariableUEFi.efi (downside: iMessage doesn't work without it). Somehow Rehabman's SSDT in /Clover/ACPI/patched helps avoiding crashes in iTunes.

      Needed kexts (on your EFI into /Clover/kexts/Other): FakeSMC, IntelMausiEthernet for ethernet, USBInjectAll and XHCI-200-series-injector for USB, Lilu and AppleALC for audio, Whatevergreen for AMD graphics, IntelGraphicsFixup and AMD9xxxControllerPatcher.kext.
      DSDT and SSDT go into EFI/Clover/ACPI/patched.