Jump to content
InsanelyMac Forum
Sign in to follow this  
Laszlo Lebrun

Can't cleanly boot from USB without involving...

Recommended Posts

Can't cleanly boot from USB without involving my HD.

 

Hi group,

 

I am a bit lost now...

My main OSX drive appears to be corrupted (according to Disk utility).

OSX Snow-Leopard works so far.

I should boot from another disk in order to repair that drive.

 

Whenever I boot from that other disk: a USB drive (over Chameleon) the boot works, but the USB drive stops and apparently passes on to the internal HD, which loads the system and only at the end the USB drive seems to "finish" the boot.

 

At the end I have a working OSX, but again Disk Utility refuses to repair the internal HD since it is in use...

 

How can I force a plain USB boot leaving the HD untouched?

I tried to change the boot order in BIOS, tried to boot with -x, to boot without caches, even disable the disk in the Bios... nothing helps.

 

OK I could physically remove the disk, but i'd like to avoid tampering my notebook.

Can someone help?

 

Thank you.

Laszlo

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By EZY
      Hello,
       
      after installing new hard drive to my functional hackintosh it doesn't shows up in disk utility at all.
      But, when I boot up Windows 8 on same machine and go to disk management it shows up normally and I can format it and do everything with it normally.
      Access with file explorer is also possible.
      I tried formatting it in MBR and GPT format style - no success.
      I tried formatting it in NTFS and exFAT - no success.
      I also tried connecting it to another SATA port - no success.
       
      Is there something else I can try?
    • By Marta Reis
      Hi,
       
      I'm facing problems with Adobe Premiere due to disk damaged and permissions that need to be repaired.
       
      I used the fsck tool booting in single user mode to repair the disk (fsck -fy)
       
      The system disk was successfully repaired but the problem with Premiere persists. When I run disk utility I see some permissions that need to be fixed. I tried "Kext Utility", "Disk Utility" and terminal with no success
       
      Using another user account the app performs flawlessly. The problem vanishes. 
       
      How can I fix those permissions? Adobe says they are the one causing the problem.
       
       
      Thx
       
       
      http://martatravassos.tumblr.com/post/133143349182
    • By fusion71au
      Disk Utility from Yosemite 10.10.5 (ver 13 (606)) patched to run on El Capitan.
      Note: After you have downloaded and unzipped the file, you need to let root:wheel take ownership of the app before the app will run...
      sudo chown -R 0:0 ~/Downloads/Disk\ Utility.app
      v1 Patching procedure from Restore old Disk Utility in OS X El Capitan, credit @Justus Beyer
      v2 Patched with patch pattern from diskUtilityPatch, credit @dimosgmx
       
      Debug menu can be enabled with
      defaults write com.apple.DiskUtility DUDebugMenuEnabled 1
      Advanced image verification options unlocked with
      defaults write com.apple.DiskUtility advanced-image-options 1
      To turn off the above options, use the same commands in terminal but type 0 instead of 1.
    • By fantomas1
      Dans OS X 10.11 ("El Capitan"), Apple a remplacé le bon vieux Utilitaire de disque par une version entièrement revue et plus coloriée mais moins performante.
       
      De nombreuses fonctionnalités ont été sacrifiées au profit d'une interface utilisateur plus simple et plus conviviale. Ce tutoriel vous montrera comment utiliser une ancienne version* d'Utilitaire de disque dans El Capitan.
       
      * version utilisée ici est celle de 10.10.5 mais celle de 10.9.5 conviendra aussi !!!
       
       
      AVERTISSEMENT : L'utilisation d'une version obsolète d'un utilitaire système porte un grand nombre de risques et peut entraîner la perte totale ou la corruption de vos données. A utiliser à vos risques et périls !!!
       
       
                                1. Pour les plus préventifs, faites une sauvegarde de vos données ou de votre installation
      via Time Machine ou d'autres logiciels tierces.

       
                   2. Faites une copie de la version 10.10.5 d'Utilitaire de disque sur votre bureau

       
      3. Téléchargez un éditeur hexadécimal comme le gratuiciel Hex Fiend.
       
         4. Lancez Hex Fiend et ouvrez le fichier Disk Utility qui se trouve dans 
      Disk Utility.app/Contents/MacOS
       
                                                                        5. Allez à l'offset 25056

       
                                     6. Comme sur la photo ci-dessus, vous devriez voir deux valeurs de quatre bytes chacune
      D584C00F 85440100
       
                                                7. Sélectionnez "85" et remplacez-le par "84". Après ce changement, ça devrait ressembler à ça :
      D584C00F 84440100

       
                                                                         8. Sauvegardez le fichier et fermez Hex Fiend.
       
                                                                         9. Terminé. Vous pouvez lancer l'Utilitaire de disque depuis votre bureau.

       
       
      Vous pouvez même débloquer l'option "Débogguer" via la commande :
      defaults write com.apple.DiskUtility DUDebugMenuEnabled 1  
       
       
       
       
       
      Credits : @Justus Phillip Beyer pour cette astuce
       
                     @dgsga pour cette découverte
       
                     @fusion71au pour la commande de l'onglet "Débogguer"
    • By georgebergling
      Hi, yesterday I upgraded my HP Envy 15-j101ss with Yosemite 10.10.2 to 10.10.3 and everything was working correctly after the update except a mistake with the new Photos app. I wasn't able to import the iPhoto gallery because the app said that I needed to repair the disk permissions and I did it with Disk Utility. But after this i'm stuck on the apple logo so I can't boot. I boot in verbose mode and everytime i see: 'Incorrect number of thread records'. I tried to repair it with fsck but there's always a loop and the system can't repair it, Also I tried it with Disk Utility in Time Machine but the fix isn't possible and I thought there were back-ups to restore it, but there aren't so it's like a joke... Moreover I have a Windows partition with MacDrive but this software can't repair it too. I don't know what can I do, maybe there's any chance to repair the OS X because in this partition I have many important files such as music projects...
       
       
       
       
×