Jump to content

Help with rEFIt

3 posts in this topic

Recommended Posts

I've got a 100gb bootcamp partition with Windows 7 64-bit installed. I recently upgraded my 2010 iMac to a 2012 iMac. Specs: 27" Core i5, 768gb SSD. I was using rEFIt on the old one just fine. rEFIt is installed on the Macintosh HD, not EFI. On the new machine, it takes upwards of 2 minutes for the refit menu to appear. First I tried a repair permissions on the Mac HD. Then I did some googling and read about "blessing" the partition that refit was installed. I tried that, but now the refit menu doesn't come up at all. It does the same ~2 minute pause and then automatically boots to Windows or OS X (depending on which one I choose in the bootcamp manager before rebooting).


If I do a diskutil list in terminal, I get the following:



0: GUID_partition_scheme 751.3 GB

1: EFI 209.7 MB

2: Apple_HFS Macintosh HD 649.0 GB

3: Apple_Boot Recovery HD 650.0 MB

4: Microsoft Basic Data BOOTCAMP 101.4 GB


I have a feeling that something USB is causing the slowdown, but I need to at least get rEFIt back to working status before I test that theory. Does anyone have suggestions? Thanks!

Share this post

Link to post
Share on other sites

Found this other thread, http://www.insanelymac.com/forum/topic/199614-refit-reinstall-problem/page__hl__refit#entry1358281


It has a post by ludacrisvp that I will try next:


this is most likely caused by using the bootcamp selector from inside windows to reboot into osx, or from inside osx using the utility that chooses your boot device.

simple solution:

Never use the 2 methods above to reboot your system into the other OS unless you want to break rEFIt.

Always use Start --> shutdown/restart/hibernate/sleep whichever you need or Apple menu --> shutdown/restart/sleep.

To fix your rEFIt just go to the drive you installed it to (most likely Macintosh HD) and open the EFI folder and open the rEFIt folder and look for "enable-always.sh"

now open Terminal and drag and drop "enable-always.sh" into Terminal

Terminal will need your root password, enter it then reboot and you will see rEFIt.

Share this post

Link to post
Share on other sites

The instructions I provided in the post above fixed the issue of refit not showing up. I then discovered that the delay was only happening when my external hard drive is plugged in. I guess something is wrong with it...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.