Jump to content
InsanelyMac Forum
CodeRush

[UEFIPatch] UEFI patching utility

Recommended Posts

Hello

juste install mavericks 10.9 but i keep getting error panic kernel while booting

I need a PMPatch for my Asus z87 pro rev1 (bios 1602) i use cpu  I7 4470k

Thank you in advance

Share this post


Link to post
Share on other sites
Advertisement

@hih64:

 

Hi and welcome. Everything you need is in the first post.

Thank you very match

So i use the tool PMPatch and follow the tutorial ?

Share this post


Link to post
Share on other sites

@Arkanis:

 

I read your previous posts again and as far as I understand you cannot flash the modified BIOS? Try the method I described a few posts earlier (link).

To summarize: 1. Backup using fpt, 2. Patch with PMPatch, 3. Flash using fpt.

 

You can find more information about fpt in post #4.

 

EDIT: I'm not sure fpt will work with your board. If it doesn't, you can try using flashrom instead.

 

Kenny,

 

Thank you for your reply, very kind of you. I tried PMPatch already but this is the message I get :

 

PowerManagement module at 006cb690 not patched : Patch pattern not found.

PowerMgmtDxe/PowerManagement2.efi modules not found.

AMI nest modules not found.

Phoenix nets modules not found.

CpuPei module at 007c72b0 not patched: Patch pattern not found.

 

My firmware is AptioV I believe from AMI, I know the board isn't the standard one since the Z9PE-D8 WS is a dual Xeon CPU board. I know it's MSR 0xE2 locked since the Asus guy confirmed that.

 

I don't really know what to do next... :-/ and sadly I'm not enough well versed in binary coding to do this myself.

Share this post


Link to post
Share on other sites

@Arkanis:

 

I see, however CodeRush already made a patch for your BIOS. You can try to make a dump of your BIOS region and send it to me via PN to modify.

Share this post


Link to post
Share on other sites

K3nny:

Thank you for your help, do you want me to dump the bios portion usin the AMI tools ? Or FPT that you linked ? (I can try both in fact and send both if you want).

Thanks again, will send you the file in 30". sent !

A.

Share this post


Link to post
Share on other sites

Hello Again

Trying using pmpatch for my asus z87 pro 

 

pmpatch.png

 

reflash but still getting error kernel panic after first reboot instalation

any help would be great ?

Share this post


Link to post
Share on other sites

@terrybogard21:

 

Look at post #1365.

 

So from my understanding, I need to make a DOS bootable USB drive. Run FPT; run the first CMD line to backup my current bios & then run the second CMD line to upload the patched bios I got off CodeRush's site? This should allow me to run OSX without the NULLCPUmanagement issue correct?

 

Just seemed easier with FTK.

 

Edit: 

 

I assume I did things correctly. Have no way based on the guides to check. 

 

I made a DOS-Bootable drive. Copied the FPT DOS version over. Renamed the Patched Bios for my motherboard to bios.mod

Restart ~

ran the 1st command line

then ran the 2nd command line

waited for the FPT operation to finish. 

poweroff or any other commands didn't work so I did a simple restart

Prayed I didn't just ruin a bios.

System booted up with a bios number of 3903x64 down from 4101x64 that was the latest from ASUS. 

 

Guess the only next step is to try & install ML. 

 

Edit Edit:

 

I also noticed that I was also getting the same error the above poster was when trying to use PMPatch within Windows to patch my own bios. The method I was doing, was probably incorrect. 

Share this post


Link to post
Share on other sites

@terrybogard21:

I don't see any error. If you mean hih64's screenshot, the output is fine as stated in the first post.

 

@everyone else:

Read the first post carefully. Stick to the instructions provided by CodeRush in his opening post. Everything you need is described there.

Flashing with the /gan switch will bypass BIOS locks set by BLE bit and also descriptor region locks. FPT just makes things more complicated in this case.

Share this post


Link to post
Share on other sites

Any news about nvram ? I bought for fun Asus P8H77-M PRO and I have SPI :) Let me know and I can test it. I need to buy only a cheap CPU.

Share this post


Link to post
Share on other sites

@CodeRush

I may possess a notebook Toshiba C75 a 154, I need a bios mod Can you please help me?


Toshiba Satellite C75-A-154

Prozessor: Intel® Core™ i5

Prozessornummer: 4200M

Prozessorgeschwindigkeit: 2,5 GigahertzGrafikkartenhersteller: Intel®

Grafikkartentyp: HD Graphics 4600

Laufwerke: Slim DVD-Supermulti

There is an immediate reboot, and I do not even get to the installation.

 

http://uploaded.net/file/098ko11s

Share this post


Link to post
Share on other sites

@rus54:

What exactly do you need help with? The actual BIOS file can be found at the path I posted above. You can patch it using PMPatch and try to flash it using the tool in your archive.

If it doesn't work, refer to the first post where alternative methods are described.

Share this post


Link to post
Share on other sites

I've got an ASUS H87M-E - I've tried flashing with fpt.exe but I get an error when running the backup command:

Error 201: [FPT.exe] cannot be run on the current platform. Please contact your vendor.

Is this related to my motherboard or current BIOS or something else? Should I try an alternative method of flashing?

 

Thanks

Share this post


Link to post
Share on other sites

I've got an ASUS H87M-E - I've tried flashing with fpt.exe but I get an error when running the backup command:

Error 201: [FPT.exe] cannot be run on the current platform. Please contact your vendor.

Is this related to my motherboard or current BIOS or something else? Should I try an alternative method of flashing?

 

Thanks

 

you'll need intel fpt for series 8 ; )

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



  • Similar Content

    • By notacone
      These are the Original iMac17,1 Firmware 0105_B20 ACPI Tables.
      They have been extracted from the firmware file provided in 10.12.4 update, so they are clean and unloaded.
      All tables are available in hex cut/new file/paste order so they are untouched and unloaded.
      I believe these files can serve to better study Skylake architecture implementation in Sierra.
      10.12.4-10.12.6 : IM171_0105_B20-10.12.4.firmware update ACPI Tables.zip
      10.13.0+ : IM171_0110_B00 10.13.0GM ACPI Tables.zip
    • By partha.slg123
      Hackintosh High Sierra 10.13.3 USB Installer Boot Into USB DIrectly Enter Exit Option Menu. Clover Boot Menu Not Showing. Plz Help .................
       

       
      My System Specification :

      CPU : Core i5 6400
      MB : Asus H110M-CS
      RAM : 8GB DDR 4
      HDD : WD 1TB For Windows And WD 500 GB For Hackintosh
      Bootloader : Clover
    • By gorans
      Hi,
       
      after updating HS my WOL stopped working. It worked for sure in El Capitan, not sure in what version of HS stopped to work. I'm using Ozmosis as bootloader and IntelMausiEthernet (in S/L/E) for network. I created ssdt.aml with ssdtPRGen, and put it in EFI/Oz/Acpi/Load/.
      WOL is enabled in BIOS, wake for network access is checked
      pmset -g System-wide power settings: DestroyFVKeyOnStandby 0 Currently in use: standby 0 Sleep On Power Button 1 womp 1 hibernatefile /var/vm/sleepimage powernap 0 networkoversleep 1 disksleep 10 sleep 15 autopoweroffdelay 28800 hibernatemode 0 autopoweroff 0 ttyskeepawake 1 displaysleep 15 standbydelay 10800 If I put machine to sleep, WOL works for a short time, but not working if I let it sleep for a while.
       
      I deleted Ethernet in Network, rebooted and recreated it, but still the same.
       
      Hardware:
      MOBO:     Gigabyte Z97-D3H rev 1.1
      processor:    i5-4460 Haswell
      graphic:    Gigabyte GeForce GT 740 OC GDDR5 2GB (GV-N740D5OC-2GI)
      memory:    2 x 8GB Kingston
      disks:    Samsung SSD 850 EVO 120GB
              Seagate 2TB
              LG DVD±RW
      Sound:     VoodooHDA
      Network:    IntelMausiEthernet.kext
       
      Any advice?
       
      Best regards,
      Goran
    • By M3G4DR01D
      Hello everyone, I have an Asus gl502vmk (i7 kabylake + GTX 1060 6 gb) laptop and I tried all the patches/kexts to get the brightness with fn keys/touchpad (I2C ELAN 1200 works with VooDoo I2C kext v1.0 but no gestures/preference pane)/Keyboard backlight to work but no success so far, any help would be appreciated, thanks in advance.
      [EDIT] (10/04/2018)
      Battery status now works, thanks to @RehabMan turned out to be incorrect SMBIOS (used iMac instead of Mbp) lol, but it drains crazy fast (~1.5 - 2 hours while on standby (all apps quited!), on windows 10 it lasts 4 - 5 hours, and on linux it lasts 6 ~ 7 hours!)
      And with VoodooI2C v2.0.1 + VoodooI2CHID kext and patched DSDT, the touchpad is now detected in the sys pref pane but still no input.
      Sound works with VoodooHDA v2.9.1, but the only issue is that the jack sense isn't working (the output device doesn't auto switch to headphone when connected)
       
      [EDIT 2] (11/04/2018)
      The system brightness now works thanks to @onejay09 but I have no brightness slider, and there are 4 extra brightness levels (brightness stops increasing after 12 levels)  and the brightness keys are not mapped correctly, plus the brightness decreases when I plug in the ac adapter, then increases if I unplug it???, the brightness level isn't also saved after reboot.
      battery still drains crazy fast (~1.5 - 2 hours, even with brightness at 50%, so apparently it is a power management issue).
      and I also have shutdowns while in sleep mode (I tried darkwake=10 and darkwake-0 and darkwake=no)
       
      P.S. I have uploaded my new report files, thanks!
       
      Latest report files (11/04/2018): https://www95.zippyshare.com/v/AMOpP0AY/file.html
    • By liuhongxin1993
      ASUS X99-E-10G WS
      I76950X
      Request to optimize
      Sleep/Wake issues, CPU Power States


      origin.zip
      ioregMac Pro.zip
      config.plist
      kexts.zip
×