Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
fpolak

Help with HD3000 on mountain lion

21 posts in this topic

Recommended Posts

Hi,

 

I can't install HD3000 on my system, Everything works fine (audio, Network, sleep) but graphic card still working as 64mb of graphics shared memory!!! my setup is:

 

mobo GA-Z68MA-D2H-B3 rev 1.0 UEFI bios U1b

BIOS Settings - Set "Internal Graphics Memory Size" to 480MB

I5 2500k

HD3000 graphics

 

First I install moutain lion with MB method. Then I installed MB 5.1.3 with:

 

Drivers

Miscellaneous

FakeSMC

FakeSMC Plugins -> Motherboard Plugins, HWMonitor Application

 

Bootleader

Chimera v1.11.1

 

Customization

System Definitions

Mac mini

 

 

GraphicsEnabler=yes don´t boot. hangs system

GraphicsEnabler=no boot, but don´t recognize graphic card

 

What can be happening?

 

Please help!

Share this post


Link to post
Share on other sites
Advertisement

Hi,

 

I can't install HD3000 on my system, Everything works fine (audio, Network, sleep) but graphic card still working as 64mb of graphics shared memory!!! my setup is:

 

mobo GA-Z68MA-D2H-B3 rev 1.0 UEFI bios U1b

BIOS Settings - Set "Internal Graphics Memory Size" to 480MB

I5 2500k

HD3000 graphics

 

First I install moutain lion with MB method. Then I installed MB 5.1.3 with:

 

Drivers

Miscellaneous

FakeSMC

FakeSMC Plugins -> Motherboard Plugins, HWMonitor Application

 

Bootleader

Chimera v1.11.1

 

Customization

System Definitions

Mac mini

 

 

GraphicsEnabler=yes don´t boot. hangs system

GraphicsEnabler=no boot, but don´t recognize graphic card

 

What can be happening?

 

Please help!

Try to injext your HD3000 with dsdt or make a string for it with gfxutil and boot in all this cases with GE=no.

 

Have fun.

Share this post


Link to post
Share on other sites

SMBios 8,1 or 8,3 ?

 

Macmini 5,1.

 

Would I try macbookpro 8,1 or 8,3?

 

Try to injext your HD3000 with dsdt or make a string for it with gfxutil and boot in all this cases with GE=no.

 

Have fun.

 

I have UEFI bios, I don't uses DSDT.

 

how can i make this string?

Share this post


Link to post
Share on other sites

try MacMini 5,1 (no kext modifications) and add this to your bootlist file

 

 

<key>device-properties</key
<string>a602000001000000010000009a0200000e00000002010c00d041030a000000000101060000027fff04000e0000006e0061006d00650000000c000000646973706c6179001e0000004100410050004c002c006f0073002d0069006e0066006f0000001800000030490112121208000001f01f01000000100700001a00000063006f006d00700061007400690062006c00650000002d000000706369313034332c3834346400706369383038362c31323600706369636c6173732c30333030303000100000006d006f00640065006c0000001b000000496e74656c204844204772617068696373203330303000140000006800640061002d0067006600780000000e0000006f6e626f6172642d3100200000004100410050004c002c00740062006c002d0069006e0066006f00000016000000304402020202000000000202020201010101240000004100410050004c002c0069006f006b00690074002d006e0064007200760000000c000000206d99807fffffff1a00000063006c006100730073002d0063006f0064006500000008000000000003000c00000072006500670000005400000000100000000000000000000000000000000000001010000200000000000000000000000000004000181000420000000000000000000000000000001020100001000000000000000000000000400000001600000070006300690064006500620075006700000009000000303a323a30160000006200750069006c0074002d0069006e0000000500000000220000004100410050004c002c0067007200610079002d00700061006700650000000800000001000000240000004100410050004c002c0067007200610079002d00760061006c0075006500000008000000c38c6400180000006400650076006900630065002d006900640000000800000026010000</string>

 

SOURCE: http://www.insanelymac.com/forum/topic/282631-hd3000-other-card-solution-by-efi-string-creation/

Share this post


Link to post
Share on other sites

SMBios 8,1 or 8,3 are for Core I5 or I7 with Sandy Bridge architecture where it has integrated HD3000 GPU.

 

Your I5 2500K should work natively with ML 10.8.2

Share this post


Link to post
Share on other sites

Finally my mac works with full resolution, but without QE/CI.

 

The method is describe below:

 

1. Delete all graphics kexts (AppleIntelHD3000, AppleIntelHD4000, AppleIntelHDGraphics, NVIDIA, ATI, GeForce, Natit, NVDAGF100Hal, NVDAResman) etc.

 

2. Repair permissions, rebuild cache (use kext wizard).

 

3. Install attached kexts. https://www.dropbox.com/s/v3ybzzh2snb6wcs/HD3000.zip

 

4. Repair permissions, rebuild cache (use kext wizard).

 

5. Restart.

 

 

Mac recognized HD3000 as 512mb VRAM instead of just 384mb configured in bios. Now I'm working with 1366x768 resolution, dvd player works, Diablo III works with full resolution, but I don't have desktop's icons animated.

 

Anyone got similar issues?

Share this post


Link to post
Share on other sites

Finally my mac works with full resolution, but without QE/CI.

 

 

Wat's your id card in system profiler ?

Share this post


Link to post
Share on other sites

Wat's your id card in system profiler ?

 

Mac recognized HD3000 as "Intel HD Graphics 512 MB" instead of just 384mb configured in bios.

Share this post


Link to post
Share on other sites

Mac recognized HD3000 as "Intel HD Graphics 512 MB" instead of just 384mb configured in bios.

 

Your id card it's a number under system profiler

Share this post


Link to post
Share on other sites

SMBios 8,1 or 8,3 are for Core I5 or I7 with Sandy Bridge architecture where it has integrated HD3000 GPU.

 

Your I5 2500K should work natively with ML 10.8.2

 

When trying to make the Intel HD 3000 work with QE/CI, should I be using SMBios 8,1 or 8,3 when my CPU is Intel Core i3 2328M?

 

"The i3-2328M offers an integrated graphics card (Intel HD Graphics 3000) which is clearly faster then the older Intel HD Graphics in the Arrandale CPUs. As the new GPU is included in the CPU, it is also manufactured in 32nm and shares the fast level 3 cache with the CPU cores (using a new ring bus)."

http://http://www.notebookcheck.net/Intel-Core-i3-2328M-Notebook-Processor.81502.0.html

Share this post


Link to post
Share on other sites

i think with i3 cpu 2xxx integrated video is a hd2000 with i5 hd3000 and i7 hd4000 this is my supposed

 

my experience is with i5 laptop and work full like hd3000, with i3 desktop and i can't enable qe/ci but only proper resolution like hd2000

Share this post


Link to post
Share on other sites

i think with i3 cpu 2xxx integrated video is a hd2000 with i5 hd3000 and i7 hd4000 this is my supposed

 

my experience is with i5 laptop and work full like hd3000, with i3 desktop and i can't enable qe/ci but only proper resolution like hd2000

 

ok! I can guarantee you I have i3 cpu 2328m and Intel HD 3000, definitely not hd 2000.

 

Wondering if there's anything else I can do to try make this QE/CI work... Been trouble shooting a week now :)

 

Any possible tips that I could try appreciated! DSDT I had no luck with, keeps kernel panicing... will take picture n post here!

Share this post


Link to post
Share on other sites

Hi everyone.

 

Im actually stuck with my hd 3000

 

I succefuled installed iAKTOS ML 2 but it wont boot because of hd 3000..

 

 

I have an HD 7770 But it wont work ok 10.8.2..

 

 

How can i boot with this hd 3000 without downloading thing because i formated my windows partition and i cant founf one until wednesday :/

 

Sorry for my english :/

Share this post


Link to post
Share on other sites

Intell HD3000 fully working with enabled QE/CI - Mountain Lion 10.8.5

 

After installing Mountain Lion on my laptop I had problem with HD3000 which was recognised as intel HD3000 but with 64 MB shared memory without QE/CI.
I want to share with others who have the same problem, how managed to make Intel HD3000 Graphics Card work fully on my laptop.
I am a simple user and I managed to do it following informations from the Internet.
Thanks to all that posted guides, instructions, kexts, tools etc and sorry for my poor English.

 

There is a folder attached with instructions, neccesary kexts and tools needed.  

 

Do not extract  attached zip folder - files in Windows OS. I found out that Info.plist were destroyed. Do it in Mac OSX environment aft.er installation of the basic system

Specifications of  my laptop:
Clevo W550EU
Intel 7 Series Chipset AHCI Sandy Bridge
CPU i3 2328M 2.2Ghz
Intel HD3000 built in Ven:8086 Dev:0116 Rev 9
DISPLAY 1366x768
WLAN Realtek RTL8723BE  (not working must be replaced)
LAN Realtek RTL8168 working
CAMERA Chicony USB 2.0 working
AUDIO VIA High Definition Ven: 1106 Dev: 8446 working with VoodooHDA 2.8.2 kext
KEYBOARD Typical PS/2 TouchPad Synaptics PS/2 working
CARD READER Realtek (don't kow if it's working)

BIOS American Megatrends Aptio Setup Utility version 2.15.1226/2012
For installation all BIOS options were disabled except AHCI which was enabled.

> I used Niresh Mountain Lion 10.8.5 iso burned in DVD with IMGBurn in Win 7.
I Know that iAtkos ML2 1.8.2 can be used with the same outcome for HD3000 (for audio,LAN,CAMERA I don't know)
(If someone want to use a Bootable USB it must be created in Mac OSX. See instructions in attached file).

 

Install options:
Chameleon, MacBookPro 8.1 SMBIOS, Disabler, Fixed Kexts, NullPowerManagement, Fake SMC, CMOS Reset Fix, PS/2, AppleRTC Patch for 10.8
At the end of installation I saw the message "Install Failed" and I repeated installation. It took me 3-4 times to succeed.  (In case of installation failure use some flags as  -v npci=0x2000, PCIRootUID=1, buratio=20 or 17 or 14). With iAtkos ML2 I didn't have that problem.

 

After successful installation  I rebooted with DVD I used for installation.
> I opened Terminal and removed the following kexts from Extensions:
AppleeIntelSNBFramebufferFB.kext (which is the main kext that had to be removed to boot in Mountain Lion) and all AppleIntelHD*.
rm -R /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions/AppleIntelSNBFramebufferFB.kext  and
rm -r /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions/AppleIntelHD*
Repaired permissions with:
chown -R root:wheel /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions
chmod -R 755 /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions
Removed cache (if there is one) with:
rm -R /Volumes/Name of the partition installed 10.8.5/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
 

> Then I rebooted to the installed Mountain Lion 10.8.5.
Used Kext Wizard and installed HD3000*.kexts and AppleIntelSNBFramebufferFB.kext.
(find them in attached inside the folder with the name "HD3000_ML10.8.2Pack.zip").
Repaired permissions and removed caches using OSXTools.
Next I edited (with TextEdit) org.chameleon.Boot.plist in the Extra folder.
Added the following:
<key>Graphics Mode</key>
<string>1366x768x32 or whatever  your display native resolution is</string>
(Do not use the option GraphicsEnabler=Yes).
> I rebooted to Mountain Lion.
In Terminal  I run the DSDTExtract.command (which is inside the folder with the same name, following the instructions which are in the same folder also).
A dsdt.aml file created on my desktop.
[Make a copy of your dsdt and rename it as you like (for example dsdtoriginal.aml)].
Opened dsdt.aml with MaciASL.
Pressed the button "Compile". Then the button "patch" and next the button "open".
Selected  from the folder "Patces Laptop-DSDT-Patch-master", subfolder "graphics" the file "graphics_HD3K_low.txt"(Select it if you have resolution until 1366x768 or select "graphics_HD3K_high.txt if you have higher resolutions).
Pressed Apply and saved dsdt file in Extra folder.

 

Rebooted and had HD3000 fully working recognised as Intel HD3000 384 MB, transparent menu, working video DVD, working QuickTime video etc.

 

I wish to you success.
 

Mountain Lion 10.8.5 HD3000 kexts utilities instructions.zip

Share this post


Link to post
Share on other sites

Intell HD3000 fully working with enabled QE/CI - Mountain Lion 10.8.5

 

After installing Mountain Lion on my laptop I had problem with HD3000 which was recognised as intel HD3000 but with 64 MB shared memory without QE/CI.

I want to share with others who have the same problem, how managed to make Intel HD3000 Graphics Card work fully on my laptop.

I am a simple user and I managed to do it following informations from the Internet.

Thanks to all that posted guides, instructions, kexts, tools etc and sorry for my poor English.

 

There is a folder attached with instructions, neccesary kexts and tools needed.  

 

Do not extract  attached zip folder - files in Windows OS. I found out that Info.plist were destroyed. Do it in Mac OSX environment aft.er installation of the basic system

 

Specifications of  my laptop:

Clevo W550EU

Intel 7 Series Chipset AHCI Sandy Bridge

CPU i3 2328M 2.2Ghz

Intel HD3000 built in Ven:8086 Dev:0116 Rev 9

DISPLAY 1366x768

WLAN Realtek RTL8723BE  (not working must be replaced)

LAN Realtek RTL8168 working

CAMERA Chicony USB 2.0 working

AUDIO VIA High Definition Ven: 1106 Dev: 8446 working with VoodooHDA 2.8.2 kext

KEYBOARD Typical PS/2 TouchPad Synaptics PS/2 working

CARD READER Realtek (don't kow if it's working)

 

BIOS American Megatrends Aptio Setup Utility version 2.15.1226/2012

For installation all BIOS options were disabled except AHCI which was enabled.

 

> I used Niresh Mountain Lion 10.8.5 iso burned in DVD with IMGBurn in Win 7.

I Know that iAtkos ML2 1.8.2 can be used with the same outcome for HD3000 (for audio,LAN,CAMERA I don't know)

(If someone want to use a Bootable USB it must be created in Mac OSX. See instructions in attached file).

 

Install options:

Chameleon, MacBookPro 8.1 SMBIOS, Disabler, Fixed Kexts, NullPowerManagement, Fake SMC, CMOS Reset Fix, PS/2, AppleRTC Patch for 10.8

At the end of installation I saw the message "Install Failed" and I repeated installation. It took me 3-4 times to succeed.  (In case of installation failure use some flags as  -v npci=0x2000, PCIRootUID=1, buratio=20 or 17 or 14). With iAtkos ML2 I didn't have that problem.

 

After successful installation  I rebooted with DVD I used for installation.

> I opened Terminal and removed the following kexts from Extensions:

AppleeIntelSNBFramebufferFB.kext (which is the main kext that had to be removed to boot in Mountain Lion) and all AppleIntelHD*.

rm -R /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions/AppleIntelSNBFramebufferFB.kext  and

rm -r /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions/AppleIntelHD*

Repaired permissions with:

chown -R root:wheel /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions

chmod -R 755 /Volumes/Name of the partition installed 10.8.5/System/Library/Extensions

Removed cache (if there is one) with:

rm -R /Volumes/Name of the partition installed 10.8.5/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache

 

> Then I rebooted to the installed Mountain Lion 10.8.5.

Used Kext Wizard and installed HD3000*.kexts and AppleIntelSNBFramebufferFB.kext.

(find them in attached inside the folder with the name "HD3000_ML10.8.2Pack.zip").

Repaired permissions and removed caches using OSXTools.

Next I edited (with TextEdit) org.chameleon.Boot.plist in the Extra folder.

Added the following:

<key>Graphics Mode</key>

<string>1366x768x32 or whatever  your display native resolution is</string>

(Do not use the option GraphicsEnabler=Yes).

> I rebooted to Mountain Lion.

In Terminal  I run the DSDTExtract.command (which is inside the folder with the same name, following the instructions which are in the same folder also).

A dsdt.aml file created on my desktop.

[Make a copy of your dsdt and rename it as you like (for example dsdtoriginal.aml)].

Opened dsdt.aml with MaciASL.

Pressed the button "Compile". Then the button "patch" and next the button "open".

Selected  from the folder "Patces Laptop-DSDT-Patch-master", subfolder "graphics" the file "graphics_HD3K_low.txt"(Select it if you have resolution until 1366x768 or select "graphics_HD3K_high.txt if you have higher resolutions).

Pressed Apply and saved dsdt file in Extra folder.

 

Rebooted and had HD3000 fully working recognised as Intel HD3000 384 MB, transparent menu, working video DVD, working QuickTime video etc.

 

I wish to you success.

 

attachicon.gifMountain Lion 10.8.5 HD3000 kexts utilities instructions.zip

 

Hello kanelip,

 

I have a clevo w550eu, and I want to install OS X.

 

Do you have a tuto ? What did you installed ?

 

Thanks a lot :)

 

Carmelo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×