Jump to content
InsanelyMac Forum

Recommended Posts

Hi all,

 

I have tried a lot of stuff in order to delete my windows partition and expand the HFS+ partition but so far nothing has worked. I've attached a screenshot of the whole SSD.

 

I disabled Journalling, tried using clonezilla but it wouldn't clone the image to a larger partition. I tried GParted but after deleting all the windows partitions it wouldn't resize the actual HFS+ partition, so I never applied it.

 

Right now my idea is using Carbon Copy Cloner, so I cloned it to a GUID Mac partition of a HDD, but no luck booting from it. I attached the partition table for that. Perhaps I need a dedicated hard drive. I was going to format the SSD and CCC back to it. I had the idea to try and use iPartition from my OSX install USB but don't know how to add apps to it.

 

Would appreciate any pointers!!

 

Thanks,

 

7L

post-1096447-0-40225300-1357151768_thumb.png

post-1096447-0-99657600-1357152016_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

for boot your clone Partition reinstall the boot loader, now boot with your clone and use DiskUtility for it

Share this post


Link to post
Share on other sites

I tried reinstalling the bootloader to that partition both manually with terminal and with the installer.

All I get when booting is:

 

boot0: GPT

boot0: testing

boot0: error

 

It is a 3tb drive and I'm using the 3rd partition.

 

Thanks for any help

Share this post


Link to post
Share on other sites

ok, this is the second option for install it, download binarios chameleon folder i386

1. open the folder i386 and copy boot1h for your USBInstaller.

2. boot from USBinstaller and go for utilities and open app Terminal

3. type diskutil list for identified your disk and partition were you installed of system ML = "(i.e: disk0s2)"

4. type diskutil unmount disk0s2

5. type cd /

6. type dd if=boot1h of=/dev/disk0s2 bs=4096

7. reboot

in steep 6 put your disk and partition "(i.e disk0s2 "), see your

Share this post


Link to post
Share on other sites

That only differed to my method with 'bs=4096' so I tried the commands within OSX first, got boot0 error again, then I followed your instructions to the letter with the USB - dd'd boot1h to disk2s3, and still no luck. :|

 

Thanks for your suggestions

Share this post


Link to post
Share on other sites

I solved this by backing up an old USB HDD, formatting it as GUID Mac OS Extended, CCC my OS to it, installing Chameleon, booting off it (So very slow! USB 2.0 2.5 inch), and CCC back to reformatted SSD and reinstalling bootloader. Works like a charm.

 

Thanks for trying to help me, but for some reason could not get a partition of a 3TB HDD to boot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×