Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sinetek

Snow Leopard kernel testing on AMD

157 posts in this topic

Recommended Posts

Had the same problem (Also have a 1055T), TSC Sync problem. You can either create a DSDT override (I can't help you with that as I have no clue myself, I will get around to it as some people say it is easy), or the easiest! Load the VoodooTSCSync.kext (I used the one from iAtkos ML2 as others I've used in the pass have killed my setup untill I delete them). To load it drag into Kext Utility, both can be found here https://www.dropbox....clrr/d0HJeoqABI

 

Thank you :) do i have to remove any other kexts or change my kernel boot options?If i use this kext will i be able to boot cpus=6 ?

I will use it,i have learned how to create dsdt files in the past,now system runs ok,audio is fine,gfx is fine,usb ports work,dvd recorder,but i have to fix the cpu stuff.I am not home now but when i go i will try to install it,then i will do repair permissions

 

First set a Password on your account if you do not have one already set.

 

Download

"amd_insn_patcher"

Find it here: http://cl.ly/2e1H2S0g352K0q2l170M

 

extract it to the desktop,

 

Then click on spotlight (the magnify glass on the top right)

Type: "terminal"

 

With terminal open type "sudo"

 

Drag "amd_insn_patcher" to terminal, the find the following

 

/System/Library/QuickTime/

QuickTimeComponents.component

(Right Click and click Show Package Contents)

/Contents/MacOS/

Drag "QuickTimeComponents" to terminal TWICE and press enter, then type your password.

 

then type sudo again, Drag "amd_insn_patcher" to terminal, the find the following

/usr/lib/

Drag "libSystem.B.dylib" to terminal TWICE and press enter.

 

then type sudo again, Drag "amd_insn_patcher" to terminal, the find the following

/usr/lib/

Drag "dyld to terminal TWICE and press enter.

 

The folder "usr" will be hidden so alternatively you can do this.

 

Open terminal and change to the directory that contains the files from the zip to the desktop like so:

cd Desktop/amd_insn_patcher/

 

Now type the following (or copy and paste in terminal, to paste in terminal right click in the terminal windows and press paste)

 

sudo ./amd_insn_patcher /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents

 

Press Enter

Type in your password.

 

sudo ./amd_insn_patcher /usr/lib/libSystem.B.dylib /usr/lib/libSystem.B.dylib

 

Press Enter

sudo ./amd_insn_patcher /usr/lib/dyld /usr/lib/dyld

 

Press Enter

 

 

 

Are you booting with -force64? what kernel are you using in the legacy range (i.e: nawcom 10.6.8 legacy_kernel)

 

I have tried this with legacy kernel and this one posted on this thread both in 32 bit mode,on -force64 mode and on arch=x86_64 there must be something wrong for some computers because as soon as dyld is patched system is destroyed there is an illegal instruction,and the i cant do anything if i reboot system kernel panics and i cant fix and i have to reinstall,

 

how are you patching those files?I definetely followed all tutorials correctly and used the terminal commands correct.I cannot finish the commands because as soon as dyld is patched then whatever i paste after it says illegal instructions,i checked forums and many people have problem with this.Can someone help?

 

I haven't used marvin's amd utility after installing the mac and updating to 10.6.8

what i did was install 10.6.2 update to 10.6.8 install legacy kernel apply fixes and rollback usb kext.Managed to boot with legacy kernel and with this one on the thread with options arch=i386 ,or arch=x86_64 (only for the one on this thread other kp) and arch=i386 -force64 for legacy kernel.

Did NOT use marvin amd at all,and i believe dyld files and other system files are not patched or changed.

Share this post


Link to post
Share on other sites

Thank you :) do i have to remove any other kexts or change my kernel boot options?If i use this kext will i be able to boot cpus=6 ?

I will use it,i have learned how to create dsdt files in the past,now system runs ok,audio is fine,gfx is fine,usb ports work,dvd recorder,but i have to fix the cpu stuff.I am not home now but when i go i will try to install it,then i will do repair permissions

 

No need to boot with any cpus kernel flag, download both, drag voodootsc to kext utility and it will install and repair all for you, BUT you can do it in a DSDT override which is better, but try the kext way first.

 

As the patching, it's so strange. Maybe later i'll upload my version of the insn patcher

Share this post


Link to post
Share on other sites

about dyld and libSystem.B.dylib patching:

 

each time you copypaste any line into a terminal, first of all: read the sentence, and read what that program do in the manual

"man nameoftheprogram"

or "nameoftheprogram --help"

this will let you think about what its happening, and what can be the problem if something goes wrong.

 

__what you have to do is to make system use one files (patched) instead of other files (original)__

 

first of all , lets go to directory /usr/lib with a tool named "cd", wich means "change directory"

you can always check where you are with a tool named "pwd", wich means "print working directory"

 

lets see what files are here wih "ls" aka list. you will see a lot of lines.

you can pass this output to another tools like "grep" "head" "tail" "less" "more" ... with whis character | a.k.a. the vertical bar.

there are other modifiers like > < see your terminal (usually bash or sh) documentation for more-

for example type "ls | less" as command. now you are creating something like a pipe between "ls" and "less".

for more interesting options see "man ls" or "ls --help" and "man grep" for example.

 

after we know thaw we have to deal with 2 specific system files (the system will look for that specific names), lets see it a bit more:

"ls -l dyld" -l modifier shows more information, but you will see only dyld. if you put dyld? (with and interrogation) you will see dyld with any following character. if you put dyld* you will see dyld with any following string.

 

at this point you should have seen those two files. lets make a copy of them just in case something goes wrong. here you can use the "cp" tool, wich means copy. here it is an example first of all, read "man cp" and then "cp dyld dyld.original" do the same with the other file you want to patch.

 

now we have to apply some threatment to those original files. the threatment program is "amd_insn_patcher" it has no helpful documentation, but i can tell you that it works like this "amd_insn_patcher inputfile outputfile", reads from inputfile and writes to outputfile. for example, "amd_insn_patcher dyld.original dyld.patched"

 

since original and patched files will be almost the same in size, we will use a tool that sums all zeroes and ones (that of course will be different). some of this tools are "md5" and "shasum". "md5 dyld*" will let you identify according to whats inside, despite they have the same size!

 

please check that permissions are the same (ls -la dyld*) as the originals. if not, you can fix this with "chmod" "chown" "chgrp". again, man chmod, man chgrp, ...

since everything has been done as root, i hope they are the same. if you are not sure, do a permissions repair after all of this.

 

when you did a full list of directory items (ls -la) you can notice files that has for example "libsomething -> libsomething.123456789"

libsomething is a link to libsomething.123456789. the system will check for "libsomething", and the filesystem will point to his corresponding. links are very useful as you see!

so, i will use the same technique, with a tool named "ln" with means link. again, read "man ln" and "ln --help" to see the possible modifiers. i will help you here: you have to create symbolic links: here it is an example

 

"ln -vis dyld.original dyld" will create a link named "dyld" that points to "dyld.original"

you can change to patched ones if you are brave enough. do the same with libSys.B...

 

in a post i wrote the other day (the one with a KP photo) there are some outputs i copied, you can use to compare. except for permissions (i have something wrong here... my fault) outputs will be similar.

 

well, i hope somebody learns something new.

remember after altering those important system files, to do an "update_dyld_shared_cache -force"

 

edit: you can type "man man" too to read the manual of the manual.

Edited by bcobco

Share this post


Link to post
Share on other sites

@bcobco

 

Awesome work explaining the terminal commands and swapping out (I remember you had to do this on the legacy_kernel to swap as mach_kernel to get VMWare Fusion working)

 

@nikosd

 

I'm gonna PM you as to not grow this thread any bigger and maybe working together we can push out a start to finish tutorial with patching and so on. (@Deltac0's tutorial on the previous pages works!)

Share this post


Link to post
Share on other sites

I am facing the stupidest issues , have installed n number of times but either I cannot go further than "transfer from a mac" screen or after all installation it either reboots. I have used SL 10.6.8 with Nawcom legacy kernel on the same system except I had a HD 5450 earlier but now it has gone kaput and I cannot use my other card the HD 7750 in SL , because of that I went and bought the Asus EN210 1GB. I think I am facing those problems because of this card. Once setup the system will run smooth but after a day or two the system will start giving problems and now I cannot even boot into my Lion partition it just reboots after saying "Header Size Incorrect " damn I have to reinstall SL and LION all over again.

 

I did try Sinetek PP kernel but that used to sit at USBF: :(.

 

Let me install everything all over.

Share this post


Link to post
Share on other sites

I have not managed to boot with cpus=6 but only cpus=5 for some reason even with the kext provided by Duran,system only wants to see up to 5 cores not the 6 one.

The kernel flags i use is "legacy_kernel arch=i386 maxmem=4096 cpus=5 -force64 gfxenabler=yes" ,now i am going to try the same kernel flags with the kernel provided on this thread and post,it seems strange to me to have waiting for root device if i have cpus=6 has anybody seen something like this before?

 

EDIT

Same thing happens with the kernel of this thread.Cpus=5 works cpus=6 goes to still waiting for root device.

Share this post


Link to post
Share on other sites

about dyld and libSystem.B.dylib patching:

 

each time you copypaste any line into a terminal, first of all: read the sentence, and read what that program do in the manual

"man nameoftheprogram"

or "nameoftheprogram --help"

this will let you think about what its happening, and what can be the problem if something goes wrong.

 

__what you have to do is to make system use one files (patched) instead of other files (original)__

 

first of all , lets go to directory /usr/lib with a tool named "cd", wich means "change directory"

you can always check where you are with a tool named "pwd", wich means "print working directory"

 

lets see what files are here wih "ls" aka list. you will see a lot of lines.

you can pass this output to another tools like "grep" "head" "tail" "less" "more" ... with whis character | a.k.a. the vertical bar.

there are other modifiers like > < see your terminal (usually bash or sh) documentation for more-

for example type "ls | less" as command. now you are creating something like a pipe between "ls" and "less".

for more interesting options see "man ls" or "ls --help" and "man grep" for example.

 

after we know thaw we have to deal with 2 specific system files (the system will look for that specific names), lets see it a bit more:

"ls -l dyld" -l modifier shows more information, but you will see only dyld. if you put dyld? (with and interrogation) you will see dyld with any following character. if you put dyld* you will see dyld with any following string.

 

at this point you should have seen those two files. lets make a copy of them just in case something goes wrong. here you can use the "cp" tool, wich means copy. here it is an example first of all, read "man cp" and then "cp dyld dyld.original" do the same with the other file you want to patch.

 

now we have to apply some threatment to those original files. the threatment program is "amd_insn_patcher" it has no helpful documentation, but i can tell you that it works like this "amd_insn_patcher inputfile outputfile", reads from inputfile and writes to outputfile. for example, "amd_insn_patcher dyld.original dyld.patched"

 

since original and patched files will be almost the same in size, we will use a tool that sums all zeroes and ones (that of course will be different). some of this tools are "md5" and "shasum". "md5 dyld*" will let you identify according to whats inside, despite they have the same size!

 

please check that permissions are the same (ls -la dyld*) as the originals. if not, you can fix this with "chmod" "chown" "chgrp". again, man chmod, man chgrp, ...

since everything has been done as root, i hope they are the same. if you are not sure, do a permissions repair after all of this.

 

when you did a full list of directory items (ls -la) you can notice files that has for example "libsomething -> libsomething.123456789"

libsomething is a link to libsomething.123456789. the system will check for "libsomething", and the filesystem will point to his corresponding. links are very useful as you see!

so, i will use the same technique, with a tool named "ln" with means link. again, read "man ln" and "ln --help" to see the possible modifiers. i will help you here: you have to create symbolic links: here it is an example

 

"ln -vis dyld.original dyld" will create a link named "dyld" that points to "dyld.original"

you can change to patched ones if you are brave enough. do the same with libSys.B...

 

in a post i wrote the other day (the one with a KP photo) there are some outputs i copied, you can use to compare. except for permissions (i have something wrong here... my fault) outputs will be similar.

 

well, i hope somebody learns something new.

remember after altering those important system files, to do an "update_dyld_shared_cache -force"

 

edit: you can type "man man" too to read the manual of the manual.

 

Thank you for this it should help all users having problems :) well i have installed linux,freebsd,unix and other stuff,i am not so much of a newbie,i know how to use the terminal,i use the sudo command correctly ,the amd patcher is copied to the usr/bin to have it in path now if i go to do this

1) sudo -s

2)amd_insn_patcher /usr/lib/libSystem.B.dylib /usr/lib/libSystem.B.dylib.patched

3)mv /usr/lib/libSystem.B.dylib.patched /usr/lib/libSystem.B.dylib

4)amd_insn_patcher /usr/lib/dyld /usr/lib/dyld.patched ------->after i do this i get illegal instruction

and so i cant go on and do this

mv /usr/lib/dyld.patched /usr/lib/dyld

 

I tried to boot and use the patcher with kernel options arch=i386 -force64 and arch=x86_64 result is the same,and system is destroyed,i have read that other people have this problem.Could you understand what is wrong and why is the illegal instruction?I would not risk to do it again,it has destroyed my system at least 4 times,right now i use the legacy kernel with arch=i386 -force64 and is very good.Also the 64 bit kernel on the thread works but does not load 32bit apps unless patched.

Is there something else i could do to patch it?Maybe this happens because dyld can't be patched while it is being used by the system?I copied dyld to another place and managed to patch it,but how do i insert the patched dyld file in to the system and tell it to use this?If i try with mv commands then probably i will destroy the system again,i am scared to do it. :(

Thank you :)

Edit:some people posted here the same with illegal instruction http://www.osx86.net/amd-processors/13063-how-patch-amd-amd_insn_patcher-apps-will-work.html

Share this post


Link to post
Share on other sites

have used two kernels one from this thread,and another one the legacy v2 kernel,both work in i386 and the thread kernel also in arch=x86_64,i have not patched anything with the amd marvin utiliity.Am i supposed to patch if applications work ok without it?Marvin utility does not run on arch=x86_64 at all.

Is it needed ?I didn't find info as to use it always to patch any executable,the amd_insn_patcher on the other had is it always needed?Most of the applications i tried work without patches.

 

I understand that in order to have arch=x86_64 and run 32bit applications i need to patch.But if i use arch=i386 -force64 i can run 64bit and 32 bit applications.

What is the difference?

Share this post


Link to post
Share on other sites

have used two kernels one from this thread,and another one the legacy v2 kernel,both work in i386 and the thread kernel also in arch=x86_64,i have not patched anything with the amd marvin utiliity.Am i supposed to patch if applications work ok without it?Marvin utility does not run on arch=x86_64 at all.

Is it needed ?I didn't find info as to use it always to patch any executable,the amd_insn_patcher on the other had is it always needed?Most of the applications i tried work without patches.

 

I understand that in order to have arch=x86_64 and run 32bit applications i need to patch.But if i use arch=i386 -force64 i can run 64bit and 32 bit applications.

What is the difference?

 

Marvin AMD is not needed, and i386 is a 32bit kernel, running -force64 still uses a 32bit kernel in a 64bit user land, meaning that it is not true 64bit.

So wait you are booting into arch=x86_64? I'm not correct about this and would have to confirm but, I'm sure that means your files are patched, which I know the nawcom did on the fly patching. If you have more then 4gb of ram can you boot without maxmem and it sees all your ram with arch=i386?

Share this post


Link to post
Share on other sites

Marvin AMD is not needed, and i386 is a 32bit kernel, running -force64 still uses a 32bit kernel in a 64bit user land, meaning that it is not true 64bit.

So wait you are booting into arch=x86_64? I'm not correct about this and would have to confirm but, I'm sure that means your files are patched, which I know the nawcom did on the fly patching. If you have more then 4gb of ram can you boot without maxmem and it sees all your ram with arch=i386?

I can boot with arch=x86_64 only with the kernel provided in this thread.Also i experiance random lockups ,with no reason,what should i patch?For some reason,system crashes,where should i look at log files?crash happen randomly on the arch=i386 -force64 it seems random ,after 10-15 or an hour.

Please help :)With the kernel provided on this thread i cannot run 32bit applications only native 64bit ones.I read that then i need to patch,dyld and other files

Share this post


Link to post
Share on other sites

I can boot with arch=x86_64 only with the kernel provided in this thread.Also i experiance random lockups ,with no reason,what should i patch?For some reason,system crashes,where should i look at log files?crash happen randomly on the arch=i386 -force64 it seems random ,after 10-15 or an hour.

Please help :)With the kernel provided on this thread i cannot run 32bit applications only native 64bit ones.I read that then i need to patch,dyld and other files

 

Give me an hour, gonna reinstall Snow Leopard and see if I can try reproduce the errors your are having.

What 32-bit Apps are you trying to run?

 

You should use Time Machine on your system before patching, that way if something fails you can restore it.

Share this post


Link to post
Share on other sites

Give me an hour, gonna reinstall Snow Leopard and see if I can try reproduce the errors your are having.

What 32-bit Apps are you trying to run?

 

You should use Time Machine on your system before patching, that way if something fails you can restore it.

IN arch=x86_64 i cant run 32bit applications,they all quit with error,on arch=i386 -force64 i run 64bit applications.

The crashes appear to be random,i played limbo game for 2 hours straight with no crash,but ran monkey island and it crashed suddenly the screen froze,other times the system may simply crash when going to a menu in firefox,now it is open for half hour with no crash... :S

Share this post


Link to post
Share on other sites

IN arch=x86_64 i cant run 32bit applications,they all quit with error,on arch=i386 -force64 i run 64bit applications.

The crashes appear to be random,i played limbo game for 2 hours straight with no crash,but ran monkey island and it crashed suddenly the screen froze,other times the system may simply crash when going to a menu in firefox,now it is open for half hour with no crash... :S

 

Ok so I reinstalled,

(This Step Not Important)

Used Nawcom MODCD, Swapped in with a Retail, Installed, Rebooted with ModCD to desktop.

 

Changed my time to 2011, Updated to 10.6.8 from 10.6.3, Installed Legacy Kernel 10.6.8v2, Ran Kext Utility to repair my permissions and Install VoodooTSCSync kext.

 

Rebooted with -force64

Copied "amd_insn_patcher" folder to the desktop,

Went to spotlight, typed terminal.

 

Last login: Mon Feb 11 15:18:50 on console
Duran-Keeleys-Mac:~ durankeeley$ cd Desktop/amd_insn_patcher/
Duran-Keeleys-Mac:amd_insn_patcher durankeeley$ ls
amd_insn_patcher amd_insn_patcher_ext
Duran-Keeleys-Mac:amd_insn_patcher durankeeley$ sudo ./amd_insn_patcher /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files. Please double-check your
typing when using sudo. Type "man sudo" for more information.
To proceed, enter your password, or type Ctrl-C to abort.
Password:
Patching universal binary (2 architectures)
Patching I386 part (processor 7, architecture 0)
No code signature found, skipping patch
Patch report (1): 0 instructions patched, 138 bad instructions, patches bypassed: NO
Skipping non-Intel architecture (1)
No patches found, not generating output fileDuran-Keeleys-Mac:amd_insn_patcher d/libSystem.B.dylib /usr/lib/libSystem.B.dylib
Patching universal binary (3 architectures)
Patching X86_64 part (processor 16777223, architecture 0)
No code signature found, skipping patch
Patch report (1): 0 instructions patched, 444 bad instructions, patches bypassed: NO
Patching I386 part (processor 7, architecture 1)
No code signature found, skipping patch
Patch report (2): 0 instructions patched, 31 bad instructions, patches bypassed: NO
Skipping non-Intel architecture (2)
No patches found, not generating output fileDuran-Keeleys-Mac:amd_insn_patcher d/dyld /usr/lib/dyld
Patching universal binary (3 architectures)
Patching X86_64 part (processor 16777223, architecture 0)
Code signature removed succesfully (64bit)Patch report (1): 0 instructions patched, 30 bad instructions, patches bypassed: NO
Patching I386 part (processor 7, architecture 1)
Code signature removed succesfully (32bit)Patch report (2): 1 instructions patched, 0 bad instructions, patches bypassed: NO
Skipping non-Intel architecture (2)
Duran-Keeleys-Mac:amd_insn_patcher durankeeley$

 

No illegal Instruction, downloaded the Sinetek SL kernel, Changed boot flags to arch=x86_64, removed -force64, changed kernel from legacy_kernel to mach_kernel (the name of Sinetek's kernel).

 

Did you find the above games in App Store? if so I can test them or if you can Compress them and upload them somewhere for me to download and test.

Share this post


Link to post
Share on other sites

I have not managed to boot with cpus=6 but only cpus=5 for some reason even with the kext provided by Duran,system only wants to see up to 5 cores not the 6 one.

The kernel flags i use is "legacy_kernel arch=i386 maxmem=4096 cpus=5 -force64 gfxenabler=yes" ,now i am going to try the same kernel flags with the kernel provided on this thread and post,it seems strange to me to have waiting for root device if i have cpus=6 has anybody seen something like this before?

 

EDIT

Same thing happens with the kernel of this thread.Cpus=5 works cpus=6 goes to still waiting for root device.

 

go to the root of your drive, then go to the Extra, Extensions, is there TotallyFixStillWaiting.kext ?

Share this post


Link to post
Share on other sites

Did you make copies of the original files and then patched the other files of the os?

I saw this on the terminal you posted

amd_insn_patcher d/libSystem.B.dylib /usr/lib/libSystem.B.dylib

d/libsystem ?you made a d folder?

 

Edit:i dont what the kext you mentioned,should i install it?

Share this post


Link to post
Share on other sites

There are various crashes happening,sometimes they are recoverable like i watch a flash then suddenly glitches appear on screen and on windows and then suddenly i can either move the mouse,it pauses for maybe 1 to 10 seconds and it may resume,other times it halts and stays like that and i have to reboot

 

i took a look at the logs in console application and here are some errors

 

2/11/13 4:57:53 PM kernel NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error

2/11/13 4:57:53 PM kernel 0000006e

2/11/13 4:57:53 PM kernel 00200000 00008297 00000474 00000010

2/11/13 4:57:53 PM kernel 0000047e 00001408 00000001 0000000a

2/11/13 4:57:53 PM kernel 00000000 00000000 00000403

2/11/13 4:57:53 PM kernel 00000010 00000000

2/11/13 4:58:22 PM [0x0-0x1e01e].org.mozilla.firefox[1296] NOTE: child process received `Goodbye', closing down

2/11/13 4:58:23 PM kernel firefox (map: 0x74a8e18) triggered DYLD shared region unnest for map: 0x74a8e18, region 0x7fff88000000->0x7fff88200000. While not abnormal for debuggers, this increases system memory footprint until the target exits.

 

that opengl nvidia errors are for many lines i just pasted one...

I still haven't patched the system.But will hopefully do it.

I also downloaded and ran the cuda nvidia drivers should i uninstall them?they seem to work and run ok,but only 32bit with -force64 on x86_64 there is an error that i should update my nvidia cuda drivers.Also i have a nvidia gts 250 with 1gigabyte,and works with full qe,and 3d acceleration in games works.

Share this post


Link to post
Share on other sites

Did you make copies of the original files and then patched the other files of the os?

I saw this on the terminal you posted

amd_insn_patcher d/libSystem.B.dylib /usr/lib/libSystem.B.dylib

d/libsystem ?you made a d folder?

 

Edit:i dont what the kext you mentioned,should i install it?

 

Nope, downloaded amd_insn_patcher when it unarchives it creates a folder called "amd_insn_patcher", copied that folder to the desktop, opened terminal.

 

In terminal

cd Desktop/amd_insn_patcher/

 

That opens the folder on the desktop,

 

I used "ls" to confirm that the files were in the folder and I was in the right place.

 

Then Copy this, and right click in the terminal window (if you are using an apple mouse hold ctrl and left click) and click paste

sudo ./amd_insn_patcher /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents

 

Press Enter and typed in my password. No copies of the original just patched them where they were.

 

It looks that way about the folder, Shouldn't. I just copied and pasted from last post. Terminal leaves of text if I copy from the browser and right click and paste in the window. But it is the WHOLE text, if I backspace in starts deleting text that should be the sudo so on part but is actually "Duran-Keeleys-Mac:~ durankeeley$ "

Share this post


Link to post
Share on other sites

There are various crashes happening,sometimes they are recoverable like i watch a flash then suddenly glitches appear on screen and on windows and then suddenly i can either move the mouse,it pauses for maybe 1 to 10 seconds and it may resume,other times it halts and stays like that and i have to reboot

 

i took a look at the logs in console application and here are some errors

 

2/11/13 4:57:53 PM kernel NVDA(OpenGL): Channel exception! exception type = 0xd = GR: SW Notify Error

2/11/13 4:57:53 PM kernel 0000006e

2/11/13 4:57:53 PM kernel 00200000 00008297 00000474 00000010

2/11/13 4:57:53 PM kernel 0000047e 00001408 00000001 0000000a

2/11/13 4:57:53 PM kernel 00000000 00000000 00000403

2/11/13 4:57:53 PM kernel 00000010 00000000

2/11/13 4:58:22 PM [0x0-0x1e01e].org.mozilla.firefox[1296] NOTE: child process received `Goodbye', closing down

2/11/13 4:58:23 PM kernel firefox (map: 0x74a8e18) triggered DYLD shared region unnest for map: 0x74a8e18, region 0x7fff88000000->0x7fff88200000. While not abnormal for debuggers, this increases system memory footprint until the target exits.

 

that opengl nvidia errors are for many lines i just pasted one...

I still haven't patched the system.But will hopefully do it.

I also downloaded and ran the cuda nvidia drivers should i uninstall them?they seem to work and run ok,but only 32bit with -force64 on x86_64 there is an error that i should update my nvidia cuda drivers.Also i have a nvidia gts 250 with 1gigabyte,and works with full qe,and 3d acceleration in games works.

 

HAHAHA gosh this is getting expensive for someone that doesn't work like me,ANYWAY I managed to get a Nvidia 9500 GT, have to use GraphicsEnabler but should do fine for testing Nvidia bugs.

 

Gonna load Firefox later and see how that goes.

 

EDIT:

AWESOME NOT! Had the same lockup when on YouTube and freezed the whole system, SO in applications, right clicked -. Get Info and clicked "Open in 32-bit mode" gonna patch the flash player plugin of OSX and let you know.

 

Could Be the VoodooTSCSync as well as this creates a lag in my system from time to time. If you can edit your DSDT that you created and in the Processor Section delete all the CPU alias. There is a patch txt file in DSDT Editor for this. As I said I am useless at DSDT as mine normally as 201 errors and I couldn't get myself to fix them all.

 

So for now try use Chrome, there is a Flash problem but I made a launcher to HOPEFULLY get around this problem. You can get the launcher here: https://www.dropbox....wgai/HPIXMSlm2B

 

Let me know how this launcher goes.

 

EDIT 2:

Ok to find what you need to patch in terms of the Flash Player Plugin

Duran-Keeleys-Mac:amd_insn_patcher durankeeley$ sudo amd_insn_patcher /Library/Internet\ Plug-Ins/Flash\ Player.plugin/Contents/PlugIns/FlashPlayer-10.6.plugin/Contents/MacOS/FlashPlayer-10.6 /Library/Internet\ Plug-Ins/Flash\ Player.plugin/Contents/PlugIns/FlashPlayer-10.6.plugin/Contents/MacOS/FlashPlayer-10.6
Code signature removed succesfully (32bit)Patch report: 6 instructions patched, 138 bad instructions, patches bypassed: NO

 

But to be honest, it seems no difference even on Safari, wonder if Firefox uses the same plugin.

Share this post


Link to post
Share on other sites

open applicationsin 32bit mode still had crashes,i can play limbo for 1 hour and not crash, i can use firefox for2-3 hours no crash,then i may just move the pointer to a menu and crash,tomorrow i will try the patches you posted let's hope it fixes the problems,monkey island special edition had gfx glitches and crashed or frozen for about half a minute then resumed and i could play for 2 hours,gfx were ok but inventory was a mess,all other was ok.

 

Tomorrow i will try to install photoshop or some applications to check.Could the crash be from the fact that i haven't used the amd marvin?

Now on legacy kernel flags are legacy_kernel arch=i386 maxmem=4096 cpus=5 -force64 gfxenabler=yes -v

 

Overall i am posting this from the snow leopatrd 10.6.8 :)

Share this post


Link to post
Share on other sites

open applicationsin 32bit mode still had crashes,i can play limbo for 1 hour and not crash, i can use firefox for2-3 hours no crash,then i may just move the pointer to a menu and crash,tomorrow i will try the patches you posted let's hope it fixes the problems,monkey island special edition had gfx glitches and crashed or frozen for about half a minute then resumed and i could play for 2 hours,gfx were ok but inventory was a mess,all other was ok.

 

Tomorrow i will try to install photoshop or some applications to check.Could the crash be from the fact that i haven't used the amd marvin?

Now on legacy kernel flags are legacy_kernel arch=i386 maxmem=4096 cpus=5 -force64 gfxenabler=yes -v

 

Overall i am posting this from the snow leopatrd 10.6.8 :)

 

Did you install the VoodooTSCSync kext? check by pressing "CMD (windows key on a 101 US Keyboard), Shift and G.

Then go to either "/System/Library/Extensions" or "/Extra/Extensions" and look for it.

 

I know on my system it creates a lag as I use it, have you removed the alias in your DSDT to allow you to boot without the cpus?

Share this post


Link to post
Share on other sites

crash means i can move the mouse in the 2 screens (dvi and vga) but i cant click and nothing happens,sometimes it may work after some seconds but it may crash again,i think i did something wrong,i instaled cuda drivers for nvidia but nvidia gts 250 does not have cuda support as far as i know,so do you know how to properly uninstall the cuda /? duran i will check tomorrow and will post,but i dont havw kernel panics,i dont see kernel panics errors with stack or register information so i must be something else. ...will check what you have told me.

Share this post


Link to post
Share on other sites

crash means i can move the mouse in the 2 screens (dvi and vga) but i cant click and nothing happens,sometimes it may work after some seconds but it may crash again,i think i did something wrong,i instaled cuda drivers for nvidia but nvidia gts 250 does not have cuda support as far as i know,so do you know how to properly uninstall the cuda /? duran i will check tomorrow and will post,but i dont havw kernel panics,i dont see kernel panics errors with stack or register information so i must be something else. ...will check what you have told me.

 

Hey, no you haven't done anything wrong because I have an ATI HD6570 and I get the same lag and stuff, I am almost sure it is the VoodooTSCSync. Since you have a DSDT (Where as I can not, 201 errors, fix then 19 error fix, try run it, Kernel panics) Run the alias fix on your DSDT. Then let us know.

 

If you do wanna remove them, a tutorial is found here: http://www.insanelymac.com/forum/topic/285345-how-to-install-and-uninstall-nvidia-retail-drivers/#entry1876699

Share this post


Link to post
Share on other sites

Hello,I'm trying almost every kernel for 10.6.8 AMD Phenom but I couldn't find any compatible settings. Now, I installed this kernel and I'M starting with following commands-v -f arch=x86_64 busratıo=16I'm getting this error. Could you please help me?http://i.imgur.com/XfttRx3.jpg

 

Edit: I deleted FakeSMC and NVEnabler.kext I could do a bit progress.

 

http://i.imgur.com/wjbMx2H.jpg

 

After some "Waiting for root device" (about 15 minutes) kernel trying to launch desktop, I see vertical some strange lines on the monitor for one second and my PC restarting suddenly.

 

Edit2: I changed SATA port of HDD and voila. No more "Waiting for root device" but restarting problem still same. I think GraphicsEnabler doesn't work.

 

Edit3: There is a small video, which I recorded, please see and give feedback. Thanks im advance:

 

http://www.youtube.com/watch?v=PnLLfNKgIGM

 

and half a second ago before the restart:

 

jsYEPPt.jpg

Edited by YaPaY

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×