Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Unsupported OS error while unable to install PS CS3 :(

4 posts in this topic

Recommended Posts

Was trying to install Photoshop CS3 onto my hackintosh mountain Lion build. It failed with an error message that the OS is unsupported. On my macbook I had it installed prior to upgrading to mountain lion and it works or runs without issue, but trying to install it fresh after mountain lion is installed fails. I tried changing security settings to allow 3rd party apps to install but that didn't work. To make matters worse I accidentally installed Mountain Lion onto a case sensitive (as opposed to case insensitive) partition. Not sure how to switch the partition to case insensitive format without reinstalling or maybe doing a clone copy though its on an SSD so hate to do another OS install and excessive writes. Guessing the issue is with the CS3 installer and mountain lion. As photoshop upgrades are pricey I would appreciate if anyone has any ideas on how to get the installer working?


Thank you.

Share this post

Link to post
Share on other sites

CS3 is definitely not supported in ML... Even CS5 has documented problems. Try installing with Pacifist and see if that works. Also, some apps (including all adobe software iirc) do not support case-sensitive file systems. As far as I know your only option is to erase the drive and reformat, BUT you should be able to clone it with CCC or SuperDuper, repartition as case-insensitive, and then clone it back. I dont think CCC or SuperDuper care whether the destination is case sensitive or not.

Share this post

Link to post
Share on other sites

I think you can still get it to work by using Pacifist. You should at least get your filesystem back to case insensitive, I know there's quite a few apps that do not support case sensitive.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.