Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
jazz

WALMART Xmas Special

1 post in this topic

Recommended Posts

For your iHac pleasure. I am proud to announce the emachine on sale(WALMART) as a 4GB system with 500GB HDD is a successful hack.

Attached is the image of proof.

 

 

 

Ok, so I bet your wondering how I did this.

 

1) AQUIRE iDeneb 1.5 AKA OSX 10.5.7(go get it elsewhere, somehow)

2) Install as following:

(Drivers)

 

ATIIXP (REQUIRED) [This is your SATA controller onboard.]

SATAFIX/ICH10FIX

ALL sound ALC/Realtek Audio codecs(not sure which it uses, quite frankly dont care. This flood method seems to work.)

SiS/VIA support(last option, not the USB option)

BIOS800 in ACPI menu

Kernel: 970 works, I checked all three.

 

LAN:

(works, no router hard wired to confirm)

LAN onboard is modified REALTEK/ INTEL PRO chipset. (1389 I think) I batch select LAN and WIFI just in case.

 

Check REALTEK/INTEL/ZYDAS anyways(fixes some cards)

 

Wifi:

Check REALTEK/INTEL/ZYDAS anyways(fixes some cards)

I grabbed NETGEAR somehow but the stick Im using is unsupported(update for mac fixes this?)

 

Video:

SELECT Nothing (EFI in CHameleon catches the framebuffer, no actual driver yet)

(reverse/recompile Ubuntu's Catalyst driver? There is a dated 2.4.4 mac catalyst driver out there.)

 

DO NOT CHOOSE GUID partition map, ensure it is MBR. Will work in a patched SNOW installer to fix, either I will or someone SHOULD.

 

THe following edits to boot.com.apple.plist may help:

busratio=8 GraphicsEnabler=Yes "GraphicsMode"="1366x768x32" (yeah, I got the 19" wide AOC screen special too while at same WalMart.)

 

Everything works WELL OOB except LAN/WIFI, as noted above. I have a known WIN only stick(WNDA3100) and no direct LAN connection to route at the moment.(dont go to best buy for this card if you can help it, get a real working NIC and CISCO blue box router instead from newegg.)

 

Im on USB Logitech mouse /keyboard so I dont know about the PS/2 checkbox. I didnt check any of this.

 

I have DSDT dump for those that need it.(cant upload?)

hacked.tiff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×