Jump to content
Sign in to follow this  
Followers 0
p.H

How do I install or extract a pkg file

1 post in this topic

Recommended Posts

How to extract ?

Original Post ( Italian ) : http://www.insanelymac.com/forum/topic/221062-come-posso-estrarre-il-contenuto-da-un-file-pkg/

 

 

Simply by using a software called Pacifist. No further explanations needed. You can find this app on the net without difficulty.

 

 

 

 

How to install ?

Original Post ( Italian ) : http://www.insanelymac.com/forum/topic/220932-come-installo-un-file-pkg/

 

 

Pkg files(short for package) are self-installing.

All you need to do is simply double click on the package icon and the installation will start after you choose to agree certain things etc.

Share this post


Link to post
Share on other sites
Advertisement
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By tlefko
      Now updated for 10.13.6+ Designed for i7 Skylake, QHD+, 256/8GB memory
      https://github.com/tlefko/OSX-XPS13-9350
      INSTALL
      you may want to disable Configure BIOS settings for EFI Booting. Disable RAID, enable AHCI, virtualization, make sure VRAM is over 32. and you should be set. also disable secure boot and enable UEFI booting You should create an EFI folder onto the USB and copy the contents of the USB onto the drive Boot off the usb using external mouse/keyboard (if required) and follow the installer prompts boot off the MAC HDD NOTES
      You may want to remove the DSDT patches if you have an issue. and manually repatch. however if you have the same model it should not be an issue. POST INSTALL
      Copy the folders from the root of the USB onto the computer efi folder. NOTES
      Some sleep bugs Tested with 10.13.6, not with 10.14 DSDT patches may have an issues if not the same model, you can remove them if there is an issue. CREDITS
      @Rehabman @maz-1 @syscl @darkvoid SUPPORT
      feel free to ask questions / open answers, you can also check out my other repository covering a previous mac version for the same model for other files for that / information on this topic Files.zip
    • By clockT
      sono un pò arrugginito ..e volevo chiedere un aiuto su come installare opencore anzichè clover. ho provato ma dopo il post installazione riesco solo a far partire catalina tramite pendrive. quale congifurazione sbaglio?
      EFI.zip

    • By Andres ZeroCross
      First my Old Threads is here http://www.insanelymac.com/forum/topic/308178-el-capitan-wih-i7-6700-skylake-gigabyte-ga-z170-hd3-palit-jetstream-gtx960/

      My Computer Specifications
      1. Processor : Intel Core i7 6700
      2. Motherboard : Gigabyte Z170-HD3
      3. VGA Card : Palit Jetstream GTX960 4GB DDR5
      4. Wifi Card ; TP-Link TL-WDN4800
      5. PCI-E to Sata = Bafo PCI-e to 2 Sata3 and 2 e-Sata
      6. PCI to USB 2.0 - NEC Chipset
      7. Main Harddisk Harddisk : Fujitsu SSD 120GB + Seagate 500GB that plug into Bafo PCIe to Sata3
      8. Other Harddisk : Natno SSD 12GB, 2x Seagate 2TB, Seagate 500GB, all of it are plug into onboard Sata Chipset Controller (But Unknow at El Capitan / 10th Intel Chipset)
      9. RAM : Team 3000Mhz 8GB (2x4GB)
      10. Display : Asus VN248H
      11. Clover version : 3280

      My Step :
      1. Because Internal Sata Chipset and USB 3.0 are not supported yet, so i clone my Fujitsu 120GB SSD from my Hacbook Asus X455LA that already installed El Capitan Build 15B30a with Carbon Copy Cloner
      2. I use MacPro 6.1 as SMBIOS and use FakeCPUIID of Intel 4790k (0x0306C3)
      3. Remove CPUSensor.kext from "FakeSMC.kext/Contents/Plugins" if you don't do this it will be stuck at ACPI log verbose.
      4. I try boot from USB that already install Clover 3280 and it boot. I use "-v nv_disable=1 dart=0"
      5. Then at desktop, i install nvidia web driver 346.03.02F02 (before that you need to modif it,, use pkgutil --expand bla bla ba,, google it and change required os to "15B" then use pkgutl --flatten bla bla to repackage) then i change info plist from AppleGraphicsControl.kext/Contents/Plugin/AppleGraphicsDevicePolicy.kext/Contents/info.plist and change line that contain board-id of MacPro 6.1 from Config2 to none
      6. Then i install that kext,, and restart
      7. i use "-v dart=0 nvda_drv=1 and it will need more time than usual to get login form,, yeah i did it. But there is some bugs
       
      Bugs :
      1. Internal sata is not function
      2. USB 3.0 is error too,,  at verbose i see "error mantisa log"
      3. Sometimes my system get freeze for a few seconds. I thinks this is error from Nvidia web driver,, i see nvdia error log from "sudo dmesg"

      At last,, sorry for my bad english
      Thanks
       
      This is for screenshots
       

       

      I upload my IOREG and DSDT
       
       
×