Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Intel HD3000 on a HP Laptop

14 posts in this topic

Recommended Posts

Hi everyone!


I'm trying to configure iATKOS L2 (OSX Lion 10.7.2) on a HP Laptop (a Pavilion g6-2040sl). I know it's quite difficult on these kind of computers... Anyway, everything works fine, except for the built-in graphics: the Intel HD3000 won't work properly on my computer. As a result, I cannot enable graphics acceleration.


By the way, the first time i booted into OSX i had to manually remove the AppleIntelHD* and AppleIntelSNB* kexts because of the well-known "SNB framebuffer did not show up, unload." error.


I've also tried booting with the flag "GraphicsEnabler=Yes", but without success, because the system hangs up at the booting prompt.


One more thing, my computer comes with another graphics card, an AMD Radeon HD 7670M, which is not yet supported by OSX. That's why I'm trying to enable the built-in one.

My CPU is an Intel Core i5 2450M.


Thanks in advance for your help.







P.S.: I've attached a screenshot of my graphics cards information.


Share this post

Link to post
Share on other sites

If you haven't, reinstall needed GPU kexts you removed and update to newer version of Enoch Chameleon here

Share this post

Link to post
Share on other sites

Hi and thanks for your quick reply. I installed the latest Enoch and reinstalled the kexts, but I still get the "SNB framebuffer did not show up" error when booting (in verbose mode, of course). Also tried booting with the "GraphicsEnabler=Yes" flag, but my computer suddenly rebooted.

Share this post

Link to post
Share on other sites

what SMBios.plist version do you use ? ... try MacBookPro8,1 or 8,3 and start with GraphicsEnabler=No


My other advice would be to go for 10.8.2 which works beautifully with HD3000 with full QE/CI (I have same device like yours x0126)

Share this post

Link to post
Share on other sites

Hi, thanks for your hint! I'm currently using the MacMini 5,1 SMBIOS, because I've read that Intel HD3000 can be recognized only if we use that one.

Anyway, I'll try with the MacBookPro 8,3 SMBIOS, because with the 8,1 one I get a kernel panic each time I try to boot.

Share this post

Link to post
Share on other sites

Hello everyone. As Biso suggested, I applied the MacBook Pro 8,3 SMBIOS and now my Intel HD3000 is recognized by OSX... Anyway, I'm still not able to use Quartz Extreme and full graphics acceleration, do I need to patch the Kexts?

Thanks to everyone for your help!

Share this post

Link to post
Share on other sites

Yep... Native resolution is 1366x768! I can use it, but I cannot get QE working.

By the way, AppleIntelSNBGraphicsFP.kext seems to be loaded... I checked it with Kext Wizard!

Share this post

Link to post
Share on other sites

I couldn't get QE/CI on my HD3000 except by using 10.8.2 ... even 10.8 didn't activate it.


So, I can't tell much about 10.7.2 ... is there a good reason not to upgrade ?

Share this post

Link to post
Share on other sites

Actually, I'm waiting for the newest iATKOS ML 10.8.2...

Anyway, I was trying to solve this problem on Lion, just because evertyhing else on my PC is working fine!

Share this post

Link to post
Share on other sites

Thank you very much for your help. I installed OSX Combo Update 10.7.3... My Intel HD3000 seems to be recognized, anyway I'm still not able to use QE.

Has anyone got any suggestions?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MetalBreaker
      I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.
      SMBIOS: iMac13,1
      Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
      CPU: Intel Core i3-3210, iGPU disabled in UEFI

      All kexts updated to their latest versions, along with Clover.

      For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3
      Any help would be appreciated.
      Thank you for your time!
    • By zafirofx
      Hi everyone. I installed MacOS High Sierra on my computer 3 months ago, in January. After a long way to get the computer fully working now I'm facing a new problem: imagine I'm working or doing something in my computer and it suddenly freezes and I have to restart it.  There's no reason why the computer restarts by itself...
      Here I also attach my Clover EFI folder in case you need it (it doesn't allow me to attach it so here i give you the link: https://mega.nz/#!92xCiLDZ!WY1F55ZvuP-9WW369EP9KY-3hNLt5sWUgJDxPrbgpPM .
      Thank you in advance.
    • By ITzTravelInTime
      This is a dedicated thread about the intel 8255X based ethernet cards which, although being old (but also very cheap and easy to find used online), they still works in the latest macOS releases today i tested mine with the 64 bit compiled AppleIntel8255X kext and works like a charm! stable and withou any issues with mine 100 mbit managed ethernet switch and also without suffering of problems like connection dieing under heavy load or sleep/wake issues, so just to report that i have create this dedicated thread about and also i leave the kext as an attachment, in this post, this may be usefoul to have cheap working ethernet for hackintosh machines running the latest macOS or just to reuse old hardware some one can have laying around.
    • By End3rPwr50
      Hi, I wanted to install macOs 10.13 on my notebook.
      Here are the technical specifications:
      -Intel i7 6500U 2.50GHz Skylake (CPU)
      -12GB ram dd4 (RAM)
      -hp 81EC (MOTHERBOARD) with BIOS insyde F09
      -Intel HD Graphics 520 - AMD Radeon R7 M440 (Graphics cards)
      -Realtek PCIe FE Family Controller (Ethernet)
      -Broadcom BCM43142 802.11 bgn Wi-Fi M.2 Adapter (Wifi and Bluetooth)
      -Realtek High Definition Audio - Audio Intel® per schermi(HDMI)
      Thanks in advance

    • By MaLd0n
        --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   Installation   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER Post Install.zip   --Reboot   DSDT DSDT.MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC ----- -Disable GPU new patch and PNLF SSDT - Credits RehabMan

      SSDT    Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha https://github.com/Piker-Alpha ssdtPRGen.command.zip   or just use "plugin-type"=0x01 in DSDT, SSDT or Clover config.plist   for check Power, Frequency, Temperature and Utilization, use it Install Intel Power Gadget.pkg.zip  
      https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/   -Atheros Ethernet https://github.com/Mieze/AtherosE2200Ethernet   -IntelGraphicsFixup https://sourceforge.net/projects/intelgraphicsfixup/   -IntelGraphicsDVMTFixup https://github.com/BarbaraPalvin/IntelGraphicsDVMTFixup   -USBInjectAll https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   Special Thanks to Pablo Galán   We're all here to have fun and learn from each other!   ENJOY!