Jump to content
InsanelyMac Forum
Sign in to follow this  
Melancholique

Help: G31M-ES2L Kit in Need

Recommended Posts

Hey there. I know I'm extremely late, but I dread updating my system as I'm sure many others do. Unfortunately, 10.5.8 is no longer cutting it for me and many of my applications... so I've decided to bite the bullet and buy a Snow Leopard DVD. At this point, I'd love to get the most up-to-date version of Snow Leopard or even Lion running on my system. This guide seems like the least amount of headaches for my setup, but the linked ES2L kit has been out of service for a while now. Does anyone have it, or a comparable kit I could use? Or even a better guide, if one's out there?

 

I'd really like to get the ball rolling on this thing before the new year. If anyone can provide any help, I'd be most grateful.

Cheers.

Share this post


Link to post
Share on other sites
Advertisement

Thank you kindly for the response, friend. I'm not absolutely clueless when it comes to Hackintosh installs, but it's been years since I've had to work with DSDT, kexts, and things of the nature. That being said: what's the easiest way to check whether I've got a 1._ or a 2._?

Share this post


Link to post
Share on other sites

Is there any way to check other than looking at the motherboard itself? It's not really an option at the moment. And assuming I do the install for the wrong rev, what's the worst case scenario? No LAN or audio? Is that a relatively easy fix?

Share this post


Link to post
Share on other sites

the LAN device id would tell me if its atheros or Realtek. realtek= rev 1.. atheros = rev2

 

yah no sound or lan.. and sleep crashes likely due to dsdt being slightly different.

 

easy fix.

Share this post


Link to post
Share on other sites

Thanks for all your responses, McG. I should be doing this update either tonight or tomorrow. I'm sure I'll bounce back to this thread if something goes terribly wrong.

Fingers crossed.

Share this post


Link to post
Share on other sites

And... I'm stuck already. Such a pain.

Following the aforementioned guide, I got to the step where myHack is used to customize the bootable USB. However, I get this error when I try to launch myHack. I simply can't choose my USB flash drive as the destination, like the guide asks me to.

 

Is there a better G31M-ES2L / retail DVD guide out there? I've got the DVD fully restored onto a USB with no issues at all. Just not sure where to go from here.

Any help would be appreciated. Thank you.

Share this post


Link to post
Share on other sites

easy.. use a bootable cd (boot132) to start the usb installer.

 

or

do u have os x working to install chameleon 2.1 to the usb?

then add

/Extra/Extensions/FakeSMC.kext

/Extra/smbios.plist with macpro 3.1(fixable with chameleon wizard.)

/Extra/org.chameleon.boot.plist that has GeneratePStates and GenerateCStates (fixable with chameleon wizard or champlist.)

 

do u know yet which rev board u have ? LAN chip is ? atheros or Realtek ??

what operating system u have so we can run a tool to let us know what lan chip.

 

i could remote to u in any os x pc (with teamviewer) and make the usb properly then u can boot and install with it.

 

france ? .. midnight for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • For me the forum seems reasonably OK, except whenever I see the word 'LOADING' - like when clicking another page of a thread - when it just stops completely and never returns.   I use an adblocker, so adverts aren't slowing me down.  Browsing the forum indexes is not too bad, as is clicking to view any thread.  Ditto clicking a link in an email notification to go to a particular post in a thread.  Sometimes it takes maybe five seconds to load a page, which is a bit too long.  But it's not terrible.   But then whenever I click on any other thread page, which tries to do the in-page content load (without a full page refresh), I see LOADING and then nothing further happens, even after minutes.   It's definitely not related to which content is loaded, but rather how it is loaded.  For example if I go to the index for this forum, then click directly to page 11 of this thread, it loads in 1-5 seconds.  But if I click the link to page 11 within the thread, it never comes back.  I just see this, forever:     This stuck issue seems to me likely something broken (code or configuration?) rather than a general slowdown.  But maybe there's also a general slowdown, especially for those who are seeing adverts.
    • This is as far as I can get with the AMD kexts and the device ID added. They load but the frame buffer isn't loaded. I've tried loading all 7 frame buffers included in the X1000 kext with no luck. From the tests Gigamaxx did there seems to be more luck spoofing as Intel graphics there. More support may come from integrated Vega though, hard to tell.    
    • as documented here it is a sample rate standard and i have also tested it and i can confirm that it works with my audigy rx at least, i have to test it with other cards   https://github.com/audiojs/sample-rate
    • Yes, if i use the EFI folder that I uploaded to the google drive then i do have Intel working properly with QE/CI.
    • ubuntu@ubuntu:~$ sudo -s
      root@ubuntu:~#  superiotool -d
      superiotool r6637
      Found SMSC FDC37N972 (id=0x0b, rev=0x00) at 0x2e
      Register dump:
      idx 02 20 21 22 23 24 25 26  27 28 29 2a 2b 2c 2d 2e  2f
      val 00 0b 00 00 00 00 00 2e  00 00 00 00 00 00 00 00  00
      def 00 0b 00 00 00 04 04 NA  NA 00 00 00 00 00 00 00  00
      LDN 0x00 (Floppy)
      idx 30 60 61 70 74 f0 f1 f2  f3 f4 f5
      val 00 00 00 00 00 00 d1 15  0b 00 10
      def 00 03 f0 06 02 0e 00 ff  RR 00 00
      LDN 0x01 (Power management (PM1))
      idx 30 60 61
      val 00 00 00
      def 00 00 00
      LDN 0x03 (Parallel port)
      idx 30 60 61 70 74 f0 f1
      val 00 00 00 00 00 00 d1
      def 00 00 00 00 04 3c 00
      LDN 0x04 (COM1)
      idx 30 60 61 70 f0
      val 00 00 00 00 00
      def 00 00 00 00 00
      LDN 0x05 (COM2)
      idx 30 60 61 62 63 70 74 f0  f1 f2 f7 f8
      val 00 00 00 00 00 00 00 00  d1 15 00 00
      def 00 00 00 00 00 00 04 00  02 03 00 00
      LDN 0x06 (Real-time clock (RTC))
      idx 30 60 61 62 63 70 f0 f1
      val 00 00 00 00 00 00 00 d1
      def 00 00 70 00 74 00 00 NA
      LDN 0x07 (Keyboard)
      idx 30 60 61 70 72 f0
      val 00 00 00 00 00 00
      def 00 00 00 00 00 00
      LDN 0x08 (Embedded controller (EC))
      idx 30 60 61
      val 00 00 00
      def 00 00 62
      LDN 0x09 (Mailbox)
      idx 30 60 61
      val 00 00 00
      def 00 00 00
      Found SMSC SCH5027 (id=0x89, rev=0x03) at 0x4e
      No dump available for this Super I/O   i was some kind of lucky to dump some information but i am still not able  to dump the sensor chip Ubuntu Dumps.zip


×