Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Micky1979

Video HDMI con Audio su Intel HD4000 Mobile

68 posts in this topic

Recommended Posts

Logo HDMI piccolo.png >>Translate

Intel HD4000, Video e Audio HDMI sul Notebook!..e forse la VGA

 

Requisiti:

 

- Un programma tipo HexEdit

- AppleHDA.kext funzionante

- Dsdt editing

 

- Kext allegato funzionante per i Notebook che normalmente usano l' ig-platform-id: 01660004 (che sono molti)

seguite perchè per utilizzarlo dovrete impostare ig-platform-id a 01660003

 

 

 

Come saprete, la nuova Intel HD4000 mobile può essere attivata tramite stringa EFI nel o.c.b.p, oppure iniettando nel dsdt il "platform-ig". Francamente preferisco il secondo metodo.

A questo punto, provando uno dei seguenti platform-ig che attivano (connettono) il Framebuffer del AppleIntelFramebufferCapri.kext:

ig-platform-id: 01660000, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3
ig-platform-id: 01660001, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3
ig-platform-id: 01660002, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 1, FBMem: 1
ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 2, FBMem: 2
ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1
ig-platform-id: 01660008, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3
ig-platform-id: 01660009, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3
ig-platform-id: 0166000A, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
ig-platform-id: 0166000B, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
ig-platform-id: 01620005, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
ig-platform-id: 01620006, Stolen RAM for FB: 0MB, Pipes: 0, Ports: 0, FBMem: 0
ig-platform-id: 01620007, Stolen RAM for FB: 0MB, Pipes: 0, Ports: 0, FBMem: 0

.......la mia scheda video si è attivata con il ig-platform-id: 01660004, e fin qui tutto ok, ma purtroppo come potete vedere dispone di una sola porta, per cui,

se è ovvio che ha attivato il mio Lvds, purtroppo è anche ovvio che non c'è posto per l'HDMI.

 

Come risolvere? Semplice:

 

dando un occhio a questi post:

 

#49 di @eep357

#50 di @rr7

(che quindi li ringrazio)

 

 

in un battibaleno, ho trovato le informazioni che mi servono:

 

 

AAPL,ig-platform-id: 01660000, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3
@0, 01 00 00 00 02 00 00 00 03 00 00 00 // (LVDS)
@1, 02 05 00 00 00 04 00 00 07 00 00 00 // (DisplayPort)
@2, 03 04 00 00 00 04 00 00 07 00 00 00 // (DisplayPort)
@3, 04 06 00 00 00 04 00 00 07 00 00 00 // (DisplayPort)- DETECTED 0x0

AAPL,ig-platform-id: 01660001, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3
@0, 01 00 00 00 02 00 00 00 30 00 00 00 // (LVDS)
@1, 02 05 00 00 00 08 00 00 06 00 00 00 // (HDMI)
@2, 03 04 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@3, 04 06 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)- DETECTED 0x0
port-number 0x7

AAPL,ig-platform-id: 01660002, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 1, FBMem: 1
@0, 01 00 00 00 00 02 00 00 30 00 00 00 // (LVDS)
port number 0x0

AAPL,ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 4, FBMem: 2
@0, 05 03 00 00 02 00 00 00 30 00 00 00 // (LVDS)
@1, 02 05 00 00 00 04 00 00 07 04 00 00 // (DisplayPort)
@2, 03 04 00 00 00 04 00 00 81 00 00 00 // (DisplayPort)
@3, 04 06 00 00 00 04 00 00 81 00 00 00 // (DisplayPort) - DETECTED 0x0 desktop


AAPL,ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1
@0, 05 03 00 00 02 00 00 00 30 02 00 00 // (LVDS)

AAPL,ig-platform-id: 01620005, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2 512mb vram
@0, 02 05 00 00 00 04 00 00 11 00 00 00 // (DisplayPort)
@1, 03 04 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@2, 04 06 00 00 00 04 00 00 07 01 00 00 // (DisplayPort) - DETECTED

AAPL,ig-platform-id: 01620006, Stolen RAM for FB: 0MB, Pipes: 0, Ports: 0, FBMem: 0

AAPL,ig-platform-id: 01620007, Stolen RAM for FB: 0MB, Pipes: 0, Ports: 0, FBMem: 0

AAPL,ig-platform-id: 01660008, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3
@0, 01 00 00 00 02 00 00 00 30 00 00 00 // (LVDS)
@1, 02 05 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@2, 03 04 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)


AAPL,ig-platform-id: 01660009, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - 0mb VRAM
@0, 01 00 00 00 02 00 00 00 30 00 00 00 // (LVDS)
@1, 02 05 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@2, 03 04 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)

AAPL,ig-platform-id: 0166000A, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
@0, 02 05 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@1, 03 04 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@2, 04 06 00 00 00 08 00 00 06 00 00 00 // (HDMI) - DETECTED

AAPL,ig-platform-id: 0166000B, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2
@0, 02 05 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@1, 03 04 00 00 00 04 00 00 07 01 00 00 // (DisplayPort)
@2, 04 06 00 00 00 08 00 00 06 00 00 00 // (HDMI) - DETECTED

 

 

 

Praticamente, per questione di comodità, o preso la stringa dal connettore funzionante:

 

AAPL,ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1
@0, 05 03 00 00 02 00 00 00 30 02 00 00 // (LVDS)

 

Come consuetudine, nei binari, le stringhe esadecimali sono a byte invertiti, per cui se vogliamo cercare 01660004, dovremo cercare così:

 

04 00 66 01 come nella foto sotto

capri 2.png

 

e l'ho trapiantata qui, e rubando dal platform-ig 0166000a anche il connettore HDMI!

Così quello che originariamente era questo:

 

AAPL,ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 4, FBMem: 2
@0, 05 03 00 00 02 00 00 00 30 00 00 00 // (LVDS)
@1, 02 05 00 00 00 04 00 00 07 04 00 00 // (DisplayPort)
@2, 03 04 00 00 00 04 00 00 81 00 00 00 // (DisplayPort)
@3, 04 06 00 00 00 04 00 00 81 00 00 00 // (DisplayPort) - DETECTED 0x0 desktop

capri 1.png

Capri 3.png

ora è così:

AAPL,ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 4, FBMem: 2
@0, 05 03 00 00 02 00 00 00 30 02 00 00 // (LVDS)
@1, 04 06 00 00 00 08 00 00 06 00 00 00 // (HDMI) - DETECTED
@2, 03 04 00 00 00 04 00 00 81 00 00 00 // (DisplayPort)
@3, 04 06 00 00 00 04 00 00 81 00 00 00 // (DisplayPort)

 

 

Ora ho anche l'HDMI video!! :thumbsup_anim:

 

Ovviamente, va fatta una modifica al dsdt, semplicemente se prima avevo l'ig 01660004 ora lo cambio a 01660003, che nel dsdt appare invertito:

 

 

assolutamente necessario per attivare la grafica della HD4000

"AAPL,ig-platform-id",
Buffer (0x04)
{
0x03, 0x00, 0x66, 0x01
},

 

inoltre, per attivare l'Audio sul monitor secondario, dovrete avere anche questo:

 

"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
},

 

 

 

Questa è per esempio la mia sezione Grafica completa, inserita dopo l'address della scheda video nel dsdt, cioè _ADR, 0x00020000

 

 

Method (_DSM, 4, NotSerialized)
{
Store (Package ()
{
"device-id",
Buffer (0x04)
{
0x66, 0x01, 0x00, 0x00
},

"vendor-id",
Buffer (0x04)
{
0x86, 0x80, 0x00, 0x00
},

"model",
Buffer (0x1E)
{
"Intel HD Graphics 4000 Mobile"
},

"AAPL,ig-platform-id",
Buffer (0x04)
{
0x03, 0x00, 0x66, 0x01
},

"hda-gfx",
Buffer (0x0A)
{
"onboard-1"
},

"AAPL00,DualLink",
Buffer (0x04)
{
0x01, 0x00, 0x00, 0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}

 

 

 

 

Da usare con GraphicsEnabler=No nel c.a.b.p, se mettete tutto quanto (device id, model etc)

 

 

 

Ovviamente anche la sezione Audio (HDEF) deve essere come questa:

 

 

 

 Device (HDEF)
 {
	 Name (_ADR, 0x001B0000)
	 Method (_DSM, 4, NotSerialized)
	 {
		 Store (Package (0x0A)
			 {
				 "built-in",
				 Buffer (One)
				 {
						 0x01
				 },
				 "device-type",
				 Buffer (0x0F)
				 {
					 "IDT 92HD91BXX"
				 },
				 "hda-gfx",
				 Buffer (0x0A)
				 {
					 "onboard-1"
				 },
				 "layout-id",
				 Buffer (0x04)
				 {
						 0x0C, 0x00, 0x00, 0x00
				 },
				 "PinConfigurations",
				 Buffer (Zero) {}
			 }, Local0)
		 DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
		 Return (Local0)
	 }

 

 

 

Nuovo metodo senza DSDT!!!!!!!!!!

 

Usando Enoch bootloader, sia per attivare la Intel HD4000, sia per l'audio attivando AppleHDA sempre senza dsdt.:

 

http://www.insanelym...ig-platform-id/

 

Nuovo metodo senza DSDT!!!!!!!!!!⬆

 

 

 

 

Mi sono accorto che ancora ho un connettore Vga sul PC, e due stringhe disponibili sul Framebuffer :lol: ……….chissà se posso attivare anche questa porta….ci provo:

 

AAPL,ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 4, FBMem: 2
@0, 05 03 00 00 02 00 00 00 30 02 00 00 // (LVDS)
@1, 04 06 00 00 00 08 00 00 06 00 00 00 // (HDMI) - DETECTED
@2, 06 02 00 00 01 00 00 00 30 00 00 00 // (VGA)
@3, 04 06 00 00 00 04 00 00 81 00 00 00 // (DisplayPort)

 

 

Purtroppo io non possiedo nessun monitor con questa porta, così se siete così gentili da riportare il suo funzionamento oppure il non funzionamento, ve ne sarei grato!

 

 

Qui un video del mio PC

 

 

..spero che vi piaccia la colonna sonora :lol:

 

 

 

Allego AppleIntelFramebufferCapri.kext modificato con connettori patchati per platform-ig che normalmente funzionava con il

ig-platform-id: 01660004, ma che dovrete cambiare nel dsdt come nell'esempio fatto, a 01660003

 

 

Micky

 

AppleIntelFramebufferCapri.kext.zip

Share this post


Link to post
Share on other sites

miki grazie sei il numero uno

Finalmente ho trovato un cavetto HDMI dall'omino che sta sopra a casa mia, e così ho potuto fare il lavoro.

Comunque il merito di questo Topic è anche tuo, perchè siccome io non credo di usare comunque l'HDMI con il mio Hackintosh (perchè non mi serve di farlo), ......

....dicevo il merito è anche il tuo...per tuttle le volte che mi hai spronato a farlo :dev: ! Perciò ringrazia anche Piero :dev: (che è il mio vicino di casa).

 

Scherzi a parte, ora il nostro hack è molto più completo, e molti utenti possono usare questo kext.

Solo una cortesia:

 

potresti farmi da tester per vedere se funziona la porta VGA?

 

 

Micky

Share this post


Link to post
Share on other sites

Pagare non è ammesso, però puoi diventare donatore se te la senti come scelta tua personale, ovvio!

Allora grazie, io purtroppo ho un monitor x pc, ma non ha la VGA, solo la DVI e l'HDMI

 

Micky

Share this post


Link to post
Share on other sites

tutte le uscite video si avviano anche dopo l'avvio del SISTEMA OPERATIVO.

Stai facendo un bellissimo lavoro

Uscita HDMI su TV FULL HD = Ok Audio Compreso

Uscita HDMI-DV su Monitor 21 Pollici = Piena Risoluzione 1960 * 1440 ( o qualcosa del genre cmq)

Uscita VGA non funziona un gran che bene...

Be Miky io sono felicissimo del punto che se riuscito a farmi raggiungere

Share this post


Link to post
Share on other sites

Posto i risultati , purtroppo sono a casa della vecchia ( mia mamma ) e non ho fatto le foto con la tv full Hd e il Monitor(DVI) esterno , ma confermo che funzionano alla grande si su tele HD e FULL HD e su montiro con DVI a massima risoluzione

SU TELE HD ( non full HD )

04122012302.jpg

SU Monitor ESTERNO VGA

04122012301.jpg

04122012303.jpg

Share this post


Link to post
Share on other sites

Posto i risultati , purtroppo sono a casa della vecchia ( mia mamma ) e non ho fatto le foto con la tv full Hd e il Monitor(DVI) esterno , ma confermo che funzionano alla grande si su tele HD e FULL HD e su montiro con DVI a massima risoluzione

SU TELE HD ( non full HD )

04122012302.jpg

SU Monitor ESTERNO VGA

04122012301.jpg

04122012303.jpg

Uscita HDMI su TV FULL HD = Ok Audio Compreso

Uscita HDMI-DV su Monitor 21 Pollici = Piena Risoluzione 1960 * 1440 ( o qualcosa del genre cmq)

Uscita VGA non funziona un gran che bene...

Be Miky io sono felicissimo del punto che se riuscito a farmi raggiungere

:thumbsup_anim:

Per la VGA, devo trovare un adattatore per provare di persona, comunque quella ce l'ho messa solo per provare, e sono contento che dia segni di vita!

direi OK senza dubbi l'HDMI.

 

Micky

Share this post


Link to post
Share on other sites

ciao miky cosi per curiosita tempo tuo permettendo hai intenzione di portare avanti questo tuo progetto di questo topic , xkè hai fatto un piacere a molte persone abilitando l'HDMI sulla intel 4000. Mi è parso di vedere che cera il richiamo al tuo topic anche su unforum di uno che chiedeva supporto per il suo ASUS

Share this post


Link to post
Share on other sites

Ciao Micky

e da un po che non scrivo sul forum ma vi seguo sempre!

 

come al solito Micky stupisci tutti.. hai fatto un lavoro pazzesco!!!

complimenti davvero... :thumbsup_anim: :thumbsup_anim: :thumbsup_anim:

 

Io in questo periodo purtroppo o per FORTUNA sono impegnatissimo col lavoro

ma non ho grandi cose da provare.. non si sa nulla nemmeno sull'aggiornamento del bios :wallbash:

 

anzi qualcosa ci sarebbe.. l'audio sull'hdmi non mi funziona

 

e poi avvolte (raramente) quando spengo il pc mi è successo in tutto 2 volte di ricevere un bel KP :wallbash:

hai idea da cosa possa dipendere??? c'è un modo per vedere quale sia il prob?

(dovrei avviare con -v sempre) perché non lo fa sempre... anzi quasi mai :thumbsup_anim:

 

Come sempre

grazie

 

Vito

Share this post


Link to post
Share on other sites

Ciao smigol, grazie per i complimenti.

Purtoppo non ho tempo ultimamente....l'ho finito ;-)

 

Posta uno screenshot del KP sul topic del dv7 di @simconti, appena ho tempo vedo se posso aiutarti!

 

Micky

Share this post


Link to post
Share on other sites

Grande Micky, ci stai dando di brutto in quest'ultimo periodo.... :boxing: Fai proprio bene!!!

Noi abbiamo mollato un po il tiro.... almeno io, ho raggiunto il risultato che volevo e una stabilità da fare invidia a i veri Apple...

Anche questa volta hai dato una mano con Intel HD4000, i notebook in commercio con questa scheda video iniziano a essere molti...

Auguri a tutti di buon Natale!!!

Share this post


Link to post
Share on other sites

Piccolo grande Micky mi daresti una mano a sistemare 2-3 cosette

è arrivato il momento di perfezionare qualcosa nella mia installazione!!!

 

1 - Prima cosa fra tutte voglio sistemare la risoluzione della schermata di avvio!

preferisco il legacy logo ma lo sempre visto un po schiacciato e forse troppo sproporzionatamente grande!!

 

2 - L'audio sulla porta HDMI

 

3 - La porta vga se c'è qualche spiraglio...

 

forse sono OT perche la mia scheda è intelHD 3000 :wallbash:

 

Grazie sempre :wink2:

Share this post


Link to post
Share on other sites

Perdonatemi per il mio italiano. Sto cercando di ottenere VGA lavoro sulla 10.8.3 .

 

Il mio Intel HD 4000 è AAPL, ig-piattaforma-id: 01.660.009

 

Il mio layout di porta è in questo modo:

AAPL,ig-platform-id: 01660009
@0, 01 00 00 00 02 00 00 00 30 00 00 00 // LVDS
@1, XXXX // VGA
@2, 03 04 00 00 00 08 00 00 06 00 00 00 00 00 00 00 // HDMI

 

Ho provato questi cerotti binari per VGA:

06 02 00 00 00 01 00 00 09 00 00 00 - schermo nero
06 02 00 00 01 00 00 00 09 00 00 00 - rigata
06 02 00 00 01 00 00 00 30 00 00 00 - schermo nero
06 02 00 00 02 00 00 00 30 00 00 00 - schermo nero

 

Grazie per l'aiuto!

Share this post


Link to post
Share on other sites

Neither of them work. The display is detected but no output (black screen).

 

Nessuno di loro lavorano. Il display viene rilevata e nessuna uscita.

Share this post


Link to post
Share on other sites

First, thx for the guide, was really handy when I was trying to enable DP on my notebook a while ago.

Now I tried a different approach and instead of moving the AAPL,ig-platform-id: 01660004 to some other platform, I decider to expand the 01660004 itself.
That is how my 01660004 looks now:

05 03 00 00 02 00 00 00 30 02 00 00
02 05 00 00 00 04 00 00 07 01 00 00
03 04 00 00 00 04 00 00 07 01 00 00
04 06 00 00 00 08 00 00 06 00 00 00
And here is the kext, if someone wants to try it.

Edit:
Ops, scusate non me ne sono accorto che sono nella sezione italiana, ho questo bookmark da mesi, comunque spero che quello che ho scritto sia chiaro.

AIFC_beta2.2.zip

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×