Jump to content
InsanelyMac Forum
MacItUpToMe

High CPU Usage

Recommended Posts

I apologize if a thread like this has already been made but after hours of searching i can not find anything about this subject matter.

 

Ok i have a question and hopefully there is somebody out there who can answer it. I wanted to see how stable my hackintosh was so i ran some programs(one at a time) like photoshop,maya,safari,firefox. When running Maya/Photoshop my cpu usage will shoot up to about 100% for either one and when running Safari/Firefox it goes up to about 60% cpu usage for either one . Heres the kicker, i ran the exact same applications on a REAL IMac and got almost the exact same results. only thing that was slightly different between the two was idle usage. Is this high cpu usage something that can damage my computer and should try to be resolved? or is it ok and no need to worry since it does the same thing on a real IMac?.

Share this post


Link to post
Share on other sites
Advertisement

i dont know your system, but if you have not overclocked your cpu or memory,

it is very ok to run at 100%. system normally takes care with fan cooling to keep damage away.

 

if you are concerned, install fakeSMC-plugins to monitor temperatures of the system parts.

Share this post


Link to post
Share on other sites

Sorry i completely forgot to post my system specs last night as i was tired. My specs are :Asus p6x58d Premium, Intel Core I7 930 2.8Ghz, EVGA Geforce 660TI,12GB of Corsair ram. Also if it helps any i patched my own DSDT as to keep kexts to a minimum.

 

Well nothing on my computer is overclocked and i figured fans could probably keep heat to a minimum but my fear is that running at 100% all the time is going to eventually kill my computer or at the very least blow a few capacitors as ive noticed a faint high frequency sound coming from my computer whenever i use maya or photoshop. and those are programs i have to use daily for work.

 

It just is confusing as to whether or not this is a problem because actual macs run at 100% too.

Share this post


Link to post
Share on other sites

Most likely it's not an issue assuming you have adequate cooling. i.e. Macs are fine. :) So if you have a good heatsink on your CPU etc. then it'll be A-OK. If your computer is too hot it will auto-shutdown.

Share this post


Link to post
Share on other sites

Most likely it's not an issue assuming you have adequate cooling. i.e. Macs are fine. :) So if you have a good heatsink on your CPU etc. then it'll be A-OK. If your computer is too hot it will auto-shutdown.

 

well thank you for trying to put my mind at ease :D. unfortunatly im OCD about my computer lol and wont be able to use it and feel at ease untill i have this issue resolved. I dont want my computer to just shut down :\.. I would really like to be able to use my computer for work and multimedia and have piece of mind knowing that doing so isnt going to shoot my cpu usage up to 100%. (even the installation process of maya shot my cpu up to 100% and made a weird sound). Do you have this CPU usage problem at all?. I created my own DSDT to keep kexts to a minimum and everything is fully functional (even sleep mode) and recognized but i am just wondering if maybe i missed a kext or a lack of kexts is what is causing it..

Share this post


Link to post
Share on other sites

On all cores? Personally I don't have that with my Core 2 Quad, but sometimes 1 core will shoot up to 100%. And I don't use Maya. But...do you have power management working? If you are using NullCPUPowerManagement.kext this will be (part of) the problem.

 

My advice: get the FakeSMC plugins. You can monitor CPU temp from there. But, about auto-shutdown...assuming you have adequate cooling and power management, your idle temp should be around 25-35°C. On load it should cap around 50-70°C. Your CPU can handle temps up to about 100°C without any risk of failure at all, and above 120°C your computer will shut down. Bottom line: unless you installed the heatsink totally wrong or the CPU's bad there's nothing to worry about. :)

 

There isn't anything wrong with running the computer at 100% per sé. Remember this: when working with video editing/animation it takes a LOT of CPU. 100% isn't bad, it just means you're giving your computer a lot of tasks to do. :) You can freak out when your computer exhibits strange behavior. :P

Share this post


Link to post
Share on other sites

Your CPU is ment to run at 100%, it isn't like a car engine.

 

However 60% to run firefox at idle is WAY to much for an i7, what install process did you use? / Have you got any plugins running? Firefox idles at 0.1% and Photoshop CS6 idles at 0.8% on my i5. Unless your talking about when its actually processing something in which case its only a problem if its NOT running at 100% (it should be).

 

High freq noise is however not normal and most likely due to you fitting a cheap PSU or the PSU being defective.

Share this post


Link to post
Share on other sites

High freq noise is however not normal and most likely due to you fitting a cheap PSU or the PSU being defective.

Or something in the monitor.

Share this post


Link to post
Share on other sites

On all cores? Personally I don't have that with my Core 2 Quad, but sometimes 1 core will shoot up to 100%. And I don't use Maya. But...do you have power management working? If you are using NullCPUPowerManagement.kext this will be (part of) the problem.

 

My advice: get the FakeSMC plugins. You can monitor CPU temp from there. But, about auto-shutdown...assuming you have adequate cooling and power management, your idle temp should be around 25-35°C. On load it should cap around 50-70°C. Your CPU can handle temps up to about 100°C without any risk of failure at all, and above 120°C your computer will shut down. Bottom line: unless you installed the heatsink totally wrong or the CPU's bad there's nothing to worry about. :)

 

There isn't anything wrong with running the computer at 100% per sé. Remember this: when working with video editing/animation it takes a LOT of CPU. 100% isn't bad, it just means you're giving your computer a lot of tasks to do. :) You can freak out when your computer exhibits strange behavior. :P

ty for this, made me fee alot better! :D. and since you and others have suggested fakesmc plugins ill probably get that. from what i can remember all cores shot up to 100 percent (very weird) and as far as i know i don't have nullcpupwermanagement because when i did the setup process all i installed was a ethernet kext, the kext to get my computer recognized as a mac pro 3.1, nvidia support kexts, and thats it i believe.

 

In response to rockinron_1: As far as Safari/Firefox goes, upon starting it up it will go to 60% cpu usage then jump down rapidly and it does this every time i load a new page and sometimes more if its flash heavy. when watching movies n such it idles at around 10 to 20% cpu usage i believe. im not booted into my hackintosh at the moment so when i do ill give a more exact estimate,. My PSU is a corsair 1000watt PSU..dont know if its cheap or not it certainly didn't seem like it was tho

Share this post


Link to post
Share on other sites

Ok so i got on my hackintosh to check what the cpu usage really was and here it goes. When i start up safari i get two other processes related to it and those are "Flash Player" and "Safari Web Content".

 

 

Flash Player: Idles at 10% Cpu Usage but when watching a video it shoots up to 28% and stays there till video is done

 

Safari Web Content: Idles at 4% cpu usage and will occasionally spike to 60% for a few seconds when on Hulu

 

Photoshop CS6: Idles at 1% cpu usage but spikes to 100% and stays untill i left off the left mouse button and this is on all cores

 

Maya: idles at 3% cpu usage and goes to 6% when rendering (this is really odd to me)

 

So with that said, i am not sure if these idle percentages are detrimental to my system or if its a case where as long as i don't use photoshop to much i should be fine. Also im beginning to think that apple software is just more cpu intensive..dont know if its poor coding or what but cpu idle usage seems to be much higher on hackintosh/actual mac than it does on a pc.

Share this post


Link to post
Share on other sites

As rockinron said, 100% doesn't equal bad. It equals heavy use. :) What's bad is if the temp spikes.

 

It could be poor coding on the programmer's part, that wouldn't surprise me. Maybe it's a bug in the Mac CS6. In any case, as long as your temp's not out of hand you should be good to go.

Share this post


Link to post
Share on other sites

As rockinron said, 100% doesn't equal bad. It equals heavy use. :) What's bad is if the temp spikes.

 

It could be poor coding on the programmer's part, that wouldn't surprise me. Maybe it's a bug in the Mac CS6. In any case, as long as your temp's not out of hand you should be good to go.

ok good :D ill reboot in a sec to check cpu temps..i noticed if i load 2 pages that are flash intense my computer freaks out but yea im gona restart in a sec and check temps.

 

 

so when i rebooted my computer it says the cpu temp was 39C/100F (not sure if thats too hot for a core i7 930) its actually more hot ust sitting in the bios screen then it was upon usage i believe(its at 40.5C which is 104.5F).

 

Now im not sure if im correct but i thought that i had read somewhere that having fakesmc plugins when you have a dsdt installed will mess things up or make something unstable..is this true?

Share this post


Link to post
Share on other sites

Flash is {censored} and always uses a lot of CPU power.

 

My laptop runs my custom DSDT + FakeSMC plugins fine so go ahead and try it.

 

Your figures seem within normal range but photoshop shouldn't always be at 100% when clicked on (my CS6 runs fine), make sure its up to date. Your temps & other programs seem fine though so don't worry about damaging anything.

 

2 things to check:

1. Install fakeSMC and check your CPU is running at the correct frequency (should hit 2800MHz under load).

2. Check your graphics card is loading a framebuffer. Click the apple logo - more info and the graphics card should be identified exactly, not by a generic series number.

 

As for Maya I've never used the software personally but consider it could be being held by by other limiting factors such as HDD speed.

Share this post


Link to post
Share on other sites

so when i rebooted my computer it says the cpu temp was 39C/100F (not sure if thats too hot for a core i7 930) its actually more hot ust sitting in the bios screen then it was upon usage i believe(its at 40.5C which is 104.5F).

Your idle temp should be around 25-35°C. On load it should cap around 50-70°C. Your CPU can handle temps up to about 100°C without any risk of failure at all, and above 120°C your computer will shut down.

There's your answer. :) And no, the BIOS screen isn't going to be as hot as full (100%) load. But in any case your temperatures are perfectly normal.

Share this post


Link to post
Share on other sites

do as promised and install fakeSMC, also in the apple store there is an app CPUled ( which shows the actual workload of your cpu)

then you have the instruments to monitor your machine out of the menubar.

 

mostly your system should stay at idle spedstep x16 and go up with workload to x38 and 100% on all cores.

if temperature does not exceed 70C on constant load everything is fine. ( the values are for my rig with an i72600k, yours are most likely different)

 

if maya does not go up to 100% while rendering, there is something wrong ( DSDT, SSDT, Smbios)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×