Jump to content
ErmaC

Clover General discussion

22,333 posts in this topic

Recommended Posts

Just now, apianti said:

Yeah, I know because I can read/write/speak Russian... Barely. Haha.

 

Knowing all the curse words doesn't count, man. :))

 

Joking, of course. :D 

Share this post


Link to post
Share on other sites
Advertisement

Oh, sorry! I have C and С at one button and they looks exactly the same. But strange that I had no build error while it must be.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm guessing you probably forgot to switch keyboard layout from RU to EN. And when you look at all that code, it's not really obvious which letter is wrong. The difference is really small. It can happen to anyone. Don't worry about it! But yeah, kinda weird that you haven't gotten any errors while compiling.

 

Also, I wanted to ask you something. :) 

A few pages ago, I mentioned an issue with one of the older themes (Minimalism) when using newer Clover. Now...I checked pointer.icns and it's not present. There's only pointer.png (which is intended). So...any idea how or if this theme can still run with newer Clover? Or do I need to switch to a newer theme entirely? Right now, I just switched to Clovy and that works perfectly fine. I was just wondering if there's still a way to fix that particular one.

 

If it requires too much effort on Clover side, don't worry about it. It's not a big deal. I can use Clovy or another theme and that's it. I feel it might not be worth the trouble, just to get these old themes to work. I just love that simple black and white one.

Edited by arsradu

Share this post


Link to post
Share on other sites
On 5/30/2020 at 1:40 PM, Slice said:

Base -> Procedure

Enable=true -> Disable=false

Identifier -> not needed, there is different sections

Count, Limit, Skip -> these values are default behaviour for Clover

MaxKernel,MinKernel -> MatchOS= All

Thanks for your explanation.

Shaneee, XLNC:

Can you confirm these work for AMD CPUs at 10.15.x ?

Or can you provide the new kernel patches for Clover users ?

Share this post


Link to post
Share on other sites
13 minutes ago, jsl2000 said:

Thanks for your explanation.

Shaneee, XLNC:

Can you confirm these work for AMD CPUs at 10.15.x ?

Or can you provide the new kernel patches for Clover users ?

Not working on mine. Did a lot (really a lot!) of tests yesterday, but mask patching is still not working.

So I'm wondering too, if anyone really got this to work on an old AMD computer (I mean bulldozer 15h_16h patches).

Including my Config.plist file here (deleted serial part). If someone can have a look at the kernel patches part. What is wrong?

config Clover AMD.txt

Share this post


Link to post
Share on other sites
6 hours ago, Slice said:

Oh, sorry! I have C and С at one button and they looks exactly the same. But strange that I had no build error while it must be.

 

Oh, I just realized that as well. I never noticed that before, lol. The cyrillic one is more tall and open where the latin one is shorter and more closed.

 

4 hours ago, Slice said:

AFAIK gcc10 allows to use cyrillic characters inside identifiers.

 

In GCC 10, they added a non-standard extended identifiers extension, enabled by default.

 

4 hours ago, arsradu said:

I'm guessing you probably forgot to switch keyboard layout from RU to EN. And when you look at all that code, it's not really obvious which letter is wrong. The difference is really small. It can happen to anyone. Don't worry about it! But yeah, kinda weird that you haven't gotten any errors while compiling.

 

Also, I wanted to ask you something. :) 

A few pages ago, I mentioned an issue with one of the older themes (Minimalism) when using newer Clover. Now...I checked pointer.icns and it's not present. There's only pointer.png (which is intended). So...any idea how or if this theme can still run with newer Clover? Or do I need to switch to a newer theme entirely? Right now, I just switched to Clovy and that works perfectly fine. I was just wondering if there's still a way to fix that particular one.

 

If it requires too much effort on Clover side, don't worry about it. It's not a big deal. I can use Clovy or another theme and that's it. I feel it might not be worth the trouble, just to get these old themes to work. I just love that simple black and white one.

 

Because this is not a problem in the other compilers since they accept extended character sets for some reason by default... What is wrong with the theme? What needs to be done to fix it? It's just missing that file, can you not just grab it from another theme or make it? Why not try to convert the old theme to svg?

Share this post


Link to post
Share on other sites
3 minutes ago, apianti said:

Because this is not a problem in the other compilers since they accept extended character sets for some reason by default... What is wrong with the theme? What needs to be done to fix it? It's just missing that file, can you not just grab it from another theme or make it? Why not try to convert the old theme to svg?

 

Here's my post from a few pages ago: 

 

The icons are all cut off... And when you use the arrow keys to select the options underneath the drives, those icons get all messed up. I posted screenshot there. :D 

As for converting it to svg, I would gladly do that...if I knew how.

 

Attached is the theme itself, if you wanna take a look.

Minimalism.zip

Share this post


Link to post
Share on other sites
1 hour ago, jsl2000 said:

Thanks for your explanation.

Shaneee, XLNC:

Can you confirm these work for AMD CPUs at 10.15.x ?

Or can you provide the new kernel patches for Clover users ?

 

Yes I've managed to get Zen working now for 10.15.5 using mask patches. I'll PM you.

 

@Slice Is there a Clover version of DummyPowerManagement or could it possibly be added? https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e

Share this post


Link to post
Share on other sites
Posted (edited)
20 minutes ago, Shaneee said:

 

Yes I've managed to get Zen working now for 10.15.5 using mask patches. I'll PM you.

 

@Slice Is there a Clover version of DummyPowerManagement or could it possibly be added? https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e

 

Does the patch not work if you just create it in patches as well?

 

EDIT: Sorry, I don't know if I was clear enough. I mean, does the patch work from config if you just copy the patch properties from the source you linked?

 

EDIT2: Starting here, https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e#diff-321493a74690c4f5eede8a18cce0eae0R883 until line 911 should be what you need. Just wondering if clover will allow an empty find.

Edited by apianti

Share this post


Link to post
Share on other sites
1 hour ago, arsradu said:

 

Here's my post from a few pages ago: 

 

The icons are all cut off... And when you use the arrow keys to select the options underneath the drives, those icons get all messed up. I posted screenshot there. :D 

As for converting it to svg, I would gladly do that...if I knew how.

 

Attached is the theme itself, if you wanna take a look.

 

I think the theme just needs updated with the newer changes that exist now. Seems like mostly the sizing is just off on everything.

Share this post


Link to post
Share on other sites
30 minutes ago, apianti said:

 

Does the patch not work if you just create it in patches as well?

 

EDIT: Sorry, I don't know if I was clear enough. I mean, does the patch work from config if you just copy the patch properties from the source you linked?

 

EDIT2: Starting here, https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e#diff-321493a74690c4f5eede8a18cce0eae0R883 until line 911 should be what you need. Just wondering if clover will allow an empty find.

 

We can patch it manually yes. It's a different patch but has the same function. Was just wondering if it could be baked into Clover for ease.

 

This is what we used before.

 

Name: com.apple.driver.AppleIntelCPUPowerManagement

Find: 05000084 C0

Replace: 050000B0 01

Share this post


Link to post
Share on other sites
6 minutes ago, Shaneee said:

 

We can patch it manually yes. It's a different patch but has the same function. Was just wondering if it could be baked into Clover for ease.

 

This is what we used before.

 

Name: com.apple.driver.AppleIntelCPUPowerManagement

Find: 05000084 C0

Replace: 050000B0 01

 

Oh yeah, then I'm betting someone can indeed add that with relative ease...

Share this post


Link to post
Share on other sites
2 hours ago, Shaneee said:

 

Yes I've managed to get Zen working now for 10.15.5 using mask patches. I'll PM you.

 

@Slice Is there a Clover version of DummyPowerManagement or could it possibly be added? https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e

Glad you got it working! Still getting instant panic on mine ( don't really know what I'm doing thought :rolleyes:)

Share this post


Link to post
Share on other sites
3 hours ago, apianti said:

 

Does the patch not work if you just create it in patches as well?

 

EDIT: Sorry, I don't know if I was clear enough. I mean, does the patch work from config if you just copy the patch properties from the source you linked?

 

EDIT2: Starting here, https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e#diff-321493a74690c4f5eede8a18cce0eae0R883 until line 911 should be what you need. Just wondering if clover will allow an empty find.

If MaskFound=0 then first byte will be found == empty found

Share this post


Link to post
Share on other sites
4 hours ago, Shaneee said:

 

Yes I've managed to get Zen working now for 10.15.5 using mask patches. I'll PM you.

 

@Slice Is there a Clover version of DummyPowerManagement or could it possibly be added? https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e

Hi Shaneee, could you PM your config file too please? I'll have a look to get it working on my fx8350 ...

thanks !

Share this post


Link to post
Share on other sites
Posted (edited)
20 hours ago, Shaneee said:

 

Yes I've managed to get Zen working now for 10.15.5 using mask patches. I'll PM you.

 

@Slice Is there a Clover version of DummyPowerManagement or could it possibly be added? https://github.com/acidanthera/OpenCorePkg/commit/462a831d02da70a1c72d2c472a1d3fc9b2ef750e

@Shaneee

Thanks for your Clover_patches_17h.plist which worked at 10.15.x in my Ryzen 1700X hackintosh, but got instant reboot or freeze  at 10.13.6, 10.14.5, & 10.14.6 no matter using MatchOS or MatchBuild or not.

Can you boot 10.13.x and 10.14.x ?

Can you wake up from S3 sleep at 10.15.x ?

Edited by jsl2000

Share this post


Link to post
Share on other sites
Posted (edited)

 

On 5/31/2020 at 9:02 PM, AntarcticP said:

Not working on mine. Did a lot (really a lot!) of tests yesterday, but mask patching is still not working.

So I'm wondering too, if anyone really got this to work on an old AMD computer (I mean bulldozer 15h_16h patches).

Including my Config.plist file here (deleted serial part). If someone can have a look at the kernel patches part. What is wrong?

config Clover AMD.txt

Please make sure you have used the correct patches for FX (15h_16h) instead of Ryzen (17h) at first.

Besides, need change respective MatchOS from 10.15 to 10.15.x. It should work at 10.15.1~10.15.5.

I can confirm it worked at 10.15.x in both Ryzen 1700X and FX-6300 hackintoshs, but not at 10.13.x or 10.14.x yet !

I need to tune CPU frequency otherwise the audio output was blurred with cracks.

[Edit]

1. After repeated testing try to find the solution at 10.13.x and 10.14.x, I got kernel panic in FX-6300 with this new mask patches for CLOVER. That means I can not regain previous results in FX-6300 now !

Asking for help to fix the following kernel panic:

 

2. It always works at 10.15.x in Ryzen 1700X.

3. Comparison of old (0~63) and new (0~32) kernel patches for 15h/16h I found several differneces as the following:

(1) No respective patches of old (0,1) in new one.

(2) No respective patches of new (7, 16~22 & 24) in old one.

(3) the new 3 (23 bytes) is different from old 6~9 (73 bytes)

(4) the new 5 is different from old 13~14

4. I hope these info can provide someone to fix it as soon as possible !

5. The remaining issues:

(1) Not working for 15h/16h AMD hackintoshs with the new patches for CLOVER

(2) Not working at 10.13.x and 10.14.x for 17h Ryzen hackintoshs with the new patches for CLOVER

[EDIT 2]

1. After repeated trial I can boot to 10.15.1~10.15.3 with my modified patches for 15h_16h in FX-6300 hackintosh now with normal sound output too.

2. It still got KP at 10.15.4 or newer as before.

3. Attached my config.plist for who may want to test.

 

Screen Shot 2020-06-02 at 5.34.10 PM.png

 

IMG_0020.JPG

config.plist

Screen Shot 2020-06-10 at 7.56.19 PM.png

Edited by jsl2000

Share this post


Link to post
Share on other sites

With the help of Shaneee I managed to get Clover booting my 10.15.5 install on fx8350 and RX580. Graphical performance is really slow and sound garbled, but at least booting.

Kernel mask patching layout was really not clear to me, and 'Clover Configurator' app is missing some of the really needed arguments. 

Need to do more testing to see if Whatevergreen is working correctly to speed up performance.

 

My config.plist without serial number attached, so others can test or give advise how to improve ;-)

config_whatevergreen.plist

Share this post


Link to post
Share on other sites
Posted (edited)

1. SSDT-PMC.aml only applicable to 300-series board or it can go higher than that?

2. ForceHPET still working in clover?

	<key>Devices</key>
	<dict>
		<key>ForceHPET</key>
		<false/>
	</dict>

 

Edited by ellaosx

Share this post


Link to post
Share on other sites
4 hours ago, ellaosx said:

1. SSDT-PMC.aml only applicable to 300-series board or it can go higher than that?

2. ForceHPET still working in clover?


	<key>Devices</key>
	<dict>
		<key>ForceHPET</key>
		<false/>
	</dict>

 

1. Need information if it is applicable.

2. Yes, ForceHPET is still here but it will work only if the hardware allowed it to be working.

Share this post


Link to post
Share on other sites

Hi @Slice

 

I probably noticed a small typo/bug in clover menu regarding settings.

 

1. Should be (FAT32)

screenshot0.png.8fed4dc86ac8fa1e5be60083f859feae.png

 

2. In Clover Changes Explanations Topic:

Rev 4427-4429
FixHeaders should be in common ACPI section, it is not DSDT-only fix.
	<key>ACPI</key>
	<dict>
		<key>FixHeaders</key>
		<true/>
The FIX is recommended to all users even if you are not going to fix DSDT. 
Anyway the fix is safe.

But FixHeaders is still inside of ACPI>DSDT>Fixes

screenshot1.png.fc027601b76e01b0688b02d717080ea9.png

Share this post


Link to post
Share on other sites

1. It is because of large font in your chosen them. Other theme, other font -> other result.

2. I see no contradiction. It is a fix for DSDT and SSDT.  The same is correct for binary ACPI patches and for device renaming.

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/31/2020 at 3:11 PM, arsradu said:

The icons are all cut off... And when you use the arrow keys to select the options underneath the drives, those icons get all messed up. I posted screenshot there. :D 

As for converting it to svg, I would gladly do that...if I knew how.

 

Attached is the theme itself, if you wanna take a look.

Minimalism.zip

 

Hey @arsradu, I too love this theme and somehow managed to fix it following the release of Clover 5105 (the one with the new theme engine)...

Here you go!

Minimalism2.zip

Edited by pit256

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

Announcements

  • Similar Content

    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By STLVNUB
      Script file to clone and help build Clover or Opencore repos
      Script will create link to itself in /usr/local/bin/bob
      Script SHOULD fix up any stray bobs you may have.
      Then you only need to type bob. and a parameter
      "a" for ACID repo, official
      "d" for ACID repo DUET build
      "c" for CLOVER
      "e" to erase UDK Folder
      Easier typing bob than.....usual stuff
      YOU WILL NEED TO cmod+x THE SCRIPT
      Enjoy
       
    • By PropoFlexWX4
      After hearing that OpenCore is so much better than Clover, and that it will probably be able to boot Big Sur before Clover does, I decided to take the jump.
       
      Running Catalina 10.15.5 18F101 with OC 0.5.9.
       
      So far I like the result. The OS feels faster, boots faster.
      And absolutely everything works (sleep, network, etc...)
       
      So, that's it? Is there anything else I have to do?
×