Jump to content
ErmaC

Clover General discussion

21,379 posts in this topic

Recommended Posts

Advertisement

I go to the Clover GitHub repository, download the source code of the last commit, then run the ./buildme script from the CloverBootloader folder, after completing the clover building, install it and get a black screen without any text after selecting the drive and pressing the enter key.

Share this post


Link to post
Share on other sites
46 minutes ago, Jief_Machak said:

Could you activate debug log and send the log ?

Yes, I switched on debug in the Clover config.plist, but the preboot.log wasn’t created in the misc folder. :(

Bat by pressing the F2 key, this log was done.

preboot.log

Edited by MakAsus

Share this post


Link to post
Share on other sites
25 minutes ago, Jief_Machak said:

The problem is that you got the log before you pressed a key. The problem seems to be after.

Can you put back a previous Clover version and confirm it's working ? Which version ?

The last working Clover revision: 5104 (master, commit 60b6eb5c3).

CLOVERX64.efi

Edited by MakAsus

Share this post


Link to post
Share on other sites
32 minutes ago, Jief_Machak said:

Did you compile 5104 yourself ?

I tried and I have a debug.log. I had to manually create "misc" folder. Does this folder exist for you ?

I compiled the latest commit Clover v2.5k r5104 (SHA: 2775f5a2d) look in attach. An attempt to boot from it wasn't successful and a log also wasn't found in the misc folder. :(

CLOVERX64.efi

Edited by MakAsus

Share this post


Link to post
Share on other sites

this latest commit (2775f5a2d) is not r5104, it's beyond it. You're, it's the latest and I'm please that some people test the latest dev version. Thanks you.

My question was : the r5104 you put back and confirm it worked, was it compiled by you ?

 

You have to check your config.plist. Is it vaild xml ? Is the

        <key>Debug</key>
        <true/>
in the right place (must be in boot dict) ? Is the folder "misc" exist ?

 

Do you try this new clover from a usb stick ?

Share this post


Link to post
Share on other sites
19 minutes ago, Jief_Machak said:

this latest commit (2775f5a2d) is not r5104, it's beyond it. You're, it's the latest and I'm please that some people test the latest dev version. Thanks you.

My question was : the r5104 you put back and confirm it worked, was it compiled by you ?

 

You have to check your config.plist. Is it vaild xml ? Is the

        <key>Debug</key>
        <true/>
in the right place (must be in boot dict) ? Is the folder "misc" exist ?

 

Do you try this new clover from a usb stick ?

 

I try r5104 (2775f5a2d) (this is really r5104 Beta or there is a problem with tag): it create misc folder. I retry with debug settings ASAP.

 

Edit: strangely pkg or something else (I don't know) add '2d' to commit name '2775f5a'

Edited by Matgen84

Share this post


Link to post
Share on other sites
1 hour ago, Matgen84 said:

 

I try r5104 (2775f5a2d) (this is really r5104 Beta or there is a problem with tag): it create misc folder. I retry with debug settings ASAP.

 

Edit: strangely pkg or something else (I don't know) add '2d' to commit name '2775f5a'

Yes, i have the folder "misc" in EFI/CLOVER and key

<key>Debug</key>
<true/>

exist in my config.plist, bat nothing happen after press enter on the mac disk, the screen is getting dark and log is not creating.

Share this post


Link to post
Share on other sites

The debug log should be created even if you don't press any key. If you see the menu, the debug must be created.

Are you sure to boot on the Clover you think ? Did you put a .VolumeLabel.txt on every Clover partition and usb stick you have ?

Share this post


Link to post
Share on other sites
42 minutes ago, chris1111 said:

After this I don't have any issue to compil and boot

Fix Done

 

Now I can’t build Clover v2.5k r5104 (SHA: 0155a4bf8) from the source.

Here is some errors:

/Users/sergeyls/src/CloverBootloader/rEFIt_UEFI/cpp_unit_test/XStringW_test.cpp:44: error: ignoring #pragma warning  [-Werror=unknown-pragmas]
   44 | #pragma warning(disable : 4066)
      |
cc1plus: all warnings being treated as errors
make: *** [/Users/sergeyls/src/CloverBootloader/Build/Clover/RELEASE_GCC53/X64/rEFIt_UEFI/refit/OUTPUT/cpp_unit_test/XStringW_test.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/sergeyls/src/CloverBootloader/Build/Clover/RELEASE_GCC53/X64/rEFIt_UEFI/refit]


build.py...
 : error F002: Failed to build module
	/Users/sergeyls/src/CloverBootloader/rEFIt_UEFI/refit.inf [X64, GCC53, RELEASE]

- Failed -
Build end time: 13:56:01, Feb.25 2020
Build total time: 00:01:01
Edited by MakAsus

Share this post


Link to post
Share on other sites
15 minutes ago, MakAsus said:

Now I can’t build Clover v2.5k r5104 (SHA: 0155a4bf8) from the source.

Here is some errors:

I don't know because there was another commits after  FIX DONE

Share this post


Link to post
Share on other sites

Tip for getting the right commit from the githab repository:
Open a terminal and paste:
cd ~/src/CloverBootloader/
git checkout <hash> (example: git checkout 60b6eb5c3)
./buildme
Finally, everything is as usual.

Share this post


Link to post
Share on other sites
20 minutes ago, Sherlocks said:

i'm finished latest clover build.

but i'm always getting black screen after enter mac disk.

i'm using buildme with xcode8 option and xcode 11 beta.

is it right? in last official release(https://github.com/CloverHackyColor/CloverBootloader/releases), there is no problem.

I just tested the r5104 and booted into Mojave with no issue. Let me see if the same this is true on Catalina as well.

 

P.S.

It's also working on Catalina 10.15.4 Beta (19E224g) too.

Share this post


Link to post
Share on other sites

@Jief_Machak

I guess I misunderstood @Sherlocks statement I didn't build the latest clover I just used the latest build by using the URL that sherlocks provided which now I just realized that he stated that there is no issues in that build clearly so sorry my bad. :blush:

 

Share this post


Link to post
Share on other sites

Thanks, Pene. Yes, it resolved my issue.

 

Now I have another issue, seems not related to this. Graphical artefacts while I didn't change graphics yet.

screenshot26.png

Someone else confirms?

Share this post


Link to post
Share on other sites
1 hour ago, Slice said:

Now I have another issue, seems not related to this. Graphical artefacts while I didn't change graphics yet.

Someone else confirms?

Yes I also saw also occasional graphical artifacts, which started appearing when I updated to latest code. I have a different theme, but glitches are similar to what is in your screenshot.

Edited by Pene

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By y010204025
      Disclaimer: All files of this article are from itpwd.com and rehabman ’s github.com

       
      After Testing:
       
      Graphics card: NVIDIA K1000M / K2000M / K2100M / K3000M / K3100M / K4000M / M1000M (ordinary TN1600x900 or 1920x1080), AMD W5170M / W7170M (DC2 or 4K), Intel HD4000 (ordinary TN1600x900 or 1920x1080) can be driven normally, but NVIDIA graphics card Brightness adjustment is disabled. AMD W5170m and w7170m are the best choices on 8570W and 8770W. The brightness can be adjusted normally and the graphics performance is very good. For WX7100m and WX4170m, the graphics card fans cannot be controlled, and other methods are required to control the fans. CPU: 3rd generation Intel Core i3, i5 and i7 (Ivy Bridge architecture, including all dual-core and quad-core. Celeron and Pentium are not supported), frequency conversion is normal. In general: If you have 8570W, 8770W, and hope you can get the best Hackintosh experience, it is recommended to replace the CPU with i7-3840QM / i7-3940XM, 8570W is recommended to choose W5170M, 8770W, and it is recommended to choose W7170M. In addition: If you want to have a 4K experience or perfect HIDPI, W5170m / W7170M supports 4K output, you can choose a suitable 4K screen to replace, but because 4K screens are mostly edp interface, and 8570W / 8770W motherboard is lvds interface, This requires a custom screen cable, which seems to be a difficult choice, but you can choose to do it yourself or buy it separately. In China, taobao.com is almighty and may be more suitable for you than eBay.
       
      EFI features:
      out of the box, the relevant hardware can be driven after the OS is installed, and it is easy to use without code operation.
      Supported models: HP EliteBook 8470p, 8570p, 8570w, 8770w (click the model for official specifications)
      Wireless network card: Recommended: BCM94360cd (requires ipex4 to ipex1,3 antenna 1300mbps), BCM94352HMB / DW1550 (2 antennas, 867mbps)
      Wireless characteristics: no white list, wireless network card with Bluetooth does not support the Bluetooth function of the wireless network card (also does not need to shield the pins), but the wireless normal use, you need the Bluetooth function to use this machine comes with Bluetooth:
      Clover version: 5103, keyboard mapping has been added Command key = Alt key, Option key = Win key
      Supported systems: macOS Mojave 10.14.6 (18G103)-macOS Catalina 10.15.x,
       
      Notes on known issues:
      1. The touchpad and the left and right keys under the touchpad are normal, the pointing stick and the left and right keys above the touchpad are temporarily unavailable (recommended to use the second generation of Apple Magic Trackpad)
      2. Indicator display problem (can be ignored, function is normal): Caps light is sometimes not switched in time, mute / wireless key may be yellow
      3.AMD graphics card / Intel nuclear display has supported sleep and 15 levels of brightness adjustment, NVIDIA has no
      4. If the AMD graphics card enters Huaping, refer to editing the Clover startup parameters, and add the Boot parameter radpg = 15 (the EFI file that has been configured with this parameter has been uploaded, refer to the following EFI-guided download link)
      5. Using the above NVIDIA graphics card with a normal TN screen 1600x900 or 1920x1080 can not enter the installation interface, please check whether the VBiOS of the graphics card is exclusively for HP, thank you for your test face K1000M
      6. Due to product design defects, the MSata positions of 8570w and 8770w cannot be used as boot disks, so EFI boot can only be placed on the main hard disk (turn the machine over and open the hard disk in the lower left corner of the cover, which is the main hard disk). Put on msata plate
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Hardware requirements:
      Model: 8470p, 8570p, 8570W, 8770W 1 or more, it is recommended to use another notebook for emergency Hard disk: It is recommended to choose an SSD hard disk of 240g or more. Samsung or Intel SATA hard disk is a good choice. Wireless card: BCM94352HMB, DW1550, BCM94360CD, miniPCIe slot U disk: 1 for 16g and above, another winPE emergency USB disk is recommended If you use a rescue USB flash drive, it means that you read this post carefully
       
      Make and install a USB flash drive:
      Get the mirror: please do it your way Making and installing a USB flash drive: macOS command line production is recommended, whether it is a real macOS model or a virtual machine (although this is not allowed to be discussed in many forums)Or you can choose to use TransMac or ether under Windows. This is not recommended, but it is simple enough for those new to Hackintosh. Make boot U disk: If you know how to put the boot into the installation U disk, unzip the EFI file and put it in the EFI partition, or you can choose a fat32 format U disk to store the EFI file separately Note: EFI is an unzipped folder, not a zip or ISO suffix file.
       
      BIOS settings From RehabMan
      To start, set BIOS to defaults.
      Then insure:
      UEFI boot is enabled (hybrid/with CSM for best result) secure boot is disabled disable fast boot IGPU graphics memory set to 64mb, if available disable the serial port via BIOS option, if available disable "LAN/WLAN switching", if available disable "Extended Idle Power States" if you find it under "Power Management Options" disable "Wake on LAN" and "Wake on USB" disable Firewire/IEEE 1394, if your laptop has it for Skylake and KabyLake laptop, enable "Launch Hotkeys without Fn keypress" Note: If you have a laptop with switchable graphics, leave it enabled. You can still use it on Windows, although the discrete card will be disabled when running OS X by the ACPI patches provided here. If you want to also disable it in Windows (via BIOS option), make sure you read about the DGPU option in your model specific SSDT (source is in SSDT-HACK.dsl), as in the scenario where the DGPU is disabled by BIOS, DGPU should be set to zero.
       
      Install:
      Please modify according to the above BIOS settings: Press F9 after booting, select the boot efi to file option, which is generally the last item. Enter your boot USB disk to find the location of cloverx64.efi, select cloverx64.efi, press Enter, and enter the clover boot interface. Select the location of the install entry and press Enter. Enter the macOS interface, use the disk tool to format the partition you need to install to hfs + or apfs format, do not choose the encryption option, this will make your efforts in vain. Note: The disk must be in gpt format, and the remaining EFI space is greater than 200M, 300mb + is recommended. If it is not, please try to modify it in WindowsPE environment. This may cause you to lose the Windows system boot and disk data. Please prepare for backup.
      After formatting the partition successfully, close the disk tool and select install, you will find the partition you installed, and follow the interface prompts. When the installation reaches a certain progress, it will restart. When restarting, select F9, enter from the boot U disk, select the disk partition where you installed macOS (no longer the U disk installation), the installation will continue, and it may restart 2 ~ 3 times Every time, you need F9 to select the boot. After entering the installation interface, except for the first installation, select the U disk, and then select the disk installation partition. Eventually you will enter the settings interface. After following the interface prompts, you will enter the macOS system interface. Remember the system password and turn off the Find my mac option.  
      Post install:
       
      After the installation is complete, you need to hang the EFI partition of the disk, copy the EFI file of the U disk to the EFI partition of the disk, so that you can directly use the disk to boot, otherwise you need to select the U disk to boot each time. The mount tool can choose cloverconfigurator. If after copying the EFI file to the disk, the computer cannot recognize your clover boot, you can use the custom boot option of bios: set the custom boot path to \efi\clover\cloverx64.efi, and set it as the first boot, Use bootice or easyUEFI to increase the clover boot option under Windows and set it as the first boot. If you do not have a wireless network card available temporarily, you can use the USB binding function of your Android phone to share the network. This may require the HoRndis driver. It is not recommended to use a US wireless network card. If you need Windows or Linux, you can install it normally. Be careful not to let Windows overwrite your boot files.  
      For other uses of macOS and brew, please pay attention to forums and other communities. Hackintosh is just the beginning.
       
      Finally, I would like to thank rehabman, vit9696 and others who contributed to Hackintosh. I also thank Cwen for his efforts to modify files and hardware tests. I hope that Hackintosh will be eternal.
       
      Please comply with the laws and regulations of your country or region. My description may not be clear or professional, but I think it is necessary. I think the existence of Hackintosh is everyone's technical hobby and experience macOS, not as a substitute for macOS cheap hardware.

      EFI_8x70_5103_W7170m_20200116 .zip
    • By StarFighter_77
      I built this hack years ago now. Started with Lion, now on El Cap. I want to update now to High Sierra.

      I think I messed up my Clover when I downloaded the update .pkg and just installed it without taking my time or customizing the install. Was on Clover r3423, now I think I'm on r5104

      I've been searching and reading this site and others for a few days before making this thread, but I need help compiling what I've learned to get my system running correctly again and ready to update to High Sierra. Then, eventually, I want to update my graphics card, switch to UEFI (if necessary) and update to Mojave.

      I couldn't get system to boot. Could get to Clover and all the options, except the Shell... I hit enter on the Shell and I get black screen and nothing.

      The only way I got it to boot was to add -v to boot args, and change smbios from 14,2 to 13,2. Not sure why that worked still. Also I'm running two monitors, but I can only now run one of them off the Intel 3000 Graphics and the second one off my GFX Card.

      So now I'm afraid to shut down or reboot.... I could really use some help with Clover.

      I'm pretty sure my config file in Clover is not right. Also, some of the files in my Clover backups are not in the new Clover install. (2.5k 5104)

      If someone could please take a look at the files I've attached and help me sort this out, I would be grateful. Thank you, Thank you, Thank you.

      I've attached
      - The last boot log
      - The current Clover folder from the EFI partition after performing Clover update. (.zip)
      - The Clover backup that was working before Clover update (.zip)
      - Library/Extensions Folder (screen shot)
      - System/Library/Extensions Folder (.zip)

      Here is my current hardware:

      Mobo: GIGABYTE GA-Z68MX-UD2H-B3

      CPU: Intel Core i7-2600K

      GPU: GIGABYTE ATI Radeon HD6870 1GB DDR5 2DVI/HDMI/2x

      RAM: Corsair Vengeance Blue 16 GB DDR3 SDRAM Dual Channel Memory Kit CMZ16GX3M4A1600?C9B

      HD0 (for OS and Apps): OCZ Technology 120 GB Vertex Series SATA II Solid State Drive

      HD1 (file storage, Adobe scratch disk): Samsung 1 TB Spinpoint 7200 RPM 32MB Cache SATA

      BURNER: LG CD/DVD Burner Model GH22NS50

      CPU COOLER: Corsair Cooling Hydro Series H50 All in One High-performanc?e CPU Cooler CWCH50-1

      P/S: Antec CP-850 850 Watt CPX Power Supply Unit

      CASE: Antec Performance One P183 V3 Case
      CLOVER.zip
      CloverBackup.zip
      bootlog.txt

      S_L_E.zip
×