Jump to content
ErmaC

Clover General discussion

21,380 posts in this topic

Recommended Posts

Advertisement
2 minutes ago, Slice said:

@fabiosun

What can I do with this knowledge?

maybe you have the skill to understand why TRX40 chip fails to boot with a memory allocation errors on both main bootloader..i mean clover and acidanthera one :)

 

Share this post


Link to post
Share on other sites
8 hours ago, Slice said:

Can you show asm codes for both cases? Where is the difference?

Historically only i++ and --i had a sense because they came from PDP11 assembler where there are instruction like

MOV (R1)+,R2

MOV R3, -(SP)

So C languages is very close to those machine codes.

Intel codes are different.

 

It is inherent in the behavior of the operator. Those CPUs have a special instruction specifically to do that, it is not very common because it is super expensive. No modern CPU has any instruction like this. The most optimized code for an increment would look like these, prefix:

mov rax, [address_of_variable_to_increment]
inc rax
mov [address_of_variable_to_increment], rax

postfix:

mov rax, [address_of_variable_to_increment]
mov rbx, rax
inc rbx
mov [address_of_variable_to_increment], rbx

This is the MOST optimized that either of these operators could be, most likely there is other stuff in registers though so you need to use graph coloring algorithm to determine how to use the registers most efficiently. I've only ever seen the prefix operator come out this optimized.

 

EDIT: I forgot you could do direct memory access, although I doubt the compiler is using these but this will actually make the postfix operator perform even worse compared to the prefix,

prefix:

inc [address_of_variable_to_increment]

postfix still has to operate some way like above.

 

EDIT2: Forgot, that those operators were created in B for convenience not C (C followed B's development at Bell Labs), the PDP-11 just easily supported these because of it's crazy complicated access modes, it didn't even exist yet when those operators were created. Dennis Ritchie even says so:

Quote

People often guess that they were created to use the auto-increment and auto-decrement address modes provided by the DEC PDP-11 on which C and Unix first became popular. This is historically impossible, since there was no PDP-11 when B was developed. 

 

Edited by apianti

Share this post


Link to post
Share on other sites

@fabiosun As I have explained various times, the cause for memory allocation errors is well known and fixed (DevirtualiseMmio) - this has nothing to do with any data sheets. Why booting fails can only be debugged with serial or by trying whitelisting all devirtualised regions one-by-one, in pairs, and so on. Taking 5 steps back towards devs who also don't have the hardware will not solve your issue.

Share this post


Link to post
Share on other sites
23 minutes ago, Download-Fritz said:

@fabiosun ……... by trying whitelisting all devirtualised regions one-by-one, in pairs, and so on. …….

Thank for your answer also in this thread

 

If you have some time to dedicate to explain "how to" apply your usefull advice in quoted part i will like to try to help people who have the right skills to understand.

 

By the way..it is no a problem of mine (my main interest is in Windows OS)..as it wasn't problem of mine when a pretty similar (initial problem) x99 Platform had with some highend xeon CPU and some people of acidanthera's staff were interested of doing betatesting to some people have v3 or v4 Xeon.

I know AMD it is not a main (or secondary) task for your team so i would like to understand if it the same for clover team 

 

Edited by fabiosun

Share this post


Link to post
Share on other sites
1 hour ago, Jief_Machak said:

I've already fixed that.

I've just recompiled from scratch and it works. Are you up to date ?

Yes I am up to date its look like the same error 

Dont know why

Share this post


Link to post
Share on other sites
1 hour ago, chris1111 said:

Compillation is good but only error when create the Package

 

Thanks

 

1592501944_Capturedcranle2020-02-2105_00_51.png.a533b8740efbbc6c76976780ccd12a5e.png

 

 

Same issue here. :wacko:

 

Lastest commit without error, and create package: r5104 200237d492.

Share this post


Link to post
Share on other sites
1 hour ago, Download-Fritz said:

@fabiosun dump thr log and add the logged addresses to the whitelist array

if you mean a log via serial output , in my tries it was not possible also with pciexpress serial card, previously i have also tested an USB to serial adapter without success (i need a driver for it you or vit9696  suggested in the past)

Normal debug output of OC (or clover) seems to have no significative data on it

 

thank you again for your time

Share this post


Link to post
Share on other sites
8 hours ago, Slice said:

Windows compilation by VS2017 is working

 

I don't know but your latest commit fix the issue 

thanks

Edited by chris1111

Share this post


Link to post
Share on other sites


 --------------------------
 Building process complete!
 --------------------------

 Build info.
 ===========
  Package name: Clover_v2.5k_r5104.pkg
  MD5:          9a9263b5e8340380bbf64a62b83d9996
  Version:      v2.5k
  Stage:        v2.5k
  Date/Time:    2020-02-21 17:11:57
  Built by:     pico
  Copyright     2012-2020

Share this post


Link to post
Share on other sites

report warning message when build

Spoiler

Active Platform          = /Users/sherlocks/src/CloverBootloader/Clover.dsc

........build: : warning: Module MetaFile [Sources] is missing local header!

    Local Header: /users/sherlocks/src/cloverbootloader/refit_uefi/version.h not found in /Users/sherlocks/src/CloverBootloader/rEFIt_UEFI/refit.inf

build: : warning: Module MetaFile [Sources] is missing local header!

    Local Header: /users/sherlocks/src/cloverbootloader/refit_uefi/version.h not found in /Users/sherlocks/src/CloverBootloader/rEFIt_UEFI/refit.inf

. done!

 

Share this post


Link to post
Share on other sites
1 hour ago, Alpha22 said:

hi, how can i run Building Clover install package

thank you

 

If I remember well:

 

Go to Clover GitHub repo, download source

Launch buildme script in cloverbootloader folder

Share this post


Link to post
Share on other sites
8 minutes ago, Matgen84 said:

 

If I remember well:

 

Go to Clover GitHub repo, download source

Launch buildme script in cloverbootloader folder

Thanks

Share this post


Link to post
Share on other sites

the "built"-script currently runs into an error:

 

Spoiler

[CPP] Events
[CPP] FixBiosDsdt
[CPP] HdaCodecDump
[CPP] Hibernate
[CPP] Injectors
[CPP] LegacyBiosThunk
[CPP] LegacyBoot
[CPP] Net
[CPP] Nvram
[CPP] PlatformDriverOverride
[CPP] Pointer
[CPP] Settings
[CPP] StartupSound
[CPP] StateGenerator
[CPP] ati
[CPP] b64cdecode
[CPP] card_vlist
[CPP] cpu
[CPP] device_inject
[CPP] gma
[CPP] guid
[CPP] hda
[CPP] kernel_patcher
[CPP] kext_inject
[CPP] kext_patcher
[CPP] nvidia
[CPP] platformdata
[CPP] plist
[CPP] smbios
[CPP] sound
[CPP] spd
[CPP] string
[CPP] usbfix
[CPP] XStringW
[CPP] global1
[CPP] global2
[CPP] globals_ctor
[CPP] globals_dtor
[CPP] memory
[CPP] operatorNewDelete
[CPP] bootscreen
[CPP] common
[CPP] legacy
[CPP] loader
[CPP] lockedgraphics
[CPP] secureboot
[CPP] securehash
[CPP] securemenu
[CPP] securevars
[CPP] tool
[CPP] BmLib
[CPP] FloatLib
[CPP] VectorGraphics
[CPP] egemb_font
[CPP] egemb_icons
[CPP] egemb_icons_dark
[CPP] image
[CPP] libscreen
[CPP] load_icns
[CPP] lodepng
[CPP] nanosvg
[CPP] nanosvgrast
[CPP] scroll_images
[CPP] text
[CPP] IO
[CPP] icns
[CPP] lib
[CPP] main
[CPP] menu
[CPP] screen
[SLINK] CLOVER
/Users/md/Documents/GitHub/CloverBootloader/toolchain/cross/lib/gcc/x86_64-clover-linux-gnu/9.2.0/../../../../x86_64-clover-linux-gnu/bin/ld: /var/folders/xx/pnhrh8mj3d33s9s8mmtxksy80000gn/T//CLOVER.dll.712WqB.ltrans13.ltrans.o: in function `RefitMain':
/Users/md/Documents/GitHub/CloverBootloader/rEFIt_UEFI/refit/main.cpp:2076: undefined reference to `all_tests()'
/Users/md/Documents/GitHub/CloverBootloader/toolchain/cross/lib/gcc/x86_64-clover-linux-gnu/9.2.0/../../../../x86_64-clover-linux-gnu/bin/ld: /Users/md/Documents/GitHub/CloverBootloader/Build/Clover/RELEASE_GCC53/X64/rEFIt_UEFI/refit/DEBUG/CLOVER.dll: hidden symbol `_Z9all_testsv' isn't defined
/Users/md/Documents/GitHub/CloverBootloader/toolchain/cross/lib/gcc/x86_64-clover-linux-gnu/9.2.0/../../../../x86_64-clover-linux-gnu/bin/ld: final link failed: bad value
collect2: error: ld returned 1 exit status
make: *** [/Users/md/Documents/GitHub/CloverBootloader/Build/Clover/RELEASE_GCC53/X64/rEFIt_UEFI/refit/DEBUG/CLOVER.dll] Error 1


build.py...
 : error 7000: Failed to execute command
    make tbuild [/Users/md/Documents/GitHub/CloverBootloader/Build/Clover/RELEASE_GCC53/X64/rEFIt_UEFI/refit]


build.py...
 : error F002: Failed to build module
    /Users/md/Documents/GitHub/CloverBootloader/rEFIt_UEFI/refit.inf [X64, GCC53, RELEASE]

- Failed -
Build end time: 17:46:20, Feb.24 2020
Build total time: 00:00:37

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By y010204025
      Disclaimer: All files of this article are from itpwd.com and rehabman ’s github.com

       
      After Testing:
       
      Graphics card: NVIDIA K1000M / K2000M / K2100M / K3000M / K3100M / K4000M / M1000M (ordinary TN1600x900 or 1920x1080), AMD W5170M / W7170M (DC2 or 4K), Intel HD4000 (ordinary TN1600x900 or 1920x1080) can be driven normally, but NVIDIA graphics card Brightness adjustment is disabled. AMD W5170m and w7170m are the best choices on 8570W and 8770W. The brightness can be adjusted normally and the graphics performance is very good. For WX7100m and WX4170m, the graphics card fans cannot be controlled, and other methods are required to control the fans. CPU: 3rd generation Intel Core i3, i5 and i7 (Ivy Bridge architecture, including all dual-core and quad-core. Celeron and Pentium are not supported), frequency conversion is normal. In general: If you have 8570W, 8770W, and hope you can get the best Hackintosh experience, it is recommended to replace the CPU with i7-3840QM / i7-3940XM, 8570W is recommended to choose W5170M, 8770W, and it is recommended to choose W7170M. In addition: If you want to have a 4K experience or perfect HIDPI, W5170m / W7170M supports 4K output, you can choose a suitable 4K screen to replace, but because 4K screens are mostly edp interface, and 8570W / 8770W motherboard is lvds interface, This requires a custom screen cable, which seems to be a difficult choice, but you can choose to do it yourself or buy it separately. In China, taobao.com is almighty and may be more suitable for you than eBay.
       
      EFI features:
      out of the box, the relevant hardware can be driven after the OS is installed, and it is easy to use without code operation.
      Supported models: HP EliteBook 8470p, 8570p, 8570w, 8770w (click the model for official specifications)
      Wireless network card: Recommended: BCM94360cd (requires ipex4 to ipex1,3 antenna 1300mbps), BCM94352HMB / DW1550 (2 antennas, 867mbps)
      Wireless characteristics: no white list, wireless network card with Bluetooth does not support the Bluetooth function of the wireless network card (also does not need to shield the pins), but the wireless normal use, you need the Bluetooth function to use this machine comes with Bluetooth:
      Clover version: 5103, keyboard mapping has been added Command key = Alt key, Option key = Win key
      Supported systems: macOS Mojave 10.14.6 (18G103)-macOS Catalina 10.15.x,
       
      Notes on known issues:
      1. The touchpad and the left and right keys under the touchpad are normal, the pointing stick and the left and right keys above the touchpad are temporarily unavailable (recommended to use the second generation of Apple Magic Trackpad)
      2. Indicator display problem (can be ignored, function is normal): Caps light is sometimes not switched in time, mute / wireless key may be yellow
      3.AMD graphics card / Intel nuclear display has supported sleep and 15 levels of brightness adjustment, NVIDIA has no
      4. If the AMD graphics card enters Huaping, refer to editing the Clover startup parameters, and add the Boot parameter radpg = 15 (the EFI file that has been configured with this parameter has been uploaded, refer to the following EFI-guided download link)
      5. Using the above NVIDIA graphics card with a normal TN screen 1600x900 or 1920x1080 can not enter the installation interface, please check whether the VBiOS of the graphics card is exclusively for HP, thank you for your test face K1000M
      6. Due to product design defects, the MSata positions of 8570w and 8770w cannot be used as boot disks, so EFI boot can only be placed on the main hard disk (turn the machine over and open the hard disk in the lower left corner of the cover, which is the main hard disk). Put on msata plate
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Hardware requirements:
      Model: 8470p, 8570p, 8570W, 8770W 1 or more, it is recommended to use another notebook for emergency Hard disk: It is recommended to choose an SSD hard disk of 240g or more. Samsung or Intel SATA hard disk is a good choice. Wireless card: BCM94352HMB, DW1550, BCM94360CD, miniPCIe slot U disk: 1 for 16g and above, another winPE emergency USB disk is recommended If you use a rescue USB flash drive, it means that you read this post carefully
       
      Make and install a USB flash drive:
      Get the mirror: please do it your way Making and installing a USB flash drive: macOS command line production is recommended, whether it is a real macOS model or a virtual machine (although this is not allowed to be discussed in many forums)Or you can choose to use TransMac or ether under Windows. This is not recommended, but it is simple enough for those new to Hackintosh. Make boot U disk: If you know how to put the boot into the installation U disk, unzip the EFI file and put it in the EFI partition, or you can choose a fat32 format U disk to store the EFI file separately Note: EFI is an unzipped folder, not a zip or ISO suffix file.
       
      BIOS settings From RehabMan
      To start, set BIOS to defaults.
      Then insure:
      UEFI boot is enabled (hybrid/with CSM for best result) secure boot is disabled disable fast boot IGPU graphics memory set to 64mb, if available disable the serial port via BIOS option, if available disable "LAN/WLAN switching", if available disable "Extended Idle Power States" if you find it under "Power Management Options" disable "Wake on LAN" and "Wake on USB" disable Firewire/IEEE 1394, if your laptop has it for Skylake and KabyLake laptop, enable "Launch Hotkeys without Fn keypress" Note: If you have a laptop with switchable graphics, leave it enabled. You can still use it on Windows, although the discrete card will be disabled when running OS X by the ACPI patches provided here. If you want to also disable it in Windows (via BIOS option), make sure you read about the DGPU option in your model specific SSDT (source is in SSDT-HACK.dsl), as in the scenario where the DGPU is disabled by BIOS, DGPU should be set to zero.
       
      Install:
      Please modify according to the above BIOS settings: Press F9 after booting, select the boot efi to file option, which is generally the last item. Enter your boot USB disk to find the location of cloverx64.efi, select cloverx64.efi, press Enter, and enter the clover boot interface. Select the location of the install entry and press Enter. Enter the macOS interface, use the disk tool to format the partition you need to install to hfs + or apfs format, do not choose the encryption option, this will make your efforts in vain. Note: The disk must be in gpt format, and the remaining EFI space is greater than 200M, 300mb + is recommended. If it is not, please try to modify it in WindowsPE environment. This may cause you to lose the Windows system boot and disk data. Please prepare for backup.
      After formatting the partition successfully, close the disk tool and select install, you will find the partition you installed, and follow the interface prompts. When the installation reaches a certain progress, it will restart. When restarting, select F9, enter from the boot U disk, select the disk partition where you installed macOS (no longer the U disk installation), the installation will continue, and it may restart 2 ~ 3 times Every time, you need F9 to select the boot. After entering the installation interface, except for the first installation, select the U disk, and then select the disk installation partition. Eventually you will enter the settings interface. After following the interface prompts, you will enter the macOS system interface. Remember the system password and turn off the Find my mac option.  
      Post install:
       
      After the installation is complete, you need to hang the EFI partition of the disk, copy the EFI file of the U disk to the EFI partition of the disk, so that you can directly use the disk to boot, otherwise you need to select the U disk to boot each time. The mount tool can choose cloverconfigurator. If after copying the EFI file to the disk, the computer cannot recognize your clover boot, you can use the custom boot option of bios: set the custom boot path to \efi\clover\cloverx64.efi, and set it as the first boot, Use bootice or easyUEFI to increase the clover boot option under Windows and set it as the first boot. If you do not have a wireless network card available temporarily, you can use the USB binding function of your Android phone to share the network. This may require the HoRndis driver. It is not recommended to use a US wireless network card. If you need Windows or Linux, you can install it normally. Be careful not to let Windows overwrite your boot files.  
      For other uses of macOS and brew, please pay attention to forums and other communities. Hackintosh is just the beginning.
       
      Finally, I would like to thank rehabman, vit9696 and others who contributed to Hackintosh. I also thank Cwen for his efforts to modify files and hardware tests. I hope that Hackintosh will be eternal.
       
      Please comply with the laws and regulations of your country or region. My description may not be clear or professional, but I think it is necessary. I think the existence of Hackintosh is everyone's technical hobby and experience macOS, not as a substitute for macOS cheap hardware.

      EFI_8x70_5103_W7170m_20200116 .zip
    • By StarFighter_77
      I built this hack years ago now. Started with Lion, now on El Cap. I want to update now to High Sierra.

      I think I messed up my Clover when I downloaded the update .pkg and just installed it without taking my time or customizing the install. Was on Clover r3423, now I think I'm on r5104

      I've been searching and reading this site and others for a few days before making this thread, but I need help compiling what I've learned to get my system running correctly again and ready to update to High Sierra. Then, eventually, I want to update my graphics card, switch to UEFI (if necessary) and update to Mojave.

      I couldn't get system to boot. Could get to Clover and all the options, except the Shell... I hit enter on the Shell and I get black screen and nothing.

      The only way I got it to boot was to add -v to boot args, and change smbios from 14,2 to 13,2. Not sure why that worked still. Also I'm running two monitors, but I can only now run one of them off the Intel 3000 Graphics and the second one off my GFX Card.

      So now I'm afraid to shut down or reboot.... I could really use some help with Clover.

      I'm pretty sure my config file in Clover is not right. Also, some of the files in my Clover backups are not in the new Clover install. (2.5k 5104)

      If someone could please take a look at the files I've attached and help me sort this out, I would be grateful. Thank you, Thank you, Thank you.

      I've attached
      - The last boot log
      - The current Clover folder from the EFI partition after performing Clover update. (.zip)
      - The Clover backup that was working before Clover update (.zip)
      - Library/Extensions Folder (screen shot)
      - System/Library/Extensions Folder (.zip)

      Here is my current hardware:

      Mobo: GIGABYTE GA-Z68MX-UD2H-B3

      CPU: Intel Core i7-2600K

      GPU: GIGABYTE ATI Radeon HD6870 1GB DDR5 2DVI/HDMI/2x

      RAM: Corsair Vengeance Blue 16 GB DDR3 SDRAM Dual Channel Memory Kit CMZ16GX3M4A1600?C9B

      HD0 (for OS and Apps): OCZ Technology 120 GB Vertex Series SATA II Solid State Drive

      HD1 (file storage, Adobe scratch disk): Samsung 1 TB Spinpoint 7200 RPM 32MB Cache SATA

      BURNER: LG CD/DVD Burner Model GH22NS50

      CPU COOLER: Corsair Cooling Hydro Series H50 All in One High-performanc?e CPU Cooler CWCH50-1

      P/S: Antec CP-850 850 Watt CPX Power Supply Unit

      CASE: Antec Performance One P183 V3 Case
      CLOVER.zip
      CloverBackup.zip
      bootlog.txt

      S_L_E.zip
×