Jump to content
ErmaC

Clover General discussion

21,408 posts in this topic

Recommended Posts

Hi again

Starting from r5099, im getting stuck on error DMMP.

Do i need to rename this like the DSM to XDSM?

I never had this error. It only appeared after the commit in FixBiosDsdt.c.

Computer in question is my Desktop Legacy

Share this post


Link to post
Share on other sites
Advertisement
5 hours ago, Sherlocks said:

 

how can we back it like a real mac?

well, if dev don't want, you could only hex patch clover binary file)

Share this post


Link to post
Share on other sites
On 12/9/2019 at 6:02 AM, Matgen84 said:

 

Just type OcQuirks on GitHub, you find this new memoryfix driver for Clover.

Doesn't work for me. I still have to use the "free" version.

Share this post


Link to post
Share on other sites
8 hours ago, Sherlocks said:

just add disable option if user dont want and keep vanilla.

 

I'd second that. I know it's only cosmetic but it still bugs me which is why I've stuck with the last Clover revision before the change was made.

Share this post


Link to post
Share on other sites
6 hours ago, Slice said:

You may do it by yourself.

Introduce a key in config.plist and insert line

if (!NoRomInfo) PatchTableType11();

 

thanks slice. after check, i will commit it

 

EDIT1.

committed

yes we back hardware overview like real mac, if you want it, add NoRomInfo TRUE in smbios part in config.

2118805010_2019-12-1312_02_30.png.f1ae94542893545de02f4b9de175c7af.png

Edited by Sherlocks

Share this post


Link to post
Share on other sites

For option 2 do I have to provide HFSPlus myself?

 

buildme, Clover v2.5k r5100 (SHA: f3797c12)
TOOLCHAIN: GCC53 (override example: './buildme XCODE8')

 1) build Clover
 2) build Clover with HFSPlus
 3) make pkg
 4) make app
 5) make iso
 6) build all
 7) test build (no autogen, no boot files)
 8) status
 9) update Clover
10) update Clover (reset changes)
11) show diff
12) open drivers directory
13) clean BaseTools
14) quit
Please enter your choice: 

 

Edited by D-an-W

Share this post


Link to post
Share on other sites
11 minutes ago, D-an-W said:

For option 2 do I have to provide HFSPlus myself?

Sure as it is owned by Apple. Goes in:

CloverBootloader/FileSystems/HFSPlus/X64/HFSPlus.efi

 

Edited by vector sigma

Share this post


Link to post
Share on other sites

@Slice

Can you complete your implementation of this protocol? Thank you!

https://github.com/CloverHackyColor/CloverBootloader/blob/master/rEFIt_UEFI/Platform/Injectors.c#L350-L355

 

//obligatory protocol
  Status = gBS->InstallProtocolInterface (&gImageHandle,
  &gDevicePropertiesGuid,
  EFI_NATIVE_INTERFACE,
  &mDeviceProperties
  );
Edited by maleorderbride

Share this post


Link to post
Share on other sites
5 hours ago, Download-Fritz said:

@maleorderbride Out of curiousity, what are you planning to use it for?

I am attempting to inject some thunderbolt AAPL,PathProperties via .efi, but am unable to do so in Clover. OpenCore supports it, but Clover does not yet.

 

Even removing this partial implementation in Clover would be an improvement since then I could use EfiDevicePathPropertyDatabase.efi to enable AAPL,PathProperties injection via .efi, which used to work in older versions of Clover before Clover partially enabled this feature.

Edited by maleorderbride

Share this post


Link to post
Share on other sites

Hi @vector sigma

 

Sorry for my stupid question: I don't understand this line in  Builme

 

buildCloverHFSPlus() {
if [[ -f "${CLOVERROOT}"/FileSystems/HFSPlus/X64/HFSPlus.efi ]]; then
  echo "building Clover with HFSPlus"
  buildClover HFSPlus
else
  echo "${CLOVERROOT}/FileSystems/HFSPlus/X64/HFSPlus.efi: no such file!"
  sleep 3
  menu
fi
}

There is no HFSPlus.efi in CloverBootloader Repo, we've to add manually in this specific directory in local repo.

 

Actually, I use "custom build script" to that: add to Clover PKG :) What is the good way to add HFSPlus.efi.

 

Please

Share this post


Link to post
Share on other sites
12 minutes ago, Matgen84 said:

Hi @vector sigma

 

Sorry for my stupid question: I don't understand this line in  Builme

 


buildCloverHFSPlus() {
if [[ -f "${CLOVERROOT}"/FileSystems/HFSPlus/X64/HFSPlus.efi ]]; then
  echo "building Clover with HFSPlus"
  buildClover HFSPlus
else
  echo "${CLOVERROOT}/FileSystems/HFSPlus/X64/HFSPlus.efi: no such file!"
  sleep 3
  menu
fi
}

 

If ../FileSystems/HFSPlus/X64/HFSPlus.efi exists then build Clover EFI with embedded HFSPlus instead of VBoxHfs

Otherwise tell the user that doesn't have HFSPlus, sleep 3 seconds and reload the initial menu.

12 minutes ago, Matgen84 said:

There is no HFSPlus.efi in CloverBootloader Repo, we've to add manually in this specific directory in local repo.

Is what I wrote 4 posts above your in this page.

 

12 minutes ago, Matgen84 said:

Actually, I use "custom build script" to that: add to Clover PKG :) What is the good way to add HFSPlus.efi.

I'm not sure your custom build script will embed HFSPlus inside boot6 or boot7 :D.

Edited by vector sigma

Share this post


Link to post
Share on other sites
18 hours ago, D-an-W said:

Ok thanks, is there only one version of the file?

it is coming from the Apple firmware, so I cannot know if and when they are going to update it. But I'm 99% sure that Apple have no great interest in making changes to an old driver used for years ... considering now it uses apfs.

Share this post


Link to post
Share on other sites
3 minutes ago, vector sigma said:

If ../FileSystems/HFSPlus/X64/HFSPlus.efi does notexist then build Clover EFI with embedded HFSPlus instead of VBoxHfs

Otherwise tell the user that doesn't have HFSPlus, sleep 3 seconds and reload the initial menu.

Is what I wrote 4 posts above your in this page.

 

I'm not sure your custom build script will embed HFSPlus inside boot6 or boot7 :D.

 

After a few days in the hospital, my mind is not clear. Sorry.

 

Right, my custom script don't embed HFSPlus inside boot 6 or boot7 for my UEFI system. If I understand well, option 2 is optional. Is it mandatory to embed VBoxHFS or HFPlus to Clover Boot :) I want to use Clover Installer like before.

 

My english is very bad

Share this post


Link to post
Share on other sites
18 minutes ago, Matgen84 said:

After a few days in the hospital, my mind is not clear. Sorry.

oh, Hope you're be well soon :)

18 minutes ago, Matgen84 said:

Right, my custom script don't embed HFSPlus inside boot 6 or boot7 for my UEFI system. If I understand well, option 2 is optional. Is it mandatory to embed VBoxHFS or HFPlus to Clover Boot :) I want to use Clover Installer like before.

Is it not mandatory to use this option. HFSPlus should be used only for UEFi boot as boot6/7 already has an HFS driver. I.e. there is no need to add it to drivers/BIOS. If you use both, Is not clear what driver will be used or anyway you are going to load both and I really don't know which one will win or if some conflicts are going to happen. 

buildme tells ebuild.sh to use HFSPlus for legacy boot and also add it to the FileSystem drivers for UEFI booting, skipping VboxHfs (so will show up in the pkg). More than one driver is embedded, but if no HFSPlus is provided, VboxHfs will be used anyway.

Edited by vector sigma
typos

Share this post


Link to post
Share on other sites
1 hour ago, Matgen84 said:

 

After a few days in the hospital, my mind is not clear. Sorry.

 

Right, my custom script don't embed HFSPlus inside boot 6 or boot7 for my UEFI system. If I understand well, option 2 is optional. Is it mandatory to embed VBoxHFS or HFPlus to Clover Boot :) I want to use Clover Installer like before.

 

My english is very bad

curl -L https://raw.githubusercontent.com/JrCs/CloverGrowerPro/master/Files/HFSPlus/X64/HFSPlus.efi -o /tmp/HFSPlus.efi
cp -rp "$3"/tmp/HFSPlus.efi ~/src/CloverBootloader/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/FileSystem
Sleep 1

rm -rf /tmp/HFSPlus.efi
echo "**********************************************  "
echo "HFSPlus Installed done. " 

Share this post


Link to post
Share on other sites
17 hours ago, vector sigma said:

oh, Hope you're be well soon :)

Is it not mandatory to use this option. HFSPlus should be used only for UEFi boot as boot6/7 already has an HFS driver. I.e. there is no need to add it to drivers/BIOS. If you use both, Is not clear what driver will be used or anyway you are going to load both and I really don't know which one will win or if some conflicts are going to happen. 

buildme tells ebuild.sh to use HFSPlus for legacy boot and also add it to the FileSystem drivers for UEFI booting, skipping VboxHfs (so will show up in the pkg). More than one driver is embedded, but if no HFSPlus is provided, VboxHfs will be used anyway.

It was special improvement in CloverEFI (file boot6 or boot7) for external driver will be winner.

It means that if boot6 was compiled with VBosHFS.efi and the folder drivers/BIOS contains HFSPlus.efi then the last will be winner. And vice versa.

Share this post


Link to post
Share on other sites
On 12/13/2019 at 6:45 AM, artur_pt said:

hello Slice 

 

Clover last commit

 

Captura de ecrã 2019-12-13, às 14.43.06.png

 

thanks

got the same thing? has this been sorted out?

 

 

 

Edited by tluck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By STLVNUB
      Script file to clone Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By TimothyF
      My PROBLEM: I followed the Plain Vanilla guide (https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/) to a T in creating the OS X Catalina installer USB. I'm totally new to Hackintosh, and just want an Apple environment to Time Machine migrate my files and system from my ageing MacBook Pro. When I start to use the USB on the target PC (Dell Inspiron 3847 desktop), I ONLY see the Microsoft (which is the original OS, and on a SEPARATE Hard drive from where I want to install Mac OS), ZERO option for installing the OSX Catalina! Please SEE PICTURE link: https://imgur.com/a/FnLB2Q9   I'm a beginner, but I tried to google my problem. The answers were either incomplete, hard for me to understand and put into action, or were outdated and applied to older OSXs. I appreciate any help in diagnosing and solving this problem!   Clover USB specs OS installer used: Catalina (10.15) Clover revision: 5103 Kexts included: ATH9KFixup.kext AppleALC.kext Lilu.kext RealtekRTL8111.kext USBInjectAll.kext VirtualSMC.kext WhateverGreen.kext config.plist: see attached ------------------------------------------ Target Desktop specs: Dell Inspiron 3847 (64 bit) CPU: Intel Core i5-4460, 3.2 GHz, 4 cores Architecture: Haswell GPU: Intel HD 4600 Motherboard: Dell 088DT1 (version A01) Chipset: Intel H81 Install method: with USB, configured with Clover, 100% following Plain Vanilla guide for Desktops RAM: 12 GB, 2 slots Hard drive for installation: SATA HDD 4TB, by HGST LAN: RTL8111/8168/8411 WLAN: AR9565 (atheros) Audio: Realtek ALC661 (not 100% sure this is correct)   ------------------------------------ Attached:
      Screenshot of Clover installer not showing the Mac OSX option
      config.plist of my installer USB
      Clover_Install_Log.txt (not sure if this is relevant)   THANK YOU VERY MUCH!     config.plist
      Clover_Install_Log.txt
    • By Simon's InsaneMac
      Hi, I'm kind of lost when scrolling to Clover Configurator, so I decided to use an EFI from the web and just configure the most basic stuff. But that sadly didn't work, im always getting the attached screen IMG_0054.HEIC (and I don't know whether all the errors are listed, as I can't scroll). 
      Anyways I thought it'd be better to do a custom setup. Can anyone give me some help with what to choose in the settings? Here's my rig:
      i7 8700k
      Asus z370-G (Rog Strix)
      gtx 1060 6gb
      samsung ssd (SATA)
      WD hard drive
       
      Your help would be much appreciated!
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on Catalina 10.15.4 and Clover EFI 5104 (Catalina Patcher)
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman Voodoo PS2 Controller (here) acidanthera AppleALC (here) acidanthera Lilu (here) acidanthera VirtualSMC (here) acidanthera SMCBatteryManager (here) acidanthera SMCLightSensor (here) acidanthera WhateverGreen (here) Mieze Realtek RTL8111 (here)
    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
×