Jump to content
ErmaC

Clover General discussion

20,006 posts in this topic

Recommended Posts

Posted (edited)
7 hours ago, arsradu said:

 

Only under Catalina...? Cause that's weird... Aside from AptioMemoryFix did you change anything else in the config? Cause I don't think Memory Fix (any of them) have anything to do with this. Maybe some kexts...need to be updated for Catalina? Do you use some of those 300-series injector kexts?

 

Edit: I see that you're using one build exclusively with Catalina and the other one exclusively with Mojave? I'm guessing that's why you couldn't test the same EFI, on the same hardware, with both Catalina and Mojave.

 

Also, digging around, I saw some people suggesting to remove FakeSMC sensors (if you're using something like that) and trying again?

 

Before OC tests installed on USB Stick to boot on Catalina (Clover), I don't have this issue. I try Reset Nvram, Rebuild and repair permissions: no success. I can't restart or shutdown.

 

All my kexts seems to be up to date. I don't use FakeSMC sensors because I use virtualSMC.

 

EDIT: different config, different OS, different EFI Folder. IvyBridge (r5039) works fine on Mojave, Coffee Lake-R Z390 no more on Beta 5 Catalina. Very strange.

Edited by Matgen84

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)
2 minutes ago, Matgen84 said:

 

Before OC tests installed on USB Stick to boot on Catalina (Clover), I don't have this issue. I try Reset Nvram, Rebuild and repair permissions: no success. I can't restart or shutdown.

 

All my kexts seems to be up to date. I don't use FakeSMC sensors because I use virtualSMC.

 

Hmmm....I saw people having some issues with VirtualSMC under Catalina...? Could you give FakeSMC a try? Or is there a specific reason why you would prefer not to?

 

Something's gotta be different before then and now. And I think it's important to figure out what that is.

Edited by arsradu

Share this post


Link to post
Share on other sites
3 minutes ago, Matgen84 said:

 

Before OC tests installed on USB Stick to boot on Catalina (Clover), I don't have this issue. I try Reset Nvram, Rebuild and repair permissions: no success. I can't restart or shutdown.

 

All my kexts seems to be up to date. I don't use FakeSMC sensors because I use virtualSMC.


Rebuild kextcache and prelinked kernel in CATALINA need run "sudo mount -uw /" first, or your prelinked kernel will never be built

Share this post


Link to post
Share on other sites
1 minute ago, Andres ZeroCross said:


Rebuild kextcache and prelinked kernel in CATALINA need run "sudo mount -uw /" first, or your prelinked kernel will never be built

 

I use @chris1111 for "sudo mount -uw /", and @Cyberdevs macoptimizer.app to do that. Is it correct. For now, no success

Share this post


Link to post
Share on other sites
1 minute ago, Matgen84 said:

 

I use @chris1111 for "sudo mount -uw /", and @Cyberdevs macoptimizer.app to do that. Is it correct. For now, no success


Did you change somthing in your bios?? Like hot plug enable for your SATA port??? In my Z170, enable hot plug in bios without Hot plug kext patch enable can prevent computer from sleep. Follow this step

1. Disable all your Hot Plug capability of sata port in BIOS
2. Boot to macOS, "sudo mount -uw /" then rebuild kextcache / prelinked kernel with "Kext utility.app".
3. Reboot, and check for the result

Share this post


Link to post
Share on other sites
Posted (edited)
47 minutes ago, Andres ZeroCross said:


Did you change somthing in your bios?? Like hot plug enable for your SATA port??? In my Z170, enable hot plug in bios without Hot plug kext patch enable can prevent computer from sleep. Follow this step

1. Disable all your Hot Plug capability of sata port in BIOS
2. Boot to macOS, "sudo mount -uw /" then rebuild kextcache / prelinked kernel with "Kext utility.app".
3. Reboot, and check for the result

 

I don't change anything in BIOS settings. Until now, I don't have this issue with Hot Plug capability of sata ports in BIOS.

 

I try your check list

 

@Andres ZeroCross No solved problem. Very strange issue.

Edited by Matgen84

Share this post


Link to post
Share on other sites
7 hours ago, vector sigma said:

Ha ha, apparently the problem is to download a file from a site. Who wants it just type a word in a search field in the broswer (please try to type "AptioMemoryFix.efi", go to "release" and bam, got it for free!... let me know how difficult is).


Well, since you've asked: Very difficult. instructions unclear! Which button do I have to press...?! There's no such button as "Release"! :huh:

 

Spoiler

1212229945_Schermafbeelding2019-08-09om10_33_25.png.dd09ce872f3362f24c35d17950c45a0c.png

 

Share this post


Link to post
Share on other sites
16 minutes ago, ricoc90 said:


Well, since you've asked: Very difficult. instructions unclear! Which button do I have to press...?! There's no such button as "Release"! :huh:

 

  Reveal hidden contents

1212229945_Schermafbeelding2019-08-09om10_33_25.png.dd09ce872f3362f24c35d17950c45a0c.png

 

 

You can download in archives repo: https://github.com/acidanthera/AptioFixPkg/releases

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for Clover r5039, mach halt (reboot / shutdown) are now working properly w/o rolling AcpiPatcher.c back to r5027 on my laptop with 2nd Gen cpu. Seems normal with or w/o PatchAPIC=NO.

 

Eh, I still use last AptioMemoryFix R27, along with HwSensor's FakeSMC v3.5.2 or VirtualSMC v1.0.7; none of them caused halt issue on my case but APIC patch since r5028 upto r5038.

Edited by Badruzeus

Share this post


Link to post
Share on other sites

Hi Guys

 

Sorry if is Off-Topic

 

I use Clover r5039 + kexts/drivers update. I can boot on Catalina (Beta 5), but I can't reboot or shutdown without panic.

 

Any ideas, please.

 

 

5.jpg

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, Matgen84 said:

Hi Guys

Sorry if is Off-Topic

 

I use Clover r5039 + kexts/drivers update. I can boot on Catalina (Beta 5), but I can't reboot or shutdown without panic.

Any ideas, please.

Did you get similar issue with prev. Clover revs or 10.15 Beta 4?

I may guess trying diff. Clovers (*.efi drivers, kexts, etc) to determine the issue is from bootloader or the OS it' s self. Thanks.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Badruzeus said:

Did you get similar issue with prev. Clover revs or 10.15 Beta 4?

I may guess trying diff. Clovers (*.efi drivers, kexts, etc) to determine the issue is from bootloader or the OS it' s self. Thanks.

 

Thanks. :)

 

I don't have this panic on Beta 5 before yesterday. I will follow your advice to determine the cause (OS, Clover). Kexts have not changed since Beta 4.

 

Edited by Matgen84

Share this post


Link to post
Share on other sites
8 hours ago, ricoc90 said:


Well, since you've asked: Very difficult. instructions unclear! Which button do I have to press...?! There's no such button as "Release"! :huh:

 

  Reveal hidden contents

1212229945_Schermafbeelding2019-08-09om10_33_25.png.dd09ce872f3362f24c35d17950c45a0c.png

 

https://github.com/acidanthera/AptioFixPkg/releases

r27 https://github.com/acidanthera/AptioFixPkg/releases/download/R27/AptioFix-R27-RELEASE.zip

Share this post


Link to post
Share on other sites
4 minutes ago, vector sigma said:


Thanks but I still don't get it. Can you instead just come by my place and do it for me? I have no idea how all of this works :huh::shock:

Share this post


Link to post
Share on other sites
Just now, ricoc90 said:


Thanks but I still don't get it. Can you instead just come by my place and do it for me? I have no idea how all of this works :huh::shock:

Ha ha, I was reading back and didn't realize of your later reponse. 

I'll made a tutorial Lol

Share this post


Link to post
Share on other sites
10 hours ago, Matgen84 said:

 

Before OC tests installed on USB Stick to boot on Catalina (Clover), I don't have this issue. I try Reset Nvram, Rebuild and repair permissions: no success. I can't restart or shutdown.

 

All my kexts seems to be up to date. I don't use FakeSMC sensors because I use virtualSMC.

 

EDIT: different config, different OS, different EFI Folder. IvyBridge (r5039) works fine on Mojave, Coffee Lake-R Z390 no more on Beta 5 Catalina. Very strange.

You can try from Mojave and do something like that:

sudo touch /Volumes/Catalina/System/Library/Extensions && sudo kextcache -u /Volumes/Catalina 

if is still a problem of cache

17 hours ago, ellaosx said:

in buildme, i got error if i select 2 & 3 option.

Im using xcode 10.1 on HighSierra

 

22 hours ago, Andres ZeroCross said:

Can't compile with buildme :o

Hi, just tried in mojave and worked here. Did you solve or it's related to Xcode 11?

Share this post


Link to post
Share on other sites
1 hour ago, vector sigma said:

Hi, just tried in mojave and worked here. Did you solve or it's related to Xcode 11?


1363450461_Schermafbeelding2019-08-09om21_14_14.png.d3a82c736830f45ed48598260e69acb6.png

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, camillionario said:

Thanks, but now I receive this error

455406803_Capturadepantalla2019-08-09alas22_35_26.png.9e72250b85949c8e192c20aa3e9caa1c.png

 

 

7 hours ago, ricoc90 said:


1363450461_Schermafbeelding2019-08-09om21_14_14.png.d3a82c736830f45ed48598260e69acb6.png

 

 

Caused by update to Ukrainian translation name commit r5038

 

Fixed by renaming /CloverPackage/package/po/uk_UA.po to shorter form - uk.po (like before the commit).

Edited by fusion71au

Share this post


Link to post
Share on other sites
11 hours ago, vector sigma said:

You can try from Mojave and do something like that:


sudo touch /Volumes/Catalina/System/Library/Extensions && sudo kextcache -u /Volumes/Catalina 

if is still a problem of cache

 

Hi, just tried in mojave and worked here. Did you solve or it's related to Xcode 11?

 

Thanks. @vector sigma

 

I can't do that from Mojave because there is two different Hack (IvyBridge/Z77/Mojave and Coffee Lake-R/Z390/Catalina). They are connected via local network (Wifi--->Ethernet).

 


iMac-de-Mathieu:~ mathieu$ sudo touch /Volumes/Catalina/System/Library/Extensions && sudo kextcache -u /Volumes/Catalina 
Password:
touch: /Volumes/Catalina/System/Library/Extensions: Read-only file system
iMac-de-Mathieu:~ mathieu$ sudo mount -uw /Volumes/Catalina
mount_smbfs: -o update: option not supported
iMac-de-Mathieu:~ mathieu$ sudo mount_smbfs -ow /Volumes/Catalina
mount_smbfs: -o w: option not supported
iMac-de-Mathieu:~ mathieu$

 

Share this post


Link to post
Share on other sites
1 minute ago, Matgen84 said:

 

Thanks. @vector sigma

 

I can't do that from Mojave because there is two different Hack (IvyBridge/Z77/Mojave and Coffee Lake-R/Z390/Catalina). They are connected via local network (Wifi--->Ethernet).

 



iMac-de-Mathieu:~ mathieu$ sudo touch /Volumes/Catalina/System/Library/Extensions && sudo kextcache -u /Volumes/Catalina 
Password:
touch: /Volumes/Catalina/System/Library/Extensions: Read-only file system
iMac-de-Mathieu:~ mathieu$ sudo mount -uw /Volumes/Catalina
mount_smbfs: -o update: option not supported
iMac-de-Mathieu:~ mathieu$ sudo mount_smbfs -ow /Volumes/Catalina
mount_smbfs: -o w: option not supported
iMac-de-Mathieu:~ mathieu$

 


just "sudo mount -uw /" not "sudo mount -uw /Volumes/Catalina"

Share this post


Link to post
Share on other sites
19 minutes ago, Andres ZeroCross said:


just "sudo mount -uw /" not "sudo mount -uw /Volumes/Catalina"

 

"sudo mount -uw /Volumes/Catalina" is in Terminal on Mojave Hack (IvyBridge). I've two hacks connected via Wifi/Ethernet (my previous post).

Share this post


Link to post
Share on other sites
Posted (edited)
12 hours ago, fusion71au said:

Fixed by renaming /CloverPackage/package/po/uk_UA.po to shorter form - uk.po (like before the commit).

We should understand firstly what is in use by the user, infact there's a uk (Ukrainian) and uk_UA (Ukrainian from Ukraine).

http://www.lingoes.net/en/translator/langcode.htm

 

one of the two probably make the package show up in english if doesn't match the  current OS language identifier

 

EDIT

taking both uk and uk_UA for the moment

 

Edited by vector sigma

Share this post


Link to post
Share on other sites

Hi Clover Developer Team

 

My Stupid question: 
Would it be possible to choose its own language file before make pkg, for those who compiles it would be more convenient.

Share this post


Link to post
Share on other sites
Posted (edited)
47 minutes ago, Matgen84 said:

Would it be possible to choose its own language file before make pkg, for those who compiles it would be more convenient.

Sorry I'm not sure what you want to do, but translations should not be there already when peoples download the stable version at source forge?

Edited by vector sigma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI CLOVER Z390 DESIGNARE.zip
       
      ---OPENCORE FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI OPENCORE Z390 DESIGNARE.zip
       
      ---DSDT patch requests is here---
       
      https://olarila.com/forum/viewtopic.php?f=19&t=1131
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kylon
      Cloud Clover Editor is an open source application that allows you to manage various Hackintosh Bootloaders configs everywhere.

      Open Cloud Clover Editor
       
      Cloud Clover Editor Wiki
      Cloud Clover Editor Sources
       
       
      Features
      Supports Clover EFI, Ozmosis, Chameleon, OpenCore GUI and Text Editor Mode CCE Bank Mobile friendly  
      Officially supported browsers
      Chrome 42+ Microsoft Edge 14+ Firefox 39+ Safari 10+ Opera 29+ Opera Mobile 12+ Chrome for Android 75+ Firefox for Android 67+  
       
      Credits
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor  (Discontinued) crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support  
      Please let me know if i forgot you!
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  AptioMemory --> (consigliato) ->  Link download
       Può essere solo aggiunto manualmente scaricando dal link sopra e collocandolo nella rispettiva cartella
       NOTA: in questo caso non selezionare nessun OsxAptioFixDRV durante l'installazione di clover oppure rimuovetelo                        successivamente. 
                               : Driver64UEFI  ApfsDriverLoader --> (consigliato) --> sostituisce l'uso del driver apfs.efi
                               : Selezionate l'altri driver come da successiva immagine,
       
      *Nota: Altri driver che si possono usare  al suo posto  sono:
       informazioni 
       
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      C_I_M.zip
       
       
       
       
       
       
       
       
       
       
       
       
       
    • By Alesss
      Good morning,
       
      I've the following pieces of hardware:
      - i7 6700K
      - GTX 1080
      - Asus Z170 Deluxe
      - NVME hard drives
       
      Yesterday I've successfully completed a High Sierra installation (I can't migrate to Mojave due to missing NVIDIA web drivers) but the system (even though it works correctly) seems to show a kernel panic at every shutdown/reboot.
       
      Please find the RunMe.app report attached.
       
      A couple of notes:
      - I've installed the audio kexts through the acidanthera AppleALC procedure
      - I've generated the SSDT with pikessdt script
      - Nvidia web drivers have been installed with the vulgo/webdriver.sh script that requires the WhateverGreen and the ngfxcompat=1 boot argument
      - AirportBrcmFixup.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext have been used to unlock the full potential of the integrated Wi-Fi card
      - I've tried to clean nvram and motherboard CMOS with no avail
      - I've tried to update Clover to the latest version but it always results in an unbootable system
       
      It's a pity because everything seems to work correctly (USB ports, graphics, Wifi card, Continuity and so on. I haven't tried sleep but I don't use it anyway ) but this crash is fairly annoying.
       
      Thank you very much,
      Alesss
       
      Send me Ales-iMac.zip
    • By Pentothal.Z
      Hello all,
      I have a working hackintosh....ok.....but it takes a lot to boot and according to the boot.log there are a few problems.
      One of them is a black screen that stays on for a long time.
      I would like to ask anyone in this community some help to fine tune my machine.
      Boot.log and config.plist attached


      Any help would be appreciated.
      bootlog.txt
      config.plist
×