Jump to content
ErmaC

Clover General discussion

20,246 posts in this topic

Recommended Posts

Posted (edited)
12 minutes ago, artur_pt said:

 

hello

 

no , never use it .. is a Lenovo no apic problem

 

thanks

Hello, could you try  to change:

 

while ((ProcLocalApic->Type == EFI_ACPI_4_0_PROCESSOR_LOCAL_APIC) && (ProcLocalApic->Length == 8)) {
  if (ProcLocalApic->Flags & EFI_ACPI_4_0_LOCAL_APIC_ENABLED) {
    ProcLocalApic++;
    ApicCPUNum++;
  }
  if (ApicCPUNum > 16) {
    DBG("Out of control with CPU numbers\n");
  break;
  }
}

to

while ((ProcLocalApic->Type == EFI_ACPI_4_0_PROCESSOR_LOCAL_APIC) && (ProcLocalApic->Length == 8)) {
  ProcLocalApic++;
  ApicCPUNum++;
  if (ApicCPUNum > 16) {
    DBG("Out of control with CPU numbers\n");
  break;
  }
}
     

(starting at line 2145)

Edited by vector sigma

Share this post


Link to post
Share on other sites
Advertisement

Hi Guys

 

Soory if this issue is Off-Topic

 

Since one hour, I can't restart or shutdown my Aorus Master Config (under Catalina). Screenshot in attachment.

I've already repair permission and kextcache...

Please help

1.jpg

Share this post


Link to post
Share on other sites
1 hour ago, Matgen84 said:

Hi Guys

 

Soory if this issue is Off-Topic

 

Since one hour, I can't restart or shutdown my Aorus Master Config (under Catalina). Screenshot in attachment.

I've already repair permission and kextcache...

Please help

1.jpg


Go back to use AptioMemoryFix.efi

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, vector sigma said:

Just discovered what was as I was unaware. My friend can't boot with any of the actual memory fix drivers... so I was curious about it.

 

Then shouldn't you rename it to what it actually is? (osxaptiofix2drv-free2000)?

Edited by meaganmargaret

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, meaganmargaret said:

Then shouldn't you rename to what it actually is

just found as is on a motherboard similar to your which work ok (in truth sent to me by whatsapp message). I know was an old driver by apianti made for your mobo (or like). Wanted to understand this was a regression or what ever since is 4 years old and if the problem was just mapping above 4GB as for the purpose of that driver because you stated that all mem fix in Clover actually doesn't work.
P.S. the name of a driver did nothing for functioning 99% of the times, only clover has a check for memory fix ones in cases you load more then one of them.

Edited by vector sigma

Share this post


Link to post
Share on other sites
1 minute ago, Andres ZeroCross said:

Can't compile with buildme

not buildme, is the uk translation just added. 

I'll take a look on it tomorrow morning

Share this post


Link to post
Share on other sites
15 minutes ago, vector sigma said:

not buildme, is the uk translation just added. 

I'll take a look on it tomorrow morning

Ok,, for temporary solution i just change uk_UA.lproj to uk.lproj before make pkg

Share this post


Link to post
Share on other sites
5 hours ago, vector sigma said:

Hello, could you try  to change:

 


while ((ProcLocalApic->Type == EFI_ACPI_4_0_PROCESSOR_LOCAL_APIC) && (ProcLocalApic->Length == 8)) {
  if (ProcLocalApic->Flags & EFI_ACPI_4_0_LOCAL_APIC_ENABLED) {
    ProcLocalApic++;
    ApicCPUNum++;
  }
  if (ApicCPUNum > 16) {
    DBG("Out of control with CPU numbers\n");
  break;
  }
}

to


while ((ProcLocalApic->Type == EFI_ACPI_4_0_PROCESSOR_LOCAL_APIC) && (ProcLocalApic->Length == 8)) {
  ProcLocalApic++;
  ApicCPUNum++;
  if (ApicCPUNum > 16) {
    DBG("Out of control with CPU numbers\n");
  break;
  }
}
     

(starting at line 2145)

 

hello

 

solved in 5039

 

thanks

 

to you and Slice

Share this post


Link to post
Share on other sites

@vector sigma

 

in buildme, i got error if i select 2 & 3 option.

Im using xcode 10.1 on HighSierra

 

make pkg:

Building CloverUpdater application...
** BUILD FAILED **


The following build commands failed:
	CompileXIB /Users/ipc/src/edk2/Clover/CloverPackage/CloverUpdater/src/uk.lproj/MainMenu.xib
(1 failure)
make[1]: *** [CloverUpdater] Error 65
make: *** [pkg] Error 2

 

make ISO:

[BUILD ISO]
================= Making all in boot1-install =================
	[XCODE] boot1-install
================= Making all in partutil =================
	[XCODE] partutil
================= Making all in bdmesg =================
	[XCODE] bdmesg
================= Making all in clover-genconfig =================
	[XCODE] clover-genconfig
================= Making all in espfinder =================
	[XCODE] espfinder
** INSTALL FAILED **


The following build commands failed:
	Ld /Users/ipc/src/edk2/Clover/CloverPackage/sym/utils/espfinder normal x86_64
(1 failure)
make[2]: *** [/Users/ipc/src/edk2/Clover/CloverPackage/sym/utils/espfinder] Error 65
make[1]: *** [all-recursive] Error 1
make: *** [utils] Error 2

 

Share this post


Link to post
Share on other sites
Just now, ellaosx said:

@vector sigma

 

in buildme, i got error if i select 2 & 3 option.

Im using xcode 10.1 on HighSierra

 

make pkg:


Building CloverUpdater application...
** BUILD FAILED **


The following build commands failed:
	CompileXIB /Users/ipc/src/edk2/Clover/CloverPackage/CloverUpdater/src/uk.lproj/MainMenu.xib
(1 failure)
make[1]: *** [CloverUpdater] Error 65
make: *** [pkg] Error 2

 

make ISO:


[BUILD ISO]
================= Making all in boot1-install =================
	[XCODE] boot1-install
================= Making all in partutil =================
	[XCODE] partutil
================= Making all in bdmesg =================
	[XCODE] bdmesg
================= Making all in clover-genconfig =================
	[XCODE] clover-genconfig
================= Making all in espfinder =================
	[XCODE] espfinder
** INSTALL FAILED **


The following build commands failed:
	Ld /Users/ipc/src/edk2/Clover/CloverPackage/sym/utils/espfinder normal x86_64
(1 failure)
make[2]: *** [/Users/ipc/src/edk2/Clover/CloverPackage/sym/utils/espfinder] Error 65
make[1]: *** [all-recursive] Error 1
make: *** [utils] Error 2

 

What is written just some post above yours?:whistle:

Share this post


Link to post
Share on other sites
1 hour ago, Andrey1970 said:

Make a fork of source codes AMF in Clover. Vit not against.

Ha ha, apparently the problem is to download a file from a site. Who wants it just type a word in a search field in the broswer (please try to type "AptioMemoryFix.efi", go to "release" and bam, got it for free!... let me know how difficult is). May be the problem is to mount the ESP to copy a file w/o using the installer? ...who knows..

BTW that was my idea also because it was firstly forked from Clover, just require time to work on.

Share this post


Link to post
Share on other sites
11 hours ago, Andres ZeroCross said:


Go back to use AptioMemoryFix.efi

 

Same issue with come back to AptioMemoryFix.efi : can't restart or shutdown :cry:

 

 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Matgen84 said:

 

Same issue with come back to AptioMemoryFix.efi : can't restart or shutdown :cry:

 

Only under Catalina...? Cause that's weird... Aside from AptioMemoryFix did you change anything else in the config? Cause I don't think Memory Fix (any of them) have anything to do with this. Maybe some kexts...need to be updated for Catalina? Do you use some of those 300-series injector kexts?

 

Edit: I see that you're using one build exclusively with Catalina and the other one exclusively with Mojave? I'm guessing that's why you couldn't test the same EFI, on the same hardware, with both Catalina and Mojave.

 

Also, digging around, I saw some people suggesting to remove FakeSMC sensors (if you're using something like that) and trying again?

Edited by arsradu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ErmaC
      Slice is glad to present a new EFI bootloader.

      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      https://sourceforge.net/projects/cloverefiboot/?source=directory
      There is a WIKI 
      http://clover-wiki.zetam.org/
      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      Post#2 CloverGrower - create Clover by yourself Post#3 Downloads Post#4 Installation of the bootloader Post#5 How to do UEFI boot Post#6 How to use - common words Post#7 Calculator for Automatic DSDT fix Post#8 Instructions for GraphicsInjector Post#9 ATIConnector patching Post#10 Any kexts patching with some Samples Post#11 CustomEDID Post#12 Hiding unnecessary menu entries Post#13 Instruction for DSDT corrections to do DeviceInjection works Post#14 Development Post#15 Themes Post#16 About kexts injection Post#17 Instructions for P- and C-states generator Post#18 Patching DSDT to get Sleep working Post#19 CPU settings and geekbench Post#20 ACPI tables loading Post#21 DSDTmini Post#22 Custom SMBios Post#23 F.A.Q. Post#24 iCloudFix Post#25 Using mouse. Post#26 How to make orange icons to be metallic Post#27 How to make software RAID (by Magnifico) Post#28 How to modify InstallESD.dmg (by shiecldk) Post#29 Config.plist settings Post#30 Using extra kexts and skipping kernelcache Post#31 Choosing EFI drivers Post#32 Configuration files Post#33 Automatic config.plist creating Post#34 Custom DSDT patches Post#35 How to do sleep/wake working with UEFI BOOT Post#36 DeviceID substitution (FakeID) Post#37 Using Custom OS Icons Post#38 Hibernation Post#39 Floating regions Post#41 Property List Editor Post#42 Blocking Bad Kext Post#43 AAPL,slot-name Post#44 FakeCPUID for unsupported CPU Post#45 Multiple Boot Options - to write into UEFI BIOS boot menu Post#46 How to install Windows UEFI Post#47 How to speedup Clover boot Post#48 Info.plist patching Post#49 Arbitrary device injection Post#50 Non-Standard Legacy Boot Files Post#51 Reboot to Windows UEFI from Mac OSX Post#52 Deprecated Features Post#53 Using UDK2018 Post#54 Device Properties Post#55 Scalable themes Post#56 How to search Clover mistakes (bisection) -----------------
       
      Slice:
      I edited all posts in the thread to correspond to actual Clover revision.
      Please install Clover at least 2652 and use new instructions.
×