Jump to content
ErmaC

Clover General discussion

20,637 posts in this topic

Recommended Posts

45 minutes ago, Sherlocks said:

but i don't have apfs fusion drive.

 

Sorry me as well.  Will require testers

1 hour ago, Badruzeus said:

It works well under 10.13.6 with HFS+. Many thanks.

Thanks for the test and the patience!

Share this post


Link to post
Share on other sites
Advertisement
7 hours ago, vector sigma said:

Sorry me as well.  Will require testers


I'll see if I have some spare drives to put in one of my spare systems so that I can test it out 

Share this post


Link to post
Share on other sites
25 minutes ago, ricoc90 said:


I'll see if I have some spare drives to put in one of my spare systems so that I can test it out 

Thanks for that, sunday I'll try to do the same.. may be we will succeded!

Share this post


Link to post
Share on other sites

Yep the Clover installs the files on the root instead of the ESP <_<

Screen Shot 2019-07-18 at 1.50.51 AM.png

 

here's the Diskutil list output:

 

Spoiler

cyberdevs@Cyberdevss-iMac ~ % diskutil list

/dev/disk0 (internal, physical):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *500.1 GB   disk0

   1:                        EFI EFI                     209.7 MB   disk0s1

   2:                 Apple_APFS Container disk2         499.9 GB   disk0s2

 

/dev/disk1 (internal, physical):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      GUID_partition_scheme                        *240.1 GB   disk1

   1:                        EFI EFI                     209.7 MB   disk1s1

   2:                 Apple_APFS Container disk2         239.8 GB   disk1s2

 

/dev/disk2 (synthesized):

   #:                       TYPE NAME                    SIZE       IDENTIFIER

   0:      APFS Container Scheme -                      +739.7 GB   disk2

                                 Physical Stores disk1s2, disk0s2

   1:                APFS Volume Macintosh HD - Data     3.8 GB     disk2s1

   2:                APFS Volume Preboot                 81.0 MB    disk2s2

   3:                APFS Volume Recovery                526.8 MB   disk2s3

   4:                APFS Volume VM                      1.1 MB     disk2s4

   5:                APFS Volume Macintosh HD            10.3 GB    disk2s5

 

cyberdevs@Cyberdevss-iMac ~ %

 

another update by @ricoc90 request:

Spoiler

cyberdevs@Cyberdevss-iMac ~ % diskutil info /dev/disk0

   Device Identifier:         disk0

   Device Node:               /dev/disk0

   Whole:                     Yes

   Part of Whole:             disk0

   Device / Media Name:       ST3500418ASQ

 

   Volume Name:               Not applicable (no file system)

   Mounted:                   Not applicable (no file system)

   File System:               None

 

   Content (IOContent):       GUID_partition_scheme

   OS Can Be Installed:       No

   Media Type:                Generic

   Protocol:                  SATA

   SMART Status:              Verified

 

   Disk Size:                 500.1 GB (500107862016 Bytes) (exactly 976773168 512-Byte-Units)

   Device Block Size:         512 Bytes

 

   Read-Only Media:           No

   Read-Only Volume:          Not applicable (no file system)

 

   Device Location:           Internal

   Removable Media:           Fixed

 

   Solid State:               No

   Virtual:                   No

   Hardware AES Support:      No

 

cyberdevs@Cyberdevss-iMac ~ % diskutil info /dev/disk1

   Device Identifier:         disk1

   Device Node:               /dev/disk1

   Whole:                     Yes

   Part of Whole:             disk1

   Device / Media Name:       KINGSTON SHSS37A240G

 

   Volume Name:               Not applicable (no file system)

   Mounted:                   Not applicable (no file system)

   File System:               None

 

   Content (IOContent):       GUID_partition_scheme

   OS Can Be Installed:       No

   Media Type:                Generic

   Protocol:                  SATA

   SMART Status:              Verified

 

   Disk Size:                 240.1 GB (240057409536 Bytes) (exactly 468862128 512-Byte-Units)

   Device Block Size:         512 Bytes

 

   Read-Only Media:           No

   Read-Only Volume:          Not applicable (no file system)

 

   Device Location:           Internal

   Removable Media:           Fixed

 

   Solid State:               Yes

   Virtual:                   No

   Hardware AES Support:      No

 

cyberdevs@Cyberdevss-iMac ~ % diskutil info /dev/disk2

   Device Identifier:         disk2

   Device Node:               /dev/disk2

   Whole:                     Yes

   Part of Whole:             disk2

   Device / Media Name:       KINGSTON SHSS37A240G

 

   Volume Name:               Not applicable (no file system)

   Mounted:                   Not applicable (no file system)

   File System:               None

 

   Content (IOContent):       EF57347C-0000-11AA-AA11-00306543ECAC

   OS Can Be Installed:       No

   Media Type:                Generic

   Protocol:                  SATA

   SMART Status:              Verified

   Disk / Partition UUID:     23E80DC2-F0ED-4DA7-8598-19AAB272D305

 

   Disk Size:                 739.7 GB (739745759232 Bytes) (exactly 1444815936 512-Byte-Units)

   Device Block Size:         4096 Bytes

 

   Read-Only Media:           No

   Read-Only Volume:          Not applicable (no file system)

 

   Device Location:           Internal

   Removable Media:           Fixed

 

   Solid State:               Yes

   Virtual:                   Yes

   Hardware AES Support:      No

 

   This disk is an APFS Container.  APFS Information:

   APFS Physical Store:       disk1s2

   APFS Physical Store:       disk0s2

   Fusion Drive:              Yes

cyberdevs@Cyberdevss-iMac ~ %

 

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/10/2019 at 2:52 PM, Slice said:

ISO image must contain necessary drivers for UEFI boot from the DVD.

At least Fat.efi, HFS+, APFS, Aptio,

 

Or UEFI boot from DVD is impossible?

 

On 7/10/2019 at 9:26 PM, vector sigma said:

I was guessing about this. Isn't a legacy boot only with the cdboot used?

 

On 7/10/2019 at 9:35 PM, Slice said:

Yes, the ISO is designed for legacy boot (and it really works!). I am just not sure if UEFI boot is also possible.

 

After a bit of digging around, the answer is definitively YES, it is possible to pure UEFI boot from CD/DVD, but a lot depends on the (U)EFI firmware doing the booting.

 

The standard Clover ISO only consists of a single 10MB HFS+ volume which can be EFI booted by firmware that understands HFS+ eg Apple machines and VMware Virtual Machines.  For it to boot on standard PCs, however, only the legacy pathway is available via the cdboot/eltorito pathway.

 

On the other hand, Ubuntu and Linux Mint Installation ISOs have dual formats for UEFI boot or Legacy boot

1) A 2.4MB FAT efi.img that contains grubx64.efi and functions as a "mini" EFI, recognizable for UEFI booting by standard PCs

2) A much larger ISO9660 file system that has all of the installation files and can also boot via the legacy eltorito pathway.

 

I was able to adapt this procedure from the Debian Wiki: RepackBootableISO, to repack the Clover ISO with an extra 2.4MB FAT efi.img containing CLOVERX64.efi, UEFI drivers, FakeSMC, the embedded theme and a custom config.plist that works for @arsradu to test on his system....

 

559451826_Cloverr5018UEFIISO.thumb.jpeg.bdd1138eabd21eeb8336ea08d9e9369f.jpeg1262232233_BootUEFIopticalfromCDROM.thumb.png.dfc03e68875857d9d81999e99feeea4d.png

 

Note: the About Clover GUI screen that shows firmware booting by American Megatrends (not Clover EFI so NOT legacy boot).....and it boots his system fine :D.

 

Ingredients needed to make a real UEFI bootable Clover CD/DVD

1) A special mbr_template that enables the booting off the 2.4MB FAT efi.img (extracted from Linux Mint 19.1 Installation ISO) ...

isohdpfx.bin ---> I saved it to /home/fusion71au/Downloads/CLOVER/isohdpfx.bin
2) A 2.4MB FAT efi.img that contains CLOVERX64.efi, UEFI drivers, FakeSMC, the embedded theme and a config.plist

3) xorriso utility in Linux (Homebrew version for OSX here).  I was able to compile Clover with Build_Clover.command, then repacked the Clover ISO with xorriso with the following terminal commands...

 

new_files=~/src/edk2/Clover/CloverPackage/sym/CloverCD
new_iso=~/src/edk2/Clover/CloverPackage/sym/CloverISO-5018/Clover-v2.5k-5018-X64_UEFI.iso
xorriso -as mkisofs \
> -r -V 'Clover-v2.5k-5018-X64.iso' \
> -o "$new_iso" \
> -J -J -joliet-long -cache-inodes \
> -isohybrid-mbr '/home/fusion71au/Downloads/Clover/isohdpfx.bin' \
> -b /usr/standalone/i386/cdboot \
> -boot-load-size 4 -boot-info-table -no-emul-boot \
> -eltorito-alt-boot \
> -e /EFI/CLOVER/efi.img \
> -no-emul-boot -isohybrid-gpt-basdat -isohybrid-apm-hfsplus \
> "$new_files"

End result....Clover-v2.5k-5018-X64_UEFI.iso

 

PS:

If you want to play around with that efi.img, you can mount it as a loop device in Linux...

 

Say it is in your ~/Downloads folder

Open terminal and type

sudo mkdir /media/floppy1

sudo mount -o loop ~/Downloads/efi.img /media/floppy1/

 

Should then see something like this....

efi_img.png.3afa1625ea75a1eb07b1c0d6babb1983.png

 

You can add/delete files to the volume as the root user.  As you can see, I only have about 300kB left to play with :).  To unmount the volume, just click the "eject" icon.

 

Edited by fusion71au
Update UEFI.iso with generic config.plist and AptioMemoryFix.efi instead of OsxAptioFix3Drv.efi

Share this post


Link to post
Share on other sites
Posted (edited)

@fusion71au I think it was a little more than "a bit of" digging around. :)) It was a lot of digging. In and around. All started from a simple question: if they can do it, why couldn't we?

 

Cheers! And thank you!

 

Edit: bdmesg added if you wanna take a look.

Terminal Saved Output Clover ISO UEFI

Edited by arsradu

Share this post


Link to post
Share on other sites
Posted (edited)

@vector sigma

latest clover vboxhfs default check was removed. is it right?

to work hfs, we have been use vboxhfs or hfsplus like current ApfsDriverLoader.efi in latest clover package.

old clover package vboxhfs default check. and script check if user have hfsplus.efi, then if have it, vboxhfs installation have been ignore.

with this log in install log

"Removing drivers64UEFI/VBoxHfs-64.efi driver because HFSPlus driver present"

 

r5027. i removed /Library/Preferences/com.projectosx.clover.installer.plist file.

the i capture this default drivers.

스크린샷 2019-07-20 오후 10.22.29.png

 

EDIT1

VirtualSMC.efi case is working

i checked this log

Removing UEFI/SMCHelper.efi driver because VirtualSMC driver present

Edited by Sherlocks

Share this post


Link to post
Share on other sites
On 7/18/2019 at 12:58 AM, fusion71au said:

Ingredients needed to make a real UEFI bootable Clover CD/DVD

1) A special mbr_template that enables the booting off the 2.4MB FAT efi.img (extracted from Linux Mint 19.1 Installation ISO) ...

isohdpfx.bin ---> I saved it to /home/fusion71au/Downloads/CLOVER/isohdpfx.bin
2) A 2.4MB FAT efi.img that contains CLOVERX64.efi, UEFI drivers, FakeSMC, the embedded theme and a config.plist

3) xorriso utility in Linux (Homebrew version for OSX here).  I was able to compile Clover with Build_Clover.command, then repacked the Clover ISO with xorriso with the following terminal commands...

 


new_files=~/src/edk2/Clover/CloverPackage/sym/CloverCD
new_iso=~/src/edk2/Clover/CloverPackage/sym/CloverISO-5018/Clover-v2.5k-5018-X64_UEFI.iso
xorriso -as mkisofs \
> -r -V 'Clover-v2.5k-5018-X64.iso' \
> -o "$new_iso" \
> -J -J -joliet-long -cache-inodes \
> -isohybrid-mbr '/home/fusion71au/Downloads/Clover/isohdpfx.bin' \
> -b /usr/standalone/i386/cdboot \
> -boot-load-size 4 -boot-info-table -no-emul-boot \
> -eltorito-alt-boot \
> -e /EFI/CLOVER/efi.img \
> -no-emul-boot -isohybrid-gpt-basdat -isohybrid-apm-hfsplus \
> "$new_files"

End result....Clover-v2.5k-5018-X64_UEFI.iso

 

As you can see, I only have about 300kB left to play with :).  To unmount the volume, just click the "eject" icon.

 

Is there a reason why the size of the efi image can't be greater than 2.4 MB?

Share this post


Link to post
Share on other sites
On 7/16/2019 at 9:08 AM, vector sigma said:

Yeah, subscripting can be a solution. Did you try your self? ok, I'll do that as soon as I can. Anyway it is not enough since we need to ensure the file system is apfs and is writable. For the fs I can just make a shell script to something like:


diskutil info / | grep 'File System Personality:' |  awk '{print $NF}'

or just forgot about aeverything and see if the root volume is read-only: 


diskutil info / | grep 'Read-Only Volume:' | awk '{print $NF}'

but since I'm on 10.11 at job, I can't ensure what's on Catalina. So please anyone... check the above command in Catalina with both cases (fs rw or ro)

 

What does the mount command show for Catalina? The output will be more succinct and easier to parse than diskutil probably. It shows each device and the mount point and the mount flags (read-only, etc.).

mount

 

I use mount to see if a partition is already mounted or not, and mount it if it's not already mounted. Here's a script to mount all EFI partitions:


for slice in $(diskutil list | sed -nE '/^ *[0-9]+: +EFI .* (disk[0-9]+s[0-9]+)$/s//\1/p'); do
    mountpoint=$(mount | sed -n -E "/\/dev\/$slice on (.*) \(.*/s//\1/p")
    if [ -z $mountpoint ]; then
        i=0
        startmountpoint=/Volumes/EFI
        mountpoint=$startmountpoint
        while [ -d $mountpoint ]; do
            ((i++))
            mountpoint=$startmountpoint$i
        done
    fi
    if [ ! -d $mountpoint ]; then
        sudo mkdir $mountpoint 2> /dev/null
        sudo mount_msdos /dev/$slice $mountpoint
    fi
done

 

Share this post


Link to post
Share on other sites

one short question:

are the MEMORY FIX drivers just UEFI or

are the MEMORY FIX drivers LEGACY & UEFI (especialy the AptioMemoryFix.efi)?

 

never used LEGACY BIOS, that's why i ask.

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/21/2019 at 8:21 AM, joevt said:

Is there a reason why the size of the efi image can't be greater than 2.4 MB?

Good question. 

 

Since I was using the Linux Mint 19.1 ISO as my template for a UEFI bootable CD/DVD, I reused its isohybrid-mbr and 2.4MB FAT efi.img for creating the Clover UEFI ISO. 

 

I have since created a larger 10MB FAT efi.img...

mkfs.msdos -C ~/src/edk2/Clover/CloverPackage/sym/CloverCD/EFI/CLOVER/efi.img 10240

and compiled successfully with xorriso, Clover-v2.5k-5027-X64_UEFI.iso.zip.  This also EFI boots Catalina DP4 OK on my VMware12 virtual machine....

1442815353_Larger10MBefi_img.thumb.png.825f6b9c53856859e213d3d0a9119742.png

 

Awaiting @arsradu's real world testing on his system :D <--- Edit: confirmed working on real hardware.

 

 

 

On 7/21/2019 at 9:08 AM, Mork vom Ork said:

one short question:

are the MEMORY FIX drivers just UEFI or

are the MEMORY FIX drivers LEGACY & UEFI (especialy the AptioMemoryFix.efi)?

 

never used LEGACY BIOS, that's why i ask.

Yes, MEMORY FIX drivers are just for UEFI booting.  Never needed AptioMemoryFix.efi for Clover's legacy boot because Clover has its own EFI firmware (based on DUET, not Aptio).

 

Edited by fusion71au
ISO confirmed working with larger FAT efi.img (UEFI or Legacy boot), added extra kexts, BIOS drivers and more universal config.plist

Share this post


Link to post
Share on other sites
Posted (edited)

@fusion71au,  you know I was asking you the very same question, right? :)) :P

I’ll take a look later today. Bit busy right now. :)

 

EDIT: it boots perfectly fine. :D Haven't tried Catalina (only Mojave), but I see no reason why it wouldn't boot that one, as well.

Edited by arsradu

Share this post


Link to post
Share on other sites
18 hours ago, joevt said:

The output will be more succinct and easier to parse than diskutil probably. It shows each device and the mount point and the mount flags (read-only, etc.).

Hi, what we use is the below code in a java script function:

    var writable = true;
    var cmd = '[[ yes == $(diskutil info / | grep -i \'read-only volume:\' | awk \'{print $NF}\' | tr \'[:upper:]\' \'[:lower:]\') ]]'
    r = system.run('/bin/bash', '-c', cmd);
    system.log('checkFileSystemIsWritable diskutil result = ' + r);

    writable = (r != 0);
    
    if (writable) {
	....

 

18 hours ago, joevt said:

Here's a script to mount all EFI partitions:

Thanks but I'm unsure we need this. What is needed is to find the ESP that belongs to the target volume, volume that can be inside a contenitor, corestorage, apfs, fv2, raid (so also combined) etc...

Share this post


Link to post
Share on other sites

With fusion drives there is no EFI partition on the target volume (obviously), but both physical storage disks do contain an EFI partition.
 

So maybe we could just check if the target volume is a Fusion Drive:

# Returns "Yes" is fusion drive and exits non-zero if not
diskutil info the_target_volume | grep -i 'Fusion Drive:' | awk '{print $NF}'


and grab the first physical storage.

i.e.:

4JzNM6Y.png

Share this post


Link to post
Share on other sites
Posted (edited)
# Check if volume is a Fusion drive
if [[ "$(echo $(LC_ALL=C diskutil info "$DiskDevice" | \
         grep -i 'Fusion Drive:' | \
         awk '{print $NF}'))" == *"Yes"* ]]; then

         # Volume is Fusion Drive, get its physical store

        realDisk=($(diskutil info "$DiskDevice" | \
                         grep -i 'APFS Physical Store:' | \
                         awk '{print $NF}'))

        echo Target volume "$1" on "$DiskDevice" is a Fusion Drive on physical store:

        for Disk in "${realDisk[@]}"
        do
            echo -e "\t$Disk"
        done

        DiskDevice=$(LC_ALL=C diskutil info "${realDisk[0]}" 2>/dev/null | \
                                             sed -n 's/.*Part [oO]f Whole: *//p')

        echo Using disk "$DiskDevice" for Clover installation
fi
Clover EFI installer log - Mon Jul 22 16:13:16 CEST 2019
Installer version: v2.5k r5027 EFI bootloader
======================================================
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk2         499.9 GB   disk0s2

/dev/disk1 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk1
   1:                        EFI EFI                     209.7 MB   disk1s1
   2:                 Apple_APFS Container disk2         119.8 GB   disk1s2

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +619.7 GB   disk2
                                 Physical Stores disk0s2, disk1s2
   1:                APFS Volume Macintosh HD - Data     14.4 GB    disk2s1
   2:                APFS Volume Preboot                 43.5 MB    disk2s2
   3:                APFS Volume Recovery                520.4 MB   disk2s3
   4:                APFS Volume VM                      1.1 GB     disk2s4
   5:                APFS Volume Macintosh HD            10.0 GB    disk2s5

/dev/disk3 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *8.0 GB     disk3
   1:                        EFI EFI                     209.7 MB   disk3s1
   2:                  Apple_HFS Install macOS 10.15 ... 7.7 GB     disk3s2

Target volume /Volumes/Macintosh HD on disk2 is a Fusion Drive on physical store:
	disk0s2
	disk1s2
Using disk disk0 for Clover installation
======================================================
Backing up EFI files

Backing up stage2 file /Volumes/Macintosh HD/EFIROOTDIR/boot  to /Volumes/Macintosh HD/EFI-Backups/r5027/2019-07-22-16h13/boot
Backing up /Volumes/Macintosh HD/EFIROOTDIR/EFI folder to /Volumes/Macintosh HD/EFI-Backups/r5027/2019-07-22-16h13/EFI
No Active Partition

Stage 0 - Writing boot0af to /dev/rdisk0
dd if=/dev/rdisk0 count=1 bs=512 of=/tmp/origMBR
cp /tmp/origMBR /tmp/newMBR
dd if=//usr/standalone/i386/boot0af of=/tmp/newMBR bs=440 count=1 conv=notrunc
fdisk -f /tmp/newMBR -u -y /dev/rdisk0

Stage 1 - Writing boot1f32 to /dev/rdisk0s1
dd if=/dev/rdisk0s1 count=1 bs=512 of=/tmp/origbs
boot volume format is FAT32
cp /tmp/boot1f32 /tmp/newbs
dd if=/tmp/origbs of=/tmp/newbs skip=3 seek=3 bs=1 count=87 conv=notrunc
dd if=/tmp/newbs of=/dev/rdisk0s1

Stage 2 - Written boot6 (x64) to /Volumes/ESP/boot

======================================================
=========== Clover EFI Installation Finish ===========
======================================================

 

Edited by ricoc90

Share this post


Link to post
Share on other sites
8 hours ago, ricoc90 said:

/dev/disk2

You hardcoded this disk device in your script.

Share this post


Link to post
Share on other sites
45 minutes ago, joevt said:

You hardcoded this disk device in your script.

 

:blush: Thanks

Share this post


Link to post
Share on other sites

Hi Guys, attached a command line called espfinder. The purpose is to find the associated EFI partition that belong to a target volume using the Clover package. Here  actually works with or whitout apfs containers. CoreStorage isn't yet implemented but I'm confident that espfinder will give Us usefull informations about it, in fact this beta version make a dump at ~/Desktop/espfinder.plist.

 

Usage:

findesp disk2s4

(whole disks like disk0, disk2 etc. are not allowed)

 

@ricoc90, @Cyberdevs please, I need the dump from both of you. To All,  please confirm you can find the ESP from regular disks (whith apfs containers or other fs).

Thanks in advance

 

P.S. would be cool to have a dump from a RAID set up as well...

espfinder_0.1_beta.zip

Share this post


Link to post
Share on other sites
10 minutes ago, vector sigma said:

Hi Guys, attached a command line called espfinder. The purpose is to find the associated EFI partition that belong to a target volume using the Clover package. Here  actually works with or whitout apfs containers. CoreStorage isn't yet implemented but I'm confident that espfinder will give Us usefull informations about it, in fact this beta version make a dump at ~/Desktop/espfinder.plist.

 

Usage:


findesp disk2s4

(whole disks like disk0, disk2 etc. are not allowed)

 

@ricoc90, @Cyberdevs please, I need the dump from both of you. To All,  please confirm you can find the ESP from regular disks (whith apfs containers or other fs).

Thanks in advance

 

P.S. would be cool to have a dump from a RAID set up as well...

espfinder_0.1_beta.zip

One drive with several partitions HFS+

espfinder.plist.zip

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/20/2019 at 3:17 PM, Sherlocks said:

@vector sigma

latest clover vboxhfs default check was removed. is it right?

to work hfs, we have been use vboxhfs or hfsplus like current ApfsDriverLoader.efi in latest clover package.

old clover package vboxhfs default check. and script check if user have hfsplus.efi, then if have it, vboxhfs installation have been ignore.

with this log in install log

"Removing drivers64UEFI/VBoxHfs-64.efi driver because HFSPlus driver present"

@Sherlocks removing the conflictual hfs driver works as intended.

#!/bin/bash

#echo "DEBUG: $ 1 = Full path to the installation package the installer app is processing: " $1
#echo "DEBUG: $ 2 = Full path to the installation destination: " $2
#echo "DEBUG: $ 3 = Installation volume (mountpoint) to receive the payload: " $3
#echo "DEBUG: $ 4 = Root directory for the system: " $4

echo "preinstall: Path to installer....... $1"
echo "preinstall: Path to destination..... $2"
echo "preinstall: Path to dest volume..... $3"
echo "preinstall: Root of system folder... $4"

#############################################################################

DEST_VOL="${3}"
EFI_ROOT_DIR=$(cd "${DEST_VOL}"/EFIROOTDIR; pwd -P)
install_log="${DEST_VOL}/Clover_Install_Log.txt"
driver_dir="UEFI"
driver_name="HFSPlus.efi"

if [[ -d "$EFI_ROOT_DIR/EFI/CLOVER/drivers/$driver_dir" ]]; then
  cd "$EFI_ROOT_DIR/EFI/CLOVER/drivers/$driver_dir"
  if [[ $driver_name == VBoxHfs.efi ]]; then
    for driver in *.efi
    do
      low=$(echo $driver | tr '[:upper:]' '[:lower:]')
      if [[ $driver != $driver_name ]] && [[ "$low" == *hfsplus* || "$low" == *grubhfs* ]]; then
        echo "Removing ${driver_dir}/${driver} because $driver_name is installed!" >> "$install_log"
        rm -f $driver
      fi
    done
  elif [[ $driver_name == HFSPlus.efi ]]; then
    for driver in *.efi
    do
      low=$(echo $driver | tr '[:upper:]' '[:lower:]')
      if [[ $driver != $driver_name ]] && [[ "$low" == *boxhfs* || "$low" == *grubhfs* ]]; then
        echo "Removing ${driver_dir}/${driver} because $driver_name is installed!" >> "$install_log"
        rm -f $driver
      fi
    done
  elif [[ $driver_name == ApfsDriverLoader.efi ]]; then
    for driver in *.efi
    do
      low=$(echo $driver | tr '[:upper:]' '[:lower:]')
      if [[ $driver != $driver_name && "$low" == apfs.efi ]]; then
        echo "Removing ${driver_dir}/${driver} because $driver_name is installed!" >> "$install_log"
        rm -f $driver
      fi
    done
  fi
fi

You can see bugs? Consider that the above is a Post install script and this operation is only performed if you install a file system driver, i.e. HFSPlus in this case.

On 7/20/2019 at 3:17 PM, Sherlocks said:

r5027. i removed /Library/Preferences/com.projectosx.clover.installer.plist file.

the i capture this default drivers.

스크린샷 2019-07-20 오후 10.22.29.png

what for person like me that really doesn't have any hfs partition? :whistle:. Anyway I'm not alone... so the the simplest and fastest solution is to remove VBoxHfs.efi from the package when HFSPlus.efi is present w/o messing with infinite statement in the Distribution file. 

2 hours ago, Slice said:

One drive with several partitions HFS+

You succeded finding the ESP?

Edited by vector sigma

Share this post


Link to post
Share on other sites
32 minutes ago, vector sigma said:

 

@ricoc90, @Cyberdevs please, I need the dump from both of you. To All,  please confirm you can find the ESP from regular disks (whith apfs containers or other fs).

Thanks in advance


Here you go for fusion drive: espfinder.plist.zip 

On my regular system it does find the ESP as it should:

2102567794_Schermafbeelding2019-07-24om23_19_05.png.1801943588cb0ed2c88d989c79368627.png

Share this post


Link to post
Share on other sites
8 hours ago, vector sigma said:

 

You succeded finding the ESP?

Of course!

I proposed you see this in log.

Yes found with any arguments. disk0s4, disk0s7

Share this post


Link to post
Share on other sites

@vector sigma

Sorry for the delay here's my log. I have one SSD and one HDD attached to the system and I made the Fusion Drive and I'm running Catalina at the moment.

 

Please let me know if there's anything else that you need me to do. :)

 

espfinder.plist.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
       
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      Download:  https://github.com/xe97/X99-8D3-Clover
       
       
       
       
       
      Anyone else I forgot
       
       
    • By digivish
      Hi All - quick thing - I have a NUC 8i7BEH with 32GB RAM and 2 x 1TB SSD drives. Each drive has its own OS - Windows 10 and Catalina 10.15.
       
      Clover works well - Catalina Boots, so does Windows.
      Catalina - has sound over HDMI (to my monitor's speakers)
      Windows - no audio device found - It does show Realtek and Intel Display Drivers - but the speaker has a red"x" and in Devices, there is no entry for Microphone Array under Audio Input/Output. It does, however, show Intel display over the HDMI - but actually no sound.
       
      I have tried reinstalling Realtek drivers - now here's the thing...when it installs, it first uninstalls existing Realtek drivers - at this stage (and it's important) the sound starts working - as if uninstalling did the trick. As part of the installing, I have to reboot and upon reboot, it actually reinstalls the Realtek drivers. After that, I'm back to square 1. Unsure if it's the config.plist or boot args in clover. But something with Clover for sure.
       
      I have tested this by removing the Mac Drive with clover and just booting directly to Windows 10 bootloader and everything works as it should, I have sound over HDMI and the audio device shows. Just not when I boot with Clover.
       
      has anyone experienced this and have thoughts or pointers.
       
      Thanks a ton!
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&amp;t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×