Jump to content
ErmaC

Clover General discussion

20,459 posts in this topic

Recommended Posts

Posted (edited)
31 minutes ago, vector sigma said:

Ok that make sense. The option is enabled/selectable only if the target volume contains /bin/launchctl. That was a way to say "this is an OS", but now is on the wrong side. Need a revise, please guys help to find a way compatible with old OSes and we can make appear CTM, the prefpanel .. (rc scrips?) only if some conditions are met, i.e. only on the right partition!


I thought we can't check/tick Preference pane because Catalina Disk - Data don't have "System/Library/PreferencePanes" directory.

Anyway, i have solved my problem about empty app in /Applications.
image.thumb.png.26820ca7788f053a5e0ea31788000115.png
ReRun Install macOS Catalina.app is the only solution :D

 

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites
Advertisement
54 minutes ago, Andres ZeroCross said:

I thought we can't check/tick Preference pane because Catalina Disk - Data don't have "System/Library/PreferencePanes" directory.

+1

Share this post


Link to post
Share on other sites
Posted (edited)

Guys, want a tool to build Clover wihin Clover itself?? Ok update and:

cd Clover
./buildme

 

What it does?

Anything special other then call make if you already have every things in place (nasm and gettext), otherwise installs them in ../src/opt/local/bin/

 

WARNING: by updating edk2, the old repo will be replaced with the content of the zipped release found at tianocore/edk2/release. Now is set to use vUDK2018, but is ready to use the new one, i.e. edk2-stable201905 that actually require new Patches_for_EDK2 before be functional.

 

Better than use svn or git? Yes! no headcache to find the right revision just because we use stable and released software. Plus is faster to checkout.

Patches are applied automatically based on the fact that edk2/BaseTools/Conf/tools_def.txt exists and or contains or not the XCODE8 toolchain.

 

Want to try before using it dayly? Set up Clover to your Desktop (one line command):

mkdir -p $HOME/Desktop/src/edk2 && cd $HOME/Desktop/src/edk2 && svn checkout https://svn.code.sf.net/p/cloverefiboot/code/ Clover

double click on ~/Desktop/src/edk2/Clover/buildme

----------------------------------------------------------
buildme Beta, Clover v2.5k r5017
EDKII in use: vUDK2018
Patches in use: Patches_for_UDK2018

1) build Clover	  3) make iso	    5) update edk2
2) make pkg	  4) update Clover  6) Quit
Please enter your choice: 

 

is Beta, let see if it's usefull.

Edited by vector sigma

Share this post


Link to post
Share on other sites
13 minutes ago, vector sigma said:

Guys, want a tool to build Clover wihin Clover itself?? Ok update and:


cd Clover
./buildme

 

What it does?

Anything special other then call make if you already have every things in place (nasm and gettext), otherwise installs them in ../src/opt/local/bin/

 

WARNING: by updating edk2, the old repo will be replaced with the content of the zipped release found at tianocore/edk2/release. Now is set to use vUDK2018, but is ready to use the new one, i.e. edk2-stable201905 that actually require new Patches_for_EDK2 before be functional.

 

Better than use svn or git? Yes! no headcache to find the right revision just because we use stable and released software. Plus is faster to checkout.

Patches are applied automatically based on the fact that edk2/BaseTools/Conf/tools_def.txt exists and or contains or not the XCODE8 toolchain.

 

Want to try before using it dayly? Set up Clover to your Desktop (one line command):


mkdir -p $HOME/Desktop/src/edk2 && cd $HOME/Desktop/src/edk2 && svn checkout https://svn.code.sf.net/p/cloverefiboot/code/ Clover

double click on ~/Desktop/src/edk2/Clover/buildme


----------------------------------------------------------
buildme Beta, Clover v2.5k r5017
EDKII in use: vUDK2018
Patches in use: Patches_for_UDK2018

1) build Clover	  3) make iso	    5) update edk2
2) make pkg	  4) update Clover  6) Quit
Please enter your choice: 

 

is Beta, let see if it's usefull.


Get some error here,,, 
Step :
after run BuildMe,,, i type 5. After finish i type 1 and enter,, result as below
image.png.ea5653be65981bb161566d34accf3cf3.png

Share this post


Link to post
Share on other sites
Posted (edited)
29 minutes ago, Andres ZeroCross said:

after run BuildMe,,, i type 5. After finish i type 1 and enter,, result as below

Ha ha, stdio.h it is a very common header inside Xcode's sdk. 

what's the result of 

/usr/bin/xcodebuild -version && xcode-select --print-path

?

Edited by vector sigma
typo

Share this post


Link to post
Share on other sites
2 minutes ago, vector sigma said:

Ha ha, stdio.h it is a very common header inside Xcode's sdk. 

wath's the result of 


/usr/bin/xcodebuild -version && xcode-select --print-path

 


You're right,, i need to sudo xcode-select --switch xcodepath.

Trying again :D

 

 image.thumb.png.263205805a9e826481a61038dbfe333f.png
 

Share this post


Link to post
Share on other sites
Just now, Andres ZeroCross said:

You're right,, i need to sudo xcode-select --switch xcodepath.

Trying again :D

this usually happen when Xcode is w/o the command line tools installed, i.e when Xcode was never opened once :lol:

ok tell me if you can compile :)

Share this post


Link to post
Share on other sites
Just now, vector sigma said:

this usually happen when Xcode is w/o the command line tools installed, i.e when Xcode was never opened once :lol:


I have compiled AppleALC.kext before run "buildme" :D

I have Build Clover r5015 with this. I don't know why...

Share this post


Link to post
Share on other sites
5 minutes ago, vector sigma said:

this usually happen when Xcode is w/o the command line tools installed, i.e when Xcode was never opened once :lol:

ok tell me if you can compile :)

 

Done :)

image.thumb.png.70d00c5a27477f41f6b3e24275a3c2e5.png

Share this post


Link to post
Share on other sites
Posted (edited)
17 minutes ago, Andres ZeroCross said:

Missing AptioMemoryFix??

Is this the first time you ask this? :P joke. Anyway just before make the package copy any desired driver in the appropriate sub directory at:

src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI

in this case inside 'MemoryFix'. See the result.

Edited by vector sigma

Share this post


Link to post
Share on other sites
12 minutes ago, vector sigma said:

Is this the first time you ask this? :P joke. Anyway just before make the package copy any desired driver in the appropriate sub directory at:


src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI

in this case inside 'MemoryFix'. See the result.


Yes, this is my first time. I always use Clover from Official release, or from Did Clobber in Github. Will try it, thanks very much

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, Andres ZeroCross said:


Yes, this is my first time. I always use Clover from Official release, or from Did Clobber in Github. Will try it, thanks very much

curl -L https://github.com/acidanthera/AptioFixPkg/releases/download/R26/AptioFix-R26-RELEASE.zip -o /tmp/AptioFix-R26-RELEASE.zip

cd /tmp
unzip AptioFix-R26-RELEASE.zip

cp -r /tmp/Drivers/AptioInputFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix
cp -r /tmp/Drivers/AptioMemoryFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix

Edited by chris1111

Share this post


Link to post
Share on other sites
30 minutes ago, vector sigma said:

Is this the first time you ask this? :P joke. Anyway just before make the package copy any desired driver in the appropriate sub directory at:


src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI

in this case inside 'MemoryFix'. See the result.

 

12 minutes ago, chris1111 said:

curl -L https://github.com/acidanthera/AptioFixPkg/releases/download/R26/AptioFix-R26-RELEASE.zip -o /tmp/AptioFix-R26-RELEASE.zip

cd /tmp
unzip AptioFix-R26-RELEASE.zip

cp -r /tmp/Drivers/AptioInputFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix
cp -r /tmp/Drivers/AptioMemoryFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix

 

 

Thanks all :D
image.png.3d64d717f4e43136acd7a9cefe2345f4.png

Share this post


Link to post
Share on other sites
37 minutes ago, vector sigma said:

Is this the first time you ask this? :P joke. Anyway just before make the package copy any desired driver in the appropriate sub directory at:


src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI

in this case inside 'MemoryFix'. See the result.


Just for the input, how about change this menu to this

 

1. Update Edk2
2. Update Clover
3. Build Clover
4. Make Pkg
5. Make ISO

6. Quit

 

image.png.c95c0298629a1b1bc490c625810e6e23.png

Share this post


Link to post
Share on other sites
Posted (edited)
28 minutes ago, chris1111 said:

curl -L https://github.com/acidanthera/AptioFixPkg/releases/download/R26/AptioFix-R26-RELEASE.zip -o /tmp/AptioFix-R26-RELEASE.zip

cd /tmp
unzip AptioFix-R26-RELEASE.zip

cp -r /tmp/Drivers/AptioInputFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix
cp -r /tmp/Drivers/AptioMemoryFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix

Hi, I have a question here: Is there a compatibility issue between AptioFix-R27-RELEASE.zip and Clover r5017, so that we have to use AptioFix-R26-RELEASE.zip? 

Edited by stevezheng

Share this post


Link to post
Share on other sites
44 minutes ago, stevezheng said:

Hi, I have a question here: Is there a compatibility issue between AptioFix-R27-RELEASE.zip and Clover r5017, so that we have to use AptioFix-R26-RELEASE.zip? 

No you can use latest R27 

I did not even check the R27 release

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, chris1111 said:

curl -L https://github.com/acidanthera/AptioFixPkg/releases/download/R26/AptioFix-R26-RELEASE.zip -o /tmp/AptioFix-R26-RELEASE.zip

cd /tmp
unzip AptioFix-R26-RELEASE.zip

cp -r /tmp/Drivers/AptioInputFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix
cp -r /tmp/Drivers/AptioMemoryFix.efi $HOME/Desktop/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix

 

Great job, thanks :) The script must be modified for each AptioFix Release: how to check and download the latest version without changing the script.

 

EDIT: AptioInputFix.efi wouldn't be in EFI/CLOVER/drivers/off/UEFI/MemoryFix, I think. But in EFI/CLOVER/drivers/off/UEFI/FileVault2. Just my opinion.

Edited by Matgen84

Share this post


Link to post
Share on other sites

Hi

 

I download Buildme from Sourceforge: it's a DMS file, can"t extract. How do you do it.

 

Please

Share this post


Link to post
Share on other sites
Posted (edited)
function abort() {
  echo "ERROR: ${1}" 1>&2
  exit 1
}

#
# Get the latest release tag on GitHub.
#
# @param author Name of user/organization on GitHub
# @param repo   Repository belonging to the author
#
# @return latest tag of author/repo
#
function getGitHubLatestReleaseTag() {
  local author="$1"
  local repo="$2"

  if [ -z "${author}" ] || [ -z "${repo}" ]; then
    echo 'Author or repository is null!' 1>&2
    exit 1
  fi

  local url="https://api.github.com/repos/${author}/${repo}/releases"

  local tag="$(curl --silent "${url}" | grep 'tag_name' | head -n 1 | awk -F ":" '{print $2}' | tr -d '"' | tr -d ',' | tr -d ' ')"
  if [ -z "${tag}" ]; then
    abort "WARNING: Failed to retrieve latest tag of release from ${author}/${repo}." 1>&2
  fi

  echo "${tag}"
}

#
# Download a file from release page of author/repo.
#
# @param author   Name of user/organization on GitHub
# @param repo     Repository belonging to the given author
# @param tag      Tag to search for, or null for latest
# @param fileName Asset of the tag
#
function downloadGitHubRelease() {
  local author="$1"
  local repo="$2"
  local tag="$3"
  local fileName="$4"

  if [ -z "${author}" ] || [ -z "${repo}" ] || [ -z "${fileName}" ]; then
    abort 'Author/repository/file name is null!'
  fi

  if [ -z "${tag}" ]; then
    tag="$(getGitHubLatestReleaseTag "${author}" "${repo}")"
  fi

  local url="https://github.com/${author}/${repo}/releases/download/${tag}/${fileName}"

  curl --silent -L "${url}" -o "${fileName}" || abort "Failed to download ${fileName}!"
}

Tiny functions extracted from one of my scripts for download from GitHub release page.

 

For this specific case, let's abstract it based on tag and fileName:

- tag is Rxx, which can be retrieved by getGitHubLatestReleaseTag()

- fileName, generally RELEASE is grabbed, then it would be "AptioFix-${tag}-RELEASE.zip"

Edited by PMheart
Fixed a severe typo.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, @vector sigma

How about chnage readme.md in Clover Source forge about ManualBuild Clover with your script or another script???
https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/Readme.md

Honestly,, for who want to start build clover will get some trouble to build if don't read some pages of this thread :D

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites
14 hours ago, vector sigma said:

By the way can I ask why there's a need to use hfs instead of apfs? It is not clear to me if this is allowed.. 

Forget about Clover installation failure on Catalina with HFS+.. But the "javascript" error also occurred on 10.11.6 and 10.12.6 (which has no APFS support CMIIW). Plus, 10.13.6.. that I use daily. Does clover installer now only support APFS and drop 10.6 up to 10.12? But installer said HFS is supported either. Thanks.

Share this post


Link to post
Share on other sites
1 minute ago, Badruzeus said:

Forget about Clover installation failure on Catalina with HFS+.. But the "javascript" error also occurred on 10.11.6 and 10.12.6 (which has no APFS support CMIIW). Plus, 10.13.6.. that I use daily. Does clover installer now only support APFS and drop 10.6 up to 10.12? But installer said HFS is supported either. Thanks.


Don't worry clover still support 10.16 -> 10.12,, let get a glass of coffee. LoL

Share this post


Link to post
Share on other sites
1 minute ago, Andres ZeroCross said:


Don't worry clover still support 10.16 -> 10.12,, let get a glass of coffee. LoL

Not talking about Clover, but the installer package only. Though, I have say thanks to Chris1111, vector sigma for that javascript. I can only test and report, am unable to reproduce the problem.. and I believe no one asked me doing so #LOL.

 

Just curious; filesystem restriction is Catalina problem (could be Beta bug either), why Clover even bother about it? I have no worry as rarely install Clover from *.pkg. But last time could not check my id.po translation on installer bcoz bloated javascript prevents it. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15
      Original link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      For any system kext installation\modification you need to boot with config_debug.plist (or disable SIP manually)
      Also on Catalina the System folder is read-only, so you need to remount in rw. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      EFI-Clover-X99.zip
       
       
       
       
       
       
      Anyone else I forgot
       
       
×