Jump to content
About Just Joined group Read more... ×
ErmaC

Clover General discussion

24,623 posts in this topic

Recommended Posts

@Sherlocks and all, r4994 should install in 10.15 by automatically change the root fs as rw (of course this is only done in 10.15+). There's a dialog anyone can translate in any language.

 

Clover_v2.4k_r4994.zip

 

@Slice take a look at localizable.strings and tell me if is now ok. To All, at the beginning of the localizable.strings now there are two new localization to be translated, as just said for the dialogs the package now show you in Catalina.

Share this post


Link to post
Share on other sites
Advertisement
1 minute ago, chris1111 said:

@vector sigma

I test the new distribution its like to be working  

I made it all "embeded" + a check for the OS should not be  older then catalina:

  function checkFileSystemIsWritable()
  {
    var result = true;
    if (-1 == system.numericalCompare('10.14.9', system.version.ProductVersion)) {
        result = false;
        var cmd = '/usr/bin/osascript -e\''
        cmd += 'do shell script "mount -uw /" with prompt '
        cmd += '"' + system.localizedString('MakingRootRW') + '"'
        cmd += ' with administrator privileges\''
        try
        {
           cmd = system.runOnce('/bin/sh', '-c', cmd);
           result = (cmd == 0);
           } catch (e) {
            system.log('mount -uw / returned with error: ' + e);
            result = false;
         }
         
         if (result == false) {
          my.result.message = system.localizedString('GoToFailRootRW');
          my.result.type = 'Fatal';
         }
     }
	system.log("checkFileSystemIsWritable() returned: " + result);
    return result;
  }

 

Share this post


Link to post
Share on other sites
1 minute ago, vector sigma said:

I made it all "embeded" + a check for the OS should not be  older then catalina:


  function checkFileSystemIsWritable()
  {
    var result = true;
    if (-1 == system.numericalCompare('10.14.9', system.version.ProductVersion)) {
        result = false;
        var cmd = '/usr/bin/osascript -e\''
        cmd += 'do shell script "mount -uw /" with prompt '
        cmd += '"' + system.localizedString('MakingRootRW') + '"'
        cmd += ' with administrator privileges\''
        try
        {
           cmd = system.runOnce('/bin/sh', '-c', cmd);
           result = (cmd == 0);
           } catch (e) {
            system.log('mount -uw / returned with error: ' + e);
            result = false;
         }
         
         if (result == false) {
          my.result.message = system.localizedString('GoToFailRootRW');
          my.result.type = 'Fatal';
         }
     }
	system.log("checkFileSystemIsWritable() returned: " + result);
    return result;
  }

 

Yea I see

did you find info from NPM site 

Share this post


Link to post
Share on other sites
22 minutes ago, chris1111 said:

did you find info from NPM site 

No on the Apple developer portal

Anyway this I guess cannot be killed by Apple because all this is done before even the target volume is selected. Which is also a downside if you want to install else where.

Edited by vector sigma

Share this post


Link to post
Share on other sites
2 minutes ago, Matgen84 said:

I try to build r4994 and I got this issue...

Make:

Status = ReadDisk (
      DiskIo,
      DiskIo2,
      MediaId,
      EfiFileCurrentExtentOffset,
      EfiFileCurrentExtentSize,
      (CHAR8*)EfiFileBuffer + CurPos
      );

to be:

Status = ReadDisk (
      DiskIo,
      DiskIo2,
      MediaId,
      EfiFileCurrentExtentOffset,
      EfiFileCurrentExtentSize,
      EfiFileBuffer + CurPos
      );

in ApfsDriverLoader.c

Share this post


Link to post
Share on other sites
14 minutes ago, vector sigma said:

Make:


Status = ReadDisk (
      DiskIo,
      DiskIo2,
      MediaId,
      EfiFileCurrentExtentOffset,
      EfiFileCurrentExtentSize,
      (CHAR8*)EfiFileBuffer + CurPos
      );

to be:


Status = ReadDisk (
      DiskIo,
      DiskIo2,
      MediaId,
      EfiFileCurrentExtentOffset,
      EfiFileCurrentExtentSize,
      EfiFileBuffer + CurPos
      );

in ApfsDriverLoader.c

 

I do make a mistake because no more directories 

 

EDIT: I try to compile in Mojave 10.14.5 / Xcode 10.2.1

 

Capture d’écran 2019-07-12 à 18.46.46.png

Edited by Matgen84

Share this post


Link to post
Share on other sites
3 minutes ago, vector sigma said:

Did you use a script or did you do that manually? Any way something should appear in terminal...

 

I use manual makepkg in Terminal

 

========= Translating Resources ========
/Users/mathieu/src/udk2018/clover/cloverpackage/package/../../../../opt/local
Updating 'en' strings file for CloverUpdater... done
Updating 'en' strings file for Clover Preference Panel... done
Updating strings file for Clover Preference Panel... done
 (204 entries)

Updating 'en' strings file for CloverUpdater... done
Generating de interface... done
Generating es interface... done
Generating fr interface... done
Generating hr interface... done
Generating id interface... done
Generating it interface... done
Generating ja interface... done
Generating ko interface... done
Generating lv interface... done
Generating nl interface... done
Generating pl interface... done
Generating pt-BR interface... done
Generating pt interface... done
Generating ro interface... done
Generating ru interface... done
Generating tr interface... done
Generating uk interface... done
Generating vi interface... done
Generating zh_CN interface... done
Generating zh_TW interface... done
Building CloverUpdater application...
[XCODE]
Updating 'en' strings file for Clover Preference Panel... done
Generating de interface... done
Generating es interface... done
Generating fr interface... done
Generating hr interface... done
Generating id interface... done
Generating it interface... done
Generating ja interface... done
Generating ko interface... done
Generating lv interface... done
Generating nl interface... done
Generating pl interface... done
Generating pt-BR interface... done
Generating pt interface... done
Generating ro interface... done
Generating ru interface... done
Generating tr interface... done
Generating uk interface... done
Generating vi interface... done
Generating zh_CN interface... done
Generating zh_TW interface... done
Updating strings file for Clover Preference Panel... done
Check de strings... done
Check en strings... done
Check es strings... done
Check fr strings... done
Check hr strings... done
Check id strings... done
Check it strings... done
Check ja strings... done
Check ko strings... done
Check lv strings... done
Check nl strings... done
Check pl strings... done
Check pt-BR strings... done
Check pt strings... done
Check ro strings... done
Check ru strings... done
Check tr strings... done
Check uk strings... done
Check vi strings... done
Check zh_CN strings... done
Check zh_TW strings... done
Building CloverPrefpane preference...
[XCODE]
================= Making all in boot1-install =================
	[XCODE] boot1-install
================= Making all in partutil =================
	[XCODE] partutil
================= Making all in bdmesg =================
	[XCODE] bdmesg
================= Making all in clover-genconfig =================
	[XCODE] clover-genconfig

  -------------------------------
  Building Clover Install Package
  -------------------------------

====================== Preinstall ======================
	[BUILD] Pre
===================== Installation =====================
	[BUILD] UEFI.only
================== Target ESP ==========================
	[BUILD] Target.ESP
=================== BiosBoot ===========================
	[BUILD] BiosBoot
===================== Utils ============================
	[BUILD] Utils
===================== EFI folder =======================
	[BUILD] EFIFolder
===================== off drivers ======================
find: /Users/mathieu/src/udk2018/clover/cloverpackage/CloverV2/EFI/CLOVER/drivers: No such file or directory
	[BUILD] off
===================== BootLoaders ======================
	[BUILD] AltBoot
	[BUILD] bootNo
	[BUILD] boot0af
	[BUILD] boot0ss
====================== CloverEFI =======================
	[BUILD] cloverEFI.64.sata
===================== RC Scripts =======================
	[BUILD] rc.scripts.on.target
	[BUILD] rc.scripts.on.all.volumes
	[BUILD] rc.scripts.core
================= Optional RC Scripts ==================
	[BUILD] disable_sleep_proxy_client
======================== Themes ========================
	[BUILD] Clovy
	[BUILD] BGM
	[BUILD] cesium
	[BUILD] CloverThemeManager
==================== Clover Prefpane ===================
	[BUILD] CloverPrefpane
================= Post =================
	[BUILD] Post

 --------------------------
 Building process complete!
 --------------------------

 Build info.
 ===========
  Package name: Clover_v2.4k_r4994.pkg
  MD5:          91def03c5481e636a48ab21c1e213d12
  Version:      v2.4k
  Stage:        v2.4k
  Date/Time:    2019-07-12 18:33:46
  Built by:     mathieu
  Copyright     2012-2019

  adding: Clover_v2.4k_r4994.pkg (deflated 0%)
  adding: Clover_v2.4k_r4994.pkg.md5 (stored 0%)
total 35064
drwxr-xr-x   9 mathieu  staff      288 Jul 12 18:43 .
drwxr-xr-x  15 mathieu  staff      480 Jul 12 18:43 ..
-rw-r--r--@  1 mathieu  staff  8754566 Jul 12 18:43 Clover_v2.4k_r4994.pkg
-rw-r--r--   1 mathieu  staff       68 Jul 12 18:43 Clover_v2.4k_r4994.pkg.md5
-rw-r--r--   1 mathieu  staff  8733421 Jul 12 18:43 Clover_v2.4k_r4994.zip
drwxr-xr-x   3 mathieu  staff       96 Jul 12 18:43 Resources
drwxr-xr-x   6 mathieu  staff      192 Jul 12 18:43 build
drwxr-xr-x   3 mathieu  staff       96 Jul 12 18:43 package
drwxr-xr-x   6 mathieu  staff      192 Jul 12 18:43 utils

 

Share this post


Link to post
Share on other sites
3 minutes ago, vector sigma said:

Drivers directories are created by ebuild.sh. Run it before ..otherwise. And please post what's on your terminal entirely please.

 

All works fine under Mojave. Thanks :)

 

Please commit your new ApfsDriverLoader.c

Share this post


Link to post
Share on other sites
2 hours ago, vector sigma said:

Make:


Status = ReadDisk (
      DiskIo,
      DiskIo2,
      MediaId,
      EfiFileCurrentExtentOffset,
      EfiFileCurrentExtentSize,
      (CHAR8*)EfiFileBuffer + CurPos
      );

to be:


Status = ReadDisk (
      DiskIo,
      DiskIo2,
      MediaId,
      EfiFileCurrentExtentOffset,
      EfiFileCurrentExtentSize,
      EfiFileBuffer + CurPos
      );

in ApfsDriverLoader.c

It rather should be (UINT8*)

Share this post


Link to post
Share on other sites

Hi @fusion71au !

 

So, after a long day of testing, I managed to find the cause for the red text screen with x64 Exception Type 06. And it seems to have something to do with Clover itself.

 

Older versions like 3911 work fine. But only if I select BiosBlockIO. With SATA, I get the exact same behavior (blinking cursor for a while, then "not found" then red screen). With BiosBlockIO it goes straight into Clover GUI (with a few icon issues for the embedded theme)...but it gets there. 

 

1706622046_Screenshot2019-07-12at23_59_51.thumb.png.bca66d81f2f6dbdbebbd1506ea19486b.png

 

Also, 3911 had its own issues (mouse and keyboard not working in Clover GUI). Fixed it by removing AppleKeyAggregator. Newer versions don't seem to have it, so I guess that's ok.

 

Another problem with 3911 is, of course, the fact that it can't boot Mojave (and not because of APFS, since I've got ApfsDriverLoader already in place, it's most likely the kext injection). :)) So...while I did get to the Clover GUI and I did manage to get my keyboard working so I can select the boot drive, I got stuck on my way to Desktop.

 

So, to sum up:

1. newer versions of Clover (such as 4993) don't have BiosBlockIO anymore, so I will get that red screen if I select the SATA option and try to boot in Legacy mode (and yes, it looks like I remembered correctly, I DO get the exact same issue booting off of the USB as I did booting from the DVD, and now we know why).

2. older versions (such as 3911) can boot ok in Legacy mode, but only if BiosBlockIO is selected. Same issue if SATA is selected. Problem here is that those versions can't boot newer MacOS versions, such as Mojave.

So...yeah, not sure why BiosBlockIO was removed for Legacy booting...but I can't seem to be able to boot otherwise.

 

So, in a nutshell, older Clover can boot to Clover GUI, but can't get any further, due to OS issues, newer Clover can't boot even into the GUI, due to SATA issues (red screen with "x64 Exception Type 06" error) but, in theory, it should be able to boot Mojave.

 

Maybe there's something in BIOS that should be checked in order for this to work with SATA, as well...? No idea. But so far, these are the results. :)

Share this post


Link to post
Share on other sites
3 hours ago, vector sigma said:

is inited as VOID*, I guess it is compatible with the smallest size of UInt8. But yes.

I made this change because of what? 

It was initially VOID*, but it is not compatible with VS2013 (error C2036).

Share this post


Link to post
Share on other sites
1 hour ago, arsradu said:

Hi @fusion71au !

 

So, to sum up:

1. newer versions of Clover (such as 4993) don't have BiosBlockIO anymore, so I will get that red screen if I select the SATA option and try to boot in Legacy mode (and yes, it looks like I remembered correctly, I DO get the exact same issue booting off of the USB as I did booting from the DVD, and now we know why).

2. older versions (such as 3911) can boot ok in Legacy mode, but only if BiosBlockIO is selected. Same issue if SATA is selected. Problem here is that those versions can't boot newer MacOS versions, such as Mojave.

So...yeah, not sure why BiosBlockIO was removed for Legacy booting...but I can't seem to be able to boot otherwise.

 

So, in a nutshell, older Clover can boot to Clover GUI, but can't get any further, due to OS issues, newer Clover can't boot even into the GUI, due to SATA issues (red screen with "x64 Exception Type 06" error) but, in theory, it should be able to boot Mojave.

 

Maybe there's something in BIOS that should be checked in order for this to work with SATA, as well...? No idea. But so far, these are the results. :)

 

@arsradu,

 

I noticed the makeiso script formats the iso with -eltorito-boot, to allow for legacy BIOS booting, and it also uses boot6 instead of boot7 (BiosBlockIO) which works on your system.  I'm guessing the presence of the legacy BIOS code is what makes the CD-DVD-ROM "invisible" to your firmware when it is set to boot to "UEFI only".

 

Try the following modified makeiso files (place in ~/src/edk2/Clover/CloverPackage) to generate the Clover ISO instead of the default one...

makeiso_boot7.zip ---> uses boot 7 instead of boot 6 for legacy boot

makeiso_uefi_only.zip ---> removed -eltorito-boot formatting so only UEFI booting possible

 

PS BiosBlockIO is still available in the latest Clover Pkg installer r4995.  If the boot7/BosBlockIO installed by r4995 doesn't work, then simply replace it with the boot7 "boot" file from Clover r3911 (keep the rest of the files from Clover r4995, including CLOVERX64.efi, BOOTX64.efi and the new drivers folder file structure)...

 

BiosBlockIO.png.b2405cfea903cbfcee7b388de9265433.png1770777261_Bootfile.png.a70ac1b6f2c7150185c4c4e99ea329a9.png

 

Good Luck!

Clover_v2.4k_r4995.pkg.zip

Edited by fusion71au
typo

Share this post


Link to post
Share on other sites
9 hours ago, Slice said:

It rather should be (UINT8*)

 

 

9 hours ago, vector sigma said:

is inited as VOID*, I guess it is compatible with the smallest size of UInt8. But yes.

 

exrpression (UNIT8*) don't work in Mojave / Xcode 10.2.1: can't compile. Please commit previous vector sigma diff or else.

 

make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
/Users/mathieu/src/UDK2018/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader.c:953:20: error: expected expression
            (UNIT8*)EfiFileBuffer + CurPos
                   ^
/Users/mathieu/src/UDK2018/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader.c:953:14: error: use of undeclared identifier 'UNIT8'
            (UNIT8*)EfiFileBuffer + CurPos
             ^
2 errors generated.
make: *** [/Users/mathieu/src/UDK2018/Build/Clover/RELEASE_XCODE8/X64/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader/OUTPUT/ApfsDriverLoader.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/mathieu/src/udk2018/Build/Clover/RELEASE_XCODE8/X64/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader]


build.py...
 : error F002: Failed to build module
	/Users/mathieu/src/udk2018/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader.inf [X64, XCODE8, RELEASE]

- Failed -

 

Share this post


Link to post
Share on other sites
21 minutes ago, Matgen84 said:

 

 

 

exrpression (UNIT8*) don't work in Mojave / Xcode 10.2.1: can't compile. Please commit previous vector sigma diff or else.

 


make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
make: Nothing to be done for `tbuild'.
/Users/mathieu/src/UDK2018/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader.c:953:20: error: expected expression
            (UNIT8*)EfiFileBuffer + CurPos
                   ^
/Users/mathieu/src/UDK2018/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader.c:953:14: error: use of undeclared identifier 'UNIT8'
            (UNIT8*)EfiFileBuffer + CurPos
             ^
2 errors generated.
make: *** [/Users/mathieu/src/UDK2018/Build/Clover/RELEASE_XCODE8/X64/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader/OUTPUT/ApfsDriverLoader.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/mathieu/src/udk2018/Build/Clover/RELEASE_XCODE8/X64/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader]


build.py...
 : error F002: Failed to build module
	/Users/mathieu/src/udk2018/Clover/FileSystems/ApfsDriverLoader/ApfsDriverLoader.inf [X64, XCODE8, RELEASE]

- Failed -

 

Not UNIT8 but UINT8 like in rev 4996.

Share this post


Link to post
Share on other sites
7 hours ago, fusion71au said:

 

@arsradu,

 

I noticed the makeiso script formats the iso with -eltorito-boot, to allow for legacy BIOS booting, and it also uses boot6 instead of boot7 (BiosBlockIO) which works on your system.  I'm guessing the presence of the legacy BIOS code is what makes the CD-DVD-ROM "invisible" to your firmware when it is set to boot to "UEFI only".

 

Try the following modified makeiso files (place in ~/src/edk2/Clover/CloverPackage) to generate the Clover ISO instead of the default one...

makeiso_boot7.zip ---> uses boot 7 instead of boot 6 for legacy boot

makeiso_uefi_only.zip ---> removed -eltorito-boot formatting so only UEFI booting possible

 

PS BiosBlockIO is still available in the latest Clover Pkg installer r4995.  If the boot7/BosBlockIO installed by r4995 doesn't work, then simply replace it with the boot7 "boot" file from Clover r3911 (keep the rest of the files from Clover r4995, including CLOVERX64.efi, BOOTX64.efi and the new drivers folder file structure)...

 

BiosBlockIO.png.b2405cfea903cbfcee7b388de9265433.png1770777261_Bootfile.png.a70ac1b6f2c7150185c4c4e99ea329a9.png

 

Good Luck!

Clover_v2.4k_r4995.pkg.zip

 

Hi there! :) 

 

So, let's see.

 

1. I'm guessing you're building Clover with a custom script or something, cause I couldn't get mine to add BiosBlockIO. :P Also, I see yours also has a few third party drivers and other wonders.

 

This is what I get with regular compiling.

743490089_Screenshot2019-07-13at08_37_37.thumb.png.6b7bcfb96c4a29f506f970492100c6ca.png

 

However, even with your 4995 pkg, I still can't boot. But the behaviour is a little different than before.

 

I get the cursor on the top-left corner, the "not found" thing, but no red screen anymore. It's just stuck at "not found".

 

Replacing boot from 3911 into the 4995 USB also doesn't do anything. Same exact behaviour as above (stuck at "not found").

 

2. makeiso_boot7 - same as above. Stuck at "not found".

 

I've got the exact same behavior when nothing was written on the CD and trying to boot from it (stupid mistake on my side, I erased the disk, but forgot to put something back on it). Still, it was interesting to me that I got the exact same behaviour. So, no difference with or without content, that's what I'm trying to say.

 

3. makeiso_UEFI_only - still not visible in boot menu.

 

Also, not sure that's intended (but I've got the same issue with the regular makeiso), but I've got no themes (at all) in the /themes folder on the iso...although the themes are present in CloverV2/themespkg. But they don't seem to make their way into the actual iso file.

 

I don't think my inability to boot has anything to do with the themes, since I have the same issue with your 4995 pkg, and I do have themes on the USB drive, so it can't be that. But I'm just mentioning it in case they should be there (which I'm guessing they should).

 

 

Edited by arsradu

Share this post


Link to post
Share on other sites
20 minutes ago, arsradu said:

1. I'm guessing you're building Clover with a custom script or something, cause I couldn't get mine to add BiosBlockIO.

you forgot to add -mc to ebuild.sh?

./ebuild.sh -mc --no-usb -D NO_GRUB_DRIVERS_EMBEDDED -t XCODE8

 

Share this post


Link to post
Share on other sites
2 minutes ago, vector sigma said:

you forgot to add -mc to ebuild.sh?


./ebuild.sh -mc --no-usb -D NO_GRUB_DRIVERS_EMBEDDED -t XCODE8

 

Can't forget something I never knew I needed. :))) But yeah, that part was missing. Thank you!

Edited by arsradu

Share this post


Link to post
Share on other sites
1 hour ago, arsradu said:

Replacing boot from 3911 into the 4995 USB also doesn't do anything. Same exact behaviour as above (stuck at "not found").

 

There might be a bit of confusion here.  Legacy boot should work now that you proved it does with r3911 :P.

  1. Install latest Clover r4996 with pkg installer in legacy mode targeting your USB drive (custom option: install in EFI etc)
  2. Make sure all your needed efi drivers are in EFI/CLOVER/drivers/BIOS, normal kexts, config.plist present in their respective folders etc
  3. Delete the file named "boot" at the root folder, / , of your USB drive's EFI partition (this is actually boot6=CloverEFI 64 bits SATA, renamed as "boot")
  4. Replace with boot7 = CloverEFI 64 bits BiosBlockIO (which I extracted from official Clover r3911 ISO on Sourceforge) on the root of the USB drive, renamed as "boot"

 

Try legacy boot again to your USB...

 

46 minutes ago, arsradu said:

Can't forget something I never knew I needed. :))) But yeah, that part was missing. Thank you!

Make sure you put the working boot7 from Clover r3911 in ~/src/edk2/Clover/CloverPackage/CloverV2/Bootloaders/x64 before running makeiso_boot7 from your ~/src/edk2/Clover/CloverPackage folder.  Otherwise it also won't be present in your Clover ISO :lol:.

 

Also regarding the missing embedded theme in your ISO:  Did you copy the embedded theme folder from ~/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/themes to ~/src/edk2/Clover/CloverPackage/CloverV2/themespkg before running makeiso?

 

 

 

2 hours ago, XLNC said:

is aptiomemfix removed from clover ? 

 

Yes, this is an acidanthera project now. 

 

If you build Clover with Build_Clover.command and specify XCODE5 toolchain, you will still find it compiled in the ~/src/edk2/Build/AptioFixPkg/RELEASE_XCODE5/X64 folder  ---> manually copy it to your ~/src/edk2/Clover/CloverPackage/CloverV2/EFI/CLOVER/drivers/off/UEFI/MemoryFix folder.  Then cd to ~/src/edk2/Clover/CloverPackage and run ./makepkg to create the Clover installer.

 

Edited by fusion71au

Share this post


Link to post
Share on other sites
8 hours ago, Slice said:

I made this change because of what? 

It was initially VOID*, but it is not compatible with VS2013 (error C2036).

Well that explain why. C standard treat void as an incomplete type while the gnu one consider it to be size 1. 

Share this post


Link to post
Share on other sites

Announcements

  • Similar Content

    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/y6avuxsv
       
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/y6avuxsv
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
      USB INTEL SERIE 400.zip
       
      Use these kexts, enable XHCI port limit patch and follow this tutorial for remap USB ports
       
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By y010204025
      Update: On October 24, 2020, using clover to solve the macOS11 beta10 boot problem, you can now enjoy macOS11beta10, and the compatibility of subsequent versions is not guaranteed.
      HIDPI uses a modified version. You can directly execute the hidpi script to get a better experience. If you lose the repair, it is not within the scope of my support.
      Support upgrades without destroying the integrity of the original image.
      There seems to be a problem with the shortcut keys. If you can help solve it, thank you for your contribution.
       
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro.  
       
    • By BALDY_MAN
      Hi All.
      Im Happy to share my new EFI file that I put together  18/10/2020. which got me up and running 11.0  Beta(20A5395g) on my hack
      a thanks you to everyone who's work I have use to assemble this EFI File. and the help I have received from this site
      I have used openCore 0.6.3, sound work for me (HDMI) and onboard Ethernet. map the usb ports as you wish.
      the definition to iMac20,2
      hope it helps all who need it
      PS. Please leave a comment if the EFI File is helpful to you
      (No Kexts were Harmed in the making of this EFI)
      THIS EFI. WAS MADE ON A Z490 GIGABYTE MASTER For the Z490 Gigabyte Master ONLY
                                                                                                                     regards
                                                                                                                                         Baldy_man
      GigabyteZ40Master.EFI.(20A539g) .zip
    • By le332313
      Can someone share the dell 5593/5493 EFI ? I try to fit the graphics driver, but it not working please help me thanks
       
    • By Nomade
      Hello All,
       
      It's been a while that I am trying to update my system to 10.15.16.
      The install seem to start, then at reboot time I only see the Normal boot and the Recovery option from the Clover boot menu.
      None of those 2 allow to complete the update.
       
      Is there any ways to force it to install and/or show the "Update" option on the Clover boot screen?
       
      PS: I'm using Z97-Gaming-3
×