Jump to content
ErmaC

Clover General discussion

21,117 posts in this topic

Recommended Posts

14 minutes ago, vector sigma said:

What about:


// SetupDataForOSX
/// Sets the DataHub data used by OS X
VOID EFIAPI
SetupDataForOSX(BOOLEAN Hibernate)
{
  EFI_STATUS Status;

  UINT32     DevPathSupportedVal;
  UINT64     FrontSideBus;
  UINT64     CpuSpeed;
  UINT64     TscFrequency;
  UINT64     ARTFrequency;
  CHAR16*    ProductName;
  CHAR16*    SerialNumber;
  UINTN      Revision;
  UINT16     Zero = 0;
  BOOLEAN    isRevLess = (gSettings.REV[0] == 0 &&
                          gSettings.REV[1] == 0 &&
                          gSettings.REV[2] == 0 &&
                          gSettings.REV[3] == 0 &&
                          gSettings.REV[4] == 0 &&
                          gSettings.REV[5] == 0);
  
  if (AsciiStrStr(gSettings.BootArgs, "-withREV") != NULL) {
    isRevLess = false;
  } else if (AsciiStrStr(gSettings.BootArgs, "-noREV") != NULL) {
    isRevLess = true;
  }

and use the same arguments used by FakeSMC??

 

good boot-arg. can we consider that no need update fakesmc that is not relate new model without boot-arg?

from check clover's any values, does fakesmc have determination to add isRevLess as free?

the recent models of apple has t2 and smc3 except imac19.x.
we just think imac19.x have t2 and smc3. but it's not correct.
in future, there are possibility that not include smc3 version in macbook11,1 or macbookpro16,1 or etc.

therefore, if we add smbios data in clover's platformdata of the future model, can we consider freely more from smc3 according to clover in fakesmc?

ofc, default value has all(rev/pbr/epci)

it's just my think. sorry for my bad english.

Edited by Sherlocks

Share this post


Link to post
Share on other sites
Advertisement
1 minute ago, Sherlocks said:

good boot-arg. can we consider that no need update fakesmc that is not relate new model without boot-arg?

from check clover's any values, does fakesmc have determination to add isRevLess as free?

the recent models of apple has t2 and smc3 except imac19.x.
we just think imac19.x have t2 and smc3. but it's not correct.
in future, there are possibility that not include smc3 version in macbook11,1 or macbookpro16,1 or etc.

therefore, if we add smbios data in clover's platformdata of the future model, can we consider freely more from smc3 according to clover in fakesmc?

it's just my think. sorry for my bad english.

FakeSMC is not used only by Clover, so it has to know which models needs REV or not. In fact REV (and a lot of keys) can be injected by it's Info.plist. 

Only users that will have older Clover or FakeSMC (the actual revisions, from now on) can decide to override this behaviour with boot-args, with or without having an updated platformdata for newer models.

Share this post


Link to post
Share on other sites
3 minutes ago, vector sigma said:

FakeSMC is not used only by Clover, so it has to know which models needs REV or not. In fact REV (and a lot of keys) can be injected by it's Info.plist. 

Only users that will have older Clover or FakeSMC (the actual revisions, from now on) can decide to override this behaviour with boot-args, with or without having an updated platformdata for newer models.

 

FakeSMC is not used only by Clover

- i forgot it. so seems it's best now.

Share this post


Link to post
Share on other sites

Anyway why Apple done that? I've received notification from the System when the revision was bad.... something tells me that this can have some evolution.. who knows..

or was something else?:unsure:

Edited by vector sigma

Share this post


Link to post
Share on other sites

Thay's bit weird that since r4956 I got random AppleSMC kernel panic when mach halt (reboot / shutdown). Not sure why mine is affected bcoz I'm sure my SMBios (MBP10,1) is not on those updated platformdata.c list. A similar issue with 10.3.6 upto 10.15 Beta using FakeSMC (Rehabman), not trying VirtualSMC yet. (Sorry, can not upload full crash logs. I'm currently on mobile).

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

Thay's bit weird that since r4956 I got random AppleSMC kernel panic when mach halt (reboot / shutdown). Not sure why mine is affected bcoz I'm sure my SMBios (MBP10,1) is not on those updated platformdata.c list. A similar issue with 10.3.6 upto 10.15 Beta using FakeSMC (Rehabman), not trying VirtualSMC yet. (Sorry, can not upload full crash logs. I'm currently on mobile).

 

strange. did you try to cleanup nvram?

Share this post


Link to post
Share on other sites
2 hours ago, Badruzeus said:

Thay's bit weird that since r4956 I got random AppleSMC kernel panic when mach halt (reboot / shutdown). Not sure why mine is affected bcoz I'm sure my SMBios (MBP10,1) is not on those updated platformdata.c list. A similar issue with 10.3.6 upto 10.15 Beta using FakeSMC (Rehabman), not trying VirtualSMC yet. (Sorry, can not upload full crash logs. I'm currently on mobile).

Is it happen with FakeSMC-6 and never with FakeSMC-3?

Share this post


Link to post
Share on other sites

Hi,

 

I propose this new patch for kext injection of 10.15:

Index: rEFIt_UEFI/Platform/kext_inject.c
===================================================================
--- rEFIt_UEFI/Platform/kext_inject.c	(revision 4959)
+++ rEFIt_UEFI/Platform/kext_inject.c	(working copy)
@@ -681,8 +681,8 @@
 // Catalina (SIP)
 // PMheart: checked
 // Need to pair with KBEMojaCata*EXT
-UINT8   KBECataSearchSIP[]            = { 0x00, 0x85, 0xC0, 0x0F, 0x84, 0x87, 0x00, 0x00, 0x00, 0x49 };
-UINT8   KBECataReplaceSIP[]           = { 0x00, 0x85, 0xC0, 0x90, 0x90, 0x90, 0x90, 0x90, 0x90, 0x49 };
+UINT8   KBECataSearchSIP[]            = { 0xE8, 0xB0, 0xEE, 0x0C, 0x00, 0x85, 0xC0, 0x0F, 0x84 };
+UINT8   KBECataReplaceSIP[]           = { 0xE8, 0xB0, 0xEE, 0x0C, 0x00, 0x31, 0xC0, 0x0F, 0x84 };
 
 // Mojave 10.14 - 10.14.3
 // Avoid race condition in OSKext::removeKextBootstrap when using booter kexts without keepsyms=1.

Don't ask me if it works, of course it does - just read the asm code. ;)

 

PMheart

Share this post


Link to post
Share on other sites
18 hours ago, Pene said:

 

True, but I already fixed that with r4949. Try a later revision.

 

OK,thx

Share this post


Link to post
Share on other sites
1 hour ago, Slice said:

Is it happen with FakeSMC-6 and never with FakeSMC-3?

I think bcoz of Nvram, no longer having issue after Clover's F11 key for full clean, thanks @Sherlocks for suggestion. Oh ya, could be affected by VirtualSMC either.. I remember previously boot with it using OpenCore, then switch to Clover (FakeSMC). I will retry with your FakeSMC v3.5.1.

Share this post


Link to post
Share on other sites
8 minutes ago, Badruzeus said:

I think bcoz of Nvram, no longer having issue after Clover's F11 key for full clean, thanks @Sherlocks for suggestion. Oh ya, could be affected by VirtualSMC either.. I remember previously boot with it using OpenCore, then switch to Clover (FakeSMC). I will retry with your FakeSMC v3.5.1.

 

probably. recent commit for smc3 is no problem for rehabman and slice fakesmc version.

anyways f11 can clean opencore nvram keys.

 

now i keep rehabman fakesmc. his kext suppport all macos(10.6~10.15). its all in one. but his kext need to update for smc3 like vector's update of hwsensor3.

Edited by Sherlocks

Share this post


Link to post
Share on other sites

When building Clover r4961 with `./ebuild.sh --ext-co -fr` I got this errors (seem related to OcSupportPkg):

Building ... /Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcStringLib.inf [X64]
[CC] OcAsciiLib
[CC] BitOverflow
[CC] DataPatcher
[CC] FileProtocol
/Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:67:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
/Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:143:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
2 errors generated.
make: *** [/Users/badruzeus/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib/OUTPUT/OcUnicodeLib.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/badruzeus/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib]


build.py...
 : error F002: Failed to build module
	/Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcStringLib.inf [X64, XCODE8, RELEASE]

- Failed -
Build end time: 09:07:33, Jun.10 2019
Build total time: 00:00:10

MacBookPro:Clover badruzeus$

Thanks.

Edited by Badruzeus

Share this post


Link to post
Share on other sites
1 hour ago, Badruzeus said:

When building Clover r4961 with `./ebuild.sh --ext-co -fr` I got this errors (seem related to OcSupportPkg):


Building ... /Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcStringLib.inf [X64]
[CC] OcAsciiLib
[CC] BitOverflow
[CC] DataPatcher
[CC] FileProtocol
/Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:67:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
/Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:143:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
2 errors generated.
make: *** [/Users/badruzeus/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib/OUTPUT/OcUnicodeLib.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/badruzeus/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib]


build.py...
 : error F002: Failed to build module
	/Users/badruzeus/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcStringLib.inf [X64, XCODE8, RELEASE]

- Failed -
Build end time: 09:07:33, Jun.10 2019
Build total time: 00:00:10

MacBookPro:Clover badruzeus$

Thanks.

It should be reported to Acidantera.

Share this post


Link to post
Share on other sites
22 hours ago, PMheart said:

Hi,

 

I propose this new patch for kext injection of 10.15:


Index: rEFIt_UEFI/Platform/kext_inject.c
===================================================================
--- rEFIt_UEFI/Platform/kext_inject.c	(revision 4959)
+++ rEFIt_UEFI/Platform/kext_inject.c	(working copy)
@@ -681,8 +681,8 @@
 // Catalina (SIP)
 // PMheart: checked
 // Need to pair with KBEMojaCata*EXT
-UINT8   KBECataSearchSIP[]            = { 0x00, 0x85, 0xC0, 0x0F, 0x84, 0x87, 0x00, 0x00, 0x00, 0x49 };
-UINT8   KBECataReplaceSIP[]           = { 0x00, 0x85, 0xC0, 0x90, 0x90, 0x90, 0x90, 0x90, 0x90, 0x49 };
+UINT8   KBECataSearchSIP[]            = { 0xE8, 0xB0, 0xEE, 0x0C, 0x00, 0x85, 0xC0, 0x0F, 0x84 };
+UINT8   KBECataReplaceSIP[]           = { 0xE8, 0xB0, 0xEE, 0x0C, 0x00, 0x31, 0xC0, 0x0F, 0x84 };
 
 // Mojave 10.14 - 10.14.3
 // Avoid race condition in OSKext::removeKextBootstrap when using booter kexts without keepsyms=1.

Don't ask me if it works, of course it does - just read the asm code. ;)

 

PMheart

Sorry for commiting too late.

Share this post


Link to post
Share on other sites

hello Slice

 

last commit r4962 have problems

 

it boot Mojave but not Catalina

 

in Catalina give KP

 

thanks

Share this post


Link to post
Share on other sites
7 hours ago, SavageAUS said:

FakeSMC jump from 3 to 6? Where is new version please?

 

Here it is;

 

cloverefiboot-code-r4961-CloverPackage-CloverV2-ThirdParty-kexts-Other.zip

 

I download a snapshot from here but I am not sure did I right.

 

https://sourceforge.net/p/cloverefiboot/code/4961/tree//CloverPackage/CloverV2/ThirdParty/kexts/Other/

Edited by telepati

Share this post


Link to post
Share on other sites

Looks like ext_packages have yet another issue when building Clover.

 

Just letting you guys know in case you come across the same thing.

 

OCSupportPkg should be for OpenCore only. Not sure why is it trying to compile it for Clover... But anyway. Maybe there's no condition put in place to detect what you're trying to compile and only add that support pkg where it's needed.

 

Anyway, I just thought you guys might wanna know about this.

[SLINK] BaseIoLibIntrinsic
Building ... /Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcDataHubLib/OcDataHubLib.inf [X64]
/Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:67:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
/Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:143:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
2 errors generated.
make: *** [/Users/jimmy/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib/OUTPUT/OcUnicodeLib.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/jimmy/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib]


build.py...
 : error F002: Failed to build module
	/Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcStringLib.inf [X64, XCODE8, RELEASE]

- Failed -
Build end time: 14:35:16, Jun.10 2019
Build total time: 00:00:04

 

Edited by arsradu

Share this post


Link to post
Share on other sites
8 minutes ago, arsradu said:

Looks like ext_packages have yet another issue when building Clover.

 

Just letting you guys know in case you come across the same thing.

 

OCSupportPkg should be for OpenCore only. Not sure why is it trying to compile it for Clover... But anyway. Maybe there's no condition put in place to detect what you're trying to compile and only add that support pkg where it's needed.

 

Anyway, I just thought you guys might wanna know about this.


[SLINK] BaseIoLibIntrinsic
Building ... /Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcDataHubLib/OcDataHubLib.inf [X64]
/Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:67:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
/Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcUnicodeLib.c:143:23: error: implicit declaration of function 'CharToUpper' is invalid in C99 [-Werror,-Wimplicit-function-declaration]
  UpperFirstString  = CharToUpper (*FirstString);
                      ^
2 errors generated.
make: *** [/Users/jimmy/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib/OUTPUT/OcUnicodeLib.obj] Error 1


build.py...
 : error 7000: Failed to execute command
	make tbuild [/Users/jimmy/src/UDK2018/Build/AptioFixPkg/RELEASE_XCODE8/X64/OcSupportPkg/Library/OcStringLib/OcStringLib]


build.py...
 : error F002: Failed to build module
	/Users/jimmy/src/EXT_PACKAGES/OcSupportPkg/Library/OcStringLib/OcStringLib.inf [X64, XCODE8, RELEASE]

- Failed -
Build end time: 14:35:16, Jun.10 2019
Build total time: 00:00:04

 

vit9696 told me on OpenCore thread it needs AUDK (Acidenthera) instead of UDK.

Share this post


Link to post
Share on other sites
40 minutes ago, arsradu said:

 

Ok...but I'm not trying to build OpenCore. I'm trying to build Clover.

I got similar error with OcSupportPkg when building Clover & OpenCore using UDK.

Share this post


Link to post
Share on other sites

Hi @Badruzeus, @arsradu

 

I think i's a AptiofixPg problem not Clover. There is some commits last 4hours 1hour in OCSupportPkg and OpenCore.

 

So wait and see :)

 

What flag to use for external package in ebuild.sh ( ---ext-co or --ext-pre)?

 

Sorry for my bad english

 

Share this post


Link to post
Share on other sites
8 minutes ago, Matgen84 said:

Hi @Badruzeus, @arsradu

 

I think i's a AptiofixPg problem not Clover. There is some commits last 4hours 1hour in OCSupportPkg and OpenCore.

 

So wait and see :)

 

What flag to use for external package in ebuild.sh ( ---ext-co or --ext-pre)?

 

Sorry for my bad english

 

At this point, all ebuild.sh parameters related to external packages will cause errors. Some will cause the error I mentioned before, others will cause other errors.

 

Anyway, these are the available options, and I've tried all of them with no success.

print_option_help "--ext-pre" "enable external driver download"
print_option_help "--ext-co" "checkout & build external drivers at ..src/EXT_PACKAGES"
print_option_help "--ext-build" "build existing external drivers located at ..src/EXT_PACKAGES"

The only way I could find to build Clover at this point is to build only Clover (no external drivers)

Edited by arsradu

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By TomZanna
      Hi, I'm trying to install Mac Os Catalina on a HP 550-132NL.
      The system has:
      i7-6700
      RAM 12 GB
      GT 730
      LAN Realtek RTL8161
      ALC3863
       
      It passes the verbose phase but after the Apple logo goes away, it gets stuck on a grey screen and I can only move the pointer.
      Can I try to boot with the iGPU?
       
      origin.zip
      CLOVER_dGPU_USB_3.zip
    • By MaLd0n
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By dgsga
      Can I propose a new subforum be created for the new OpenCorePkg OpenCore front end being created by vit9696 and others, it is a fantastic piece of work:
      https://github.com/acidanthera/OpenCorePkg
      Even at version 0.1 it runs my Mojave 10.14.4 setup very nearly flawlessly. It consists of a 10KB bootstrap BootX64.efi and a 200KB OpenCore.efi OS loader. All configuration is done using a very well documented config.plist 
       
       
×