Jump to content
ErmaC

Clover General discussion

20,459 posts in this topic

Recommended Posts

4 minutes ago, Matgen84 said:

 

Thanks :)

 

I actually use AptioMemoryFix. Also I've to change for OSXAptioFix_Drv-64, Right or Not?

 

You can use AptioMemoryFix along with EmuVariableUefi. 

Share this post


Link to post
Share on other sites
Advertisement
6 hours ago, Slice said:

We should erase the key from FakeSMC. Let it be always from Clover present or not to be depend on Model.

 

Looks like your ACPI has some difficulties for Clover. Provide, please, debug.log to see the moment of the stop.

 

It is surely on-topic.

There was several changes in Clover concerning CoffeeLake CPU. You should search what is the key.

First I will propose to set manually

CPU->Type = 0x0705

 

I use CPU->Type = 0x0705, can't reboot or shutdown (SMBIOS Imac19,1 and Imac19,2).

 

Debug.log attached

 

Config:

Asus Prime Z390-A

i7 9700K

MSI Radeon RX580

Corsair Vengeance LPX 3000Mhz 2x8Go

 

debug.log

Share this post


Link to post
Share on other sites
On 6/1/2019 at 4:43 PM, Matgen84 said:

 

I use CPU->Type = 0x0705, can't reboot or shutdown (SMBIOS Imac19,1 and Imac19,2).

 

Debug.log attached

 

Config:

Asus Prime Z390-A

i7 9700K

MSI Radeon RX580

Corsair Vengeance LPX 3000Mhz 2x8Go

 

debug.log

In vain you did not do as Vandroiy2012 told you. "Install EmuVariableUefi"

You said that you use AptioMemoryFix but this is not enough!

Chipset 390 has no support for real NVRAM even with AptioMemoryFix. You have to install EmuVariableUefi-64.efi.

Share this post


Link to post
Share on other sites
On 6/1/2019 at 10:25 AM, Slice said:

Looks like your ACPI has some difficulties for Clover. Provide, please, debug.log to see the moment of the stop.

 

 

I checked the debug.log but didn't see anything.

 

On 6/1/2019 at 10:34 AM, arsradu said:

Running 4934 here. Aaand..no issues getting the ACPI tables on my side. So, as Slice mentioned, it's most likely something specific for your case. :)

 

Just wanted to share my own results, so you don't think it's a general issue with this version. Cause it doesn't look like it.

 

I mentioned the version which I used recently. But this has happened to me with the earlier version too. Just like you said probably this is specific to my case.

debug.log

Share this post


Link to post
Share on other sites
1 hour ago, telepati said:

 

I checked the debug.log but didn't see anything.

 

debug.log

You said the the boot freezed but in this debug.log there are no freezes. Reproduce the action with freeze.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, Slice said:

You said the the boot freezed but in this debug.log there are no freezes. Reproduce the action with freeze.

 

I don't know how do I do that?  When the clover freeze I am making force restart from the case and next boot clover creates a new debug.log without freeze log. is clover capable of creating multiple debug.log for every boot?

 

Cause when I make a boot I can see just one debug.log file in the MISC folder.

Edited by telepati

Share this post


Link to post
Share on other sites
Posted (edited)

Will Clover in the future support Symbolic kext and kernel patcher like OpenCore, so you don't always have to update Clover to support the latest version of macOS?

 

Edited by Cod32

Share this post


Link to post
Share on other sites
2 hours ago, Cod32 said:

Will Clover in the future support Symbolic kext and kernel patcher like OpenCore, so you don't always have to update Clover to support the latest version of macOS?

 

Make pull request please.

Share this post


Link to post
Share on other sites

Hi @Slice

 

Thanks for merging, but I made a very stupid typo in FakeCPUID patch, which can be checked here:

https://sourceforge.net/p/cloverefiboot/code/4939/tree//rEFIt_UEFI/Platform/kernel_patcher.c#l569

https://sourceforge.net/p/cloverefiboot/code/4939/tree//rEFIt_UEFI/Platform/kernel_patcher.c#l578

 

&HSieMojSearchModel[0] and &CataSearchModel[0] got reversed by accident, and I think you know the correct order. ;)

 

By the way, I also missed a prompt line like

DBG_RT(Entry, "...done!\n");

 

Please fix it! Thanks!

 

PMheart

Share this post


Link to post
Share on other sites
1 hour ago, PMheart said:

Hi @Slice

 

Thanks for merging, but I made a very stupid typo in FakeCPUID patch, which can be checked here:

https://sourceforge.net/p/cloverefiboot/code/4939/tree//rEFIt_UEFI/Platform/kernel_patcher.c#l569

https://sourceforge.net/p/cloverefiboot/code/4939/tree//rEFIt_UEFI/Platform/kernel_patcher.c#l578

 

&HSieMojSearchModel[0] and &CataSearchModel[0] got reversed by accident, and I think you know the correct order. ;)

 

By the way, I also missed a prompt line like

DBG_RT(Entry, "...done!\n");

 

Please fix it! Thanks!

 

PMheart

OK, committed.

Share this post


Link to post
Share on other sites
11 hours ago, telepati said:

 

I don't know how do I do that?  When the clover freeze I am making force restart from the case and next boot clover creates a new debug.log without freeze log. is clover capable of creating multiple debug.log for every boot?

 

Cause when I make a boot I can see just one debug.log file in the MISC folder.

Yes, debug.log is concatenated with previous one so you can see first attempt up to freeze and then next successful start.

Share this post


Link to post
Share on other sites

Hi,

 

I have updated XCPM patches in kernel_patcher.c (is there still anyone using KernelXCPM now? ...) and checked some parts (RTC and PCI) in kext_patcher.c (although it turned out that all the old patches still remain available, I'd still like to do this renaming, just for confirmation. :))

 

Index: rEFIt_UEFI/Platform/kernel_patcher.c
===================================================================
--- rEFIt_UEFI/Platform/kernel_patcher.c	(revision 4940)
+++ rEFIt_UEFI/Platform/kernel_patcher.c	(working copy)
@@ -896,6 +896,11 @@
         STATIC UINT8 find[] = { 0x89, 0xD8, 0x04, 0xC4, 0x3C, 0x22 };
         STATIC UINT8 repl[] = { 0x89, 0xD8, 0x04, 0xC1, 0x3C, 0x22 };
         applyKernPatch(kern, find, sizeof(find), repl, comment);
+    // PMheart: attempt to add 10.15 compatibility
+    } else if (os_version < AsciiOSVersionToUint64("10.16")) {
+        STATIC UINT8 find[] = { 0x8D, 0x43, 0xC4, 0x3C, 0x22 };
+        STATIC UINT8 repl[] = { 0x8D, 0x43, 0xC1, 0x3C, 0x22 };
+        applyKernPatch(kern, find, sizeof(find), repl, comment);
     }
     
     DBG("Searching _xcpm_pkg_scope_msr ...\n");
@@ -1051,12 +1056,17 @@
         STATIC UINT8 find[] = { 0x89, 0xD8, 0x04, 0xC4, 0x3C, 0x22 };
         STATIC UINT8 repl[] = { 0x89, 0xD8, 0x04, 0xC6, 0x3C, 0x22 };
         applyKernPatch(kern, find, sizeof(find), repl, comment);
+    // PMheart: attempt to add 10.15 compatibility
+    } else if (os_version < AsciiOSVersionToUint64("10.16")) {
+        STATIC UINT8 find[] = { 0x8D, 0x43, 0xC4, 0x3C, 0x22 };
+        STATIC UINT8 repl[] = { 0x8D, 0x43, 0xC6, 0x3C, 0x22 };
+        applyKernPatch(kern, find, sizeof(find), repl, comment);
     }
 
     comment = "_cpuid_set_info_rdmsr";
-    // PMheart: attempt to add 10.14 compatibility
-    if (os_version >= AsciiOSVersionToUint64("10.12") && os_version < AsciiOSVersionToUint64("10.15")) {
-        // 10.12 - 10.14
+    // PMheart: bytes seem stable as of 10.12
+    if (os_version >= AsciiOSVersionToUint64("10.12")) {
+        // 10.12+
         STATIC UINT8 find[] = { 0xB9, 0xA0, 0x01, 0x00, 0x00, 0x0F, 0x32 };
         STATIC UINT8 repl[] = { 0xB9, 0xA0, 0x01, 0x00, 0x00, 0x31, 0xC0 };
         applyKernPatch(kern, find, sizeof(find), repl, comment);
@@ -1138,6 +1148,11 @@
     STATIC UINT8 find[] = { 0x89, 0xD8, 0x04, 0xC4, 0x3C, 0x22 };
     STATIC UINT8 repl[] = { 0x89, 0xD8, 0x04, 0xC6, 0x3C, 0x22 };
     applyKernPatch(kern, find, sizeof(find), repl, comment);
+  // PMheart: attempt to add 10.15 compatibility
+  } else if (os_version < AsciiOSVersionToUint64("10.16")) {
+      STATIC UINT8 find[] = { 0x8D, 0x43, 0xC4, 0x3C, 0x22 };
+      STATIC UINT8 repl[] = { 0x8D, 0x43, 0xC6, 0x3C, 0x22 };
+      applyKernPatch(kern, find, sizeof(find), repl, comment);
   }
   
   DBG("KernelIvyBridgeXCPM() <===\n");
@@ -1279,8 +1294,13 @@
   } else if (os_version < AsciiOSVersionToUint64("10.15")) {
     // 10.13/10.14
     STATIC UINT8 find[] = { 0x89, 0xD8, 0x04, 0xC4, 0x3C, 0x22 };
-    STATIC UINT8 repl[] = { 0x89, 0xD8, 0xC2, 0xC1, 0x3C, 0x22 };
+    STATIC UINT8 repl[] = { 0x89, 0xD8, 0x04, 0xC1, 0x3C, 0x22 };
     applyKernPatch(kern, find, sizeof(find), repl, comment);
+  // PMheart: attempt to add 10.15 compatibility
+  } else if (os_version < AsciiOSVersionToUint64("10.16")) {
+      STATIC UINT8 find[] = { 0x8D, 0x43, 0xC4, 0x3C, 0x22 };
+      STATIC UINT8 repl[] = { 0x8D, 0x43, 0xC1, 0x3C, 0x22 };
+      applyKernPatch(kern, find, sizeof(find), repl, comment);
   }
   
   DBG("KernelIvyE5XCPM() <===\n");
Index: rEFIt_UEFI/Platform/kext_patcher.c
===================================================================
--- rEFIt_UEFI/Platform/kext_patcher.c	(revision 4940)
+++ rEFIt_UEFI/Platform/kext_patcher.c	(working copy)
@@ -410,9 +410,9 @@
 STATIC UINT8   MavMoj3Search[]  = { 0x75, 0x2e, 0x0f, 0xb6 };
 STATIC UINT8   MavMoj3Replace[] = { 0xeb, 0x2e, 0x0f, 0xb6 };
 
-// RodionS: 10.14.4+
-STATIC UINT8   Moj4Search[]  = { 0x75, 0x33, 0x0f, 0xb7 };
-STATIC UINT8   Moj4Replace[] = { 0xeb, 0x33, 0x0f, 0xb7 };
+// RodionS: 10.14.4+ / 10.15 DB1
+STATIC UINT8   Moj4CataSearch[]  = { 0x75, 0x33, 0x0f, 0xb7 };
+STATIC UINT8   Moj4CataReplace[] = { 0xeb, 0x33, 0x0f, 0xb7 };
 
 //
 // We can not rely on OSVersion global variable for OS version detection,
@@ -442,7 +442,7 @@
     NumLion_X64 = SearchAndCount(Driver, DriverSize, LionSearch_X64, sizeof(LionSearch_X64));
     NumML  = SearchAndCount(Driver, DriverSize, MLSearch,  sizeof(MLSearch));
     NumMavMoj3 = SearchAndCount(Driver, DriverSize, MavMoj3Search, sizeof(MavMoj3Search));
-    NumMoj4 = SearchAndCount(Driver, DriverSize, Moj4Search, sizeof(Moj4Search));
+    NumMoj4 = SearchAndCount(Driver, DriverSize, Moj4CataSearch, sizeof(Moj4CataSearch));
   } else {
     NumLion_i386 = SearchAndCount(Driver, DriverSize, LionSearch_i386, sizeof(LionSearch_i386));
   }
@@ -469,7 +469,7 @@
     Num = SearchAndReplace(Driver, DriverSize, MavMoj3Search, sizeof(MavMoj3Search), MavMoj3Replace, 1);
     DBG_RT(Entry, "==> Mav/Yos/El/Sie/HS/Moj3 X64: %d replaces done.\n", Num);
   } else if (NumMoj4 == 1) {
-    Num = SearchAndReplace(Driver, DriverSize, Moj4Search, sizeof(Moj4Search), Moj4Replace, 1);
+    Num = SearchAndReplace(Driver, DriverSize, Moj4CataSearch, sizeof(Moj4CataSearch), Moj4CataReplace, 1);
     DBG_RT(Entry, "==> Mojave4 X64: %d replaces done.\n", Num);
   } else {
     DBG_RT(Entry, "==> Patterns not found - patching NOT done.\n");
@@ -841,8 +841,8 @@
 STATIC UINT8   BroadwellE_IOPCI_Repl_SieHS[] = { 0x48, 0x81, 0xFB, 0x00, 0x00, 0x00, 0x80 };
 
 // Mojave
-STATIC UINT8   BroadwellE_IOPCI_Find_Moj[] = { 0x48, 0x3D, 0x00, 0x00, 0x00, 0x40 };
-STATIC UINT8   BroadwellE_IOPCI_Repl_Moj[] = { 0x48, 0x3D, 0x00, 0x00, 0x00, 0x80 };
+STATIC UINT8   BroadwellE_IOPCI_Find_MojCata[] = { 0x48, 0x3D, 0x00, 0x00, 0x00, 0x40 };
+STATIC UINT8   BroadwellE_IOPCI_Repl_MojCata[] = { 0x48, 0x3D, 0x00, 0x00, 0x00, 0x80 };
 
 VOID BDWE_IOPCIPatch(UINT8 *Driver, UINT32 DriverSize, CHAR8 *InfoPlist, UINT32 InfoPlistSize, LOADER_ENTRY *Entry)
 {
@@ -864,7 +864,7 @@
   } else if (os_ver < AsciiOSVersionToUint64("10.14")) {
     count = SearchAndReplace(Driver, DriverSize, BroadwellE_IOPCI_Find_SieHS, sizeof(BroadwellE_IOPCI_Find_SieHS), BroadwellE_IOPCI_Repl_SieHS, 0);
   } else {
-    count = SearchAndReplace(Driver, DriverSize, BroadwellE_IOPCI_Find_Moj, sizeof(BroadwellE_IOPCI_Find_Moj), BroadwellE_IOPCI_Repl_Moj, 0);
+    count = SearchAndReplace(Driver, DriverSize, BroadwellE_IOPCI_Find_MojCata, sizeof(BroadwellE_IOPCI_Find_MojCata), BroadwellE_IOPCI_Repl_MojCata, 0);
   }
   
   if (count) {

 

Thanks!

Share this post


Link to post
Share on other sites

Hi

 

Latest r4940 failed twice to install (compile with kids script UDK2018). Anyone have this problem?

Capture d’écran 2019-06-04 à 12.07.19.png

Share this post


Link to post
Share on other sites

does anyone know how to find what "CPUType" is supported in which smbios? and more importantly the value to use?

Share this post


Link to post
Share on other sites
25 minutes ago, Wackymac said:

does anyone know how to find what "CPUType" is supported in which smbios? and more importantly the value to use?

Let Clover do this itself.

Share this post


Link to post
Share on other sites
22 hours ago, Matgen84 said:

Hi

 

Latest r4940 failed twice to install (compile with kids script UDK2018). Anyone have this problem?

Capture d’écran 2019-06-04 à 12.07.19.png

 

Uhm....nope. No such issue on my side. I've had 4940 a few days ago. Now I'm on 4945. But no...no such issues on my side.

Share this post


Link to post
Share on other sites
1 minute ago, arsradu said:

 

Uhm....nope. No such issue on my side. I've had 4940 a few days ago. Now I'm on 4945. But no...no such issues on my side.

 

I use newfs_mdos command and reinstall Clover on EFI partition. Succeed. I don't know why there is such issue. I'm on 4945 now.

Share this post


Link to post
Share on other sites
4 minutes ago, Matgen84 said:

 

I use newfs_mdos command and reinstall Clover on EFI partition. Succeed. I don't know why there is such issue. I'm on 4945 now.

not related.

Share this post


Link to post
Share on other sites
3 hours ago, vector sigma said:

not related.

 

Thanks. 

 

what is the reason for the installation failure

Share this post


Link to post
Share on other sites
Just now, Matgen84 said:

 

Thanks. 

 

what is the reason for the installation failure

ESP already corrupted, otherwise why use newfs_mdos? Anyway when that happens you can find the reason by looking at the installation log of Installer.app by just looking at its Menu before closing the application.

Share this post


Link to post
Share on other sites
16 minutes ago, vector sigma said:

ESP already corrupted, otherwise why use newfs_mdos? Anyway when that happens you can find the reason by looking at the installation log of Installer.app by just looking at its Menu before closing the application.

 

 

I use newfs_msdos command because I supposed ESP corrupted when I try to install Clover. 
I did not know there was a install.log in Installer.app

 

Sorry for my bad english

Share this post


Link to post
Share on other sites
38 minutes ago, Matgen84 said:

I use newfs_msdos command because I supposed ESP corrupted when I try to install Clover. 

Why I told you was corrupted already:

 

4 hours ago, Matgen84 said:

I use newfs_mdos command and reinstall Clover on EFI partition. Succeed.

 

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Matgen84 said:

 

 

I use newfs_msdos command because I supposed ESP corrupted when I try to install Clover. 
I did not know there was a install.log in Installer.app

 

Sorry for my bad english

See in Root disk /Volumes

2074230145_Capturedcranle2019-06-0510_14_42.png.fef38059aaf7d764e40147ce065a6741.png

 

if you have folder EFI, ESP or EFIROOTDIR delete them and try again

Edited by chris1111

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15
      Original link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      For any system kext installation\modification you need to boot with config_debug.plist (or disable SIP manually)
      Also on Catalina the System folder is read-only, so you need to remount in rw. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      EFI-Clover-X99.zip
       
       
       
       
       
       
      Anyone else I forgot
       
       
×