Jump to content
ErmaC

Clover General discussion

22,334 posts in this topic

Recommended Posts

Advertisement

can someone please tell me the use of apfsdriverloader.efi?

 

In the past, I manually copy apfs.efi to the clover drivers folder. Not sure how apfsdriverloader would affect this.

 

thank you.

Share this post


Link to post
Share on other sites
can someone please tell me the use of apfsdriverloader.efi?
 
In the past, I manually copy apfs.efi to the clover drivers folder. Not sure how apfsdriverloader would affect this.
 
thank you.

You only need APFSDriverLoader, apfs is no longer needed as long your using APFS file system. Do not use both together.


Sent from my iPhone using Tapatalk
can someone please tell me the use of apfsdriverloader.efi?
 
In the past, I manually copy apfs.efi to the clover drivers folder. Not sure how apfsdriverloader would affect this.
 
thank you.

You only need APFSDriverLoader, apfs is no longer needed as long your using APFS file system. Do not use both together.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
7 minutes ago, mrjayviper said:

can someone please tell me the use of apfsdriverloader.efi?

 

In the past, I manually copy apfs.efi to the clover drivers folder. Not sure how apfsdriverloader would affect this.

 

thank you.

 

apfsdriverloader.efi  replace apfs.efi in kexts folder. If you want to use it, delete apfs.efi and install this file with Clover package Installer.

Share this post


Link to post
Share on other sites

Stupid question about Clover. If there is a option set as 'NO' in default Clover Config.plist, can it be deleted? Or could Clover assume that something is 'YES' if it is missing on Config.plist? I would like to delete all options in plist that I've set as 'NO' for simplicity.

Edited by Amble

Share this post


Link to post
Share on other sites
Stupid question about Clover. If there is a option set as 'NO' in default Clover Config.plist, can it be deleted? Or could Clover assume that something is 'YES' if it is missing on Config.plist? I would like to delete all options in plist that I've set as 'NO' for simplicity.

Not for all option, at GUI -> Scan, if you set Legacy = No, then there is no Legacy entry boot (if you boot with legacy). But if you delete this line, then legacy entry will shown. It's just for sample,

 

Sent from my Mi Note 2 using Tapatalk

 

 

 

Share this post


Link to post
Share on other sites
10 hours ago, Andres ZeroCross said:

Not for all option, at GUI -> Scan, if you set Legacy = No, then there is no Legacy entry boot (if you boot with legacy). But if you delete this line, then legacy entry will shown. It's just for sample,

 

Sent from my Mi Note 2 using Tapatalk

 

 

 

 

Thank you. I guess it's better to leave 'No' entries in the plist.

Share this post


Link to post
Share on other sites

I got a board without built-in NVMe port in the motherboard.

 

Has anyone been able to use a PCIe-based NVMe and uses a USB drive/frontend with clover so the NVMe can be use as an OS drive? So the motherboard is booting off the USB stick and then clover will then be booting off the NVMe drive.

 

seems like it's going to work but wanting to know if anyone has used/tested such a setup.

 

Thanks a lot! :)

Edited by mrjayviper

Share this post


Link to post
Share on other sites
12 hours ago, pkdesign said:

Latest Clover 4769 breaks legacy BIOS boot. Had to revert back to 4741 in order to boot my system.

Working fine here either, I've 3 ancient machines using Legacy.

 

7 hours ago, ellaosx said:

latest has verbose before GUI. can we clean that?

On my case is not Clover, but recent "ApfsDriverLoader*.efi".

Share this post


Link to post
Share on other sites
5 hours ago, Badruzeus said:

Working fine here either, I've 3 ancient machines using Legacy.

 

On my case is not Clover, but recent "ApfsDriverLoader*.efi".

Is it a version from github where there is debug or from clover package where release version?

Share this post


Link to post
Share on other sites
52 minutes ago, Slice said:

Is it a version from github where there is debug or from clover package where release version?

I did test again using ApfsDriverLoader-64.efi from r4769 (SourceForge release), and it gives no Apfs related debug logs. A same result with ApfsDriverLoader-64.efi v2.0.5 (github release). I was referring to this commit, but I could be wrong if this is the cause. I've reported this here on November 7th with r4741.

 

 

@ellaosx Is this debug logs you meant? I guess, it is from ApfsDriverLoader built with ebuild.sh --ext-co (or buildclover script) contains latest change from AppleSupportPackage (since, the build script will pull it).

VirtualBox_Clover Bootloader_22_11_2018_20_17_18.png

Share this post


Link to post
Share on other sites

@Badruzeus @ellaosx

 

There is no issue with ApfsDriverloader.efi using Clover r4771 :)

 

If In understand well, ebuild.sh file: "--ext-co" "checkout & build external drivers at ..src/EXT_PACKAGES". It means download and compile from source this driver. Right? 

 

Share this post


Link to post
Share on other sites
2 minutes ago, Matgen84 said:

@Badruzeus @ellaosx

 

There is no issue with ApfsDriverloader.efi using Clover r4771 :)

 

If In understand well, ebuild.sh file: "--ext-co" "checkout & build external drivers at ..src/EXT_PACKAGES". It means download and compile from source this driver. Right? 

 

It should be: Yes (compiled from source using latest commit).

 

I just rebuilt r4771 using UDK, and weird is.. still ApfsDriverLoader gives debug logs (files attached).

@ellaosx is your 10.13 (or 10.14) using HFS+ or APFS? On my case is: HFS+, though I saw no diff with APFS previously. 

r4771-UDK-Apfs.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By STLVNUB
      Script file to clone and help build Clover or Opencore repos
      Script will create link to itself in /usr/local/bin/bob
      Script SHOULD fix up any stray bobs you may have.
      Then you only need to type bob. and a parameter
      "a" for ACID repo, official
      "d" for ACID repo DUET build
      "c" for CLOVER
      "e" to erase UDK Folder
      Easier typing bob than.....usual stuff
      YOU WILL NEED TO cmod+x THE SCRIPT
      Enjoy
       
    • By PropoFlexWX4
      After hearing that OpenCore is so much better than Clover, and that it will probably be able to boot Big Sur before Clover does, I decided to take the jump.
       
      Running Catalina 10.15.5 18F101 with OC 0.5.9.
       
      So far I like the result. The OS feels faster, boots faster.
      And absolutely everything works (sleep, network, etc...)
       
      So, that's it? Is there anything else I have to do?
×