Jump to content
ErmaC

Clover General discussion

22,340 posts in this topic

Recommended Posts

4 minutes ago, ellaosx said:

What are these ps2Dxe, usbDxe, mouseDxe for? Are they mandatory?

These are drivers for keyboard for Clover GUI. Some of them may be needed if your keyboard is not working without them. And for mouse as you see the driver name.

Share this post


Link to post
Share on other sites
Advertisement
41 minutes ago, Slice said:

These are drivers for keyboard for Clover GUI. Some of them may be needed if your keyboard is not working without them. And for mouse as you see the driver name.

Got it. I thought it was for FV.

Never had an issues in the past, till now regarding kb & mouse on any of my computers. I guess im not needing these.

 

Thanks @Slice

Share this post


Link to post
Share on other sites

Hi

 

I don't understand well commit r4692: VirtualSMC support: checkout and compilation (XCODE5 only ATM)

 

I don't have virtualsmc-64.efi when I use my build script with Xcode 10. Tell me why, please.

 

Sorry if this comment is off-topic

Share this post


Link to post
Share on other sites

Just an FYI, i installed 4674 on my legacy rig and I could not boot. Just got a (non-blinking) cursor in the upper left hand corner. I had to go back to 4658 in order to boot.

 

I also have a question about BIOS boot systems. There are four kexts, that I do not believe have anything to do with FileVault, listed in the "BIOS Drivers" section. But do they need to be installed? My system runs fine without them but not sure if I need them anyway:

 

  • FSInject
  • SMCHelper
  • ApfsDriver laoder
  • AppleEfiFat

 

Also, there are always some UEFI drivers that have check marks next to them even though I am insatlling on a BIOS based system. I always have to uncheck these.

 

 

Share this post


Link to post
Share on other sites

I remember back when fusion drives first came out that clover would not install to the efi partition.   This seems to have returned with the apfs fusion drives.  It installs to the root partition.  It does not mount the efi partition to install.

Share this post


Link to post
Share on other sites
11 hours ago, Slice said:

Highlighted drivers are not needed.

As well as AppleImageLoader.

 

Hi Slice,

 

I was under the impression that both ApfsDriverLoader-64.efi and AppleImageLoader-64.efI were required if not using APFS.efi?

Share this post


Link to post
Share on other sites
13 minutes ago, D-an-W said:

 

Hi Slice,

 

I was under the impression that both ApfsDriverLoader-64.efi and AppleImageLoader-64.efI were required if not using APFS.efi?

Both not required.

Share this post


Link to post
Share on other sites

941775925_ScreenShot1.png.676813a70b05786d296d934cbf095994.png

 

Sorry guys, but wasn't that suggested for clearing doubts about which drivers choose during installation?

FV-UEFI Drivers was the intent..  i guess

anyway thx for doing it

Edited by LAbyOne

Share this post


Link to post
Share on other sites
[mention=112217]Slice[/mention]
What is AppleImageLoader for if its not mandatory? Is it part of FV too?
read here
https://github.com/acidanthera/AppleSupportPkg/blob/master/README.md

나의 LG-F800S 의 Tapatalk에서 보냄

941775925_ScreenShot1.png.676813a70b05786d296d934cbf095994.png
 
Sorry guys, but wasn't that suggested for clearing doubts about which drivers choose during installation?
FV-UEFI Drivers was the intent..  i guess
anyway thx for doing it
i found it. i will change it

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
52 minutes ago, ellaosx said:

I have read that. but still, is it part of FV or partner of ApfsDriverLoder that they must exist together?

 

i saw that

AppleImageLoader -> osxfatbinary driver replacement

AppleUISupport(AIO) -> Old FV2 drivers replacement

ApfsDriverLoader -> loading original apfs driver without manually adding and checking latest apfs file when update macOS

 

anyone who check package in english?

Edited by Sherlocks

Share this post


Link to post
Share on other sites
19 minutes ago, Sherlocks said:

AppleImageLoader -> osxfatbinary driver replacement

Ahh, i didn't know this. :)

Because the last time i asked, it was still under developement.

So its ok to replace osxfatbinary with appleimageloader now?

 

Thanks!

 

Edited by ellaosx

Share this post


Link to post
Share on other sites
Ahh, i didn't know this.
Because the last time i asked, it was still under developement.
So its ok to replace osxfatbinary with appleimageloader now?
 
Thanks!
 
not yet. appleimageloader need more development to replace osxfatbinary. i checked this result. i recommend you use appleimageloader and osxfatbinary until complete appleimageloader. hope wait and appreciate to savvass for hard work


나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
6 minutes ago, Sherlocks said:

i recommend you use appleimageloader and osxfatbinary until complete appleimageloader.
 

Are you saying I will use both?

Ok. i will use both for a test :D

Share this post


Link to post
Share on other sites
44 minutes ago, Sherlocks said:

AppleUISupport(AIO) -> Old FV2 drivers replacement

 

 

are we still need AppleUISupport if we don't use FV2? I think it is in the release notes AppleImageLoader and AppleUISupport must be used together is that right?

Share this post


Link to post
Share on other sites
 

are we still need AppleUISupport if we don't use FV2? I think it is in the release notes AppleImageLoader and AppleUISupport must be used together is that right?

actually no need both for boot if you don't need FV2. if you use FV2, not sure that must be use both. because i can't test FV2 by myself.

 

anyway in readme, AppleImageloader doesn't have FileVault word. mentioned only Fat word.

 

i think AppleUISupport is only for FV2

 

나의 LG-F800S 의 Tapatalk에서 보냄

 

 

 

Share this post


Link to post
Share on other sites
24 minutes ago, Sherlocks said:

actually no need both for boot if you don't need FV2. if you use FV2, not sure that must be use both. because i can't test FV2 by myself.

 

anyway in readme, AppleImageloader doesn't have FileVault word. mentioned only Fat word.

 

i think AppleUISupport is only for FV2

 

나의 LG-F800S 의 Tapatalk에서 보냄

 

 

 

 

You're right about AppleUiSupport. It implements FileVault support and replaces AppleKeyMapAggregator.efi, AppleEvent.efi, AppleUiTheme.efi, FirmwareVolume.efi, AppleImageCodec.efi. (Readme.md from repo AppleSupportPkg) 

Edited by Matgen84

Share this post


Link to post
Share on other sites

Hi

 

I don't understand well commit r4692: VirtualSMC support: checkout and compilation (XCODE5 only ATM)

 

I don't have virtualsmc-64.efi when I use my build script with Xcode 10. Tell me why, please.

 

Sorry if this comment is off-topic

Share this post


Link to post
Share on other sites

Thanks folks,

 

This is what I have now and both Sierra (10.12.6) and Mojave (10.41.1) boot just fine...

1734137962_ScreenShot2018-10-03at06_49_56.png.6255a75e6237960679f414375ffa994e.png

 

Now I just need to verify if I need SMCHelper-64.efi after checking my Kexts but I am almost certain I use the Kozlek one built with HWMonitor.

 

 

EDIT: Using either FakeSMC.kext (Slice or Kozlek) and with SMCHelper-64.efi present I get this is my Config.plst...

575873765_ScreenShot2018-10-03at23_02_06.png.b5628095c926d95713413687fd66f9b4.png

 

Removing SMCHelper-64.efi and with the Kozlek FakeSMC.kext I get this...

1847728854_ScreenShot2018-10-03at23_02_38.png.92c93ec63fe6c9be14e7287d6ae309df.png

 

So it would appear SMCHelper-64.efi is having an effect with that version of FakeSMC.kext loaded?

Edited by D-an-W

Share this post


Link to post
Share on other sites

@Slice

i install osx ubuntu and windows on same disk in uefi mode but after installing ubuntu my clover bootloader entries  from bios also force boot to grub bootloader how to fix this.

No matter what entry i choose from boot menu it always boot to grub and from them i can only boot to windows or ubuntu but cant find clover.

how to fix this issue??

pls help me

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By STLVNUB
      *Put the script into its own folder as it will create other folders*
      What is BTB?
      Script file to clone and help build Clover or Opencore repos
      Script will create link to itself in /usr/local/bin/bob
      Script SHOULD fix up any stray bobs you may have.
      Then you only need to type bob. and a parameter
      "a" for ACID repo, official
      "d" for ACID repo DUET build
      "c" for CLOVER
      "e" to erase UDK Folder
      Easier typing bob than.....usual stuff
      YOU WILL NEED TO cmod+x THE SCRIPT
      Enjoy
       
    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By PropoFlexWX4
      After hearing that OpenCore is so much better than Clover, and that it will probably be able to boot Big Sur before Clover does, I decided to take the jump.
       
      Running Catalina 10.15.5 18F101 with OC 0.5.9.
       
      So far I like the result. The OS feels faster, boots faster.
      And absolutely everything works (sleep, network, etc...)
       
      So, that's it? Is there anything else I have to do?
×