Jump to content
ErmaC

Clover General discussion

18,084 posts in this topic

Recommended Posts

Advertisement
On 6/30/2018 at 12:48 PM, ellaosx said:

In clover gui, it has an option to disable kexts in clover folder. how to do it in config.plist?

Maybe this would help?

 

1340184760_Screenshot2018-07-01at15_51_09.thumb.png.6adeec9464fdac73469b94cb944e80b3.png

Share this post


Link to post
Share on other sites
Posted (edited)

That would disable all.

disabling kext in gui is only temporary in case we cant boot. So i guess no need for it to be written in config, thats why there is no feature on that.

Screenshot 2018-07-01 at 15.51.09.png

Edited by ellaosx

Share this post


Link to post
Share on other sites
16 hours ago, telepati said:

is FSInject-64.efi mandatory on Mojave? 

 

FSInject is used to block files from being loaded and also inject files from pre exit boot services for the kernel. It probably does not have much of a use since it was mainly for preventing the kernel cache from loading.

Share this post


Link to post
Share on other sites
Posted (edited)

Indeed. That would disable it all. But...since you asked for something to be done from config...that would be the only way I know. Of course that way would also be permanent. default_smile.png) I don’t know of a temporary way to disable that..and also do it from config. default_smile.png

 

And as you said, it would be recommended to use the UI instead of config, in case things go horribly wrong at some point, with the current config.

But, just to clarify, are you looking for disabling specific kexts, from config? Cause now I’m a bit confused as to what the use case of such a feature would be.

Edited by arsradu

Share this post


Link to post
Share on other sites

 

5 hours ago, telepati said:

 


So, is it or not? :D

 

 I can answer "Yes" and this is safe for you.

All drivers can be considered as mandatory until you are know exactly what and for a what and may say that you have another way to go without this driver.

 

Share this post


Link to post
Share on other sites
Posted (edited)

hi all,

I don't know if this question was answered before, but here it goes... what drivers from the list in clover that are essential for most of the users?

I ask because sometimes I feel myself confused with so many information.

Thanks in Advance

PS: by the way I have another question, today I lost the ability to boot in my hack, in all my 3 disks, 2 ssd and one hdd, because all my usb installs are lost and now the only thing that appear at the beginning of boot are this... 

I already tried to re install clover in the usb, erase the EFI, how do I solve this?

The last usb installers are made in my real Mac, but don't work too...

Sorry for the long rant...

Thanks 

IMG_6881.JPG

Edited by MorenoAv

Share this post


Link to post
Share on other sites

@MorenoAV

you have been confsuing yourself with those multiple HDD/SSD plugged n your computer.

Plug only what's needed untill you're done installing to make life easier for you.

Share this post


Link to post
Share on other sites
5 hours ago, MorenoAv said:

hi all,

I don't know if this question was answered before, but here it goes... what drivers from the list in clover that are essential for most of the users?

 

Again. All drivers are essential.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @ellaosx, @Slice,

Thanks for you advice, and you are right, I'm confused with all my drives... and I'm going to follow your suggestion as soon as I can boot again in one of them... all are in a no bootable state, including all my usb installs.

This time I {censored}ed the thing really bad, and no matter what I do, I can't make new usb installers even in my real Mac. The result is shown in the photo I uploaded...

And @Slice i am completely clear now...

 

Edited by MorenoAv

Share this post


Link to post
Share on other sites

can anyone help me please for this Problem "Hide WindowsHDD" ?

in my old Clover 4449 work this:

 

<string>WindowsHDD</string>
               <string>HD(2,MBR,0x5777E8C8,0xC738800,0xEA60000)</string>
               <string>HD(3,MBR,0x5777E8C8,0x1B198800,0x20848800)</string>
               <string>HD(1,MBR,0x000460C8,0x800,0x11170000)</string>

in the new 4577 work this not. What is the error ?

Thank you for help please

Share this post


Link to post
Share on other sites

Hi guys, why lastest clover update just removed my OsxAptioFixDrv64.efi  from driver folder?

Share this post


Link to post
Share on other sites

I had newer kabylake refresh that can boot uefi with clover and extract dsdt and several ssdt there when booting clover.

 

question: my old sandy bridge u36sd support Mbr and partial uefi (no csm option). I want to extract dsdt and ssdt using clover. I had install clover ESP on USB GUID flash disk with Mbr boot0af wrote in USB.

but I can't find the f2 f4 menu to extract dsdt .

AIDA64 extract dsdt and several ssdt that I need to compare.

aipcdump and old iasl -g can't dump ssdt.

I had newer kabylake refresh that can boot uefi with clover and extract dsdt and several ssdt there when booting clover.

 

question: my old sandy bridge u36sd support Mbr and partial uefi (no csm option). I want to extract dsdt and ssdt using clover. I had install clover ESP on USB GUID flash disk with Mbr boot0af wrote in USB.

but I can't find the f2 f4 menu to extract dsdt/ssdt.

AIDA64 extract dsdt and several ssdt that I need to compare.

aipcdump and old iasl -g can't dump ssdt.

Share this post


Link to post
Share on other sites
6 hours ago, Maniac10 said:

 

I'll test the newer version (tried it a while ago) but AptioMemoryFix is the only driver capable of booting my system.

 

He is talking about AptioMemoryFix, the installer apparently does not correctly select the driver when upgrading or something as some previous options were removed, I think.

Share this post


Link to post
Share on other sites
9 hours ago, apianti said:

 

He is talking about AptioMemoryFix, the installer apparently does not correctly select the driver when upgrading or something as some previous options were removed, I think.

Can be true. From a certain commit I've added a suffix for them and the identifier can be different. If that is the case, next time will be fine.

Share this post


Link to post
Share on other sites
Posted (edited)

I'm just curious about this, so...

<key>BooterConfig</key>
	<string>0x28</string>
	<key>CsrActiveConfig</key>
	<string>0x67</string>

^ does it fully disable SIP, or not? Thanks.

Screenshot 85.png

Edited by Badruzeus

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, Badruzeus said:

I'm just curious about this, so...


<key>BooterConfig</key>
	<string>0x28</string>
	<key>CsrActiveConfig</key>
	<string>0x67</string>

^ does it fully disable SIP, or not? Thanks.

As far as I know 0x67 disables SIP but it won't allow for untrusted kexts to be loaded, if you run "csrutil status" in terminal you can see which part of SIP is disabled, I guess with 0x3e7 SIP will be totally disabled and it will expose macOS even more.

 

Addition:

Take a look at this for more info

Edited by Cyberdevs

Share this post


Link to post
Share on other sites

So I just downloaded the 10.13.6 installer from the app store so I can update my usb stick and after the installer downloaded it opened and it said "To install mac os high sierra a firmware update is required."  I'm not wanting to go through the installation or anything, I'm just curious on this message.

 

My clover boot log shows:

 

2:912  0:000  Using ProductName from config: MacPro5,1
2:912  0:000  BiosVersion: not set, Using BiosVersion from clover
2:912  0:000  BiosVersion: MP51.88Z.0087.B00.1804181525
2:912  0:000  BiosReleaseDate: 04/18/18
2:912  0:000  Using FirmwareFeatures from clover: 0xE80FE137
2:912  0:000  Using FirmwareFeaturesMask from clover: 0xFF1FFF3F
2:912  0:000  PlatformFeature will not set in SMBIOS
 

 

Is this bios version correct?  I'm using the clover autogenerated one.  Clover 4586 is what I am on.

Share this post


Link to post
Share on other sites
On 7/14/2018 at 1:11 AM, Badruzeus said:

I'm just curious about this, so...


<key>BooterConfig</key>
	<string>0x28</string>
	<key>CsrActiveConfig</key>
	<string>0x67</string>

^ does it fully disable SIP, or not? Thanks.

Screenshot 85.png

how about 0x77?

Share this post


Link to post
Share on other sites
3 hours ago, Alpha22 said:

hello,

when I install Clover, this happens
even with different versions of Clover

 

10zs6qq.png

 

advice

 

yes, disable SIP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By thomaspetersen
      Hi All
       
      I'm trying to start a Hackintosh High Sierra 10.13.5 installation:
      - MSI B350 PC Mate
      - Ryzen 5 - 2600
      - Radeon Pro 580 GPU
      - 4 x 8GB DDR4
      (Have a working clover bootloader for HS 10.13.3 - but for some reason, I can't use that setup with the 10.13.5) 
       
      Have tried different bootloader setup, with different outcomes...
      ATM. I get this error/hang - "Unknown CPU: family = 0x17, model = 0x8, Stepping = 0x2"
      Have search google, and can see that the threads ppl. are getting this, is when they look at "About this mac", I haven't yet installed the OSX.
       
      So can someone help...

      I'm running the newest Kexts: AppleALC, FakeSMC, Lilu, RealtekRTL8111, USBInjectAll and WhateverGreen.
      In Bootloader setup, i'm running: -v, -s, -f, -no_compat_check, busratio=34, PCIRootUID=1, npci=0x2000, dart=0 and nv_disable=1
      In SMBIOS i'm using the iMac18,2 and in RT i'm using BooterConfig: 0x28 and CsrActiveConfig: 0x67
      In installed drivers i'm using: AptioMemoryFix, EmuVariableUefi-64, OsxAptioFixDrv-64 (Have tried Fix2 as well)
       
      But i'm, keep getting the Unknown CPU hang/error, can someone help...
      Or do someone have a setup with the same CPU and GPU, that can show me his/her setup for Bootloader/Kexts...
    • By Teress
      I get a lot of questions about HOW TO BACKUP A HACKINTOSH. So I decided to create Complete Guide with 5 methods described in detail, how to easily make bootable clones of Hackintosh system disks, or backup your data. Full step by step tutorial is here:
       
       
    • By STLVNUB
      Reviving my old INSTAHackintosh, it's been a while....
      Purpose:
      Create User Custom Install iso/dmg with bootloader, apps and user-settings.
      Create Live iso/usb.
      What Versions:
      Tiger-Current ( bit ambitious but hey I like a challenge ).
      Why:
      Because I can!
      I'm not too impressed with the way Apple and others handle their installs.
      Support for 4 Bootloaders:
      Chameleon
      Clover Legacy
      Refit Ozmosis
      Clover UEFI
      Keep you informed as I progress from scratch.
      This could take a while, it's NOT my priority.
      Will probably release in Os versions, starting at Mojave and working backwards.
    • By FernandoCoverdale
      Buenas!
      recuerdo que cuando empece a instalar el clover para hacer mi hackintosh el boot de clover tenia una cuenta atrás en la que pasado “no se si eran 5 o 6 segundos”se iniciaba la opcion de arranque de high sierra del disco duro que es la que se marca por defecto, seguramente habré instalado un theme que me lo deja fijo y no recuerdo como volver activarlo.
      gracias de antemano!!!
      adjunto foto

×