Jump to content
ErmaC

Clover General discussion

18,354 posts in this topic

Recommended Posts

Posted (edited)
54 minutes ago, Matgen84 said:

HI

 

Can apfs.efi Mojave version be use on High Sierra 10.13.5 in /EFI/CLOVER/Drivers64UEFI ?

 

Any ideas? Please.

 

Yep. It's backwards compatible with High Sierra.

Edited by arsradu

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

I bet the problem in drivers boot order in Clover, so Clover loads drivers from drivers64uefi by alphabet starting from A ... Z that means that ApfsDriverLoader loads before PartitionDXE - thats the problem. You can try to rename PartitionDxe to something like A1 and ApfsDriverLoader to A2 and report

I'll fix it in next version

Edited by savvamitrofanov

Share this post


Link to post
Share on other sites
1 hour ago, savvamitrofanov said:

I bet the problem in drivers boot order in Clover, so Clover loads drivers from drivers64uefi by alphabet starting from A ... Z that means that ApfsDriverLoader loads before PartitionDXE - thats the problem. You can try to rename PartitionDxe to something like A1 and ApfsDriverLoader to A2 and report

I'll fix it in next version

 

insanelymac's upload isn't working. so i uploaded image in imagur.

here

https://imgur.com/a/f92xtg5

 

i'm using CLOVER UEFI. i tested both PartitionDxe and without PartitionDxe and changed name. but still not work..

only v1.0.2 works

Share this post


Link to post
Share on other sites
7 minutes ago, Sherlocks said:

 

insanelymac's upload isn't working. so i uploaded image in imagur.

here

https://imgur.com/a/f92xtg5

 

i'm using CLOVER UEFI. i tested both PartitionDxe and without PartitionDxe and changed name. but still not work..

only v1.0.2 works

Hello! Try to load debug 1.1.1 version manually from shell and give me debug information from ApfsDriverLoader and drivers list from shell

Share this post


Link to post
Share on other sites
Posted (edited)
39 minutes ago, savvamitrofanov said:

Hello! Try to load debug 1.1.1 version manually from shell and give me debug information from ApfsDriverLoader and drivers list from shell

 

i can't get log.

i followed this

change name ApfsDriverLoader.efi to 1

then place 1.efi in ESP 

load -nc 1.efi > 1.txt

 

- ApfsSupport-v1.1.1-DEBUG -

Image 'FS0:\1.efi' loaded at D4E69000 - Success

 

- ApfsSupport-v1.0.2-DEBUG -

Image 'FS0:\2.efi' loaded at D4DCE000 - Success
Apfs Container found.
CsbMagic: 4253584E
Should be: 4253584E
Container Blocksize: 4096 bytes
ContainerSuperblock checksum: 4659DE52DE399B7E 
EfiBootRecord located at: 1479746 block
EfiBootRecordBlock offset: 175D42000 
EfiBootRecordBlock checksum: 3EEB3E142E7E793F
ApfsDriver located at: 2835065 block
ApfsDriver offset: 2C0B79000 
ApfsDriver size: 610304 bytes
Loading apfs.efi from memory!

 

- PartitionDxe / ApfsSupport-v1.1.1-DEBUG -

3.efi = PartitionDxe

1.efi = ApfsSupport-v1.1.1-DEBUG

Image 'FS0:\3.efi' loaded at D4E5D000 - Success

Image 'FS0:\1.efi' loaded at D4E58000 - Success

still no luck

Edited by Sherlocks

Share this post


Link to post
Share on other sites
Posted (edited)
53 minutes ago, Sherlocks said:

 

i can't get log.

i followed this

change name ApfsDriverLoader.efi to 1

then place 1.efi in ESP 

load -nc 1.efi > 1.txt

 

- ApfsSupport-v1.1.1-DEBUG -

Image 'FS0:\1.efi' loaded at D4E69000 - Success

 

- ApfsSupport-v1.0.2-DEBUG -

Image 'FS0:\2.efi' loaded at D4DCE000 - Success
Apfs Container found.
CsbMagic: 4253584E
Should be: 4253584E
Container Blocksize: 4096 bytes
ContainerSuperblock checksum: 4659DE52DE399B7E 
EfiBootRecord located at: 1479746 block
EfiBootRecordBlock offset: 175D42000 
EfiBootRecordBlock checksum: 3EEB3E142E7E793F
ApfsDriver located at: 2835065 block
ApfsDriver offset: 2C0B79000 
ApfsDriver size: 610304 bytes
Loading apfs.efi from memory!

 

- PartitionDxe / ApfsSupport-v1.1.1-DEBUG -

3.efi = PartitionDxe

1.efi = ApfsSupport-v1.1.1-DEBUG

Image 'FS0:\3.efi' loaded at D4E5D000 - Success

Image 'FS0:\1.efi' loaded at D4E58000 - Success

still no luck

Partitiondxe should start before ApfsDriverLoader. Rename  ApfsDriverLoader to Z.efi and keep partitiondxe it's original name

Edited by savvamitrofanov

Share this post


Link to post
Share on other sites
Posted (edited)
12 minutes ago, savvamitrofanov said:

Partitiondxe should start before ApfsDriverLoader. Rename  ApfsDriverLoader to Z.efi and keep partitiondxe it's original name

 

changed name still no luck.

i typed manual load in shell.

first load PartitionDxe.efi

then v1.1.1 debug version.

still no luck. i think i tested all cases enough. i never success v1.1.1

Edited by Sherlocks

Share this post


Link to post
Share on other sites
Posted (edited)

 

17 minutes ago, Sherlocks said:

 

changed name still no luck.

i typed manual load in shell.

first load PartitionDxe.efi

then v1.1.1 debug version.

still no luck. i think i tested all cases enough. i never success v1.1.1

Partitiondxe needs connecting, which implemented in Clover. Push ApfsDriverLoader with name zz.efi and partitiondxe with its name in drivers64uefi and start Clover - it should work 

I'll fix it in next version

Edited by savvamitrofanov

Share this post


Link to post
Share on other sites
5 minutes ago, savvamitrofanov said:

Partitiondxe needs connecting, which implemented in Clover. Push ApfsDriverLoader with name zz.efi and partitiondxe with its name in drivers64uefi and start Clover - it should work

Partitiondxe needs connecting, which implemented in Clover. Push ApfsDriverLoader with name zz.efi and partitiondxe with its name in drivers64uefi and start Clover - it should work

still no luck.

first checked PartitionDxe efi file load with v1.0.2. yes it's connecting in log.

then i changed name zz.efi from ApfsDriverLoader(1.1.1 Debug). then push it in Drivers64UEFI folder. and reboot. there is still no entry in GUI. it is same like i reported before

Share this post


Link to post
Share on other sites
4 minutes ago, Sherlocks said:

still no luck.

first checked PartitionDxe efi file load with v1.0.2. yes it's connecting in log.

then i changed name zz.efi from ApfsDriverLoader(1.1.1 Debug). then push it in Drivers64UEFI folder. and reboot. there is still no entry in GUI. it is same like i reported before

Nasty situation! However I'll fix it soon in next version. Thank you for testing

Share this post


Link to post
Share on other sites
2 minutes ago, savvamitrofanov said:

Nasty situation! However I'll fix it soon in next version.

IMHO, Clover does not sort .efi files by name/.... It just load them as they listed in folder directory (random).

Share this post


Link to post
Share on other sites

Your driver should not rely on loading order.

If you have a dependency then you must write your driver with check and wait until your dependency satisfied.

Share this post


Link to post
Share on other sites
14 hours ago, Sherlocks said:

still no luck.

first checked PartitionDxe efi file load with v1.0.2. yes it's connecting in log.

then i changed name zz.efi from ApfsDriverLoader(1.1.1 Debug). then push it in Drivers64UEFI folder. and reboot. there is still no entry in GUI. it is same like i reported before

well in my case its loading just ok os x without partitiondxe

(uefi apfs container)

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, Sherlocks said:

still no luck.

first checked PartitionDxe efi file load with v1.0.2. yes it's connecting in log.

then i changed name zz.efi from ApfsDriverLoader(1.1.1 Debug). then push it in Drivers64UEFI folder. and reboot. there is still no entry in GUI. it is same like i reported before

Im on Mojave B2 with APFS {Haswell Laptop currently) and i also do not need PartitionDxe

I have

ApfsDriverLoader-64.efi

AppleImageCodec-64.efi

AppleKeyAggregator-64.efi

AppleUITheme-64.efi

AptioMemoryFix-64.efi

DataHubDxe-64.efi

FirmwareVolume-64.efi

FSInject-64.efi

HFSPlus.efi

SMCHelper-64.efi

The only ones i need are ApfsDriverLoader-64.efi, AptioMemoryFix-64.efi and HFSPlus.efi

The rest Clover keeps insisting on me to install.

 

I'm not sure when ApfsDriverLoader actually loads the apfs from but maybe there is something wrong with yours? Have you tried just adding apfs.efi into drivers64UEFI? Try a fresh install?

Edited by SavageAUS

Share this post


Link to post
Share on other sites
2 hours ago, Slice said:

Your driver should not rely on loading order.

If you have a dependency then you must write your driver with check and wait until your dependency satisfied.

Hello! I understood this and just made a bit testing with Sherlock's platform.

However I made test version with PartitionDriver availability check

ApfsDriverLoader 1.1.2

@Sherlocks, test it please

 

Share this post


Link to post
Share on other sites
23 minutes ago, savvamitrofanov said:

Hello! I understood this and just made a bit testing with Sherlock's platform.

However I made test version with PartitionDriver availability check

ApfsDriverLoader 1.1.2

@Sherlocks, test it please

 

 

hi.

still no luck

https://imgur.com/a/7VinhTy

 

i tested both PartitionDxe and without PartitionDriver.

here is log in shell

Image 'FS0:\1.efi' error in StartImage: Invalid Parameter

Share this post


Link to post
Share on other sites
Posted (edited)
7 minutes ago, Sherlocks said:

 

no luck

Image 'FS0:\3.efi' is not an image.

i saw partition blah bla message when getting gui on left top

 

Why 3.efi not an image? From what did you load 3.efi? And how?

Did you try to rescan volumes in Clover by pressing ESC?

Edited by savvamitrofanov

Share this post


Link to post
Share on other sites
12 minutes ago, savvamitrofanov said:

Why 3.efi not an image? From what did you load 3.efi? And how?

Did you try to rescan volumes in Clover by pressing ESC?

 

i renamed apfsloader.efi to 3.efi. no need to type full name when test. also in shell i typed load 3.efi. this process is working v1.0.2 i shell. you can see it i reported above in this thread.

Share this post


Link to post
Share on other sites
1 minute ago, Sherlocks said:

 

i renamed apfsloader.efi to 3.efi. no need to type full name when test. also in shell i typed load 3.efi. this process is working v1.0.2 i shell. you can see it i reported above in this thread.

Got it. Try 1.1.5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By fusion71au
      Clover r4799 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4799 for VMware.zip". Mount Clover-v2.4k-4799-X64 by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By sonicthehedgehog2
      Apologies for the lack of information (and for posting in the wrong place), but I can't even boot into Clover so screenshots of verbose mode aren't even possible. I've been running the beta of 10.14.2 for sometime (-using this excellent guide 
      ) without any issues. When I tried to apply the new update for 10.14.2, my pc downloaded the update, shutdown but applied some updates then rebooted into a blank screen. I've tried several things since then. Specifically:
       
      * Booting from the installation USB created using the above guide - same blank screen
      * Booting from an external HDD - successful launch of OS. From here I have tried different versions of Clover including the one on my HDD r4644 (all have been unsuccessful). I have also tried different memory management options osxaptiofix (1, 2 & 3)
       
      The only other information I can provide is in the screenshots below (including a brief of my drive configuration)
       
      Please let me know if and how I can get more information to help resolve the issue, or if I have to rebuild from scratch.
       
      Many thanks in advance
       
       


    • By Teress
      To build a Hackintosh never was easier. If you want cheap Hackintosh and have it quickly and 100% working and without any knowledge how to tweak things, this video is right for you.
       
    • By superdooper71
      Hi all,
      I hope someone can help me as I am struggling with this bloody installation.
      I am running on several problems that I can't face : (
       
      First of all my config:
      Mobo: ASROCK H81M-DGS R2
      CPU: Intel Xeon E3-1220 v3 @3.10ghz
      RAM: 16gb DDR3 1600Mhz
      SSD: Crucial BX100 120Gb SSD
      Monitor: Hp 27w Hdmi
       
      POST Installation CLOVER
       
      Current Issues:
      • System will not boot (clover boot loader do not shows up) from SSD
         - System boot only with USB stick
      • Screen Resolution is only 1024x768
      • Monitor recognised as 17" instead of 24"
      • Monitor identified as secondary
      • Grafic Card Geforce GT710 shows 0 Mb
      • System info do not match Config.plistin Clover
       
      I attach screenshot of System Info, Kext in Clover, Resolution etc etc.
       
      Please can someonhelp me?
       
      Please can you tell me what is the Clover Parameter to activate when installing Clover  (Clover_v2.4k_r4722) into Boot Disk?
       
      I hope someone can help me out of this little troble: )
       
      Cheers
      Franco
       
      system info.tiff
      kext.tiff
      resolution.tiff
      system.tiff
      config.plist
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  selezionate OsxAptioFixDrv-64
                             *  :Se nel vostro sistema è presente una scheda grafica (discreta) della serie 9xx nVidia selezionate OsxAptioFix2Drv-64 al posto di  OsxAptioFixDrv-64 *
      ** OsxAptioFix2Drv :E' necessario per poter impostare CsrActiveConfig= 0x3 **
      ***OsxAptioFix3Drv oppure AptioMemory --> (consigliato) devono essere usati su hardware Skylake o successivi perché permettono alla nvram di lavorare correttamente
           (mi raccomando o uno o l'altro)
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      apfs.efi-10.13-NoLog.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      apfs.efi-10.13.1-No_LOG.zip
      apfs.efi-10.13.2_No_Log.zip
      apfs.efi-10.13.3-No_Log.zip
      apfs.efi-10.13.4-No_Log.zip
      apfs.efi-10.13.5_No_Log.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip






×