Jump to content
ErmaC

Clover General discussion

19,119 posts in this topic

Recommended Posts

replace bootx64.efi too with same file slice post.

 

Replaced both BOOTX64 and CLOVERX64 and i changed my boot args to erase the nvda_drv=1 key : it booted !

So, i changed the default drivers to Nvidia Web in prefpane.

Reboot and ... no boot.

So i booted on USB ad i could see that the boot args in nvram.plist changed with the nvda_drv=1 added.

 

I tried to redo the trick twice but i never got i boot with the 1707 files.

Sorry, don't know how to help.

Share this post


Link to post
Share on other sites
Advertisement

Replaced CLOVERX64.efi in EFI/CLOVER and I can't boot.

Stuck before theme.

I'm a noob, so i think i've missed something.

 

I built the installer package for 1708 and mine gets stuck before the theme as well. I had to roll back to 1703.

Share this post


Link to post
Share on other sites

Replaced both BOOTX64 and CLOVERX64 and i changed my boot args to erase the nvda_drv=1 key : it booted !

So, i changed the default drivers to Nvidia Web in prefpane.

Reboot and ... no boot.

So i booted on USB ad i could see that the boot args in nvram.plist changed with the nvda_drv=1 added.

 

I tried to redo the trick twice but i never got i boot with the 1707 files.

Sorry, don't know how to help.

Set PatchVBios=No

Set Debug, boot and wait for 10 minutes. Then find debug.log in /EFI/CLOVER/misc and show me.

<key>GUI</key>
<dict>
 <key>DebugLog</key>
 <true/>

Share this post


Link to post
Share on other sites

Thats all I do all day, is look at GUI, when I finish I would like to shutdown with button, NOT use power button.

After all the button does say "Shutdown", NOT "Exit" ;)

 

edit:

Maybe this needs to be in config.plist, after all it is a user choice.

Shutdown = Yes [ we Shutdown- Hooray]

Shutdown = No [ we Exit ]

u dont have Shutdown = Never :D

just a joke.i vote for this be user choice.

Share this post


Link to post
Share on other sites

Sorry for the mistake. Corrected in 1711

CLOVERX64.efi-1711.zip

 

While trying to use the new nvidia 313 drivers I added "nvda_drv=1" to my config.plist but my system still reports that I am using 310. I updated to this version and now Clover prefpane reports version 1709, not 1711. Is this cosmetic or do I need to wait until 1711 hits sourceforge?

 

I was going to look into using CloverGrower, but git is blocked currently.

Share this post


Link to post
Share on other sites
I was going to look into using CloverGrower, but git is blocked currently.

 

CloverGrower is working perfectly - the current version as of this moment is 1717.

Share this post


Link to post
Share on other sites

Hi to all theme lovers!

I modify some of themes i found here,projectosx,and voldemort castle to work with r1690+,and uploaded in one zip archive. for easy instalation.

 

how to download this from goodle drive ????

invZIGh.png

 

They all have screenshots from prefpane.

Its not perfect screenshot but i think anyone can see how theme look like.

Dont know if i make something wrong about theme name or autor name,soo sry for this.

All Credits for this goes to themes autors.

 

List of themes are:

 

oAV7cH3.png

 

ExNFwSR.png

 

g05Xo1N.png

 

pzzi8YN.png

 

jBVYlv4.png

 

OzYxsEq.png

 

Hur1XcC.png

 

d1j8qFQ.png

Share this post


Link to post
Share on other sites

Just ran cloverpro and got an oddly named package "Clover_v2_r1653/1720.pkg" - a new naming scheme? r1653 was the last build I did, r1720 the current one.

 

Looks like it really is just installing 1653. No changes to clover prefpane etc.

 

Think I'll run cloverpro setup again...

 

Noticed an error in console app

 

 

22/05/2013 13:04:43.702 SystemUIServer[288]: Invalid kMDItemPath for CloverUpdater.app
22/05/2013 13:04:43.713 SystemUIServer[288]: problem with path CloverUpdater.app

 

And this at end of cloverpro run

### Rez - SysError -37 during create of "sym/Clover_v2_r1653:1720.pkg".
### Rez - Fatal error trying to open the resource file "sym/Clover_v2_r1653:1720.pkg" for writing.
Fatal Error!
### Rez - Fatal Error, can't recover.
### Rez - Since errors occurred, sym/Clover_v2_r1653:1720.pkg's resource fork was not completely updated.
### Rez - SysError -43 during set file info.

Edited by ZenGiga

Share this post


Link to post
Share on other sites

Thanks for the update to Clover, I am now running 1717, but I can still not use the new NVIDIA 313 web drivers. Was there something I missed when adding the kernel flag to my config.plist

 

<key>boot-args</key>
<string>slide=0 nvda_drv=1 WithKexts</string>

Share this post


Link to post
Share on other sites

Hi to all theme lovers!

I modify some of themes i found here,projectosx,and voldemort castle to work with r1690+,and uploaded in one zip archive. for easy instalation.

 

how to download this from goodle drive ????

 

 

They all have screenshots from prefpane.

Its not perfect screenshot but i think anyone can see how theme look like.

Dont know if i make something wrong about theme name or autor name,soo sry for this.

All Credits for this goes to themes autors.

 

 

Please another icons from Magnifico

vol_internal_hfs.icns.zip

Share this post


Link to post
Share on other sites

i'm posting again about my problem with no information during verbose mode boot.

If I remove PatchVBios from config the verbose booting looks like this

http://youtu.be/DqLVqZWdGDo

If PatcgVBios is set to yes in config the verbose boot looks like this:

http://www.youtube.com/watch?v=CACb5JESPt4

 

There is for sure an option that i'm setting wrong, and maybe you can tell me because i cannot find it.

here is my efi folder https://mega.co.nz/#...qwrjovspk9APfiA

and here is kernel log https://mega.co.nz/#...O3Vx33Squyv3-yA

 

 

if you need anything else tell me and i will provide it just to solve this problem :)

 

PS: I'm using UEFI Boot without CSM

 

@slice or @xpamamadeus any feedback for my issue?

Share this post


Link to post
Share on other sites

So, I followed the advice to 'let clover choose' the model defined in smbios, and it chose imac8,1 - having got sleep/wake and speedstep working with this I've now turned my attention to my geforce 660 ti graphics card and find that imac8,1 doesn't load AGPM kext :(

 

So whats the best path forward? Go back to using macpro4,1 as I was before installing clover? Or is there another way? I noticed what looked like graphics card power management code in ACPI_SMC_PlatformPlugin.kext for imac8,1. Any advice welcome.

Share this post


Link to post
Share on other sites

guys I have this problem , why with clover the sleep it doesn't work?

 

It's been a problem for a long time now, but it only happens booting UEFI, CloverEFI (like any other legacy bootloader) can sleep/wake just fine.

Share this post


Link to post
Share on other sites

Answering my own question: turns out

clover + iMac8,1 + IOPlatformPluginFamily edit + 660 ti => speedstep but no AGPM

clover + MacPro3,1 + 660 ti + Nvidia web driver for osx => native speedstep, no AGPM *but* nvidia drivers do power management of the 660 ti

 

So I'm going back to MacPro3,1 which always worked well for my motherboard/cpu combo and installing the nvidia drivers.

 

FWIW the nvidia drivers are preferred when using 'unsupported' nvidia cards on real macpro's now too. The scores in OpenGL extension viewer tests doubled with the nvidia drivers.

 

Need to reread clover smbios docs, I think all I need is to specify MacPro3,1 in conf and Clover is fantastic enough to deal with the rest of the smbios, right?

Share this post


Link to post
Share on other sites

Answering my own question: turns out

clover + iMac8,1 + IOPlatformPluginFamily edit + 660 ti => speedstep but no AGPM

clover + MacPro3,1 + 660 ti + Nvidia web driver for osx => native speedstep, no AGPM *but* nvidia drivers do power management of the 660 ti

 

So I'm going back to MacPro3,1 which always worked well for my motherboard/cpu combo and installing the nvidia drivers.

 

FWIW the nvidia drivers are preferred when using 'unsupported' nvidia cards on real macpro's now too. The scores in OpenGL extension viewer tests doubled with the nvidia drivers.

 

Need to reread clover smbios docs, I think all I need is to specify MacPro3,1 in conf and Clover is fantastic enough to deal with the rest of the smbios, right?

 

Read this, you need to add your graphics in the iMac8,1 AGPM profile.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By AppleBytes
      OK, I've searching for days trying to gather up the tools to make my current install work correctly. I'm well on my way. But all the links to the things I currently must have were apparently nuked "during a forum upgrade". :(
      As far as EFI Studio goes; I can find many links to it. But for Insanelymac, they're broken (due to the upgrade), or for the Netkas site, they're links to either Rapidshare, or Mediafire that also no linger exist. I see many users here indicating that they used it to tweak their DSDT. But the web (google/duckduckgo), Instanelymac, and Netkas seem to have no idea where it's gone.
      Could some kind soul please share a copy, or a link? I'm a loooong time hacker, and would love to bring it back to life. In fact, I'd love to improve it -- or at least bring it up to current times. If only I knew where it was.
      Thank you for all your time, and consideration.
       
      --Chris
       
    • By SoThOr
      This was spurred on from a discussion in the Clover General thread. Where there was a debate on bcdedit being able create/read/edit (U)EFI Boot entries. I didn't think it appropriate to post all this information there and somebody may want to make use of this and its likely to get lost in that massive thread.
       
      Out of curiosity I decided to see if I could create an EFI entry using bcdedit. What can I say I like a challenge.  Whilst is not a documented method by Microsoft, as it turns out in a round about way it IS possible to create an EFI entry using bcdedit and these are the steps I went through to add UEFI Shell located on a USB stick to the EFI entries. 
       
      Third party software is available that can create and edit UEFI entries from Windows with better support and more features. I'm just making this information available in case those options are unavailable. 
       
      DISCLAIMER - This is not a supported method. Use at your own risk. I recommend backing up your BCD/Firmware variables/settings beforehand.
       
      1) Copy {bootmgr} entry.
      C:\Windows\System32>bcdedit /copy {bootmgr} /d "UEFI Shell" The entry was successfully copied to {34e8383c-73a7-11e9-9cb0-94de8078a7b5}. 2) Edit the new entry using the new GUID bcdedit generated in the copy step.
        a) Set the device and path for UEFI shell on my USB stick.
      bcdedit /set {34e8383d-73a7-11e9-9cb0-94de8078a7b5} device partition=G: bcdedit /set {34e8383d-73a7-11e9-9cb0-94de8078a7b5} path \EFI\SHELL\SHELLX64.efi   b) Clean up some of the stuff that was copied from {bootmgr} (optional as far as I can tell, just makes things tidier in bcdedit)
      3) Put the new EFI entry first in boot order. (optional)
       
      After completing the steps above, here is what "bcdedit /enum firmware" shows:
       
      I shutdown my computer and when I turned my computer back on it booted up into UEFI Shell. After exiting the shell my PC went on to boot Windows.
      Here is the resulting dump using "bcfg boot dump -v" from that shell:
       
      You may notice that the shell shows as "Windows Boot Manager" in the bcdedit output. This I believe is because of the "WINDOWS" at the beginning of the option data that bcdedit added to the EFI Boot entry. I also believe this why bcdedit shows my Windows 8 installation as "Firmware Application" because it has no option data. I don't know how to remove this data using bcdedit nor do I know how the option data, that bcdedit adds, will affect other EFI applications.

      There might be a way to create the EFI entry without copying the Windows entry but if there is I'm unable to find any documentation on how one would do so. If you use the create command then it just puts it in the BCD and I'm unaware of a way to tell it to create it in EFI instead, other than by doing the above.
    • By cvad
      Small tool to download, compile and build the latest Clover X64 package.
       
       
       

      The script inside is editable.

       
      Enjoy...
       
      Many thanks to the comrade SunKi for help with creating the script.
       
       
       
       
       
      Best thanks - click "Rate File".
       
    • By blxkspell
      Hey!
      As I have 3 Monitors connected, my RX 570 gets arround 50°C while ideling/ web browsing etc. The problem is, that this temp is apparently just the threshold, when the fans start to spin. So the fans start spinning for a minute then they stop for a while again... This is very annoying for me as the rest of my hackintosh is nearly quiet (SSD, 120mm low RPM cpu fan, nearly silent PSU,...), especially when Im using the pc to revise for school. Does somebody know wether its possible to "change" the threshold till the fans start spinning? Like it would probably not be a problem for the gpu at all, if the temp rises to 55°C but therefore be soundless....
       
       
    • By kylon
      Cloud Clover Editor allows you to manage Clover EFI and Ozmosis configs everywhere!
       
       
      WEB
      Open Cloud Clover Editor
       
      APP (MacOS - Discontinued)
      Clover flying editor ( Micky1979 )
       
       
       
       
      Sources: https://bitbucket.org/kylon/cloud-clover-editor-cce/overview


      To run CCE at home you will need:
       
      An HTTP server (Apache, Nginx, ...) PHP 5.3.3+ (latest PHP version is always recommended for better performances/security) Sqlite3 PHP extension  
       
      Some Features:
       
      Edit text in tables:
      Editable fields are marked with a text cursor.
      Double click, or tap and hold, to open the inline editor.
      You can now press Enter or click outside to save your changes.
       
       
      Tri-state checkboxes:
      There are 3 possible states for a checkbox: Checked, indeterminate and unchecked.
       
      Checked: Value is true;
      Indeterminate: Value is false;
      Unchecked: Value is not set (ie, removed from plist)
       
      Working with multiple configs:
      The right sidebar is your multitasking menu.
      Use the add button to create a new config and add it to the list.
      You can safely switch between all your configs, no changes will be lost.
      You can mix Clover EFI and Ozmosis configs.


      Config Upgrade feature:
      In the case you are using old configuration options, CCE gives you the ability to automatically upgrade your config.
       
       
      Copy to:
      You can copy patches between your configs (you will love this when you need to copy kernel and kext patches ;D ).
      You will find a yellow copy icon if that field does support the copyTo feature.
       
       
      Ozmosis Mode:
      A new setting, Cloud Clover Editor Mode, is now added in Cloud Clover Editor -> CCE Settings.
      This will let you switch from Clover EFI to Ozmosis mode.
      Changes to your current file will be lost.
       
       
      CCE Bank 2.0:
      Thanks to @cecekpawon for the idea.
       
      CCE Bank is a database where you can save/load Clover EFI and Ozmosis configs.
      You can protect your config from unwanted modifications or make a publicly editable config.
       
      To save a config in CCE Bank you only need to check the "Save to CCE Bank" option.
       
      Tick the box generate a new CID, if you don t have one.
       
      A CID (CCE ID) acts like a container and it is your authentication key.
      You can group multiple configs under the same CID or generate as many CIDs as you like.
       
      Edit Modes:
      Public: Anyone can make modifications, only the owner can change its settings. Private: Only the owner can make modifications and change its settings. MyBank: Only the owner can see this config, make modifications or change its settings.  
      MyBank is your private area.
      Change the 'view mode' to switch between the public bank and your personal bank.
       
      To manage your currently loaded config, go to Cloud Clover Editor -> Open config -> click the settings button.
       
       
      Notes:
      Locked/Private configs are marked with a padlock MyBank configs are only visibile in your private area Only the owner of a locked config can save the modifications in CCE Bank, hower you are free to do whatever you want in CCE and download the modified config If you loose your CID you can just reply or pm me No account is required!  
       
      Main Features:
      Left sidebar does support touch swipe on touch devices.
      No changes will be lost on page reload.
       
       
      Credits
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support Please let me know if i forgot you!
×