Jump to content
ErmaC

Clover General discussion

20,446 posts in this topic

Recommended Posts

Advertisement

Yeah, it's not persistent unless it's flashed with the firmware. ...

 

 

It alone is not going to protect from the vulnerability, because the problem is in the actual silicon of the chip, so the memory map can be side-channeled through speculation. The memory map needs to be separated from any other memory map if you want to not have this vulnerability.

"Cache me outside, how 'bout dat?"  :wink_anim: 

 

Thanks for all your great work Apianti, Slice, Vit, RM, RHM, DFritz, CCPW, et al.

 

Now, about plug and play Thunderbolt...?

Share this post


Link to post
Share on other sites

Hey guys, is there a standard way to pass arguments to the binary of a macos kext? Or a standard section for that in the info.plist of the kext?

There are several ways. All of them "standard".

Constant parameters written into info.plist IOKitPersonality section. See hundreds macOS examples.

Tunable parameters can be passed through DeviceTree. This is the way TouchPad get options from PrefPane.

DynamicParameters can be passed changed by IOUserClient interface. (RadeonDump for example).

As well it can be shared memory access (VoodooHDA PrefPane).

Moreover it can be SMC exchange, Apple's way.

Or other methods...

 

Now, about plug and play Thunderbolt...?

IOPCIFamily.kext assumes fixed PCIe configuration while Thunderbolt devices assumed to be PCIe devices.

Share this post


Link to post
Share on other sites

There are several ways. All of them "standard".

Constant parameters written into info.plist IOKitPersonality section. See hundreds macOS examples.

Tunable parameters can be passed through DeviceTree. This is the way TouchPad get options from PrefPane.

DynamicParameters can be passed changed by IOUserClient interface. (RadeonDump for example).

As well it can be shared memory access (VoodooHDA <-> PrefPane).

Moreover it can be SMC exchange, Apple's way.

Or other methods...

 

Thanks a lot for that info!  I was referring to these findings in NVDAResmanWeb.kext. What would you assume is the correct way to pass these arguments to that kext?

Share this post


Link to post
Share on other sites

 

Ha, I know why!

 

On your config.plist you have to set Scan > tool  to true:

<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<true/>
			<key>Linux</key>
			<false/>
			<key>Tool</key>
			<true/>
		</dict>

Share this post


Link to post
Share on other sites

 

Ha, I know why!

 

On your config.plist you have to set Scan > tool  to true:

<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<true/>
			<key>Linux</key>
			<false/>
			<key>Tool</key>
			<true/>
		</dict>

Thank you, that was it. I never could have guessed.

 

EDIT : My available available region is: 0000000100000000 (00000000) I guess I do not need any slide value.

Share this post


Link to post
Share on other sites

i wonder one.

if we set lang in config without emul, always shown lang set window.

 

 

SherlocksuiMBP2:~ sherlocks$ nvram -p

fakesmc-key-MSWr-ui8 %00

fakesmc-key-RPlt-ch8* j130%00%00%00%00

fakesmc-key-RBr -ch8* 2016mb%00%00

EFILoginHiDPI %00%00%00%00

fakesmc-key-#KEY-ui32 %00%00%00%11

SystemAudioVolumeDB %de

fakesmc-key-BATP-flag %00

fakesmc-key-MSTc-ui8 %00

fakesmc-key-BNum-ui8 %01

security-mode none

csr-active-config w%00%00%00

fakesmc-key-$Num-ui8 %01

fakesmc-key-MSFW-ui8 %01%00

fakesmc-key-REV -ch8* %026%0f%00%00%97

fakesmc-key-MSPS-ui16 %00%03

fmm-computer-name Sherlocks%ec%9d%98 MacBook Pro (2)

backlight-level i%05

bootercfg (%00

fakesmc-key-$Adr-ui32 %00%00%03%00

fakesmc-key-EPCI-ui32 %09 %f0%00

bluetoothActiveControllerInfo z%e0%89%04%00%00%00%000%14%ac%d1%b8%e2%a4%d0

fakesmc-key-MSAc-ui16 %00%00

boot-args

SystemAudioVolume (

fakesmc-key-RMde-char A

fakesmc-key-BBIN-ui8 %01

flagstate %00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00

specialbootdevice %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%01%00%00%00%00%00%04%01*%00%02%00%00%00%00H%06%00%00%00%00%00%00(*%08%00%00%00%00%8f%0a5%8c%c6P%e6C%ad%a6^%16p%d2e%d9%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hB%bd%d2_[%80%18%0e6%8a%cd%f1%f1_%b8%9c%b7%7f%ff%04%00

 

fakesmc-key-BEMB-flag %01

 

 

i can't see prev-lang:kbd part. if i use emul, system set i want to lang.

 

because of this part?

https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/rEFIt_UEFI/Platform/DataHubCpu.c#l212

 

can we consider it?

 

thanks in advance.

 

EDIT1

seems that it causes lang complex(kor+eng) like this.

i first see this issue since new aptiov2 without emul

 

EDIT2

new aptiov2 + emul

 

 

SherlocksuiMBP2:~ sherlocks$ nvram -p

fakesmc-key-BEMB-flag %01

fakesmc-key-RPlt-ch8* j130%00%00%00%00

fakesmc-key-RBr -ch8* 2016mb%00%00

EFILoginHiDPI %00%00%00%00

fakesmc-key-#KEY-ui32 %00%00%00%11

SystemAudioVolumeDB %de

fakesmc-key-BATP-flag %00

EmuVariableUefiPresent Yes

fakesmc-key-MSTc-ui8 %00

prev-lang:kbd ko:0

fakesmc-key-BNum-ui8 %01

security-mode none

csr-active-config w%00%00%00

fakesmc-key-$Num-ui8 %01

fakesmc-key-MSFW-ui8 %01%00

fakesmc-key-REV -ch8* %026%0f%00%00%97

fakesmc-key-MSPS-ui16 %00%03

fmm-computer-name Sherlocks%ec%9d%98 MacBook Pro (2)

backlight-level i%05

bootercfg (%00

fakesmc-key-$Adr-ui32 %00%00%03%00

fakesmc-key-EPCI-ui32 %09 %f0%00

bluetoothActiveControllerInfo z%e0%89%04%00%00%00%000%14%ac%d1%b8%e2%a4%d0

fakesmc-key-MSAc-ui16 %00%00

boot-args

SystemAudioVolume (

fakesmc-key-RMde-char A

fakesmc-key-BBIN-ui8 %01

specialbootdevice %02%01%0c%00%d0A%03%0a%00%00%00%00%01%01%06%00%00%17%03%12%0a%00%01%00%00%00%00%00%04%01*%00%02%00%00%00%00H%06%00%00%00%00%00%00(*%08%00%00%00%00%8f%0a5%8c%c6P%e6C%ad%a6^%16p%d2e%d9%02%02%04%03$%00%f7%fct%be|%0b%f3I%91G%01%f4%04.hB%bd%d2_[%80%18%0e6%8a%cd%f1%f1_%b8%9c%b7%7f%ff%04%00

flagstate %00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00%00

 

fakesmc-key-MSWr-ui8 %00

 

 

i see prev-lang:kbd ko:0 in nvram

but still

 

EDIT3

i have to lang reset from setting after update macos10.13.3 beta4 with aptiov2 except emul

1. go setting and lang

2. add english

3. select kor lang(already exist) and remove english lang.

4. reboot

5. get full kor lang on osx

 

there is no problem of lang on this combination before.

old aptiov2+osxemuvaribalesuefi.efi

 

i'm still suspecting this part.

https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/rEFIt_UEFI/Platform/DataHubCpu.c#l212

 

Well, when you installed and had emulated NVRAM you selected some value, remember? When you stopped emulating NVRAM that value was left in nvram.plist somewhere, different value was written from clover if you set language key, and if you set ":0" after that means US ANSI keyboard, I believe. So it makes sense you would need to go in and set the correct language and keyboard settings again, since they were kinda removed from your NVRAM by side effect of the switch back to native from emulated. Read like three lines below where you linked in the source.

 

About spectre / meltdown slowdown:

https://reverse.put.as/2018/01/07/measuring-osx-meltdown-patches-performance/

 

Properly benchmarked. It means that all syscalls will be drastically slower, so assumingly audio i/o, disk i/o, memory allocation?. The speed will be even more reduced with 10.13.3, since it contains more security mechanisms. I hope they will continue to trying to find faster ways, but i doubt that, because they already developed for the last 6 months or so.

 

I am still not entirely sure, why it seens to be not enough to simply patch the outside communicating apps like browser, email, etc.

 

Please notice that running geekbench is not an accurate measuring for this problem.

 

Because what app doesn't communicate with icloud now or some other apple service? Their newest FIRMWARE for the iMacPro will require internet... I think that the entirety of the operating systems developer community and the chip engineers who have discussed the best way to solve this have probably come up with the best solution, separating the memory spaces so that they cannot be attacked. They will develop ways to make system calls less frequently and overall you are probably not even really going to notice anything once it settles down. Don't forget that software has a life cycle and macOS is currently going through a redesign phase anyway so it is kinda good that it happens during now, their next release will most likely be very excellent.

 

"Cache me outside, how 'bout dat?"  :wink_anim:

 

So dumb... lol.  :no:

 

Thanks for all your great work Apianti, Slice, Vit, RM, RHM, DFritz, CCPW, et al.

 

Now, about plug and play Thunderbolt...?

 

What about it? I mean like is it a thing? Or does it work? Or what? I mean that's not very specific....

 

Thank you, that was it. I never could have guessed.

 

What did you think the tool scan did then?

 

EDIT : My available available region is: 0000000100000000 (00000000) I guess I do not need any slide value.

 

That is not a valid region because it is above the 4GB barrier that a 32bit address can represent. You need to find a region in the range 0x100000 to 0x20200000.

Share this post


Link to post
Share on other sites

Well, when you installed and had emulated NVRAM you selected some value, remember? When you stopped emulating NVRAM that value was left in nvram.plist somewhere, different value was written from clover if you set language key, and if you set ":0" after that means US ANSI keyboard, I believe. So it makes sense you would need to go in and set the correct language and keyboard settings again, since they were kinda removed from your NVRAM by side effect of the switch back to native from emulated. Read like three lines below where you linked in the source.

 

you are right.
i just confirmed it. if i remove EmuVariableUefi-64.efi
there is no prev-lang:kbd key in nvram.
before i update beta4, i removed EmuVariableUefi-64.efi and nvram.plist to surely check where is problem.
 
and default kor lang before update beta4. when updating beta4, i saw english word example "install 14 minutes left".
after finished beta4, then booted, i just saw eng+kor combination of system part. example reboot dialog above pic.
 
when used EmuVariableUefi-64.efi, always correct lang shown example "설치 14분 남았습니다"
after finished beta4, then booted, i saw correct kor lang of system part without eng.
 
i used this combination of EmuVariableUefi-64.efi+old aptioV2 long time.
now, i returned old aptioV2 to avoid this issue after update lang issue. also i didn't notice keyboard problem that you mentioned keyboard. i just checked lang part.

<key>Language</key>

<string>ko:0</string>

 
thanks
 
EDIT1
this issue happen new aptiov1 and aptiv2.
i tested skylake laptop and sandy laptop.

Share this post


Link to post
Share on other sites

That is not a valid region because it is above the 4GB barrier that a 32bit address can represent. You need to find a region in the range 0x100000 to 0x20200000.

Share this post


Link to post
Share on other sites

 

There are more memory regions above, you need to press Pg Up. Or better yet, you need to export your memmap to a file. The instructions are a couple of pages back (basically enter fs0: ; cd EFI/CLOVER/misc ; memmap > memmap.txt and then mount EFI with the started system).

Share this post


Link to post
Share on other sites

I don't know why you showing me a picture of it makes it any more valid. First, the address can't go beyond 32bits so only eight hexadecimals, so 0x100000000 would be truncated to zero, which is definitely not valid. Second, the address has to be in the range 0x100000 to 0x20200000 aligned by 0x200000 because those are the only possible slide locations.

Share this post


Link to post
Share on other sites

I seems should not bother about slide value?

Available  0000000000100000-0000000082D1DFFF 0000000000082C1E 000000000000000F

Thanks a lot for that info!  I was referring to these findings in NVDAResmanWeb.kext. What would you assume is the correct way to pass these arguments to that kext?

You can send any argument to driver if it waits an argument from you.

Share this post


Link to post
Share on other sites

...

how is the noEFI setting passed to the nvidia web driver by clover? Is it a DSDT patch, or a binary patch or a argument passing?

 

Found this in clover source:

https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/rEFIt_UEFI/Platform/nvidia.c#l2414

DSDT Patch:

"NVDA,noEFI",
Buffer (0x05)
{
  "true"
},

or Clover Patch:

<key>Graphics</key>
     <dict>
	   <key>NvidiaNoEFI</key>
	   <true/>
     </dict>

Share this post


Link to post
Share on other sites

Hey slice,

 

how is the noEFI setting passed to the nvidia web driver by clover? Is it a DSDT patch, or a binary patch or a argument passing?

 

Found this in clover source:

https://sourceforge.net/p/cloverefiboot/code/HEAD/tree/rEFIt_UEFI/Platform/nvidia.c#l2414

 

Looks like a device tree modification to me?

Yes, device tree modification.

 

 

Thanks. And what exactly is this DSDT key for:  

NVDA,Features

I have seen it in old DSDTs, but it seems to be still present in NVDAStartupWeb.

You may use AddProperties feature for this case.

Or modify DSDT, or create SSDT. At your will.

If you want it to be implemented in Clover then you should give me full explanation what is and for a what.

Share this post


Link to post
Share on other sites

What about OsxLowMemFixDrv? Is there anybody use it or it is obsolete?

 

 

hello Slice 

 

I use it in clover legacy for my old Packard Bell

Share this post


Link to post
Share on other sites

hello Slice

 

I use it in clover legacy for my old Packard Bell

Legacy Clover only using Drivers64 not Drivers64UEFI.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

USBMousseDxe-64 I have this on Drivers64 in my Packages

I have never needed it before so im unsure if its clover or the new dev beta build.

Even with the driver its slow, i have to have settings like this for decent movement.

post-1083558-0-09471600-1515669894_thumb.png

Share this post


Link to post
Share on other sites

I have never needed it before so im unsure if its clover or the new dev beta build.

Even with the driver its slow, i have to have settings like this for decent movement.

attachicon.gifScreen Shot 2018-01-11 at 9.53.27 pm.png

Yea I see its new adition in UEFI Drivers → USBMousse

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15
      Original link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      For any system kext installation\modification you need to boot with config_debug.plist (or disable SIP manually)
      Also on Catalina the System folder is read-only, so you need to remount in rw. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      EFI-Clover-X99.zip
       
       
       
       
       
       
      Anyone else I forgot
       
       
×