Jump to content
ErmaC

Clover General discussion

20,627 posts in this topic

Recommended Posts

Advertisement

how about this error on r4289 official?

The same thing happens with official r4289.

 

It's not a big deal though, I see that the ACPI tables get dumped but it ends up with the error I posted earlier. The same thing happens with all the newer versions of clover. It dumps the tables but the error happens anyway and I have to reset the pc.

Share this post


Link to post
Share on other sites

The same thing happens with official r4289.

 

It's not a big deal though, I see that the ACPI tables get dumped but it ends up with the error I posted earlier. The same thing happens with all the newer versions of clover. It dumps the tables but the error happens anyway and I have to reset the pc.

 

Try r4278

r4278.zip

Share this post


Link to post
Share on other sites

The same thing happens with official r4289.

 

It's not a big deal though, I see that the ACPI tables get dumped but it ends up with the error I posted earlier. The same thing happens with all the newer versions of clover. It dumps the tables but the error happens anyway and I have to reset the pc.

Any revision before 4276?

Share this post


Link to post
Share on other sites

Any revision before 4276?

I tried with 4273 (not the official build) and it's still happening. Could it be some misconfiguration in the system's BIOS settings?

Try r4278

The same thing happens.

Share this post


Link to post
Share on other sites

@Sherlocks

 

Attached Boot Log with SSDT and without

Out of the question.

Your LAN card is Intel

0:102  0:000  PCI (00|00:1F.06) : 8086 15B8 class=020000
0:102  0:000   - LAN: 0 Vendor=Intel

So you have to use IntelMausi and you may delete RealtekRTL8111 and Atheros

Share this post


Link to post
Share on other sites

clover made SSDT for max 47 following your overclocked speed. log is good.

check your power management from intel power gadget

So Clover now handles power management? No SSDT needed? I removed mine and seems ok on my skylake rig.

post-1083558-0-40049100-1511258193_thumb.png

Share this post


Link to post
Share on other sites

So Clover now handles power management? No SSDT needed? I removed mine and seems ok on my skylake rig.

attachicon.gifScreen Shot 2017-11-21 at 8.24.46 pm.png

Man,

Clover handles Power Management since 2010 (Chameleon AMLGenerator by Kozlek) while Pike made his script only in 2011.

Share this post


Link to post
Share on other sites

So Clover now handles power management? No SSDT needed? I removed mine and seems ok on my skylake rig.

 

This confuses me, there has always been support for c and p state generation in clover. The only problem is that it doesn't have an exhaustive list of cpus and values like that script does so it usually severely unpowers the cpu causing it to usually stay stuck in a subset of the available p-states...

 

Man,

Clover handles Power Management since 2010 (Chameleon AMLGenerator by Kozlek) while Pike made his script only in 2011.

 

I was confused by his statement as well, lol.

 

So how come his script has been recommended so much?

 

Who's recommending that script? Why not do what is suggested by us and modify your original firmware tables to be correct for compliance with Apple firmware.

Share this post


Link to post
Share on other sites

Could you point me in right direction to study what you suggested?

Thank you

 

Who's recommending that script? Why not do what is suggested by us and modify your original firmware tables to be correct for compliance with Apple firmware.

Share this post


Link to post
Share on other sites

Who's recommending that script? Why not do what is suggested by us and modify your original firmware tables to be correct for compliance with Apple firmware.

How so?

Share this post


Link to post
Share on other sites

Could you point me in right direction to study what you suggested?

Thank you

How so?

It's pretty easy, the most difficult part is understanding ACPI. You need to dump your original ACPI tables from clover or linux or something else like Aida64 from windows. DO NOT dump from macOS. Get iasl, here is binary built from RehabMan. Decompile the tables with

iasl -d TABLENAME.aml
Then edit the tables and correct the definitions of _PSS and _CST to APSS and ACST. There are topics you can search for to figure out exactly how to do it but this will give better frequency to power ratio that is expected by the motherboard to perform these power changes correctly. I think to recompile to table its like

iasl -tc TABLENAME.dsl
Don't quote me on that though lol.

 

EDIT: Which also reminds me that I just updated my firmware and did not get the new tables to patch... Probably not the same now. So that might explain my AICPUPM panic... I'm an idiot.

 

EDIT2: You should make copies of the tables in a backup location you can easy copy back if you mess up as it may overwrite the original table when you recompile... I can't remember. I'm sure if you look at the help you can find out what the commands are and use them accordingingly.

Share this post


Link to post
Share on other sites

It's pretty easy, the most difficult part is understanding ACPI. You need to dump your original ACPI tables from clover or linux or something else like Aida64 from windows. DO NOT dump from macOS. Get iasl, here is binary built from RehabMan. Decompile the tables with

iasl -d TABLENAME.aml
Then edit the tables and correct the definitions of _PSS and _CST to APSS and ACST. There are topics you can search for to figure out exactly how to do it but this will give better frequency to power ratio that is expected by the motherboard to perform these power changes correctly. I think to recompile to table its like

iasl -tc TABLENAME.dsl

I have a perfectly working DSDT just always been concerned / worried about cpu power management.

Attached is my clover extracts  :yes:

If you wanna look see.

origin.zip

Share this post


Link to post
Share on other sites

I have a perfectly working DSDT just always been concerned / worried about cpu power management.

Attached is my clover extracts  :yes:

If you wanna look see.

 

I'm not going to do it for you man, put in the research, learn about it.

Share this post


Link to post
Share on other sites

I'm not going to do it for you man, put in the research, learn about it.

Was just seeing if you could take a look and see if i need to do adjustments, and if i do can you point me to where i need to look.

Share this post


Link to post
Share on other sites

This is my speedstep on Skylake (#1 in signature):

- no external SSDT

- config->ACPI->SSDT->Generate->PState=Yes, CState=Yes.

- CPU->SavingMode=15

- HWPEnable=NO

others by default.

Снимок экрана 2017-11-21 в 22.45.14.png


And  this is speedstep for my IvyBridge laptop (#2 in signature)

boot-arg = -xcpm

no CPU SSDT

Generate=YES (don't know if needed for xcpm)

Screen Shot 2017-11-18 at 14.08.32.png

 

In past I had Dell Inspiron 1525 with Core 2 Duo Penryn. I aalso had very good speedstep for it.

Moreover. PlimitDict and UnderVoltStep was invented for those computer to reduce temperature.

 

Share this post


Link to post
Share on other sites

This is my speedstep on Skylake (#1 in signature):

- no external SSDT

- config->ACPI->SSDT->Generate->PState=Yes, CState=Yes.

- CPU->SavingMode=15

- HWPEnable=NO

others by default.

What does - CPU->SavingMode=15 do?

Also what is C2, C4 and C6 options for in cpu section?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      Download:  https://github.com/xe97/X99-8D3-Clover
       
       
       
       
       
      Anyone else I forgot
       
       
    • By digivish
      Hi All - quick thing - I have a NUC 8i7BEH with 32GB RAM and 2 x 1TB SSD drives. Each drive has its own OS - Windows 10 and Catalina 10.15.
       
      Clover works well - Catalina Boots, so does Windows.
      Catalina - has sound over HDMI (to my monitor's speakers)
      Windows - no audio device found - It does show Realtek and Intel Display Drivers - but the speaker has a red"x" and in Devices, there is no entry for Microphone Array under Audio Input/Output. It does, however, show Intel display over the HDMI - but actually no sound.
       
      I have tried reinstalling Realtek drivers - now here's the thing...when it installs, it first uninstalls existing Realtek drivers - at this stage (and it's important) the sound starts working - as if uninstalling did the trick. As part of the installing, I have to reboot and upon reboot, it actually reinstalls the Realtek drivers. After that, I'm back to square 1. Unsure if it's the config.plist or boot args in clover. But something with Clover for sure.
       
      I have tested this by removing the Mac Drive with clover and just booting directly to Windows 10 bootloader and everything works as it should, I have sound over HDMI and the audio device shows. Just not when I boot with Clover.
       
      has anyone experienced this and have thoughts or pointers.
       
      Thanks a ton!
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kylon
      ACPI and Clover config for Acer Aspire v5-571PG
       
      Tested on Catalina 10.15.1 and Clover EFI 5098 (Should work on MacOS 10.9.x - 10.15.x)
       
      Not Working:
      - sd card reader
      - Atheros AR9462 (use a compatible USB wireless adapter, see below)
      - Touchscreen (MacOS 10.15 only)
       
       
      Notes:
      Disable Secure Boot and enable Legacy Boot. Legacy Mode is recommended.  
      **To reset your BIOS, power on the pc and hold the power button for about 30-40 seconds or you can short G2101 (RAM SLOT 1)**
       
       
      About the Atheros card:
      You can install ATH9KFixup (you will also need additional patches on 10.14+ to restore Atheros support) to enable this card, however,
      it will break sleep on MacOS 10.14+, it can freeze your OS at any time and it can freeze your network settings.
      Because of its instability it is highly recommended to buy a USB wireless adapter.
       
      You can find a list of working adapters, and the drivers, here.
       
       
      Additional things you will need:
      Latest Clover config (AcerAspireV5-571pg - CCE Bank) from here CloverEFI (download) or OpenCore (download - Untested) WhateverGreen (download) VoodooPS2 (download) VirtualSMC + SMCBatteryManager (download) AppleALC (download) Lilu (download) Mieze Realtek RTL8111 (download)  
      CloverEFI drivers you will need:
      ApfsDriverLoader EmuVariableUefi FSInject DataHubDxe VBoxHfs (if you have hfs partitions)  
      Remember to install BIOS drivers if you enable Legaby Boot.
       
       
       
      Feel free to ask for help.
      Please send me a PM if you have fixes or improvements, thanks.
    • By oldman20
      Hi all, i just want to know how can use mouse & keyboard USB with USB port when Cloverbootloader startup? I installed Ps2MouseDxe.efi and UsbMouseDxe.efi but not work, while touchpad and keyboard integrated laptop working!!
      thanks all!
      and 2nd question is: i installed success Catalina with APFS format, in Disk Utility show 2 partition is Catalina SSD and Catalina Data?? what is it?

      more and last, sorry cause it's short question: which most right, in 2 ways create USB installer Catalina,
      sorry my bad english!

      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled && echo Catalina Boot Drive Created

      sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ Catalina.app --nointeraction

      thanks and regards    
×