Jump to content
ErmaC

Clover General discussion

20,226 posts in this topic

Recommended Posts

It gave me sed: 1: "s/.*<//;s/>.*//;}": unexpected }

 

Sorry, my bad, corrected below...

 

ioreg -lw0 -p IODeviceTree -n efi -r -x | grep device-properties | sed 's/.*<//;s/>.*//;'

 

[EDIT]

 

You always can use DarwinDumper > http://www.insanelymac.com/forum/index.php?showtopic=282794

 

 

 

Nope, not yet. If you're meaning the perl script.

 

Yes, you can patch manually or you can let Clover do this...

 

<key>AppleRTC</key>
<string>Yes</string>

 

 

Thank you for the info. This parameter is for quiet boot, right?

 

Yes...

Share this post


Link to post
Share on other sites
Advertisement

@dmazar

 

No, no. For UEFI boot definately needed in /efi/drivers64UEFI: HFSPlus (or VboxHfs) and FatBin. Then try to boot.

 

If this does not work, then add LowMemFix and try to boot.

 

If still does not work, then remove LowMemFix and add AptioFix (so, HFS, FatBin and AptioFix). aptioFix requires adding "slide=0" to boot args in config.plist.

 

If this does not work, then there is a problem.

 

Seems like there is a problem. :( I've tried everything you mentioned, but still can't boot with UEFI. :(

 

 

Yes, you can patch manually or you can let Clover do this...

 

<key>AppleRTC</key>

<string>

Yes

</string>

 

@kyndder

 

Tried both. Pearl script ...

 

sudo perl -pi -e 's|\x75\x30\x89\xd8|\xeb\x30\x89\xd8|' /System/Library/Extensions/AppleRTC.kext/Contents/MacOS/AppleRTC

 

and ...

 

<key>KernelAndKextPatches</key>
<dict>
 <key>AppleRTC</key>
 <string>Yes</string>
</dict>

 

​... unfortunately with the same result, no screen after sleep. Without DSDT everything works fine. So is this something DSDT related or could it be something hardware related?

Share this post


Link to post
Share on other sites

@kyndder

 

Tried both. Pearl script ..

 

​... unfortunately with the same result, no screen after sleep. Without DSDT everything works fine. So is this something DSDT related or could it be something hardware related?

 

Did you have SBUS fix on your DSDT???

 

If yes, did you already tried to wake your machine using the power button instead of moving the mouse or pressing some keyboard key???

Share this post


Link to post
Share on other sites

Without DSDT everything works fine. So is this something DSDT related or could it be something hardware related?

Yes, it is DSDT related. Why you need your quirky DSDT if without it "all works fine"?

Share this post


Link to post
Share on other sites

It showed "There is a problem with TSC detection and calibration! Assume calibrated one" before getting into the harddrive-selecting screen.

How can I do to fix this error?

I remember it didn't have this problem when I was using Clover r718.

 

I'm using r732 now.

Share this post


Link to post
Share on other sites

@kyndder

Did you have SBUS fix on your DSDT???

 

If yes, did you already tried to wake your machine using the power button instead of moving the mouse or pressing some keyboard key???

 

Yes, I have. I'm only able to wake my computer from sleep using power button. Pressing keybord keys won't work for me in Clover.

 

 

@Slice

Yes, it is DSDT related. Why you need your quirky DSDT if without it "all works fine"?

 

Thank you for the info. Why do I need my DSDT ... this is a good question! ;) My "old" machine wasn't able to boot without DSDT and editing DSDT brought me some benefits, so I decided to create a DSDT for my new machine.

 

I guess I'll have to check whats wrong with my edits and meanwhile work without DSDT. But my primary goal is to get Clover booting with UEFI.

Share this post


Link to post
Share on other sites

I'm only able to wake my computer from sleep using power button. Pressing keybord keys won't work for me in Clover.

 

For me works the same way... I really don't know if there's a fix for this... In true, I do not usually use sleep function...

 

Why you don't give a try (if you already not) to Clover's automatic DSDT fix ??? > #7

 

But Slice is right, if you have everything working fine without DSDT, you should not use it...

 

About Clover's direct UEFI boot I can't tell you anything, you will have to wait till someone with the needed

knowledge to answer...

Share this post


Link to post
Share on other sites

It showed "There is a problem with TSC detection and calibration! Assume calibrated one" before getting into the harddrive-selecting screen.

How can I do to fix this error?

I remember it didn't have this problem when I was using Clover r718.

 

I'm using r732 now.

This is a bug but not influence on functionality. Hope will be resolved soon.

Share this post


Link to post
Share on other sites

I could use some help getting Clover working with my Nvidia 560m. I have set Graphics Injector to "Yes" however I never get to the login screen from a verbose boot. The card works without issue under Chameleon but my laptop has CMOS corruption issues that I hope to fix with Clover's NMI patching.

Share this post


Link to post
Share on other sites

So what is wrong with ProjectOSX site??

Seems to be getting harder to access.

 

+1

 

i have massive probs since one week to get access :worried_anim:

 

IPS Driver Error
There appears to be an error with the database.
You can try to refresh the page by clicking here

 

Most of the time down with above message

Share this post


Link to post
Share on other sites

Slice, will you fix the third-part USB3 problem in Clover? (Boot0:Done7)

Does anyone who enable onboard third-part USB3.0 be capable of booting with Clover?

 

(I'm guessing UEFI should be fine with Clover when third-part USB3 is enabled.)

Share this post


Link to post
Share on other sites

Slice, will you fix the third-part USB3 problem in Clover? (Boot0:Done7)

Does anyone who enable onboard third-part USB3.0 be capable of booting with Clover?

 

(I'm guessing UEFI should be fine with Clover when third-part USB3 is enabled.)

 

For me bios booting only works with USB3 ( Etron EJ168 ) disabled.

Can't say anything about UEFI...

Share this post


Link to post
Share on other sites

Does anyone who enable onboard third-part USB3.0 be capable of booting with Clover?

 

Works OK with PXHCD.kext....

 

But I'm not using the kext anymore (also disabled in BIOS) because I don't have any USB3.0 device....

Share this post


Link to post
Share on other sites

Works OK with PXHCD.kext....

 

But I'm not using the kext anymore (also disabled in BIOS) because I don't have any USB3.0 device....

 

I'm curious with which PXHCD.kext you got your USB3 working !

There are some patches floating around but none of them worked for me.

My mobo has the same controller as yours, so i'd like to try out !

Would you please share a link or upload that file ?

 

Thank you

Share this post


Link to post
Share on other sites

Would you please share a link or upload that file ?

 

 

No problem...

 

I'm at work now, later when I get home I´ll send to you a copy of the kext...

Share this post


Link to post
Share on other sites

Haven't tried for a while, unless something has drastically changed, could not boot at all.

Have been using Clover (boot) up until now.

 

I think rEFInd is better suited to the task at hand, and that is booting rEFit_UEFI (CloverX64.efi) straight UEFI mode.

So Clover (boot) is for Hacks and rEFInd is for Macs, simple.

If I had a Mac, I would be using rEFInd, So Now I use it for my Hack "As My Hack Is Now A Mac"

I am not clear about what you are speaking.

Vanilla DUET is not working for OSX

rEFIt and rEFInd doesn't boot HackOSX

So why Clover project was burned. We are working not for cosmetic.

Share this post


Link to post
Share on other sites

No, no. For UEFI boot definately needed in /efi/drivers64UEFI: HFSPlus (or VboxHfs) and FatBin. Then try to boot.

 

If this does not work, then add LowMemFix and try to boot.

 

If still does not work, then remove LowMemFix and add AptioFix (so, HFS, FatBin and AptioFix). aptioFix requires adding "slide=0" to boot args in config.plist.

 

If this does not work, then there is a problem.

 

Hi dmazar,

 

After flash my old F7 BIOS of my GA P67A-D3-B3 for the U1a Firmware of GA P67A-UD3-B3 using "flashrom", I'm able to direct boot Clover's "BOOTX64.efi"...

 

However, seems that none of HFS drivers are working on my machine... I followed all your instructions quoted above

with no apparent effect as I can't boot OS X... Windows and Linux booting from Clover works OK...

 

Do you have any hint???

 

post-628175-0-98948900-1350028799_thumb.jpg

Share this post


Link to post
Share on other sites

Yes. Explain what is happening on the screen, or make a screenshot/photo. Plus, press F2 to generate /EFI/misc/preboot.log and give it here.

Share this post


Link to post
Share on other sites

Yes. Explain what is happening on the screen, or make a screenshot/photo.

 

There's nothing abnormal during preload or after load Clover...

 

post-628175-0-74056900-1350045685_thumb.jpg

 

Plus, press F2 to generate /EFI/misc/preboot.log and give it here.

 

Here > preboot.log.zip (UEFI Boot)

 

[EDIT]

 

Full DarwinDump > DarwinDump.htm (Standart Clover Boot)

Share this post


Link to post
Share on other sites

Hi dmazar,

 

After flash my old F7 BIOS of my GA P67A-D3-B3 for the U1a Firmware of GA P67A-UD3-B3 using "flashrom", I'm able to direct boot Clover's "BOOTX64.efi"...

 

However, seems that none of HFS drivers are working on my machine... I followed all your instructions quoted above

with no apparent effect as I can't boot OS X... Windows and Linux booting from Clover works OK...

 

Do you have any hint???

 

post-628175-0-98948900-1350028799_thumb.jpg

 

So you flash the Bios with the UEFI firmware of P67A-UD3-B3?? That's amazing! XD Won't it be dangerous?

I'm wondering why gigabyte don't release other firmware for P67, since it seems you don't get much problem with the un-mach firmware, do you?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ErmaC
      Slice is glad to present a new EFI bootloader.

      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      https://sourceforge.net/projects/cloverefiboot/?source=directory
      There is a WIKI 
      http://clover-wiki.zetam.org/
      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      Post#2 CloverGrower - create Clover by yourself Post#3 Downloads Post#4 Installation of the bootloader Post#5 How to do UEFI boot Post#6 How to use - common words Post#7 Calculator for Automatic DSDT fix Post#8 Instructions for GraphicsInjector Post#9 ATIConnector patching Post#10 Any kexts patching with some Samples Post#11 CustomEDID Post#12 Hiding unnecessary menu entries Post#13 Instruction for DSDT corrections to do DeviceInjection works Post#14 Development Post#15 Themes Post#16 About kexts injection Post#17 Instructions for P- and C-states generator Post#18 Patching DSDT to get Sleep working Post#19 CPU settings and geekbench Post#20 ACPI tables loading Post#21 DSDTmini Post#22 Custom SMBios Post#23 F.A.Q. Post#24 iCloudFix Post#25 Using mouse. Post#26 How to make orange icons to be metallic Post#27 How to make software RAID (by Magnifico) Post#28 How to modify InstallESD.dmg (by shiecldk) Post#29 Config.plist settings Post#30 Using extra kexts and skipping kernelcache Post#31 Choosing EFI drivers Post#32 Configuration files Post#33 Automatic config.plist creating Post#34 Custom DSDT patches Post#35 How to do sleep/wake working with UEFI BOOT Post#36 DeviceID substitution (FakeID) Post#37 Using Custom OS Icons Post#38 Hibernation Post#39 Floating regions Post#41 Property List Editor Post#42 Blocking Bad Kext Post#43 AAPL,slot-name Post#44 FakeCPUID for unsupported CPU Post#45 Multiple Boot Options - to write into UEFI BIOS boot menu Post#46 How to install Windows UEFI Post#47 How to speedup Clover boot Post#48 Info.plist patching Post#49 Arbitrary device injection Post#50 Non-Standard Legacy Boot Files Post#51 Reboot to Windows UEFI from Mac OSX Post#52 Deprecated Features Post#53 Using UDK2018 Post#54 Device Properties Post#55 Scalable themes Post#56 How to search Clover mistakes (bisection) -----------------
       
      Slice:
      I edited all posts in the thread to correspond to actual Clover revision.
      Please install Clover at least 2652 and use new instructions.
×